Forum: PC Hard- und Software [Win7] CD-Laufwerk statt DVD-RW-Laufwerk


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Lu (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Hallo zusammen,

Ich habe ein sehr schräges Problem. Wollte mal wissen ob jemand etwas 
ähnliches bereits hatte und/oder vielleicht einen Lösungsvorschlag für 
mich hat.

Ich habe hier einen Laptop mit Windows 7 x64 am laufen. Leider erkennt 
dieser jegliche DVD-Laufwerke nur als CD-Laufwerk.
Egal welches DVD- oder DVD-RW-Laufwerk ich anstecke, es wird als 
CD-Laufwerk erkannt und kann damit nicht zum brennen von DVDs verwendet 
werden. (Auch Nero oder CDBurnerXP können nicht brennen. Beim Versuch 
stoppt/freezed der Vorgang bei der Initialisierung ohne Fehlermeldung)
Die selben DVD-Laufwerke (USB) an anderen PCs (ebenfalls Win7 x64) 
werden korrekt erkannt und können normal verwendet werden.

Ich habe jetzt schon alles Mögliche versucht, verschiedene Treiber 
installiert, Tage lang Google gefoltert. Kein Erfolg.
Sogar ein virtuelles DVD-RW-Laufwerk mit KerSafe TotalMounter wird als 
CD-Laufwerk erkannt und kann nicht zum (virtuellen) Brennen verwendet 
werden.

Hat irgendjemand eine Idee, was das wieder sein könnte?

Vielen Danke und ein schönes neues Jahr
Lu

von Lukas (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Besteht das Problem schon immer?

AHCI Eingeschaltet?
Boardtreiber installiert?

Welcher Treiber wird für das Laufwerk geladen?

von Lu (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die schnelle Antwort!

Also bei der Hardware handelt es sich um ein altes Lenovo ThinkPad T61.

AHCI Treiber-details. Wo genau schaust du die nach? das Fenster finde 
ich jetzt nicht...
Sind die Treiber für jeden Speicherbus einzeln gültig, oder 
Windows-weit.
Die getesteten externen Laufwerke hängen ja an USB-Adaptern.

von Lukas (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Doppelklick aufs Laufwerk >> Treiber >> Treiberdetails

von Lu (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Oh, na klar... Was ich mit der Modelbezeichnung andeuten wollte, das 
"inderne" (Ultrabay Slim) DVD-RW-Laufwerk hängt an einem PATA nicht am 
SATA.
 Nicht, dass das jetzt besonders relevant wäre, aber ich glaube den 
AHCI-Modus, gabs doch erst bei SATA. Oder täusche ich micht jetzt. Ich 
muss mir da nochmal Google durchlesen...

von Lu (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hmm... Treiberdetails. Ich hab da keinen iaStorF.sys

von Lukas (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Der DVD Brenner welcher nicht funktioniert ist nun Intern PATA oder USB?

von Lu (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Keiner funktioniert... PATA, USB, virtuell... keiner

von Lukas (Gast)


Bewertung
0 lesenswert
nicht lesenswert
in einer per admin gestarteten cmd:

sfc /scannow

Ausgabe posten.

Falls keine Besserung Reperaturinstallation machen.

von bluppdidupp (Gast)


Bewertung
2 lesenswert
nicht lesenswert
Irgendwelche Software für virtuelle Laufwerke installiert?
Ggf. hast du auf deinem System Filter-Treiber, die am eigentlichen 
Treiber dran hängen und (beabsichtigt oder unbeabsichtigt) 
Funktionalitäten blockieren.
Dann müssten hier speziell Punkt 3+6 relevant sein:
https://support.microsoft.com/en-us/kb/314060
(Der Troubleshooter bei Punkt 2 prüft den Kram vermutlich auch, vllt. 
zuerst versuchen, falls nicht schon geschehen)

Je nach Brenner-Software kann ggf. auch eine Gruppenrichtlinie Schuld 
sein:
Ab Win7 Pro:
"gpedit.msc" per Start > Ausführen öffnen
Dann Einstellung "User Configuration" > "Administrative Templates" > 
"Windows Components" > "File Explorer" > "Remove CD Burning features" 
kontrollieren (bzw. analogen Pfad auf deutschem Windows)

von Simon L. (dfgh)


Bewertung
1 lesenswert
nicht lesenswert
Hatte ich auch schon mal mit einem Laptop. Plötzlich wurden alle 
optischen Laufwerke nur noch als CD-Laufwerk erkannt.

Schuld war ein Fehler im Laufwerks-Treiber. Manuelles Entfernen des 
Treibers half leider nicht, weil Windows den natürlich für später noch 
bereitliegen hatte und die defekte/falsche? Konfiguration einfach wieder 
installiert hat.

Lösung war dann das Entfernen eines bestimmten Registry-Schlüssels 
(natürlich mit Backup), so das die Laufwerke ordnungsgemäß neu 
installiert werden konnten.

Ich muss mal suchen -- vielleicht findet sich die Anleitung, die ich mir 
damals geschrieben habe ja noch.
----------------------------------------------------------
Edit: gemeint war Punkt 3 im gerade von bluppdidupp (Gast) geposteten 
Link.

: Bearbeitet durch User
von michael_ (Gast)


Bewertung
0 lesenswert
nicht lesenswert
bluppdidupp schrieb:
> Irgendwelche Software für virtuelle Laufwerke installiert?

Lu schrieb:
> Sogar ein virtuelles DVD-RW-Laufwerk mit KerSafe TotalMounter wird als
> CD-Laufwerk erkannt und kann nicht zum (virtuellen) Brennen verwendet
> werden.

Dann deinstalliere mal den ganzen Mist, welcher irgendwie nach CD 
riecht.
Wenn ich schon "TotalMounter" höre!
Dann deinstallierst du den CD-Treiber.
Echt runterfahren und WIN selbst den Treiber suchen lassen.

Oder hast du mal den Treiber händisch ausgewählt?
Nimmt er den MS-Treiber nicht an?

von Teo (Gast)


Bewertung
0 lesenswert
nicht lesenswert
michael_ schrieb:
> Dann deinstallierst du den CD-Treiber.
> Echt runterfahren und WIN selbst den Treiber suchen lassen.

Löschen und nach geänderter Hardware suchen reicht.

von Lu (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke euch allen fürs fleißige miträtseln.

Ich glaube dieser Laptop unterliegt einfach einem Fluch.
Hab alle eure Tips probiert, kein Erfolg.


michael_ schrieb:
> Dann deinstalliere mal den ganzen Mist, welcher irgendwie nach CD
> riecht.
> Wenn ich schon "TotalMounter" höre!
> Dann deinstallierst du den CD-Treiber.
> Echt runterfahren und WIN selbst den Treiber suchen lassen.
>
> Oder hast du mal den Treiber händisch ausgewählt?
> Nimmt er den MS-Treiber nicht an?

Jetzt habe ich sogar mal Windows komplett von null neu installiert 
(Festplatte vorher getauscht, dass ich die alte Installation als Backup 
noch habe)
Auch hier direkt nur CD-Laufwerke. Die Hardware hat einfach keine Lust 
auf DVDs hab ich das Gefühl. Frage mich nur welche Komponente das 
auslösen kann, dass sowohl das PATA als auch USB-Laufwerke nicht richtig 
erkannt werden.

von Paul B. (paul_baumann)


Bewertung
0 lesenswert
nicht lesenswert
Lu schrieb:
> Frage mich nur welche Komponente das
> auslösen kann, dass sowohl das PATA als auch USB-Laufwerke nicht richtig
> erkannt werden.

...und im BIOS stimmt der Eintrag für ein DVD-Laufwerk?

MfG Paul

von Lu (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Paul B. schrieb:
> ...und im BIOS stimmt der Eintrag für ein DVD-Laufwerk?

Ganzes Bios durchsucht. Kein Eintrag für das Laufwerk.
Man kann den AHCI modus auf compatible stellen, was ich aber nicht getan 
habe. Sollte aber ja auch die USB-Laufwerke nicht betreffen.

von Paul B. (paul_baumann)


Bewertung
0 lesenswert
nicht lesenswert
Lu schrieb:
> Sollte aber ja auch die USB-Laufwerke nicht betreffen.

Wir haben es mit Computern zu tun. Da darf Einen Nichts wundern....
;)
MfG Paul

von Günter R. (guenter-dl7la) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
ACK. Andere Frage: Was passiert, wenn du eine DVD einlegst? Bei einer 
Maschine hatte ich mal den Fall, dass sich der Brenner erst beim 
Einlegen einer unformatierten DVD als Brenner meldete, vorher war er nur 
Leser. Der Treiberhersteller lobte sich sogar für diese "Feature"-

von Lu (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Günter R. schrieb:
> ACK. Andere Frage: Was passiert, wenn du eine DVD einlegst? Bei einer
> Maschine hatte ich mal den Fall, dass sich der Brenner erst beim
> Einlegen einer unformatierten DVD als Brenner meldete, vorher war er nur
> Leser. Der Treiberhersteller lobte sich sogar für diese "Feature"-

Haha, bei einer leeren DVD passiert nix. Bei einer beschriebenen dauert 
es ehwig, dann erkennt er eine verdammt große CD.

von S. R. (svenska)


Bewertung
0 lesenswert
nicht lesenswert
Starte mal ein Linux (Knoppix oder so). Was sagt das zu dem Laufwerk?

Die AHCI-Einstellung betrifft nur die SATA-Schnittstelle (und ist bei 
modernen Betriebssystemen zu empfehlen). Ist der Brenner am IDE (PATA) 
angeschlossen, wird der davon nicht betroffen, USB-Geräte haben damit 
überhaupt nichts zu tun.

von michael_ (Gast)


Bewertung
0 lesenswert
nicht lesenswert
S. R. schrieb:
> Starte mal ein Linux (Knoppix oder so). Was sagt das zu dem Laufwerk?

Hardwaremäßig ist alles in Ordnung.
Sonst hätte er die W7 DVD nicht installieren können.

Bei der Neuinstallation von W7 hätte alles i.O. sein sollen.

Ich habe kein gutes Gefühl zur Fragestellung des TO.

von Sven K. (svenk)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

mir ist noch etwas eingefallen.
Dies Problem trat aber unter XP auf, aber vielleicht ist es auch unter 
W7 möglich.

Ein mir vorgesetzter Rechner eines bekannten war komplett eingerichtet 
es sollte nur noch ein Nero aufgespielt werden. Hat dieser auch gemacht. 
Das war dann natürlich ein Nero mit Serial aus einer dubiosen Quelle. 
Nero hatte da etwas programmiert den Treiber oder Windows so zu 
modifizieren das nur noch CD-ROM ging.

Vielleicht da mal nachforschen?

Nach langem hin und her wurde der Rechner nochmal komplett neu 
aufgesetzt.
Von daher ist die Idee LiveCd Linux nicht so abwegig ?

Gruß Sven

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.