Forum: Analoge Elektronik und Schaltungstechnik EGO Herdplatte defekt


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von MCMajus (Gast)


Lesenswert?

Hallo,

unser Induktionskochfeld zuhause hat heute den Geist aufgegeben. Das 
bedeute, dass nur noch die LED Anzeige zur Bedienung funktioniert und 
die Relais der Herdplatten gar nicht schalten.
Ich habe die Platte kurzerhand ausgebaut und auseinander genommen um 
nach der Fehlerquelle zu suchen. Folgende Sachen konnte ich 
herausfinden:

- Der Herd ist von Miele, die Elektronik von der EGO Oberderdingen
- Kein Kondensator sieht aufgebläht aus (was nicht heißen muss dass er 
nicht trotzdem kaputt ist)
- Jeweils zwei Herdplatten hängen an einer Platine
- Pro Herdplatte gibt es 2 IGBTs (Typ ixgr40n60c2d1)
- Pro Platine à 2 Herdplatten gibt es 1 Brückengleichrichter (Typ 
unbekannt)
- Die IGBTs und der Gleichrichter hängen an einem Alukühler

Folgende Schlüsse würde ich ziehen:
- Nachdem alle vier Platten auf einmal ausgefallen sind können es nur 
sehr unwahrscheinlich die IGBTs oder die Brückengleichrichter sein
- Die Spannungsversorgung funktioniert, da die Anzeige leuchtet
Vielleicht sind das auch Fehlschlüsse, da ich nicht weiß ob der 
Controller mitbekommt, wenn etwas nicht stimmt und vorsorglich alles 
abstellt.

Die Frage ist nun: Hatte so was schon mal jemand?
Habt ihr einen Verdächtigen? Was geht üblicherweise kaputt, was das sein 
könnte?
Was verlangt Miele/EGO für so eine Reparatur?

Herzlichen Dank für alle Antworten
Bitte einfach verlinken, wenn die Frage schon mal irgendwo geklärt 
wurde. Hier im Forum habe ich sie nicht gefunden.

MCMajus

von Der T. (Gast)


Lesenswert?

Ich würde jetzt primär auf die Versorgung tippen.
Wenn die Anzeige noch läuft, bedeutet das nicht zwangsmäßig, dass alle 
Spannungen ok sind..

von MCMajus (Gast)


Lesenswert?

Hallo,

danke für die sehr schnelle Antwort.
Auf welcher Seite? Von meiner Installation über die drei Phasen, Null 
und Erde oder schon auf der Platine?
Welches Bauteil könnte es dann sein?

Weiß jemand ob es da eine Sicherung gibt? Ich habe nur zwei leere Rahmen 
für Glas-Sicherungen entdeckt aber sonst keine...

Gruß

McMajus

von Der T. (Gast)


Lesenswert?

Mach mal hochauflösende und scharfe Fotos.
Evtl. können wir dann weiterhelfen..

von MCMajus (Gast)


Angehängte Dateien:

Lesenswert?

Hallo,

wie gewünscht ein Foto des Innenlebens. Ich hoffe dass es was hilft.

Gruß

MCMajus

von HabNix (Gast)


Lesenswert?

Ich kenne mich mit Herden zwar nicht aus, aber der Fehler dürfte im 
Schaltnetzteil liegen. Mindestens zwei Elkos sehen oben etwas deformiert 
aus z.B. C122.

MfG

von Der T. (Gast)


Lesenswert?

HabNix schrieb:
> Mindestens zwei Elkos sehen oben etwas deformiert aus z.B. C122.

Ja, die beiden haben auf jeden Fall "Bauchweh".. ;-)

von MCMajus (Gast)


Lesenswert?

Hallo,

habe ich auch gedacht, aber hängen die Herdplatten überhaupt am 
Schaltnetzteil oder nur der Rest der Elektronik? Weil an gegangen ist 
der Herd schon noch. Oder anders gefragt: Wenn das Schaltnetzteil die 
Platten tatsächlich versorgen würde und kaputt wäre, wer versorgt dann 
die Anzeigeelektronik?

Gruß

MCMajus

von Rufus Τ. F. (rufus) Benutzerseite


Lesenswert?

MCMajus schrieb:
> aber hängen die Herdplatten überhaupt am Schaltnetzteil

Nein, das tun sie nicht. Dieses Schaltnetzteilchen kann nicht 
ansatzweise die Leistung erzeugen, die die Herd"platten" umsetzen. Das 
sind ein par Kilowatt, das Netzteilchen da ist nur für ein paar Watt 
ausreichend, die nämlich, die für den Niederspannungsteil der 
Steuerelektronik erforderlich sind.

Das Schaltnetzteil besteht aus dem kleinen Übertrager mit rotem 
Kunststoffteil neben dem Anschluss für den Lüfter; die anderen 
Induktivitäen sind Netzfilter etc.

Zu jeder Koch"platte" gehen zwei Kabel - ein Flachbandkabel für die 
Steuerung und eine zweiadrige Leitung mit größerem Querschnitt, über die 
recht sicher Netzspannung transportiert wird.

von Der T. (Gast)


Lesenswert?

Und wenn die Steuerung nicht sauber/vollständig versorgt wird, können 
die Platten auch nicht eingeschaltet werden.. ;-)

von MCMajus (Gast)


Lesenswert?

Hallo,

eben, das dachte ich auch, dass das SNT zu klein ist. Wenn also das 
Schaltnetzteil kaputt wäre, wer versorgt dann die sieben Segment 
Anzeigen und die Reflexlichtschranken?

Meint ihr es reicht, die Kondensatoren zu tauschen? Ich trau mich nicht 
die Spannungen im laufenden Betrieb nachzumessen....


Gruß

McMajus

von hinz (Gast)


Lesenswert?

MCMajus schrieb:
> Meint ihr es reicht, die Kondensatoren zu tauschen?

Die Chancen stehen nicht schlecht.

von Rufus Τ. F. (rufus) Benutzerseite


Lesenswert?

MCMajus schrieb:
> Wenn also das Schaltnetzteil kaputt wäre, wer versorgt dann die sieben
> Segment Anzeigen und die Reflexlichtschranken?

Das Schaltnetzteil liefert möglicherweise mehr als nur eine Spannung, 
und ist eben nicht komplett hin, sondern nur teilweise.

von Der T. (Gast)


Lesenswert?

Nimm aber unbedingt schaltfeste Typen mit geringem ESR - und am besten 
auch gleich welche für 105°C.. :-)

Deine Chancen stehen gut, dass dies der ganze Fehler ist.

von hinz (Gast)


Lesenswert?

Der T. schrieb:
> Nimm aber unbedingt schaltfeste Typen mit geringem ESR - und am besten
> auch gleich welche für 105°C.. :-)

Meist sind Panasonic FR eine gute Wahl.

von oldeurope O. (Gast)


Lesenswert?

Wo bleibt denn jetzt das sonnst übliche
geplante  obsoleszenz  geschreie?

hinz schrieb:
> Panasonic FR eine gute Wahl.

Ich hoffe das auch mal.
Wissen tue ich das erst in einigen Jahren.

LG
old.

von MCMajus (Gast)


Angehängte Dateien:

Lesenswert?

Hallo,

vielen Dank für die Tipps.
Ich habe nun beide Kondensatoren ausgetauscht.
Beide waren 470uF /25V /105° Typen.
Leider hatte ich in meinem kleinen Bastlerlager nur Kondensatoren mit 
470uF /16V /105° - ich hätte (sofern das die Lösung gewesen wäre) 
selbstverständlich von der Spannung passende Elkos nachbestellt und dann 
eingebaut.

Leider besteht das Problem nach wie vor.
Zwar haben die alten Kondensatoren laut meinem Messgerät noch 150uF 
(sind also kaputt) - offenbar hat es aber noch etwas anderes erwischt.

Habt ihr noch eine Idee? Könnte es die 16V Typen gleich wieder zerstört 
haben?

Gruß
MCMajus

von hinz (Gast)


Lesenswert?

> Ich habe nun beide Kondensatoren ausgetauscht.
> Beide waren 470uF /25V /105° Typen.

Und laut Foto Yageo SJ.


> Leider hatte ich in meinem kleinen Bastlerlager nur Kondensatoren mit
> 470uF /16V /105° - ich hätte (sofern das die Lösung gewesen wäre)
> selbstverständlich von der Spannung passende Elkos nachbestellt und dann
> eingebaut.
>
> Leider besteht das Problem nach wie vor.
> Zwar haben die alten Kondensatoren laut meinem Messgerät noch 150uF
> (sind also kaputt) - offenbar hat es aber noch etwas anderes erwischt.
>
> Habt ihr noch eine Idee? Könnte es die 16V Typen gleich wieder zerstört
> haben?

Sie könnten von Anfang an einen zu hohen ESR haben.

Und 16V Typen einzubauen wo 25V Typen drin waren ist ohne Messung 
ziemlich leichtfertig.

von MCMajus (Gast)


Lesenswert?

Hallo,

ich weiß dass das leichtfertig ist. Aber ich dachte für einen ersten 
Test wird's schon reichen.

Aber wenn das die einzige Alternative ist, werde ich neue Bauteile 
bestellen und einbauen.

Sonst noch Anmerkungen?

Gruß
MCMajus

von G. H. (schufti)


Lesenswert?


: Bearbeitet durch User
von MCMajus (Gast)


Lesenswert?

+++GELÖST+++

Hallo,

herzlichen Dank euch allen. Es ist mir überaus peinlich, aber die Lösung 
ist mal wieder so dämlich, da habe ich viel zu kompliziert gedacht. Das 
PDF von  G. H. (schufti) war die entscheidende Lösung. Dort steht drin, 
dass der Herd einen Demo-Modus besitzt. Durch langes Drücken der 
Ein-Taste und der P-Taste kann man einstellen, dass der Herd nur so tut, 
als ob er funktionieren würde.

Warum der Modus drin ist, weiß ich nicht. Hier will's keiner gewesen 
sein (Vielleicht ist ein Bit getoggelt? Ich hätte allerdings gesichertes 
Speichern erwartet...). Jedenfalls wusste ich nicht mal, dass der Herd 
so einen völlig unsinnigen Modus (für Seriengeräte!) hat.

Nochmals herzlichen Dank

MCMajus

von andrer (Gast)


Lesenswert?

Bravo,
endlich mal jemand, der einen gelösten Fall beschreibt.

von hinz (Gast)


Lesenswert?

Du wirst dir aber noch geeignete Elkos besorgen?

von MCMajus (Gast)


Lesenswert?

Hallo,

hinz schrieb:
> Du wirst dir aber noch geeignete Elkos besorgen?
Klar werde ich das. Sonst habe ich den Ärger bald wieder.

Gruß
MCMajus

von hinz (Gast)


Lesenswert?

MCMajus schrieb:

>> Du wirst dir aber noch geeignete Elkos besorgen?

> Klar werde ich das. Sonst habe ich den Ärger bald wieder.

Dann nimm die erwähnten Panasonic FR, und besser mit mehr als 25V 
Spannungsfestigkeit, eben was mechanisch Platz hat. Die halten die 
Betriebsbedingungen dann auch deutlich länger durch.

von oldeurope O. (Gast)


Lesenswert?

hinz schrieb:
> besser mit mehr als 25V
> Spannungsfestigkeit, eben was mechanisch Platz hat. Die halten die
> Betriebsbedingungen dann auch deutlich länger durch.

Das stimmt nicht.

LG
old.

von hinz (Gast)


Lesenswert?

OXI T. schrieb:
> hinz schrieb:
>> besser mit mehr als 25V
>> Spannungsfestigkeit, eben was mechanisch Platz hat. Die halten die
>> Betriebsbedingungen dann auch deutlich länger durch.
>
> Das stimmt nicht.

Ach Darius, davon hast du doch keine Ahnung.

von oldeurope O. (Gast)


Lesenswert?

hinz schrieb:
> davon hast du doch keine Ahnung

Sagt wer?
Wenn ich Leute hinter die Fichte führen wollte,
würde ich auch als Gast und/oder mit verdeckter
Identität schreiben.

LG
old.

von hinz (Gast)


Lesenswert?

OXI T. schrieb:
> hinz schrieb:
>> davon hast du doch keine Ahnung
>
> Sagt wer?

Schon das Datenblatt.


> Wenn ich Leute hinter die Fichte führen wollte,
> würde ich auch als Gast und/oder mit verdeckter
> Identität schreiben.

Ja, deine Paranoia ist bekannt.

von Manfred (Gast)


Angehängte Dateien:

Lesenswert?

OXI T. schrieb:
> hinz schrieb:
>> besser mit mehr als 25V
>> Spannungsfestigkeit, eben was mechanisch Platz hat. Die halten die
>> Betriebsbedingungen dann auch deutlich länger durch.
>
> Das stimmt nicht.
Indirekt schon, je dicker, desto länger leben sie - sagt zumindest das 
Datenblatt.

von oldeurope O. (Gast)


Angehängte Dateien:

Lesenswert?

Manfred schrieb:
> Indirekt schon, je dicker, desto länger leben sie

Ich meine nicht, dass es einem Wechselstrom
beaufschlagtem Elko gut tut wenn er dauerhaft
mit einer, in Relation zur Nennspannung,
sehr viel kleineren Gleichspannung betrieben wird.

Das ist aber der Fall wenn Du der Dicke wegen eine
höhere Nennspannung wählst.

Wenn die Schaltung das erlaubt, solltest Du lieber
die Kapazität erhöhen und die Nennspannung verringern.

Sonnst halt reintun was drin war.

Der Yaego ist laut  Datenblatt  übrigens kein
schlechter Kondensator. Der Ausschnitt im Bild
kommt von:
www.yageo.com/exep/pages/download/literatures/E-cap_2011.pdf

LG
old.

von MM (Gast)


Lesenswert?

OXI T. schrieb:
> Ich meine nicht, dass es einem Wechselstrom
> beaufschlagtem Elko gut tut wenn er dauerhaft
> mit einer, in Relation zur Nennspannung,
> sehr viel kleineren Gleichspannung betrieben wird.

Eine Spannungsstufe höher zu gehen bewirkt in keinster Weise dein 
gedachtes (Horror-)Szenario. Für mehr Sprünge ist meistens sowieso kein 
Platz.

OXI T. schrieb:
> Wenn die Schaltung das erlaubt, solltest Du lieber
> die Kapazität erhöhen und die Nennspannung verringern.

Demzufolge (sorry) totaler Käse. Bei zuvielen µF greift dann der ADFC 
ein um Verschwendung zu verhindern.

OXI T. schrieb:
> Der Yaego ist laut  Datenblatt  übrigens kein
> schlechter Kondensator.

In der Praxis schon. Unterstes Mittelfeld circa.


Der ESR ist nun mal mehr Gehäusegrößen- als Kapazitäts-/ 
Spannungsabhängig. Das ein größeres Gehäuse bei gleicher Kapazität eine 
höhere Spannungsfestigkeit bietet lässt sich leider nicht verhindern. 
Bringt aber außer natürlich bei dir niemanden Nachteile.

von oldeurope O. (Gast)


Angehängte Dateien:

Lesenswert?

MM schrieb:
> OXI T. schrieb:
>> Ich meine nicht, dass es einem Wechselstrom
>> beaufschlagtem Elko gut tut wenn er dauerhaft
>> mit einer, in Relation zur Nennspannung,
>> sehr viel kleineren Gleichspannung betrieben wird.
>
> Eine Spannungsstufe höher zu gehen bewirkt in keinster Weise dein
> gedachtes (Horror-)Szenario. Für mehr Sprünge ist meistens sowieso kein
> Platz.

Wenn das Szenario mal nicht schon eingetreten ist.
Ich wäre jetzt gar nicht überrascht, wenn C122
für die 12V des Lüfters verantwortlich ist!

MM schrieb:
> OXI T. schrieb:
>> Wenn die Schaltung das erlaubt, solltest Du lieber
>> die Kapazität erhöhen und die Nennspannung verringern.
>
> totaler Käse.

Der Käse hat sich sehr gut bewährt. :-)

Im Bild:
Eine Reihenschaltung von Elkos hoher Kapazität
und niedriger Nennspannung auf der Sekundärseite
eines Schaltnetzteils.

LG
old.

von hmm (Gast)


Lesenswert?

OXI T. schrieb:
> Im Bild:
> Eine Reihenschaltung von Elkos hoher Kapazität
> und niedriger Nennspannung auf der Sekundärseite
> eines Schaltnetzteils.

Könnte das nicht auch der niedrigeren Bauhöhe geschuldet sein? :-)

von hinz (Gast)


Lesenswert?

hmm schrieb:
> OXI T. schrieb:
>> Im Bild:
>> Eine Reihenschaltung von Elkos hoher Kapazität
>> und niedriger Nennspannung auf der Sekundärseite
>> eines Schaltnetzteils.
>
> Könnte das nicht auch der niedrigeren Bauhöhe geschuldet sein? :-)

Nö, das sind Doppelschichtkondensatoren, ganz andere Baustelle.


Darius schwurbelt sich halt was zusammen wie er es lustig findet.

von MM (Gast)


Lesenswert?

OXI T. schrieb:
> Im Bild:
> Eine Reihenschaltung von Elkos hoher Kapazität
> und niedriger Nennspannung auf der Sekundärseite
> eines Schaltnetzteils.

Soll das der Beweis sein? Kapazitäten ohne µ gibt es nur in 
Reihenschaltung wenn die Spannung über dem Gebilde höher sein muss. Das 
ist bewährt weil es prinzipbedingt notwendig ist.

Schon mal einen 9V Block geöffnet? Da sind 6 Zellen in Reihe. Hat sich 
auch bewährt. Könnte aber auch daran liegen das eine Zelle nur 1,5 V 
bietet...

von Der T. (Gast)


Lesenswert?

MM schrieb:
> Schon mal einen 9V Block geöffnet? Da sind 6 Zellen in Reihe. Hat sich
> auch bewährt. Könnte aber auch daran liegen das eine Zelle nur 1,5 V
> bietet...

Ach komm schon - Du zerstörst ihm seine Illusion.. ;-)

von oldeurope O. (Gast)


Lesenswert?

Nachdem Ihr eine Nebelkerze nach der anderen
abgeschossen habt ...

OXI T. schrieb:
> MM schrieb:
>> OXI T. schrieb:
>>> Ich meine nicht, dass es einem Wechselstrom
>>> beaufschlagtem Elko gut tut wenn er dauerhaft
>>> mit einer, in Relation zur Nennspannung,
>>> sehr viel kleineren Gleichspannung betrieben wird.
>>
>> Eine Spannungsstufe höher zu gehen bewirkt in keinster Weise dein
>> gedachtes (Horror-)Szenario. Für mehr Sprünge ist meistens sowieso kein
>> Platz.
>
> Wenn das Szenario mal nicht schon eingetreten ist.
> Ich wäre jetzt gar nicht überrascht, wenn C122
> für die 12V des Lüfters verantwortlich ist!

Kann ja MCMajus mal messen wieviel Spannung an
C122 im Betrieb anliegt.

LG
old.

von hinz (Gast)


Lesenswert?

OXI T. schrieb:
> Nachdem Ihr eine Nebelkerze nach der anderen
> abgeschossen habt ...

War ja klar, dass du stur bei deinen Phantasien bleibst.


OXI T. schrieb:
> Kann ja MCMajus mal messen wieviel Spannung an
> C122 im Betrieb anliegt.

Ist jetzt nicht mehr nötig.

von oldeurope O. (Gast)


Lesenswert?

hinz schrieb:
> OXI T. schrieb:
>> Kann ja MCMajus mal messen wieviel Spannung an
>> C122 im Betrieb anliegt.
>
> Ist jetzt nicht mehr nötig.

Leute, schaut mal was geblähte Kondensatoren
für eine Nennspannung haben und mit welcher
Spannung sie betrieben werden.
Ich habe meine Schlüsse daraus gezogen und sage
das auch, egal wie hier die Trolle poltern.

LG
old.

von MM (Gast)


Lesenswert?

OXI T. schrieb:
> Leute, schaut mal was geblähte Kondensatoren
> für eine Nennspannung haben und mit welcher
> Spannung sie betrieben werden.

Jeder, wirklich jeder Elko muss mit Unterspannung betrieben werden. Der 
aufgedruckte Wert ist das absolute Maximum. Die Elkos werden nicht 
mangels Spannung schwanger, sondern aufgrund von zuviel Wärme. Kennt man 
aus der Ehe - viel Streit = Kinderlos.

> Ich habe meine Schlüsse daraus gezogen und sage
> das auch, egal wie hier die Trolle poltern.

Der Herd tut schon lange wieder. Bist du da nicht der trotzige Troll?

Du kannst deine Schlüsse ziehen wie du magst. Aber deine Irrungen 
solltest du bitte nicht als Weisheiten verbreiten, sondern daraus 
versuchen zu lernen.

von oldeurope O. (Gast)


Lesenswert?

MM schrieb:
> Jeder, wirklich jeder Elko muss mit Unterspannung betrieben werden.

16V Elko an 12V gut.
25V Elko an 12V nicht gut.

Aber das willst Du nicht kapieren.

LG
old.

von MM (Gast)


Lesenswert?

OXI T. schrieb:
> Aber das willst Du nicht kapieren.

Das dein Käse Käse ist kapiert sich recht einfach.

Du machst es einem wirklich nicht einfach bei dir Fachwissen zu 
entdecken.

von hinz (Gast)


Lesenswert?

MM schrieb:
> OXI T. schrieb:
>> Aber das willst Du nicht kapieren.
>
> Das dein Käse Käse ist kapiert sich recht einfach.

Limburger

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.