Forum: Analoge Elektronik und Schaltungstechnik Spannungsversorgung über Spannungsregler


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Marie A. (marie27)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute _:)

Ich habe vor kurzen eine Spannungsversorgung gebaut, die soll die 
Eingangssignalspannung DC 12V aud 5V und auf der nächsten Klemme auf 
3,3V heruntersetzen.
Ich habe die Schaltung jetzt aufgebaut leider ohne den gewünschten 
Ergebnis.

Kann mir jeman sagen, ob da an meinen Schaltplan etwas nicht in Ordnung 
ist?

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Marie A. schrieb:
> Ich habe die Schaltung jetzt aufgebaut
Wie wurde die aufgebaut? Lochraster? Steckbrett?

> leider ohne den gewünschten Ergebnis.
Sondern? Was passiert? Welche Spannungen kannst du messen?

> Kann mir jeman sagen, ob da an meinen Schaltplan etwas nicht in Ordnung
> ist?
Der ist abgesehen von den teils fehlenden Bauteilwerten tadellos in 
Ordnung. Das ist ja letztlich nur die Schlatung von Seite 1 des 
Datenblatts...

von Georg (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Marie A. schrieb:
> Kann mir jeman sagen, ob da an meinen Schaltplan etwas nicht in Ordnung
> ist?

Da ist alles ok, ich würde nur die LED1 mit weniger Strom betreiben, 
wenn du nicht gerade 20 Jahre alte LEDs aus der Bastelkiste verwenden 
willst.

A passende Spule?

B entspricht der Aufbau tatsächlich dem Schaltplan, und sind die 
Verbindungen kurz?

Georg

von Marie A. (marie27)


Bewertung
0 lesenswert
nicht lesenswert
Ich benutze die Spule
BOURNS  SRF1280A-3R3Y  Induktivität, gekoppelt, 3.3µH, 30%, 0.011 Ohm, 
10.4A, 12.5mm x 12.5mm x 8mm

Am Ausgang der Spannungsreglers habe ich komischer weise gleiche 
Spannung wie am Eingang d.h. sogar über die erwarteten +5V.

Der Aufbau entspricht dem Schaltplan. (Es wurde mit Eagle eine Platine 
gefertigt)


Danke im Voraus! :)

von Andreas S. (Firma: Schweigstill IT) (schweigstill) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Marie A. schrieb:
> 3.3µH

Und da haben wir schon das erste Problem gefunden...

Laut Beschreibung willst Du die Schaltung mit 12V und laut Schaltplan 
mit 9V versorgen.

Was soll denn überhaupt eine "Shotkay"-Diode sein? Welchen Typ hast Du 
denn da eingesetzt?

von Stephan (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Andreas S. schrieb:
> Und da haben wir schon das erste Problem gefunden...

Ja, Dimensionen und Typen würden helfen. Und auch ein Bild vom Layout.

3,3µH sind jedenfalls deutlich zu wenig. Im Datenblatt gibt's glaub ich 
gar kein Szenario unter 22µH.

von Marie A. (marie27)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
1.Spannungsregler:
1)
PMIC - Spannungsregler - DC/DC-Schaltregler Texas Instruments 
LM2596S-ADJ/NOPB Halterung TO-263-5

2)
Spannungsregler - Linear, Typ78 STMicroelectronics LD1117V33 TO-220 
Positiv Fest 3.3 V 800 mA

3)
Schottky-Diode - Gleichrichter STMicroelectronics 1N5822 DO-201AD 40 V 
Einzeln

4)Spule:
BOURNS  SRF1280A-3R3Y  Induktivität, gekoppelt, 3.3µH, 30%, 0.011 Ohm,
10.4A, 12.5mm x 12.5mm x 8mm

von Andreas S. (Firma: Schweigstill IT) (schweigstill) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Das Layout ist eine völlige Katastrophe mit riesigen Schleifen und einer 
ungünstigen Masseführung. Es wäre wesentlich sinnvoller gewesen, das 
große Massepad des LM2596S auch mit dem GND-Signal zu verbinden und das 
ganze in eine einigermaßen große Massefläche zu integrieren.

Hast Du etwa nicht die Layouthinweise von National bzw. TI angeschaut?

von Thomas E. (picalic)


Bewertung
0 lesenswert
nicht lesenswert
Andreas S. schrieb:
> und das
> ganze in eine einigermaßen große Massefläche zu integrieren.

Ich vermute, daß die gepunktete Linie am Rand die Massefläche umspannt 
(beidseitig?). Ist hier nur nicht zu sehen, weil sie nicht ausgefüllt 
dargestellt ist.

von MaWin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Andreas S. schrieb:
> Das Layout ist eine völlige Katastrophe

?!?

Schlechten Tag gehabt?

von Andreas S. (Firma: Schweigstill IT) (schweigstill) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
MaWin schrieb:
> Schlechten Tag gehabt?

Nein.

von René H. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Thomas E. schrieb:
> Andreas S. schrieb:
> und das
> ganze in eine einigermaßen große Massefläche zu integrieren.
>
> Ich vermute, daß die gepunktete Linie am Rand die Massefläche umspannt
> (beidseitig?). Ist hier nur nicht zu sehen, weil sie nicht ausgefüllt
> dargestellt ist.

Ich denke Du vermutest richtig :)

Grüsse,
René

von Marie A. (marie27)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So ist es denke ich besser

von Andreas S. (Firma: Schweigstill IT) (schweigstill) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Dummerweise sind aber weder die obere noch untere Massefläche überhaupt 
mit GND verbunden.

von Marie A. (marie27)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich verstehe das nicht :/

Ich habe doch die GNDs alle miteinander verbunden.
Außerdem, wenn der Schaltplan richtig ist, da müssen auch die 
Verbindungen auf dem Layer richtig sein.

Was soll ich auf meinen Layer anders machen?

: Bearbeitet durch User
von Luca E. (derlucae98)


Bewertung
0 lesenswert
nicht lesenswert
Marie A. schrieb:
> Ich habe doch die GNDs alle miteinander verbunden.

Du musst deinem Massepolygon natürlich auch den Namen "GND" geben.

von Andreas I. (andy5macht)


Bewertung
0 lesenswert
nicht lesenswert
Allgemein bekannt ist, dass DCDC Wandler im Vergleich zu Linearregler 
ein ordentliches Layout erfordern. Nichtsdestotrotz ist die Drossel um 
den Faktor 10 zu klein Dimensioniert (3,3µH => 33µH) aber das wurde 
beides bereits angesprochen.

von Marie A. (marie27)


Bewertung
0 lesenswert
nicht lesenswert
Das Massepolygon hat den Namen GND schon bekommen. :)

Also ist die Spule eigentlich der Grund, warum es nicht funktioniert.

von Stephan (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Marie A. schrieb:
> PMIC - Spannungsregler - DC/DC-Schaltregler Texas Instruments
> LM2596S-ADJ/NOPB Halterung TO-263-5

Wenn es der Einstellbare (ADJ) ist fehlt auch der Widerstand für den 
Spannungsteiler (7,6k) zwischen Feedback und Pufferkondensator.
Ohne den dürften es nur 1,2V am Ausgang sein.

Die Spule ist auf jeden Fall zu klein und das Layout "nicht schön".

Wie hoch ist die Eingangsspannung und die gemessene Ausgangsspannung an 
C4?
Hast du ein Oszi?

von Marie A. (marie27)


Bewertung
0 lesenswert
nicht lesenswert
Ich habe gerade eine Spule
"Induktivität radial bedrahtet Rastermaß 5 mm 22 mH 0.07 A Fastron 
11P-223K-50 1 St" installiert.
Am Eingang gebe ich eine Spannung von 10,5V.
Am Ausgang bekommen ich wo 5V am Ausgang sein sollten bloß eine Spannung 
von 1,5V.

(Mit OSZI gemessen)

: Bearbeitet durch User
von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Marie A. schrieb:
> 22 mH 0.07 A

Die ist nicht nur in der Induktivität um Faktor 700 zu hoch, sondern 
auch nur für sehr wenig Strom gedacht, sie ist also ein heftiger 
Widerstand.
Geeignet wären 33µH-47µH Speicherdrosseln, die bis zu 2A tragen können.
Z.B.
http://www.reichelt.de/Fest-Induktivitaeten-radial/L-07HCP-33-/3/index.html?ACTION=3&LA=2&ARTICLE=86400
oder
http://www.reichelt.de/Fest-Induktivitaeten-radial/L-07HCP-47-/3/index.html?ACTION=3&LA=2&ARTICLE=86401

: Bearbeitet durch User
von Marie A. (marie27)


Bewertung
0 lesenswert
nicht lesenswert
Stephan schrieb:
> Marie A. schrieb:
>> PMIC - Spannungsregler - DC/DC-Schaltregler Texas Instruments
>> LM2596S-ADJ/NOPB Halterung TO-263-5
>
> Wenn es der Einstellbare (ADJ) ist fehlt auch der Widerstand für den
> Spannungsteiler (7,6k) zwischen Feedback und Pufferkondensator.
> Ohne den dürften es nur 1,2V am Ausgang sein.
>
> Die Spule ist auf jeden Fall zu klein und das Layout "nicht schön".
>
> Wie hoch ist die Eingangsspannung und die gemessene Ausgangsspannung an
> C4?
> Hast du ein Oszi?

Habe jetzt die richtige Spule :).
Ich bekomme wie du schon geschrieben hast eine Spannung von 1,2V am 
Ausgang. Diese Spannung ist auch am Kondensator C4.
D.h. ich muss zwischen C4 und Kanal 4 (Feedback) einen Wiederstand von 
7,6k einsetzen??

von Manfred (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Marie A. schrieb:
> Ich bekomme wie du schon geschrieben hast eine Spannung von 1,2V am
> Ausgang. Diese Spannung ist auch am Kondensator C4.
> D.h. ich muss zwischen C4 und Kanal 4 (Feedback) einen Wiederstand von
> 7,6k einsetzen??
WiEderstand, autsch !

Nein! Du musst einen Teiler verwenden, in dem hier aus dem Forum 
verlinkten TI-Datenblatt in Bild 35 auf Seite 26.

Der FB-Eingang ist hochohmig, also z.B. 1k nach GND und 3k1 vom Ausgang. 
Ich würde oben einen 3k3 einbauen und mir den genauen Wert durch 
Parallelschalten eines weiteren Widerstandes abgleichen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.