Forum: Analoge Elektronik und Schaltungstechnik Simulation zeigt das Gegenteil der Praxis


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Dan B. (treki)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich verstehe nichts mehr.
Die abgebildete Schaltung läuft in der Simulation korrekt.
Nur in der Praxis nicht. Muss Collector und Emitter tauschen, damit es 
richtig läuft.
Habe hier einen einfachen Serie-Transistor. Wobei ich die negative 
Halbwelle gebrauche.!
Den Rest der Schaltung hab ich rausgeschnitten!
Simulation ist in LTspice.
Gerne hätte ich die Frage in meinem Forum gestellt (ltspiceusers.ch). 
Leider läuft da nicht so viel :(
Warum zeigt mir die Simulation das, was ich mir menschlich im Gehirn 
ausgedacht habe und die Praxis ist anders?

: Verschoben durch Moderator
von hp-freund (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Moin,
Du bist ja nicht der Erste der sich das ausgedacht hat:

http://circuitswiring.com/circuit-diagrams/24/uploads/allimg/100606/103625C37-0.gif

Stimmt mit dem Transistor etwas nicht? Andere Anschlussbelegung, 
Hersteller oder Typ?

von Dan B. (treki)


Bewertung
0 lesenswert
nicht lesenswert
Hab den Typ ja angehängt. Pin Belegung sollte stimmen...oder nicht?
Hab auch mit LTspice integrierten Typen getestet: Gleiches Resultat

von hp-freund (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich meine den realen Transistor.
Die Simulation passt ja.

von Dan B. (treki)


Bewertung
0 lesenswert
nicht lesenswert
Wie jetzt?
Zusammengelötet funzt es nur, wenn C & E getauscht sind.

von hp-freund (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ist doch aber falsch herum.
Ist ein Kühlkörper dran und wenn, hat der Kontakt mit irgend etwas?

von Dan B. (treki)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Genau das ist ja mein Problem!
Die Simulation zeigt nicht die Realität!
Temperatur/Zeit hab ich nicht in die Simulation integriert. Also egal.
Blöd ist, dass die Basis nicht in der Mitte ist. So wird ein physisches 
Umdrehen schwierig.

: Bearbeitet durch User
von Dumdi D. (dumdidum)


Bewertung
0 lesenswert
nicht lesenswert
steht auf dem echten transistor 3055?

von Wolfgang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Dan B. schrieb:
> Die Simulation zeigt nicht die Realität!

Die Realität zeigt nur ein Photo vom Aufbau

von Wolfgang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Dumdi D. schrieb:
> steht auf dem echten transistor 3055?

Dann wäre es kein MJE2955T, wie in der Simulation :-(

von Dan B. (treki)


Bewertung
0 lesenswert
nicht lesenswert
Wenn Ihr Zeit findet, probiert es aus!

von Dumdi D. (dumdidum)


Bewertung
0 lesenswert
nicht lesenswert
Wolfgang schrieb:
> Dann wäre es kein MJE2955T, wie in der Simulation :-(

Genau das würde ich ja gerne deswegen überprüft wissen.

von hp-freund (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Was passiert wenn Du in der Simulation den Generator, der mit + und - 
gekennzeichnet ist umdrehst?

von Dan B. (treki)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Foto!

von Dan B. (treki)


Bewertung
0 lesenswert
nicht lesenswert
hp-freund schrieb:
> Was passiert wenn Du in der Simulation den Generator, der mit + und -
> gekennzeichnet ist umdrehst?

Habe ja ein Wechselstrom Generator

von hp-freund (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Kannst es aber probieren, wenn die Simulation falsch ist.

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Dan B. schrieb:
> Den Rest der Schaltung hab ich rausgeschnitten!
Welchen "Rest"? Der, der.in der Realität verbaut ist?

> Warum zeigt mir die Simulation das, was ich mir menschlich im Gehirn
> ausgedacht habe und die Praxis ist anders?
Was ist das für ein Generator?  Ist der wirklich richtig modelliert?

Dan B. schrieb:
> Die Simulation zeigt nicht die Realität!
Dann zeig doch mal die Realität. Also einfach die ganze Schaltung.

BTW: probier doch mal, in der Simulation C und E zu tauschen. Und einen 
NPN Transistor zu nehmen. Denn so, wie jetzt gezeichnet, ist die 
Schaltung sinnlos.

von Helmut S. (helmuts)


Bewertung
0 lesenswert
nicht lesenswert
Vielleicht ist ja der Transistor schon kaputt wegen fehlender Kühlung.
Die Idee der Schaltung ist es -12V Ausgamgsspannung zu bekommen. Die 
Differenzspannung Eingangsspannung minus 12V fällt dabei am Transistor 
(Uce) ab.

I = 12V/30Ohm = 0,4A

P = I*(Uein-Uce)

Da kommen schon 4W zusammen. Das geht nur mit Kühlkörper.

von Dan B. (treki)


Bewertung
0 lesenswert
nicht lesenswert
Lothar M. schrieb:
> Dan B. schrieb:
>> Den Rest der Schaltung hab ich rausgeschnitten!
> Welchen "Rest"? Der, der.in der Realität verbaut ist?
>
>> Warum zeigt mir die Simulation das, was ich mir menschlich im Gehirn
>> ausgedacht habe und die Praxis ist anders?
> Was ist das für ein Generator?  Ist der wirklich richtig modelliert?
>
> Dan B. schrieb:
>> Die Simulation zeigt nicht die Realität!
> Dann zeig doch mal die Realität. Also einfach die ganze Schaltung.
>
> BTW: probier doch mal, in der Simulation C und E zu tauschen. Und einen
> NPN Transistor zu nehmen. Denn so, wie jetzt gezeichnet, ist die
> Schaltung sinnlos.

Hatte die Schaltung nach der Simulation gebaut.
0 Erfolg.
Habe dann C E getauscht. Funzt.
Ich nehme die negative Halbwelle (siehst im Schema), darum pnp und zener 
invers.
Ist recht verwirrend, wenn die Masse positiver sein kann als der "Plus"

: Bearbeitet durch User
von Dan B. (treki)


Bewertung
0 lesenswert
nicht lesenswert
Helmut S. schrieb:
> Vielleicht ist ja der Transistor schon kaputt wegen fehlender Kühlung.
> Die Idee der Schaltung ist es -12V Ausgamgsspannung zu bekommen. Die
> Differenzspannung Eingangsspannung minus 12V fällt dabei am Transistor
> (Uce) ab.
>
> I = 12V/30Ohm = 0,4A
>
> P = I*(Uein-Uce)
>
> Da kommen schon 4W zusammen. Das geht nur mit Kühlkörper.

Habe das Ganze ohne Last getestet.
Der Transistor ist also ok.

@Helmut: Wäre schön, wenn Du wieder kämest!

: Bearbeitet durch User
von voltwide (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Lothar M. schrieb:
> BTW: probier doch mal, in der Simulation C und E zu tauschen. Und einen
> NPN Transistor zu nehmen. Denn so, wie jetzt gezeichnet, ist die
> Schaltung sinnlos.

Die Simulationsschaltung liefert die neg Halbwellen, spannungsbegrenzt.
Das zeigt ja auch der plot. Was ist daran bitte sinnlos?

von Paul B. (paul_baumann)


Bewertung
-1 lesenswert
nicht lesenswert
Dan B. schrieb:
> @Helmut: Wäre schön, wenn Du wieder kämest!

https://www.youtube.com/watch?v=kSYblBKZ75Y

von Dan B. (treki)


Bewertung
0 lesenswert
nicht lesenswert
Dan B. schrieb:
>>> Den Rest der Schaltung hab ich rausgeschnitten!
>> Welchen "Rest"? Der, der.in der Realität verbaut ist?

Der andere Pfad, welcher die positive Halbwelle nimmt ^^

von Dan B. (treki)


Bewertung
0 lesenswert
nicht lesenswert
Paul B. schrieb:
> Dan B. schrieb:
>> @Helmut: Wäre schön, wenn Du wieder kämest!
>
> https://www.youtube.com/watch?v=kSYblBKZ75Y

Helmut Sennewald. Hab ihn wohl erbost. Aber ein MUSS für mein Forum wäre 
er!

Zumal auch mein Englisch zu wünschen übrig lässt.

Nichts desto Trotz....ich glaube, die Simulation macht einen Fehler, 
oder das Datasheet ist falsch.

Lötet das Ding mal zusammen. Ihr werdet sehn!
123 = BCE

: Bearbeitet durch User
von Paul B. (paul_baumann)


Bewertung
0 lesenswert
nicht lesenswert
Dan B. schrieb:
> Nichts desto Trotz....ich glaube, die Simulation macht einen Fehler,
> oder das Datasheet ist falsch.
>
> Lötet das Ding mal zusammen. Ihr werdet sehn!

Ich löte die Dinger immer zusammen, weil mir das Vertrauen in 
Simulationen fehlt. Insbesondere solche Schaltungen mit wenigen 
Bauelementen sind schneller aufgebaut als die Simulation auf dem Rechner 
zusammengestellt ist.

MfG Paul

von Lurchi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Die meisten Transistoren funktionieren auch noch mit Einschränkungen 
wenn man Emitter und Collektor vertauscht. Die Schaltung sollte auch 
funktionieren wenn der Transistor richtig herum drin ist - nur nicht mit 
kalten Lötstellen.

Und natürlich sollte man nicht erwarten dass die Schaltung als GPS 
Störsender oder Tester für Rauchmelder funktioniert.

von Dan B. (treki)


Bewertung
0 lesenswert
nicht lesenswert
Vielleicht hat ja jemand zeit und Interesse, die Schaltung zusammen zu 
löten.
Zugegeben: Im Labor hab ich das Ganze ohne Last getestet.

: Bearbeitet durch User
von Dan B. (treki)


Bewertung
0 lesenswert
nicht lesenswert
Dan B. schrieb:
>>> Den Rest der Schaltung hab ich rausgeschnitten!
>> Welchen "Rest"? Der, der.in der Realität verbaut ist?

Hier die ganze Schaltung: 
http://www.ltspiceusers.ch/showthread.php?t=228

von Thomas E. (picalic)


Bewertung
0 lesenswert
nicht lesenswert
Dan B. schrieb:
> Hier die ganze Schaltung:
> http://www.ltspiceusers.ch/showthread.php?t=228

Ich melde mich nicht in dem Forum an, nur um Deine Schaltung zu sehen! 
Poste das bitte hier!

von Dan B. (treki)


Angehängte Dateien:

Bewertung
-2 lesenswert
nicht lesenswert
Hier bitte sehr:
Ist eine "nur-idee".
Brauche die positive Halbwelle für den 2A USB (5V)
Die negative für die Beleuchtung (sparsame LED 12V).
Das Problem ist: Der Mofa-Dynamo liefert max 17W, wobei die 6V 
Lichtspule gegen eine 12V getauscht wurde.
Bild 1 = Vollgas
Bild 2 = Die gemessenen Kurven an einem original 6V Generator (wobei NUR 
die oberste Tabelle aussagekräftig ist)
Plan B ist: https://www.pololu.com/product/2574

Ich melde mich nicht in dem Forum an, nur um Deine Schaltung zu sehen!
Poste das bitte hier!
@Dan B:
Naja, warum nicht? Wirst null gespammt. Hat auch 0 Werbung!

: Bearbeitet durch User
von karadur (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ohne Last fließt kein Strom über die Basis-Emitter-Strecke.

Voltmeter ist zu hochohmig.

von Dan B. (treki)


Bewertung
0 lesenswert
nicht lesenswert
Gute Idee. Aber in der Praxis läuft die Schaltung mit E>C Reihenfolge.
Werde aber das nochmal genauer prüfen.

von Thomas E. (picalic)


Bewertung
0 lesenswert
nicht lesenswert
Dan B. schrieb:
> Naja, warum nicht? Wirst null gespammt. Hat auch 0 Werbung!

Ja, vielleicht mache ich das sogar - fand es halt in dem Moment etwas 
blöd, den Link zu klicken und da nur zum Anschauen eines 
Briefmarkengroßen Vorschaubildes berechtigt zu sein.

Die erwähnten Bilder vom realen Aufbau bzw. dessen Messwerten (Bild 1, 
Bild 2) sind offenbar noch nicht korrekt!

: Bearbeitet durch User
von karadur (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Mit falscher Folge E-C wirst du die Basisspannung über die B-C-Diode 
messen.  Mit kleiner Last wird das über die 400R auch gehen.

von Thomas E. (picalic)


Bewertung
0 lesenswert
nicht lesenswert
karadur schrieb:
> Ohne Last fließt kein Strom über die Basis-Emitter-Strecke.

Das ist Quatsch - wenn C4 noch nicht geladen ist, fießt auch Strom. Es 
braucht keine Last, um am Ausgang ca. 12V zu sehen.

von karadur (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ist der real auch vorhanden ?

von B e r n d W. (smiley46)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich beziehe mich auf die erste Schaltung ganz oben. Einzelne Exemplare 
dieses Transistors haben ein Hfe von nur 20! Es würden bei -12V 
Ausgangsspannung impulsförmige Ströme mit -2A peak fließen.Der 
Transistor benötigt dabei eine Ansteuerung von 100mA, was jedoch der 
R1=400 Ohm nicht liefern kann. Probiers mal mit R1=100 Ohm. Alternativ 
könntest du einen Darlington Transistor verwenden.

Gruß, Bernd

von Thomas E. (picalic)


Bewertung
0 lesenswert
nicht lesenswert
Unabhängig davon würde ich vorschlagen, noch eine Diode (1N4148 reicht) 
antiparallel zu BE des Transistors zu schalten, sonst könnte durch 
Rückwärtsstrom von D1 die maximale Emitter-Basis-Spannung von Q1 (=5V) 
überschritten werden!

von Dan B. (treki)


Bewertung
0 lesenswert
nicht lesenswert
Werde die Tage mal die Vorschläge testen.
Gebe dann Feedback.
Danke schon mal an alle.

von Dan B. (treki)


Bewertung
0 lesenswert
nicht lesenswert
So, habe das Ganze nochmal auf dem Testboard zusammen gesteckt.
Jetzt funzt alles wie in der Simulation. Ob 100 oder 400 Ohm Widerstand 
spielt keine Rolle.
Habe zum Testen eine Glühlampe als Last angehängt.
Keine Ahnung, warum der andere Transistor sowas Komisches machte.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.