Forum: Mikrocontroller und Digitale Elektronik Netzteil, regelbar über µC-PWM-Signal, Spannungsschritte zu gross


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von schüler (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Tag,

ich habe folgende Schaltung aufgebaut, und ein Problem festgestellt.

PWM Tastgard 'a' geht von 0 bis 1 mit 0,01 Schritten (gesteuert durch 
Arduino)

Bis Tastgrad = 0,12 passiert nichts, an der Last liegt keine Spannung 
an.
Bei Schritten 0,13 ; 0,14 springt die Spannung auf 30V bzw 80V hoch.

Ab 80V is die Spannung sehr gut und wie gewünscht regelbar mit 5 - 7V 
Schritten.

Ich dachte zunächst MOSFET schaltet nicht richtig durch, bei so kleiner 
Schaltdauer. Die Widerstände R2 und R3 habe ich auf 10 KOhm (10Watt) und 
300 Ohm verkleinert, mit der Hoffnung dass, während kleiner Schaltdauer 
ausreichend Ladung an MOSFET geschickt wird, war leider nicht der Fall, 
Problem ist geblieben wie es war.

Kann was an Optokoppler liegen?
Oder Soll ich mit Schaltfrequenz "spielen".
Leider habe ich keine weiteren Ideen zu meine Problem.

von Falk B. (falk)


Bewertung
0 lesenswert
nicht lesenswert
@schüler (Gast)

>ich habe folgende Schaltung aufgebaut, und ein Problem festgestellt.

Das soll das werden? Das ist KEIN regelbares Netzteil, eher Murks.

>PWM Tastgard 'a' geht von 0 bis 1 mit 0,01 Schritten (gesteuert durch
>Arduino)

Hast du das mal mit dem Oszi gemessen? Und zwar an ALLEN relavanten 
Punkten in der Signalkette. Arduino-Ausgang und MOSFET-Gate?

>Bei Schritten 0,13 ; 0,14 springt die Spannung auf 30V bzw 80V hoch.

>Ab 80V is die Spannung sehr gut und wie gewünscht regelbar mit 5 - 7V
>Schritten.


>Ich dachte zunächst MOSFET schaltet nicht richtig durch, bei so kleiner
>Schaltdauer. Die Widerstände R2 und R3 habe ich auf 10 KOhm (10Watt) und
>300 Ohm verkleinert,

AUA!

>Kann was an Optokoppler liegen?

Ja. Aber auch an deiner merkwürdigen Schaltung.

>Oder Soll ich mit Schaltfrequenz "spielen".
>Leider habe ich keine weiteren Ideen zu meine Problem.

MESSEN!

von schüler (Gast)


Bewertung
0 lesenswert
nicht lesenswert
die Gate-Spannung am MOSFET habe ich gemessen, erscheint erst ab a=0,13
-> verstehe es so, dass Opto bis dahin nicht mitgeht.

Falk B. schrieb:
> Ja. Aber auch an deiner merkwürdigen Schaltung.

Was ist genau an der Schaltung merkwürdig? Bitte genauer

P.S danke für hilfreiche Kritik

von Michael B. (laberkopp)


Bewertung
0 lesenswert
nicht lesenswert
schüler schrieb:
> ich habe folgende Schaltung aufgebaut

Was bitte soll die Schaltung machen ?

Sie ist KEIN linear regelbares Netzteil.

Sie gibt die PWM Impulse des Arguino an den MOSFET weiter, und der 
schaltet entsprechend kurz ein.

Das funktioniert auch bei deiner Frqequenz, die Aufladezeit zum 
Einschalten ist ca. 0.2us und die Entladezeit durch die 2k ungefähr 2us.

Du misst also keine Gleichspannung, sondern gepulste Spannung, die dein 
Messgerät wohl nicht anzeigen kann.

von schüler (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Michael B. schrieb:
> Sie ist KEIN linear regelbares Netzteil.
>
> Sie gibt die PWM Impulse des Arguino an den MOSFET weiter, und der
> schaltet entsprechend kurz ein.

Das ist mir auch klar.

Michael B. schrieb:
> Du misst also keine Gleichspannung, sondern gepulste Spannung, die dein
> Messgerät wohl nicht anzeigen kann.

Ich messe mit Oszi.

von Michael B. (laberkopp)


Bewertung
0 lesenswert
nicht lesenswert
schüler schrieb:
> Ich messe mit Oszi.

Dann miss auch mal die Spannung am Gate, ob die den Impulsen des Arduino 
folgt.

von schüler (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Michael B. schrieb:
> Dann miss auch mal die Spannung am Gate, ob die den Impulsen des Arduino
> folgt.

schüler schrieb:
> die Gate-Spannung am MOSFET habe ich gemessen, erscheint erst ab a=0,13
> -> verstehe es so, dass Opto bis dahin nicht mitgeht.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.