mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik OP liefert ständig Offset-Spannung


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Elektronix (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich möchte einen einfachen Verstärker basteln der mein Signal um den 
Faktor 3 verstärkt. Ich hatte noch einen LM741 zur Hand weswegen ich 
diesen dann verwendet habe. Ich habe den Verstärker dazu in 
Grundbeschaltung für einen nicht invertierenden Verstärker beschaltet 
(siehe Anhang aus TI Datasheet). Ich betreibe den OP im Single-Supply 
Betrieb mit +12V und 0V, R2 hat 10k Ohm und R1 5k Ohm. Die Simulation in 
LTSpice lief wunderbar, daraufhin habe ich den OP direkt auf eine 
Platine gebastelt und verlötet, kann ja nichts schiefgehen dachte ich. 
Komischerweise erhalte ich am Ausgang eine Spannung von 5,6V obwohl ich 
am Eingang kein Signal angelegt habe, auch beim Anlegen von 0V erhalte 
ich 5,6V. Die Spannung zwischen R1 und R2 beträgt dabei 1,9V. Beim 
Anlegen einer höheren Spannung entsprechend mehr. Ich habe den OP auch 
schon durch einen TL081 ersetzt, gleiches Ergebnis. Daraufhin habe ich 
das ganze auf einem Steckbrett aufgebaut, wieder gleiches Ergebnis. Ich 
zweifle so langsam echt an mir selbst, habe ich irgend etwas übersehen? 
Die OPs haben jeweils noch Null-Offset Eingänge, jedoch weiß ich nicht 
ob mir das weiterhilft :/ ich habe dort bereits 0V und die 1,9V 
angelegt, jedoch ohne Ergebnis. Ich hoffe jemand sieht meinen Fehler und 
kann mir helfen..

Vielen Dank vorab!

von mal überlegen... (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Datenblatt lesen: erkennen das der Ruhezustand eines OPV normalerweise 
in der Mitte der Betriebsspannung liegt sowie die Aussteuerbarkeit des 
OPV-Ausganges gewissen Grenzen unterliegt.

von mal überlegen... (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Die Eingänge mögen natürlich auch nicht immer den vollen 
Spannungsbereich um wie erwartet zu reagieren.

von Elektronix (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für deine Antwort, sowas hatte ich auch schon vermutet, 
allerdings steht im Datenblatt explizit, dass ein Single-Supply Betrieb 
möglich ist?

von Der Andere (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ziemlich suboptimal, wenn man mit symmetrischer Versorgungsspannung 
simuliert (siehe Schaltplan) und dann aysmmetrisch versorgt.
Der 741 ist kein Rail to Rail OP. Wenn du seine negative Versorgung auf 
Masse legst, dann ist die niedrigste nutzbare Spannung der Eingänge und 
des Ausgangs 1-3V über der negativen Versorgung also in deinem Fall über 
Masse (=0V).

Schau dir das Datenblatt an. z.B. 
http://www.ti.com/lit/ds/symlink/lm741.pdf
Tabelle 6.5 "Input voltage range" und "Output voltage swing" bei einer 
Versorgung von +-15V.

von Der Andere (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Elektronix schrieb:
> allerdings steht im Datenblatt explizit, dass ein Single-Supply Betrieb
> möglich ist?

Verstehe ich nicht.

von mal überlegen... (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Elektronix schrieb:
> allerdings steht im Datenblatt explizit, dass ein Single-Supply Betrieb
> möglich ist?

Das ändert nichts an den Rahmenbedingungen zur Aussteuerbarkeit. Der OPV 
weiß nichts von Single- oder Dual-Speisung und kann sich mit Abstrichen 
nur innerhalb des Potentialunterschiedes seiner Versorgungsanschlüsse 
bewegen.

von Elektronix (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Siehe Anhang. Ich haben außerdem auch asymmetrisch simuliert, allerdings 
mit einem anderen Modell. Aber da im Datenblatt eben Stand, dass 
Single-Supply möglich ist, bin ich davon ausgegangen dass es 
funktioniert. Ich habe auch schon OPs in dieser Konfiguration betrieben.

Das heißt ich muss wohl nach einem anderen OP schauen oder eine passende 
Spannungsversorgung bereitstellen :/

von mal überlegen... (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Elektronix schrieb:
> Das heißt ich muss wohl nach einem anderen OP schauen oder eine passende
> Spannungsversorgung bereitstellen :/

Ja, das ist die Schlussfolgerung.

von Elektronix (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Okay schade, vielen Dank euch trotzdem:)

von Christian K. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Der uA741 ist ein uralt Typ, der war noch nie single supply fähig. Heute 
versteht man unter single supply, das der Eingangs common mode Bereich 
bis GND reicht und der Ausgang dem recht nahe kommt (einige 10mV) . 
TL082 als J-Fet war auch noch nie single supply. Wahrscheinlich haben 
die TI-ler aus dem alten Ursprungsdatenblatt des uA741 abgeschrieben, wo 
man wohl stolz war, das man mit einem Widerstandsteiler eine künstliche 
Mittelspannung erzeugen kann und den Opamp darum arbeiten lässt.

Warum hier immer mit über 40 Jahre alten Opamps gebastelt wird, verstehe 
wer will. Damals war eine +/- 15V Versorgungspannung Standard. Die auf 
+/- 12V abzusenken galt schon als verwegen.

von Helmut L. (helmi1)


Bewertung
0 lesenswert
nicht lesenswert
Elektronix schrieb:
> Aber da im Datenblatt eben Stand, dass
> Single-Supply möglich ist,

So steht das da aber nicht drin. Die meinen das man ihm mit +12V und GND 
versorgen kann. Man darfaber mit dem Potential seiner Eingaenge nicht 
bis an die Versorgungsspannung kommen. Wenn du jetzt den + Eingang auf 
6V legst mit einem Spannungsteiler und das Rueckkopplungsnetzwerk mit 
einem Kondensator gegen GND abblocks dann kann er durchaus dein Signal 
verstaerken. Und das ist hiermit gemeint.

von Elektronix (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Achso 🙈 ja wie gesagt ich hatte den OP eben noch in der Schublade. Genau 
das meinte ich was Christian geschrieben hat, in der Simulation kommt 
der OP bis auf 40mV an 0V das reicht mir aber völlig. Ich meine der 
LM324 kann das (ist aber auch schon etwas älter). Vielen Dank euch:)

von Manfred K. (mkch)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,
also ich hätte genau so ein "ominöses" Verhalten erwartet, denn der OP 
ist am Plus-Eingang extrem hochohmig. Koppelkapazitäten nach überall hin 
sind in Natura ebenfalls vorhanden und so zieht es den offenen 
Pluseingang irgendwo hin. Wenn sie den Pluseingang mit einem 
Eingangssignal belegen, wird der OP "richtig" funktionieren.
Grüße Manfred

von Possetitjel (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Elektronix schrieb:

> Genau das meinte ich was Christian geschrieben hat, in der
> Simulation kommt der OP bis auf 40mV an 0V das reicht mir
> aber völlig.

Wenn das wirklich so ist, dann taugt mMn die Simulation nix.
Lt. Innenschaltung ist das naemlich nicht moeglich.

> Ich meine der LM324 kann das (ist aber auch schon etwas
> älter).

Hieran kannst Du lernen, dass Christians Diffamierung
aufgrund des Alters der Bausteine Unsinn ist. Der LM324
kann naemlich Rail-to-Rail am Eingang, was man auch sofort
versteht, wenn man die Innenschaltung im DaBla ansieht.

von Paul B. (paul_baumann)


Bewertung
-1 lesenswert
nicht lesenswert
>> allerdings steht im Datenblatt explizit, dass ein Single-Supply Betrieb
>> möglich ist?


Der Andere schrieb:
> Verstehe ich nicht.

Vielleicht, weil es nicht in deutscher Sprache dort steht?


Zitat aus dem Datenblatt von Texas Instruments:
8.2.2 Detailed Design Procedure
The LM741 can be operated in either single supply or dual supply.


@TO
Du mußt natürlich dafür sorgen, daß am  nichtinvertierendem Eingang die 
halbe Betriebsspannung anliegt. Das läßt sich mit einem Spannungsteiler 
machen, so wie hier (ganz unten) gezeigt:
http://www.talkingelectronics.com/projects/OP-AMP/OP-AMP-1.html

MfG Paul

: Bearbeitet durch User
von Elektronix (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für die Antwort, aber damit bekomme ich ja dann auch ein 
Offset rein um das ich mich dann bewege oder? Ich habe damit ja dann 
eine virtuelle Masse erzeugt?

von Paul B. (paul_baumann)


Bewertung
0 lesenswert
nicht lesenswert
Elektronix schrieb:
> Vielen Dank für die Antwort, aber damit bekomme ich ja dann auch ein
> Offset rein um das ich mich dann bewege oder?

Ja, und? Wenn Dein "Signal" eine Wechslespannung ist, ist das doch egal.
Schließlich sind Kondensatoren im Signalweg, da ist die Offsetspannung 
für die Stufen davor und dahinter egal.

>Ich habe damit ja dann eine virtuelle Masse erzeugt?

...die aber nötig ist, damit die Spannung am Ausgang, bezogen auf die 
"richtige" Masse ausgesteuert werden kann. Sonst bekämest Du ja nur z.B.
"Halbe Sinüsse" d.h. nur positive Halbwellen heraus.

MfG Paul

von Christian K. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Possetitjel schrieb:
> Elektronix schrieb:
>
>> Ich meine der LM324 kann das (ist aber auch schon etwas
>> älter).
>
> Hieran kannst Du lernen, dass Christians Diffamierung
> aufgrund des Alters der Bausteine Unsinn ist. Der LM324
> kann naemlich Rail-to-Rail am Eingang, was man auch sofort
> versteht, wenn man die Innenschaltung im DaBla ansieht.

Der LM358/324 290X ist jünger wie der uA741 (der kam nach dem 709)
Er ist keinesfalls rail-to-rail am Eingang sondern der Eingangs Common 
mode Range geht nur bis etwas unter GND wegen der PNP Eingangsstufe. 
Nach oben bleibt der Bereich einiges unter der "rail". Echte 
rail-to-rail Eingänge sind hier doppelt (NPN und PNP Stufen) aufgebaut. 
Der Ausgang ist stark unsymmetrisch mit wenig pull up (irgendwas um 
400uA) und anständiger pull down Fähigkeit (20mA). Slew rate ist 
anämisch noch unter den 0,5V/us der frühen intern kompensierten 
Bipolar-opamps. Beliebt ist der 324 noch, weil robust und mit einer 
Handvoll Masken in einem billigen bipolar Prozess herstellbar.
Einsetzen kann man ihn prima, wenn man genau im Bilde ist, was er alles 
nicht kann.

von Yalu X. (yalu) (Moderator)


Bewertung
0 lesenswert
nicht lesenswert
Christian K. schrieb:
> Der Ausgang ist stark unsymmetrisch mit wenig pull up (irgendwas um
> 400uA) und anständiger pull down Fähigkeit (20mA).

Anders herum: Er kann am Ausgang relativ viel Strom abgeben (hat dafür
extra einen Darlington am Ausgang), aber nur wenig aufnehmen (unterhalb
von 500mV Ausgangsspannung sind es nur noch ca. 50µA). Das ist aber
meist kein Problem, da bei einer typischen DC-Single-Supply-Anwendung
die Last am Ausgang gegen GND geschaltet ist und damit der Strom immer
aus dem Ausgang heraus- und nie hineinfließt. In diesem Fall stören auch
die Übernahmeverzerrungen, für die der LM324 bekannt ist, nicht.

von Christian S. (roehrenvorheizer)


Bewertung
0 lesenswert
nicht lesenswert
Hallo

Du hast bei der Ubertragung der Simulation in die Realität vermutlich 
genau diesen Fehler gemacht, wie schon genannt

"Ziemlich suboptimal, wenn man mit symmetrischer Versorgungsspannung 
simuliert (siehe Schaltplan) und dann aysmmetrisch versorgt."

"Du mußt natürlich dafür sorgen, daß am nichtinvertierendem Eingang die 
halbe Betriebsspannung anliegt. Das läßt sich mit einem Spannungsteiler 
machen, so wie hier (ganz unten) gezeigt:
http://www.talkingelectronics.com/projects/OP-AMP/...";

Also dort wo Dein Ground-Symbol steht, soll die halbe Betriebsspannung 
anliegen, z.B. mittels Spannungsteiler 2 x 2,2 kOhm.

Dann geht das auch mit dem Veteranen ganz leicht.

Mit freundlichem Gruß

von Manfred (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Elektronix schrieb:
> ch hatte noch einen LM741 zur Hand weswegen ich
> diesen dann verwendet habe.
Der ist nie mein Freund geworden und für DC-Anwendungen nicht wirklich 
gut.

Etwas teurer, aber recht gut funktioniert der OPA, schaue Dir mal den 
Meßverstärker vom Lötkolben an:
http://www.martin-kumm.de/wiki/doku.php?id=Projects:SMD_Loetstation

Christian K. schrieb:
> TL082 als J-Fet war auch noch nie single supply.
Stimmt, aber an DC garnicht mal so schlecht, driftet deutlich weniger 
als LM324 und andere durch die Gegend.

von Elektronix (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

sorry für die späte Antwort. Ich wollte nur nochmal zurückmelden, dass 
ich mich jetzt für einen LM6154BCM von TI entschieden habe, dieser hat 
für meine Anwendung ein sehr gutes Rail-to-Rail verhalten und ist völlig 
ausreichend.

Vielen Dank für eure Hilfe!

von MaWin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Elektronix schrieb:
> Ich betreibe den OP im Single-Supply Betrieb mit +12V und 0V

In deinem kopierten Schaltplan steht ja wohl nicht ohne Grund +Supply 
und -Supply, du wirst schon mit -12V kommen müssen.

Ein steinzeit-OpAmp wie 741 kann nicht an 0V messen und liefern, wenn er 
nur mit 0V versorgt wird. Der TL081 auch nicht. Mindestens -3V benötigen 
beide am -Supply Anschluss, um mit 0V umgehen zu können.

Und auch ein LM321/LM358/LM324/LT1013 wird die 0V nur liefern, wenn ein 
Widerstand den Ausgang nur nach Masse zieht (was bei deiner Schaltung 
der Fall wäre).

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.