Forum: Analoge Elektronik und Schaltungstechnik Aktive Frequenzweiche - Fehler bei Bauteilauslegung?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Sangri (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich bastel gerade für ein zukünftiges Projekt an einer aktive 
Frequenzweiche für Audioanwendung. Habe die Schaltung in LTSpice 
theoretisch entworfen und sieht auch (wie im Bild zu sehen) erstmal ganz 
vernünftig aus. Trennfrequenz sind ca. 2000 Hz. Daraufhin habe ich die 
Schaltungen testmäßig auf dem Steckbrett zusammengeschustert. Der 
Hochtonzweig (obere Schaltung)läuft soweit einwandfrei. Habe das 
Frequenzspektrum des Lautsprechers mittels Messmikrofon aufgenommen und 
siehe da..es tut was es soll! Problematischer ist der Tieftonbereich. 
Dieser läuft bei Musikwiedergabe für ca. 10 Sekunden ohne Beanstandungen 
und danach fängt er stark an zu verzerren und wird sehr sehr leise. Die 
10 Sekunden reichten aber aus um auch hier die Messung durchzuführen und 
die Grundschaltung scheint erstmal zu funktionieren. Ich denke also, 
dass die Bauteildimensionierung für den NE5532 vllt nicht geeignet ist?! 
Die Berechnung erfolge nach Excel-Dateien, welche ich hier:

http://www.hifi-forum.de/viewthread-42-51.html

heruntergeladen habe. Die Ergebnisse decken sich auch mit denen auf 
dieser Seite:

http://www.wa4dsy.com/robot/active-filter-calc

Beim ersten Link steht lediglich bei, dass beim Tiefpass die Widerstände 
nicht größer als 10k sein sollen, weshalb ich diese so gewählt habe 
(1k), dass ich die passenden Kondensatoren da hatte.
Ich habe die aufgenommenen Messungen auch mal mit hochgeladen. Ohne 
Weiche (Blau) , Hochpass (Grün), Tiefpass (Rot).

Erkennt jemand den Fehler?

von Sangri (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Noch als Ergänzug:

- Wenn das Signal leise wird sind auch die hohen Frequenzen wieder im 
Signal      zu hören. Als würde die Schaltung irgendwie umgangen 
werden..

- sobald die Schaltung einmal Spannungsfrei geschaltet wurde und man sie 
wieder anschließt läuft sie wieder 10 Sekunden ohne Probleme

von Joe F. (easylife)


Bewertung
0 lesenswert
nicht lesenswert
U1 ist durch C2 vom Audioeingang abgekoppelt (korrekt), U2 allerdings 
nicht.
Das Audiosignal hat ja einen Bezug zu GND, und deine Op-Amps arbeiten um 
15V/2 herum.
Du brauchst also einen Koppelkondensator zwischen Audio-In und R1 (z.B. 
10uF).
Nach diesem Koppelkondensator muss das Signal aber auf 15V/2 gezogen 
werden.
C4 kann auch nach GND gehen. Dann kannst du R7/R8 gleich dafür benutzen.

Deine Bias-Teiler (100K/100K) sind sehr hochohmig. Wenn du dann mit 
R2=16K dagegen ziehst, verändert sich die Bias-Spannung an diesem Punkt.
Besser wäre R2 wegzulassen, und für R4 und R5 je 32K zu nehmen (ergibt 
16K zu 15V/2).

Hinter deinen Filtern muss vermutlich wieder ausgekoppelt werden, wenn 
die Verstärker ein Signal mit GND Bezug benötigen.
10uF und 47K nach GND könnten dies erledigen.

von Trumpeltier (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Naja, U2 bekommt keine U/2, falls die Audioquelle für DC undurchlässig 
ist. Der 2. Bias-Teiler hängt ziemlich sinnfrei nur über nen Kondensator 
(C4) am OPV. Da fehlt ein Gleichstrompfad...

von Joe F. (easylife)


Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Also ungefähr so wie im Anhang.

2000 Hz ist übrigens eine ungünstige Frequenz für einen Crossover.
Liegt im besonders gut hörbaren Bereich, und 2000 Hz sind für manche 
Tweeter noch recht niedrig (der Tweeter muss dann sehr viel Leistung 
aushalten).
Für den Tweeter günstiger ist ein Crossover etwa ab 3-4 KHz.
http://education.lenardaudio.com/en/06_x-over.html

: Bearbeitet durch User
von tweety (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Joe F. schrieb:
> Für den Tweeter günstiger ist ein Crossover etwa ab 3-4 KHz.

Quatsch.

Für ein drei Wege wäre die Aussage vielleicht noch ok, nicht bei einem 2 
Wege System wie hier besprochen wird.

Je nach größe des Tieftöners hat man schon wieder eine fehlerhafte 
Bündelung des Tieftöners und einen Sprung zum Hochtöner. Bei einem zwei 
Wege versucht man den Hochtöner so tief wie möglich anzukoppeln.

von Sangri (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für die kompetenten Antworten.

Zur Trennfrequenz:

Ich kenne es eigentlich auch so, dass Hochtöner zwei Zweiweglern relativ 
tief angekoppelt werden. Häufig 2500 Hz. Aber das hier ist sowieso 
erstmal zum experimentieren. Die Frequenz lässt sich ja anschließend 
recht einfach über die Bauteilwerte anpassen. Das ist ja das schöne an 
einer aktiven Weiche.

Zur Schaltung:

Ich habe die Schaltung jetzt angepasst und sie funktioniert. Danke!
Es gibt allerdings ein "Problem". Sowohl in LTSpice als auch in der 
realen Messung ist der Hochtonzweig wesentlich lauter als der 
Tieftonzweig. (siehe Bilder) Was ist der Grund hierfür? Muss das über 
eine Verstärkung am IC korrigiert werden? Ich habe spaßeshalber die 
Kopplungskondensatoren in der Simulation erhöht. Wenn ich sie auf 1000 
µF erhöht habe nähern sich die Pegel fast komplett an. Das kann aber 
doch nicht die Lösung sein?!

von Sangri (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Sorry..hier noch die Messung

von Joe F. (easylife)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Dann ist in deiner Schaltung immer noch etwas falsch.
Frequenzgänge sollten so aussehen wie im Anhang.

Dein Audiosignal GND hängt am (schwächlichen) Bias des HP. Das wird es 
sein.
Audio-In GND gehört mit GND verbunden.

: Bearbeitet durch User
von Sangri (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Okay dankeschön. Ich werde es mir nochmal anschauen :)

Nochmal eine andere Sache aus Interesse:

Da die Lautsprecher die ich bauen werde relativ kleine Membranen haben 
werden hatte ich eventuell auch vor diese bei ca. 80 Hz per Hochpass von 
den Bässen zu entlasten und gleichzeitig über die Filtergüte ein paar 
Dezibel an der Grenzfrequenz anzuheben. Ist es möglich hinter/vor den 
Tiefpass einen weiteren Hochpass zweiter Ordnung zu schalten, sodass im 
Endeffekt ein Bandpass von 70-2000 Hz entsteht? Oder macht das Probleme, 
weil Hoch- und Tiefton anschließend unterschiedlich viele Filterstufen 
durchlaufen haben?

von Joe F. (easylife)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Sangri schrieb:
> Okay dankeschön. Ich werde es mir nochmal anschauen :)
>
> Nochmal eine andere Sache aus Interesse:
>
> Da die Lautsprecher die ich bauen werde relativ kleine Membranen haben
> werden hatte ich eventuell auch vor diese bei ca. 80 Hz per Hochpass von
> den Bässen zu entlasten und gleichzeitig über die Filtergüte ein paar
> Dezibel an der Grenzfrequenz anzuheben. Ist es möglich hinter/vor den
> Tiefpass einen weiteren Hochpass zweiter Ordnung zu schalten, sodass im
> Endeffekt ein Bandpass von 70-2000 Hz entsteht? Oder macht das Probleme,
> weil Hoch- und Tiefton anschließend unterschiedlich viele Filterstufen
> durchlaufen haben?

Macht es. Im Augenblick hast du eine Phasendifferenz von 180°, d.h. wenn 
du einen der Lautsprecher umgepolt anschließt stimmt wieder alles.

Du könntest den 70 Hz Hochpass aber einfach vor beide Filter legen (also 
vor dem Punkt an dem sich das Signal zum HP und TP verzweigt).

Dein jetziger Crossover hat übrigens einen 3dB Höcker bei 2KHz. Siehst 
du in der Simulation, wenn du dir mal V(out_hp)-V(out_tp) plotten lässt.
Für einen echten Linkwitz-Riley bräuchtest du eine höhere 
Filter-Ordnung.
Wenn du die Grenzfrequenzen von HP und TP etwas auseinanderziehst, wird 
es am Übergang zwar etwas welliger, aber der Höcker wird etwas 
gemindert.
Wenn man R5 und R6 auf ca. 2K setzt ist man in etwa in diesem Bereich.

: Bearbeitet durch User
von Mani W. (e-doc)


Bewertung
-1 lesenswert
nicht lesenswert
Sangri schrieb:
> Problematischer ist der Tieftonbereich.
> Dieser läuft bei Musikwiedergabe für ca. 10 Sekunden ohne Beanstandungen
> und danach fängt er stark an zu verzerren und wird sehr sehr leise.

Erinnert mich an meine erste, geschlossene und abgedichtete Box...


Nach ein paar Bässen ist der Gegendruck oder Unterdruck so stark, dass
sich die Bassmembrane fast nicht mehr bewegt...

In dem Fall ist ein Scharnierbohrer 25 mm Dm oder größer gefragt,
dann funktioniert es wieder und ein Bassreflexrohr kann man auch noch
einbauen...

von Sangri (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Danke für eure Antworten :)

Die Lautsapecher mit denen ich teste sind bereits nach dem 
Bassreflexprinzip entworfen. Allerdings sollte sich auch bei einer 
geschlossenen Bauweise weder Über- noch Unterdruck entwickeln, da keine 
Luft aus dem System entweichen bzw. einströmen kann. Ich baue schon seit 
vielen Jahren Lautsprecher, allerdings fand die Trennung bisher immer 
passiv nach dem Verstärker statt. Da mir das aber manchmal zu unflexibel 
ist und wenn man viel ausprobieren will schnell ins Geld geht, möchte 
ich meine ersten Gehversuche in diese Richtung gehen.

Ich habe die Schaltung jetzt soweit umgestellt, dass ich das gesamte 
Signal zunächst durch den Hochpass mit 70 Hz speise und anschließend in 
die eigentliche Frequenztrennung. (Siehe Bilder) Wenn ich nur einen 
Lautsprecher seperat ansteuere funktioniert das auch einwandfrei, 
allerdings funktionieren beide zusammen nicht. Sobsld ich das Signal 
nach der Frequenzweiche in den Verstärker schleuse kann ich nur seeehr 
sehr leise hören. Ansonsten fängt der Hochtöner (welcher zum testen auch 
ein Breitbandlautsprecher ist) an zu knacken und macht ganz verrückte 
Membranauslenkungen. Sobald der Tieftonzweig abgetrennt ist geht es auch 
laut ! Ideen?

von Joe F. (easylife)


Bewertung
0 lesenswert
nicht lesenswert
Klingt danach als ob irgendetwas wild schwingt.
Wie sieht denn dein Aufbau aus?
Blockkondensatoren an V+ der Op-Amps vorhanden?
Oszilloskop verfügbar?

: Bearbeitet durch User
von Sangri (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Aufbau ist wie folgt:

Der Aufbau befindet sich momentan auf einem Steckbrett. Verwendet werden 
zwei IC (NE5532). Einer für den 70 Hz Hochpass und je 1/2 IC für Hoch- 
und Tiefpass. Als Kondensatoren sind bis auf die Koppelkondensatoren 
MKP's (WIMA) verbaut. Koppelkondensatoren sind Elkos. Spannungsquelle 
ist ein Labornetzteil. Wobei ich es auch aus Interesse schon mit einem 
Akku ausprobiert habe. Das hat allerdings keine Verbesserung 
herbeiführen können. Das Signal, welches aus dem Laptop kommt, wird nach 
der Frequenzweiche in einen herkömmlichen Stereoverstärker gespeist 
(Class-AB).

Ein Oszilloskop habe ich leider nicht. Die hohen Membranauslenkungen am 
"Hochtöner" treten auch immer dann auf, wenn die Musik sehr impulsiv ist 
(bspw. Bassdrums).

Ich habe jetzt parallel  zu den beiden ICs (Vcc+ --> Vcc-) je ein 100 nF 
Kerko geschaltet. Ist es das was du mit Blockkondensator meinst? Ist es 
das gleiche wie ein Siebkondensator zum Abfangen der Schaltspitzen? 
Keine Veränderung festzustllen.

von MaWin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Joe F. schrieb:
> Klingt danach als ob irgendetwas wild schwingt.

Oder wegen niedrigem Lastwiderstand überhitzt und seine Strombegrenzung 
verringert.

von Sangri (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Nein heiß wird da nichts. Vor allem würde das Problem dann ja nicht 
sofort nach dem Einschalten auftreten?!

Ich konnte das Problem lösen. War im Endeffekt sehr trivial. Ich hatte 
die Spannungsversorgung mittels Krokodikklemmen angeschlossen. Das 
scheint den ICs wohl irgendwie nicht gefallen zu haben. Jetzt 
funktionierts und Messung schauen erstmal gut aus. Siehe Bilder. Einmal 
auf Achse (0°) und einmal 30°.

Generell scheint der Hochton etwas im Pegel angehoben zu sein. Außerdem 
gibt es eine Überhöhung bei ca. 1500 Hz was aber eine Membranresonanz 
ist. Mit ein bisschen Fantasie lässt sich auch der angesprochene 
"Buckel" bei der Übernahmefrequenz erkennen welcher evtl. noch 
Verbessrungspotential aufzeigt.
Erstmal bin ich aber überrascht wie gut es insgesamt doch klingt.

Vielen Dank für eure Hilfe. Falls es dennoch Vorschläge zur Optimierung 
gibt. Immer her damit :)

von Lurchi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Das Abschneiden nach unten schon bei 70 Hz ist ungewöhnlich, wenn man 
nicht noch zusätzlich einen Subwoofer hat. Normal hat man das Rumpel und 
Subsonic Filter eher so bei 10-20 Hz, also eher unter dem Bereich den 
man hört.

Die Widerstände im Tiefton Filter dürften schon noch etwas größer (z.B. 
5 K) werden - dann hat man es mit dem Koppelkondensator leichter. Da am 
Ausgang auch noch mal eine AC Kopplung ist, kann man auch den 
Koppelkondensator (C4) und damit auch die DC Vorspannung dort auch 
verzichten. Der 70 Hz Hochpass liefert bereits den richtigen DC Pegel.

von Trumpeltier (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Zusammenfassung:

;-)

von Sangri (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke für die Anregung.

Das es ungewöhnlich ist stimmt. Allerdings geht es hierbei nicht um 
einen Rumpelfilter oder um was man hört oder nicht. Die sinnvolle 
Frequenz ab der man abschneiden sollte hängt doch stark von der 
Gehäuseresonanz ab. Normalerweise schneidet man wenige Hz unter der 
Rosonanzfrequenz des Gehäuses ab, da unterhalb dieser Frequenz sowieso 
nichts Nennenswertes von dem Lautsprecher wiedergegeben werden kann. 
Zudem hängt es von der Resonanzfrequenz des Chassis ab. Denn auch dieses 
kann unterhalb seiner Resonanzfrequenz nicht wirklich Ton erzeugen. 
Anregung unterhalb dieser Frequenz führt nur zu unverhältnismäßig hohen 
Membranauslenkung, welche die erreichbare Lautstärke stark beeinflussen, 
da der Lautsprecher schnell an seine mechanische Grenze kommt, ohne 
dabei etwas wiederzugeben.

Der gestestete Lautsprecher ist ein 3" Lautsprecher. (Tangband 316b) Die 
bei den Messung erreichte Grenzfrequenz von ca 70 Hz (-3 db) ist für den 
kleinen schon Zumutung genug :). Das Gewäuse fasst 2,5 Liter 
(Nassreflex) und hat eine Gehäuseresonanz von 78 Hz. Deshalb die 
gewählten 70 Hz des Hochpasses.

von Trumpeltier (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Dann nimm für C3 und C4 halt 120nF - 150nF oder passe meinetwegen die 
Widerstandswerte an. Meiner Erfahrung nach klingt das dann aber arg 
dünn.

mfg

von Stromtuner (Gast)


Bewertung
0 lesenswert
nicht lesenswert
den vierten OPV kann man noch als Eingangspuffer vors Filter schalten, 
damit dieses ausreichend niederohmig angesteuert wird. Oder man 
schliesst noch einen 32Ω parallel zum Eingang der Schaltung, wenn es 
sich um einen Kopfhöhrerausgang handeln sollte.

StromTuner

von Trumpeltier (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Stromtuner schrieb:
> den vierten OPV kann man noch als Eingangspuffer vors Filter schalten,
> damit dieses ausreichend niederohmig angesteuert wird.

@Stromtuner
Guter Einwand. Hätte ich an meiner Statt sowieso getan.
Schaltung nochmal aktualisiert.

mfg

von Trumpeltier (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ja, ich weiß,
damit das Ding (U1) noch was sinnvolleres tut, eine weitere Eränzung.

von Trumpeltier (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Oh, habe ein "g" vergessen, bitte selbständig einfügen. :-)

von Joe F. (easylife)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Lurchi schrieb:
> Da am
> Ausgang auch noch mal eine AC Kopplung ist, kann man auch den
> Koppelkondensator (C4) und damit auch die DC Vorspannung dort auch
> verzichten.

Ja, das ist gut. Der zwischen den Stufen mögliche Offset spielt bei 15V 
Versorgung keine Rolle.

Trumpeltier schrieb:
> Schaltung nochmal aktualisiert.

An alle Op-Amp-Ausgänge könnte man sowas wie 22..47K zu GND legen, damit 
die Opamps ein bisschen was zu treiben haben.
Ebenso an den Ausgängen. Da würde ich ebenfalls 47K zu GND legen, damit 
hier ein definierter Bezug zu GND hergestellt wird.

von Trumpeltier (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Joe F. schrieb:
> An alle Op-Amp-Ausgänge könnte man sowas wie 22..47K zu GND legen, damit
> die Opamps ein bisschen was zu treiben haben.

Ganz wie der Herr meinen. Man könnte auch noch an allen OPAMP-Ausgängen 
nen 100Ω-Widerstand klemmen, allerdings wirds mir dann doch zu 
esoterisch.

Joe F. schrieb:
> Ebenso an den Ausgängen. Da würde ich ebenfalls 47K zu GND legen, damit
> hier ein definierter Bezug zu GND hergestellt wird.

Dem stimme ich zu, denn dann haben die OPAMPs 1. was zum treiben, und 2. 
sorgen die für definiertes Potential. Konsequenterweise gehört dann auch 
ein hochohmiger Widerstand vor C11 nach GND.

Ich denke, nun ist alles gesagt.

von Sangri (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hey,

danke für die Zusammenfassung! Ich werde die Schaltung entsprechend 
anpassen.

Ich verstehe noch nicht 100%ig die Funktion des vierten OPVs. Gibts da 
einen  speziellen Namen für, dass ich es nachlesen kann? Ich hatte 
überlegt den vierten OPV als kleinen Preamp für leistungsschwache 
MP3-Player oder ähnliches zu Nutzen. Ist aber vermutlich überflüssig.

Noch etwas:

Gibt es eine Möglichkeit, was man es sonst passiv nach dem Verstärker 
über MOX-Widerstände macht, innerhalb der Filterschaltung mittels 
Spannungsteiler den Pegel des Hochtöners an den Wirkungsgrad des 
Tieftöners anzupassen? (abzusenken)

Vielen Dank nochmals

MfG

von MaWin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sangri schrieb:
> Nein heiß wird da nichts. Vor allem würde das Problem dann ja nicht
> sofort nach dem Einschalten auftreten?!

Ich dachte, ich hätte gelesen, dass es direkt nach dem Einschalten geht 
und erst 10 Sekunden später begrenzt und verzerrt. Nun ja, waren wohl 
alternative Fakten von denen du geschrieben hast.

von Sangri (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Kennt jemand eine Möglichkeit?

von Dr. Google (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich möchte Dir die Schaltungen von linkwitzlab ans Herz legen. Die 
24dB/Oktave sind wirklich den Aufwand wert. Bei der Flankensteilheit 
gibt es weniger Probleme mit der Belastbarkeit des Hochtöners bei 
2000Hz. Eine niedrige Güte mit 0,5 ist auch wichtig.

Man kann im 2-Wege Fall das Zeugs auch passiv mit Boxsim und 24dB 
realisieren. Die Spulen sind wegen des Kupferpreises teuer, kommt 
praktisch genauso teuer wie aktiv.

Mit Boxsim kann man aktiv und passiv gleichzeitig simulieren und die 
Kurven fast deckungsgleich machen. Auf eine gleichmässige 
Impedanzkorrektur muss dann geachtet werden. Die Impedanzänderung 
während der Wiedergabe bringt die Verzerrungen und das ist dann der 
Vorteil einer Aktivierung.

Wichtiger ist aber die Güte von <=0,5 der "aperiodische Grenzfall"...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.