Forum: PC Hard- und Software Verständnisproblem Netzwerk/Providerproblem


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Christian M. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen!

vor etwa einem Jahr haben wir den Provider gewechselt. Ist jetzt alles 
viel billiger, viel schneller (50Mb/s rauf UND runter) aber oft geht gar 
nichts (manchmal einmal pro Woche einen halben Tag). Uns bleibt dann 
nur, ab und zu alles zu resetten und warten - ooooder aber bei der 
Hotline anzurufen! Und da fangen die Probleme an:

Man schickt einen in den "Serverraum" um einen Rechner direkt an den 
Router anzuschliessen ob es dann geht. Was das bringen soll, versteh ich 
nun nicht, weil ich ja Verbindung zu Router habe (über Switch). Kurz: 
sie suchen den Fehler bei mir, obwohl es meiner Meinung nach bei ihnen 
hakt.

Jetzt meine Fragen:

- Kann es sein, dass in diesem Fall ein Switch Probleme macht?

- Kann ich mit einem (Log-)Programm rausfinden, wo das Problem ist? Vor 
ein paar Monaten gab's mal einen Thread, wo jemand einen Logger empfahl 
bei solchen Problemen.

- Beim Pingen ins Internet (zum Testen, ob's wieder geht) kommt 
natürlich eine "Zeitüberschreitung der Anforderung", aber zufällig ist 
mir aufgefallen, dass die DNS-Auflösung immer andere IP-Adressen gibt! 
Also kann die Auflösung ja nicht aus der hosts-Datei kommen!? Unten ist 
eine Zusammenfassung des gestern-abend-Pingens angehängt.

Infrastruktur: Fernsehkabel - Kästchen von Provider - Router mit PPPoE - 
Switch - alle Rechner mit WinXP/Vista/7 oder Android

Danke und Gruss Chregu


1
Microsoft Windows [Version 6.3.9600]
2
(c) 2013 Microsoft Corporation. Alle Rechte vorbehalten.
3
4
C:\Users\Chregu>ping 192.168.1.1
5
6
Ping wird ausgeführt für 192.168.1.1 mit 32 Bytes Daten:
7
Antwort von 192.168.1.1: Bytes=32 Zeit=1ms TTL=64
8
Antwort von 192.168.1.1: Bytes=32 Zeit=2ms TTL=64
9
Antwort von 192.168.1.1: Bytes=32 Zeit=2ms TTL=64
10
Antwort von 192.168.1.1: Bytes=32 Zeit=2ms TTL=64
11
12
Ping-Statistik für 192.168.1.1:
13
    Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
14
    (0% Verlust),
15
Ca. Zeitangaben in Millisek.:
16
    Minimum = 1ms, Maximum = 2ms, Mittelwert = 1ms
17
18
C:\Users\Chregu>ping www.google.ro
19
20
Ping wird ausgeführt für www.google.ro [216.58.209.195] mit 32 Bytes Daten:
21
Zeitüberschreitung der Anforderung.
22
23
Ping wird ausgeführt für www.google.ro [62.231.91.88] mit 32 Bytes Daten:
24
25
Ping wird ausgeführt für www.google.ro [62.231.91.88] mit 32 Bytes Daten:
26
27
Ping wird ausgeführt für www.google.ro [86.127.118.183] mit 32 Bytes Daten:
28
29
Ping wird ausgeführt für www.google.ro [216.58.214.227] mit 32 Bytes Daten:
30
31
Ping wird ausgeführt für www.google.ro [216.58.214.227] mit 32 Bytes Daten:
32
33
Ping wird ausgeführt für www.google.ro [62.231.91.94] mit 32 Bytes Daten:
34
35
Ping wird ausgeführt für www.google.ro [216.58.214.195] mit 32 Bytes Daten:
36
37
Ping wird ausgeführt für www.google.ro [62.231.91.104] mit 32 Bytes Daten:
38
39
Ping wird ausgeführt für www.google.ro [216.58.214.227] mit 32 Bytes Daten:
40
41
Ping wird ausgeführt für www.google.ro [62.231.91.94] mit 32 Bytes Daten:
42
Antwort von 62.231.91.94: Bytes=32 Zeit=24ms TTL=59
43
Antwort von 62.231.91.94: Bytes=32 Zeit=12ms TTL=59
44
Antwort von 62.231.91.94: Bytes=32 Zeit=29ms TTL=59
45
Antwort von 62.231.91.94: Bytes=32 Zeit=26ms TTL=59

von lolnein (Gast)


Bewertung
0 lesenswert
nicht lesenswert
mit

tracert www.google.ro

kannst du schauen wo die Pakete verloren gehen

von Christian M. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
lolnein schrieb:
> tracert

Danke!

Hiess das nicht mal "traceroute"? Das habe ich nähmlich probiert...

Gruss Chregu

von lolnein (Gast)


Bewertung
0 lesenswert
nicht lesenswert
ja, Linux & co verwenden traceroute. Windows war schon immer tracert.

von Sheeva P. (sheevaplug)


Bewertung
0 lesenswert
nicht lesenswert
Christian M. schrieb:
> - Beim Pingen ins Internet (zum Testen, ob's wieder geht) kommt
> natürlich eine "Zeitüberschreitung der Anforderung", aber zufällig ist
> mir aufgefallen, dass die DNS-Auflösung immer andere IP-Adressen gibt!
> Also kann die Auflösung ja nicht aus der hosts-Datei kommen!? Unten ist
> eine Zusammenfassung des gestern-abend-Pingens angehängt.

Die Namensauflösung kommt ohnehin nicht aus der Hosts-Datei, sondern vom 
DNS. Und da konfiguriert Google mehrere IP-Adressen für einen Hostnamen, 
die -- im Round-Robin-Verfahren oder nach einer intelligenteren, 
lastabhängigen Logik -- bei jeder DNS-Abfrage unterschiedliche Adressen 
zurückgeben. Das dient dazu, die Last auf mehrere Server zu verteilen. 
Insofern ist das kein Hinweis auf Probleme, sondern vollkommen korrekt 
und erwünscht.

Was Deine Verbindungsprobleme angeht, ist es sicherlich hilfreich, sich 
mal auf dem Webinterface des "Routers" (DSL-Gateway) einzuloggen und 
dort dessen Konnektivität zu prüfen.

von (prx) A. K. (prx)


Bewertung
0 lesenswert
nicht lesenswert
Christian M. schrieb:
> sie suchen den Fehler bei mir, obwohl es meiner Meinung nach bei ihnen
> hakt.

Alte Support-Weisheit, besonders im Privatkundensupport und bei 
Providern mit schwach ausgeprägtem Business-Segment. Einerseits ist das 
billiger für die, andererseits nicht selten auch zutreffend.

Aber auch im echten Business-Segment kommt ein Provider gerne auf die 
Idee, dass beim Ausfall eines Anschlusses vielleicht der Strom der 
Lokation ausgefallen sein könnte und wartet deshalb erst einmal ab. Und 
damit haben sie in meinem Umfeld nicht einmal Unrecht. Das ist wirklich 
der häufigste Grund.

: Bearbeitet durch User
von Rufus Τ. F. (rufus) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Naja, wenn die Namensauflösung für Google ständig andere Adressen 
liefert, müssen die ja irgendwo herkommen - der Router denkt sich die 
nicht aus. Also besteht eine Internetverbindung mindestens bis zum 
DNS-Server des Providers (ich nehme an, daß der im Router konfiguriert 
ist).

Wenn es möglich ist, einen anderen DNS-Server zu konfigurieren, könntest 
Du mal 8.8.8.8 ausprobieren, das ist ein von Google selbst betriebener 
DNS-Server.

Wenn auch mit dem geredet werden kann (d.h. auch mit dem Namensauflösung 
funktioniert, und das auch mit anderen Adressen als google.ro), 
spätestens dann ist sicher davon auszugehen, daß eine 
Internetverbindung in irgendeiner Art besteht.

von (prx) A. K. (prx)


Bewertung
0 lesenswert
nicht lesenswert
Christian M. schrieb:
> nichts (manchmal einmal pro Woche einen halben Tag).

Bisschen häufig für normale Internet-Probleme. Aber es kommt schon mal 
vor, dass das Internet nicht universell erreichbar ist, dass Teile des 
Netzes zeitweilig nicht erreichbar sind. Google ja, IBM nicht, oder 
umgekehrt. Peering-Probleme zwischen grossen Netzbetreibern können dazu 
führen. Ist aber in meiner Praxis eher ein paarmal im Jahr, nicht ein 
paarmal pro Woche.

Such dir die IP-Adresse einer Station deines Providers raus. Vielleicht 
der nächste Hop jenseits deiner Leitung auf dem Weg ins Internet, wenn 
pingbar. Und an die machst du auf einem System innerhalb deines Netzes 
einen Dauerping. Fällt der aus, dann liegt das Problem bei dir oder der 
Anbindung. Einen zweiten Dauerping machst du beispielsweise an 8.8.8.8. 
Fällt nur der aus liegt das Problem ausserhalb von dir und deiner 
direkten Anbindung an den Provider.

: Bearbeitet durch User
von Pete K. (pete77)


Bewertung
-1 lesenswert
nicht lesenswert
Wenn es nach der Neuwahl des Providers diese Probleme gibt, wird wohl 
der Provider daran schuld sein.
Gab es diese Probleme auch mit dem alten Provider?

Ansonsten könnte Du versuchen, eine Störungsseite für Dein Provider zu 
finden, ähnlich dieser hier:
http://xn--allestrungen-9ib.de/

von Christian M. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
A. K. schrieb:
> Such dir die IP-Adresse einer Station deines Providers raus.

So geil, ausgerechnet von dort kommt kein Pong zurück:
1
C:\Users\Chregu>ping www.rcs-rds.ro
2
3
Ping wird ausgeführt für www.rcs-rds.ro [81.196.14.172] mit 32 Bytes Daten:
4
Zeitüberschreitung der Anforderung.
5
Zeitüberschreitung der Anforderung.
6
Zeitüberschreitung der Anforderung.
7
Zeitüberschreitung der Anforderung.
8
9
Ping-Statistik für 81.196.14.172:
10
    Pakete: Gesendet = 4, Empfangen = 0, Verloren = 4
11
    (100% Verlust),

Rufus Τ. F. schrieb:
> wenn die Namensauflösung für Google ständig andere Adressen
> liefert, müssen die ja irgendwo herkommen - der Router denkt sich die
> nicht aus.

Ja genau, das war ja schon ein guter Hinweis!

Pete K. schrieb:
> Gab es diese Probleme auch mit dem alten Provider?

Nein. Das war ADSL über Telephonleitung. Dort hatten wir andere 
Probleme... Sozialer Art und so... Und änderten dauernd meine "fixe" 
IP-Adresse. Jetzt habe ich keine Fixe mehr, aber bezahle auch nicht 
dafür.

Gruss Chregu

von (prx) A. K. (prx)


Bewertung
0 lesenswert
nicht lesenswert
Christian M. schrieb:
> So geil, ausgerechnet von dort kommt kein Pong zurück:

Nicht jeder Server ist per Ping ansprechbar. Dieser ist es nicht. Man 
muss schon welche verwenden, die in normalen Zeiten auch auf Ping 
reagieren. Die Router auf dem Weg von dir zum Server sind es meist, die 
Server selbst nicht immer.

: Bearbeitet durch User
von Christian M. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sheeva P. schrieb:
> Was Deine Verbindungsprobleme angeht, ist es sicherlich hilfreich, sich
> mal auf dem Webinterface des "Routers" (DSL-Gateway) einzuloggen und
> dort dessen Konnektivität zu prüfen.

Das mache ich ja jeweils, und es erscheint immer "Connected"! Habe mal 
eine Kopie gemacht, vielleicht hilft's:


1
WAN:
2
MAC Address:        00-15-E9-E2-38-EC
3
Connection:         PPPoE Connected 
4
IP Address:         100.104.66.43  
5
Connection Time:    13:23:31  
6
Subnet Mask:        255.255.255.255
7
Gateway:            100.104.66.43
8
Domain Name Server: 193.231.252.1, 213.154.124.1

Der Shoot ist von jetzt! Wie man sieht, bin ich jetzt schon wieder 13h 
ohne Probleme verbunden! Wenn's nicht geht, sieht's nicht viel anders 
aus. Ich könnte dann die DNS-IP's anpingen, zeigt mir das was?

Ich betone nochmal: Wenn das Internet "nicht geht" steht im Router 
trotzdem "PPPoE Connected", DNS Namensauflösung scheint Remote zu 
funktionieren, und irgendwann geht's nach dem Resetten der ganzen 
Ethernet-Infrastruktur inkl. des "Modems".
An diesem Modem hängt auch ein Kästchen für die a/b-Schnittstelle; Das 
Telephon geht IMMER!

Gruss Chregu

von (prx) A. K. (prx)


Bewertung
0 lesenswert
nicht lesenswert
PS: Für mich ist www.rcs-rds.ro per IPv6 pingbar, per IPv4 nicht. Port 
80 geht aber mit beiden. Deren Server bzw. die Firewall(s) dorthin 
akzeptiert also Ping auf IPv6, nicht aber auf IPv4.

: Bearbeitet durch User

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.