Forum: Analoge Elektronik und Schaltungstechnik LTSpice voltage controlled switch


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Christian M. (c_moeller)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe die beiden angehängten Schaltung simuliert. Sie machen so 
keinen Sinn und sind nur ein Teile einer größeren Schaltung.
Wenn ich 1_and.asc simuliere schaltet der Schalter S1 wie gewollt nach 
4ms und das Signal von a liegt auf b an.
Wenn ich die Schaltung um ein AND Gatter (A2) erweitere (2_and.asc) 
liegt das Signal von a die ganze Zeit (bevor der Schalter durchschaltet) 
an b an.
Was mache ich falsch?

Danke für die Hilfe im Voraus

Gruß
Christian

von hurlak (Gast)


Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Christian M. schrieb:
> Was mache ich falsch?
Du solltest deinem Schalter auch Eigenschaften zuweisen (Ron, Roff und 
Schaltschwellen).
Auch die Pulsspannungsquelle prüfen - oder möchtest du tatsächlich nur 
eine ansteigende Rampe nach 3.5ms haben?

Die Spannungen an a und b sind identisch, weil der Schalter auch bei AUS 
einen Widerstand (Roff) hat. Die Eingänge der Gatter sind aber sehr 
hochohmig, so dass am dadurch entstehenden Spannnugsteiler kaum eine 
Änderung sichtbar ist.

von Helmut S. (helmuts)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Christian,

Mach mal einen 1k Widerstand vom Punkt B nach Masse damit der Leckstrom 
abfließen können. Dann funktioniert es wie erwartet.

(Es ist natürlich trotzdem "komisch", dass es im 1. Fall funktioniert 
hat obwohl auch diese 1. Schaltung nicht wie gewünscht funktionieren 
sollte.)


Tipps:
Ich empfehle eine Schwellspannung im Schalter zu definieren die nicht 
der Ruhespannung entspricht.

.model SW SW(Vt=0.1)

oder

.model SW SW(Vt=0.1 Ron=1 Roff=100G)


Man kann Bauteile mit CTRL-r drehen und mit CTRL-e spiegeln damit der 
SChaltplan leichter lesbar ist.


Wenn man trise und tfall auf 0 setzt, dann wird für trise und tfall 
intern ein Wert von 10% von Ton bzw. (Tperiod-Ton) verwendet.


Nachtrag: Ich war zu langsam. Mein Vorredner hatte schon die Lösung 
geschrieben.

: Bearbeitet durch User
von Christian M. (c_moeller)


Bewertung
0 lesenswert
nicht lesenswert
Kaum macht man's richtig gehts. Vielen Dank für die Hilfe. Danke auch 
für den Hinweis mit den 10% für trise / tfall.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.