mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Latch als Ausgangstreiber? Bestückungsfehler?


Autor: Matthias Laubnitz (mcl024)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen,

ich habe folgenden Schaltungsaufbau. Eine Schrittmotor Controller Karte 
welche via RS232 mit einem PC kommuniziert. Die Schrittmotor Controller 
Karte bietet zusätzlich 16 Inputs und 16 Outputs an, welche über die 
RS232 Schnittstelle gelesen oder geschrieben werden können. Der 
Schaltungsteil der I/O Pins ist im Anhang "IO Schematic".

Die eingesetzten Latches sind 74HCT373. Die Signale sind in den beiden 
anderen Anhängen zu sehen. Das Problem ist das diese Schaltung meiner 
Ansicht so nicht funktionieren kann. Dadurch das WR_OUT die meiste Zeit 
auf High liegt werden die Ausgänge hochohmig geschaltet.

Könnte es sein das hier ein Bestückungsfehler vorliegt und eigentlich 
ein passendes Flip-Flop eingesetzt werden müsste.

Die Firmware lässt sich leider nicht anpassen :-(

Vielen Dank für eure Mithilfe.

Autor: Wolfgang R. (mikemcbike)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sehe ich auch so, 74HCT273 bei den Ausgängen wäre sinnvoller.

Autor: Matthias Laubnitz (mcl024)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Leider passen bei dem Pin 1 und 11 nicht :-(
Umgekehrt wäre schön :-)

: Bearbeitet durch User
Autor: Stefan Us (stefanus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Warum sind denn die Signale so schlimm verwackelt? Sind deine GND 
Verbindungen (auch die vom Oszilloskop) in Ordnung und hast du jedem IC 
einen eigenen Abblock-Kondensator spendiert?

Autor: ubd689 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias L. schrieb:
> Könnte es sein das hier ein Bestückungsfehler vorliegt und eigentlich
> ein passendes Flip-Flop eingesetzt werden müsste.
FF muß nicht sein.

Mit _OE -> GND und LE -> WR_OUT folgen die Ausgänge den Eingängen, 
solange WR_OUT High ist. Ansonsten bleiben sie im letzten Zustand. 
Könnte man also mit Inverter und etwas Draht reparieren ;)

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie immer fehlt eine menge C - also Abblockkondensatoren ...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.