mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Hochtöniges Rauschen auf Line-In


Autor: Andreas (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe einen einfachen Tongenerator, welcher das erzeugte Signal auf 
eine Klinkenbuchse ausgibt. Wenn ich dieses Signal über einen Verstärker 
anhöre klingt es normal und auch auf dem Oszilloskop ändert sich mein 
Ausgangssignal nicht - der Verstärker wird ja hochohmig sein und das 
Signal nicht belasten.

Gehe ich nun auf das Audiointerface meines Rechners (eine MBox2), wird 
das Signal um ca. 50% gedämpft und ich höhre zusätzlich ein hohes 
Fiepen.

Meine Schaltung habe ich als Bild angehangen. Die Analoge Masse kommt 
aus der anderen Hälfte des OPVs und beträgt ca. 2V. Die 
Versorgungsspanung ist insgesamt 0-5V, das Tonsignal 0-3.3V maximal 
(wird gedämpgt auf 1-3V) mit Nullinie bei 1.65V.

Ich denke die Lösung wird einfach sein, aber leider bin ich kein 
Analogkenner :)

Autor: Joe F. (easylife)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Schaltung hat 3 Probleme:

a) Der Ausgang hat keinen definierten GND Bezug.
Ein Widerstand (z.B. 47K) zwischen C14 und R16 nach GND kann hier 
helfen.

b) Der Ausgang ist direkt mit dem Filter verbunden, und kann ihn zum 
schwingen bringen (z.B. durch die Induktivität eines langen Kabels).
Besser wäre nach dem Filter einen weiteren Opamp (1:1) als 
Ausgangstreiber zu verwenden.

c) Wenn die analoge (virtuelle) Masse aus einem Op-Amp kommt, und du 
diese analoge Masse mit GND der Ausgangsbuchse legst, muss 
sichergestellt sein, dass GND des Audiogerätes nicht über einen anderen 
Weg mit dem tatsächlichen GND deines Audiogerätes verbunden ist.
Besser wäre GND ist überall GND, und der Op-Amp wird symmetrisch 
versorgt.
Oder der Op-Amp wird unsymmetrisch versorgt, und das Signal wird vor dem 
Filter auf VCC/2 verschoben, und nach dem Auskoppelkondensator wieder 
auf GND-Bezug gebracht. Dann kann man sich die negative 
Versorgungsspannung sparen.

Nachtrag zu C:
Achso, verstehe jetzt erst. "DGND" ist das tatsächliche GND und "GND" 
sind die 2V. Sollte also so gehen, wie du es gemacht hast. Man könnte im 
Schaltplan statt "GND" dann einfach ein anderes Symbol nehmen und es 
"BIAS" oder so nennen.

Bleiben noch die Punkte a) und b).
Was auch nicht zu sehen ist sind Abblockkondensatoren am Op-Amp. Die 
braucht man natürlich auch.

: Bearbeitet durch User
Autor: Andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Abblockkondensatoren sind natürlich standard :). Das mit dem 47k und 
OP-Amp werde ich mal probieren, danke.

Autor: voltwide (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dir ist klar, dass R24 und R28 als Spannungsteiler Dein Eingangssignal 
abschwächen?

Autor: Andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
voltwide schrieb:
> Dir ist klar, dass R24 und R28 als Spannungsteiler Dein Eingangssignal
> abschwächen?

Das ist beabsichtigt, da der MCP602 den ich momentan verwende bei 0/5V 
maximal 3.8V am Eingang erlaubt. Das einkommende Signal wird auf 2V 
spitze-spitze gedämpft, so dass es nach C13 von 1-3V ausschlägt und 
alles im grünen Bereich ist.

Autor: Andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Achja, Koppelkondensator und 47k zwischen R14 und C16 haben leider 
schonmal nichts bewirkt.

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas schrieb:
> Gehe ich nun auf das Audiointerface meines Rechners (eine MBox2)

Auf welchen Eingang gehst du denn? XLR, Mic, Line , DI? Oder hast du 
schon alle durch?
Phantomspeisung muss auf jeden Fall aus sein, wenn du auf den XLR gehst, 
es sei denn, du hast einen Übertrager zwischen.

: Bearbeitet durch User
Autor: Joe F. (easylife)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann mache mal C14 kleiner (z.B. 1uF) und R16 größer (2.2K, 3.3K, ...) 
und gucke ob es damit besser wird.
Der gewählte Opamp ist wohl ein wenig zickig mit Ausgangskapazitäten...
Evtl. ist ihm auch schon C8 zu heftig...

: Bearbeitet durch User
Autor: Andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab bis jetzt nur den Line-In getestet. Bei meinen 
Gitarrenverstärker höre ich z.B. kein Pfeifton. Welcher Opamp wäre denn 
besser geeignet? Das tolle an dem MCP6002 ist, dass dieser 0-5V und 
In/Out Rail-to-Rail ist :).

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ich hab bis jetzt nur den Line-In getestet. Bei meinen
>Gitarrenverstärker höre ich z.B. kein Pfeifton. Welcher Opamp wäre denn
>besser geeignet? Das tolle an dem MCP6002 ist, dass dieser 0-5V und
>In/Out Rail-to-Rail ist :).

Kein OPV ist besser oder schlechter.
Aber
   Gain Bandwidth Product: 2.8 MHz (typical)

ist nicht so der Hammer.
Male doch mal auf, wie Du alles zusammengebunden hast.
Abblock-Cs hast Du zwar genannt, aber wo sind die drin? Auch zw. den 
Massen sollte die mit rein - sieht man aber nicht in Deinem Plan.

Und dann kommt es noch auf Deinen konkreten Aufbau an - Wenn Steckbrett, 
dann gibt'S reichlich Stolperfallen.

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Ausgang ist zwar eigentlich nicht für einen Kopfhörer gedacht, ich 
kann da aber gut etwas hören, wenn ich diesen anschließe. Dort habe ich 
keine hohen Störgeräusche.

Ich habe auch mal einen TLC2272 getestet, das selbe Problem. Evtl. macht 
auch  mein Audiointerface Probleme?

Abblockkondensator ist 100nF direkt zwischen Pin8/4. Was meinst du mit 
"Auch zw. den Massen sollte die mit rein".

Ja die Schaltung ist auf einem Steckbrett.

Autor: Karl B. (gustav)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jürgen schrieb:
> Evtl. macht
> auch  mein Audiointerface Probleme?

Hi,
habe bei der PC-Soundkarte lange rumgehext, bis ich rausgefunden hatte, 
dass man den Mikro-Eingang höchstens auf 65 % drehen darf, sonst gibt es 
ein pfeiftonähnliches Geräusch (nicht Rückkoppelpfeifen). Dann hängt das 
auch noch von den Mikrofonen ab. Einige 
Headset/Soundkarten-Kombinatiponen sind da ganz problematisch. Viele 
Soundkarten haben deswegen schon gar keinen Mikro-Eingang mehr, weil 
Einstreungen vom Mainboard-Bus in den Vorverstärker nicht immer 
vermieden werden können. Da schließt man das Mikro erst an einen 
externen Vorverstärker an, hebt den Pegel auf Line-In-Pegel an und 
verbindet das dann mit dem Line-In der PC-Soundkarte. Hab's ausprobiert, 
das "Pfeifgeräusch" (-teilweise irgendewie "geechot" noch-) ist weg.

ciao
gustav

Autor: Mark S. (voltwide)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei Desktop-PCs mit eingebauten Soundkarten habe ich auch schon völlig 
unaktzeptable Pfeif- und Nebengeräusche gehört. Keinerlei Probleme hatte 
ich bislang mit externen USB-Soundkarten.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.