mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Unterspannungsschutz Schaltung Problem


Autor: Fabs (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe mir die Schaltung im Anhang ausgedacht (LTSpice), die aber 
leider nicht so funktioniert.
Mein Problem: sechs seriell geschaltete LiTi Zellen mit einer 
Entladespannung von 1,8 V pro Zelle. Sicherheitshalber möchte ich bei 
11,4 V abschalten um nicht in den kritischen Bereich zu kommen. Dieses 
Pack soll ein Gerät betreiben, was nicht eigenständig abschaltet. Daher 
benötige ich eine Schutzschaltung.
Soweit klappt es auch bis hinter den OPV. Wenn das Signal (OPV) am 
+-Eingang unter 1,5 V fällt (Entspricht durch den Spannungsteiler 11,4 
V), wird der Ausgang vom OPV auf LOW gesetzt. Über 11,4 V hat der 
Ausgang ein HIGH Signal.
Mein Problem sind die MOSFETS. Den P-Channel MOSFET muss ich verbauen. 
Dabei handelt es sich um einen IRF9328, da dieser vorhanden ist und 
einen hohen Strom leiten kann.
Den N-Channel MOSFET habe ich mir gestern bei Conrad besorgt. Das ist 
ein IRF3710.
Leider sind MOSFETs mir noch reichlich unbekannt. Ich vermute mal, dass 
entweder der Gate Strom zu klein ist oder ein undefinierter Zustand 
vorliegt weil irgendwo noch ein Widerstand auf Masse gelegt werden muss.
Verschiedene Ansätze mit Transistoren haben mich auch nicht weiter 
gebracht.

Ich würde mich sehr über konstruktive Verbesserungsvorschläge freuen :)

1000 Dank vorab!

Fabs

Autor: Fabs (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bin immer noch auf der Suche nach einer Lösung. Bei dem Wetter sind wohl 
alle noch unterwegs :)

Autor: Max M. (jens2001)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fabs schrieb:
> Schaltung im Anhang

Ich SEH keine Schaltung!

: Bearbeitet durch User
Autor: Dennis K. (scarfaceno1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry... Nicht alles Standard Bauteile...

Beim Laden "Can´t find AD823"...

Autor: Lothar M. (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fabs schrieb:
> Ich würde mich sehr über konstruktive Verbesserungsvorschläge freuen :)
Du solltest für die Android-Tablet-Nutzer und für die, die kein LT-Spice 
installiert haben, einfach einen Screenshot ahnängen.

Autor: THOR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dennis K. schrieb:
> Sorry... Nicht alles Standard Bauteile...
>
> Beim Laden "Can´t find AD823"...

Bei mir auch, wird wohl der OPV sein.

Um das mal abzukürzen:
www.linear.com/docs/4829

So macht man das, so funktionierts auch, die Referenzspannungsquelle 
kann man durch ne Z-Diode ersetzen.

Autor: fabs (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Entschuldigung für die Komplikationen. Hier im Anhang nun der 
Screenshot. Der AD823 war tatsächlich kein Standardbauteil, habe ihn 
durch einen LT1077 ersetzt. Funktioniert auch so weit.

Zu dem Beitrag von THOR:

danke für den Link! Ich habe hier noch einen 7805 als 5 V 
Spannungsquelle. Müsste doch auch gehen, oder?

Autor: Zoltan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
R2 und R3 sind ja mal hübsche Widerstandswerte.
Werden die als Hybridmodul mit Lasertrimming hergestellt? ;-)

Autor: Michael B. (laberkopp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
fabs schrieb:
> Hier im Anhang nun der Screenshot.

Theoretisch funktioniert die Schaltung, praktisch gibt es folgende 
Probleme:

Die Schaltung hat keine Hysterese.

Es gibt ein Probelm, wenn die 5V mit der Ausgangsspannung abgeschaltet 
werden.

5V für den OpAmp macht am Ausgang 5V und der N-MOSFET IRF3710 schaltet 
sicher erst bei 10V ein. Er ist übrigens von der Grösse her massiv 
überdimensioniert.

Entweder also den AD824 aus der Akkuspannung versorgen, oder einen 
LogicLevel N-MOSFET nehmen (durchaus kleinerer Leistung) wie 2N7002.

Insgesamt ist fraglich, warum man so einen Bauteilaufwand treibt, wenn 
es bei den Spannungen mit einem ICL7665 problemlos ginge.

Autor: Lothar M. (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
fabs schrieb:
> Ich habe hier noch einen 7805 als 5 V Spannungsquelle. Müsste doch auch
> gehen, oder?
Du solltest aber aufpassen, dass nicht deine Entladeschutzschaltung 
letztlich so viel Strom zieht, dass der leere Akku vollends tiefentladen 
wird. Der Ruhestrom (bis zu 8mA) des 7805 ist da schon ein spürbarer 
Minuspunkt. Da hilft dann auch kein Mikropower-OP hinterher.

Ich würde auch den ICL7665 nehmen... ;-)

: Bearbeitet durch Moderator
Autor: fabs (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die hilfreichen Antworten!
Werde mal eine Schaltung mit dem ICL7665 aufbauen und diese dann hier 
wieder einstellen.

Beste Grüße

Autor: Fabs (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich muss noch einmal nachfragen:
Das Bild im Anhang zeigt die Beispielschaltung für die 
Batteriespannungswarnung und Abschaltung aus dem Datenblatt.
Mich verwirrt jetzt gerade der ICL7663s. Welche Funktion hat er?
Warum kann ich nicht von OUT1 (oder OUT2, sollte ja egal sein?) direkt 
einen n- bzw. p-channel MOSFET schalten? Hat der 7665 nicht genug 
Spannung/Strom zum durchschalten eines MOSFETs?

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fabs schrieb:
> Warum kann ich nicht von OUT1 (oder OUT2, sollte ja egal sein?) direkt
> einen n- bzw. p-channel MOSFET schalten?

Es sind open drain Ausgänge. Zum abschalten des MOSFETs braucht man also 
noch einen pull up Widerstand.

> Hat der 7665 nicht genug
> Spannung/Strom zum durchschalten eines MOSFETs?

Doch, aber deine katasttophale Schaltung verwendet einen NPN bipolaren 
Transistor, den kann der 7665 nicht direkt schalten und die verwenden 
den 7663 dazu unnötigerweise.
       /
   +-o/ o--+------+---+
   |       |      |   |
   |       |     10k  |
   |   +-------+  |   |S
 Akku  |ICL7665|--+--|I PMOSFET (ggf. LogicLevel)
   |   +-------+Out1  |
   |       |      Schaltung
   |       |          |
   +-------+----------+

Autor: Fabs (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo MaWin,

danke für die Antwort.
Deine Schaltung müsste dann doch nur noch um V_Set1 ergänzt werden, 
oder? An dieser würde ich einen Spannungsteiler so einstellen, dass er 
bei Packspannung von 11,4 V unter 1,3 V fällt um abzuschalten, richtig?

Beste Grüße

Autor: Fabs (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So nun im Anhang mal die umgesetzte Schaltung.

Sollte es so funktionieren?

Beste Grüße

Autor: Michael B. (laberkopp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fabs schrieb:
> Sollte es so funktionieren?

Nein, V+ sicher nicht über 600k. Einfach die Schaltung aus dem 
Datenblatt abzeichnen und die Bauteilwerte entsprechend der dort 
genannten Formeln berechnen.

: Bearbeitet durch User
Autor: Fabs (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im Datenblatt wird als maximale Versorgungsspannung 16 V angegeben.
Mein Akkupack kann aber 16,5 V, im ganz vollen Zustand sogar 16,8 V 
erreichen. Wollte das nicht einfach irgnorieren und die Spannung um 2 V 
senken.

Autor: Jens G. (jensg)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo mal,

ich habe es mal mit einem Komperator probiert - schaltet bei "11,0V aus" 
und bei "11,4V ein"  ..

eine Hysterese sollte immer dabei bei sein .. hier etwa 0,4V.  Weil .. 
beim ausschalten steigt die Spannung am Akku -- was dann die Last wieder 
einschalten lässt.  --  Wie hoch die Hyterese sein sollte, nachmessen! 
Die Hysterese ist die Differenz zwischen Leerlaufspannung und der 
Spannung im eingeschalteten Zustand.

Aus Sicherheitsgründen würde ich die Hsyterese auf 1,5x der gemessenen 
Differenz nehmen.

Autor: Jens G. (jensg)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
anbei meine Schaltung als Bild. Mit R7 wird die Hysterese bestimmt. 
Damit es beim ein- und ausschalten nicht schwingt. Teure 
Spezialschaltkreise würde ich nur in notwendigen Ausnahmefällen 
verwenden.

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fabs schrieb:
> Im Datenblatt wird als maximale Versorgungsspannung 16 V
> angegeben.
> Mein Akkupack kann aber 16,5 V, im ganz vollen Zustand sogar 16,8 V
> erreichen. Wollte das nicht einfach irgnorieren und die Spannung um 2 V
> senken.

Der Chip hält laut Datenblatt 18V aus, oberhalb 16V kann es aber sein, 
dass einzelne Datennlattwerte, wie Stromaufnahme, überschritten werden.

Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jens G. schrieb:
> Mit R7 wird die Hysterese bestimmt.
Die Frage ist, ob man nicht eher in Selbsthaltung gehen sollte: Aus ist 
Aus, bis manuell ein Taster betätigt wird oder Ladespannung anliegt.

Autor: Jens G. (jensg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn man sich den Zustand merken will .. macht man die Hysterese sehr 
hoch und schaltet den Trigger mit einem Taster wieder an.

Da ist dann der berühmte Timer-IC 555 "Mittel der Wahl" -- den habe ich 
beruflich für eine Überstromabschaltung verwendet, den der µC dann 
wieder zurüchsetzen musste. Betreibt man den Timer-IC 555 an 5V so hat 
man auch einigermaßen stabile Schaltschwellen.

Wie man den Timer-IC 555 beschaltet, möchte ich jetzt nicht weiter 
vertiefen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.