Forum: Mikrocontroller und Digitale Elektronik Problem mit Bluetooth Verstärker


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Niklas (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

für einen Eigenbau Bluetooth Lautsprecher hab ich mir die Verstärker auf 
dem Bild bestellt.

Zuerst wollte ich den Rechten testen, da ich diesen verbauen wollte. 
Also hab ich zwei Visaton FR58 mit 4Ohm angeschlossen und als 
Spannungsquelle einen 18650 Akku mittels Step Up auf 5V gebracht.

Wenn ich den Verstärker einschalte knistern die Lautsprecher nur und der 
Verstärker Chip wird sofort heiß. Bluetooth schaltet sich auch nicht 
ein.
Habe danach die Lautsprecher wieder ab gemacht, aber auch dann wird der 
Amp nur heiß. Ich fürchte der ist schon hinüber.

Nach dem gleichen Schema bin ich auch bei dem anderen Amp vorgegangen, 
aber auch da das selbe Resultat.
Da ich von diesem Modell noch einen zweiten hatte, habe ich diesen 
direkt ohne Lautsprecher eingeschaltet und er wird nicht heiß.

Beide Verstärker sind für 4-8Ohm angegeben.

Da ich leider keine Idee habe, was ich jetzt machen soll und nicht noch 
mehr Verstärker riskieren möchte, wende ich mich nun an euch.
Ich hoffe ihr könnt mir weiterhelfen.

MfG
Niklas

von >_ pr0 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Kriegste mit deinem Step Up auch wirklich 5V oder mehr?

von Nick S. (c0re)


Bewertung
0 lesenswert
nicht lesenswert
Schaltbild, Datenblatt der Verstärker? Irgendwas?

von Niklas (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Der kleine Amp ist ein PAM8403. Hier das Datenblatt dazu: 
http://www.allelectronics.com/mas_assets/theme/allelectronics/spec/AMP-8403.pdf

Zu dem Anderen hab ich leider garnichts. Das Ding wird als CSR8645 
Bluetooth Amplifier Board verkauft.
Ich weiß nur, dass er mit 2 mal 5W und 3,6-6,5V Betriebsspannung 
angegeben ist.

Laut Multimeter bekomme ich genau 5V raus. Hab es aber auch schon mit 
weniger versucht.

Das einzige was ich mir vorstellen könnte, ist, dass die Amps nicht mit 
4Ohm klar kommen, aber es scheint ja genug Leute zu geben, die 4Ohm 
Lautsprecher daran betreiben.

von Jim M. (turboj)


Bewertung
0 lesenswert
nicht lesenswert
Niklas schrieb:
> Wenn ich den Verstärker einschalte knistern die Lautsprecher nur und der
> Verstärker Chip wird sofort heiß. Bluetooth schaltet sich auch nicht
> ein.

Klingt schwerstens nach: Quelle verkehrtherum angeschlossen (verpolt). 
Damit ist das Modul in die weigen Jagtgründe gegangen.

Das CSR8645 Modul sieht für mich auch eher nicht nach einem 5V Design 
aus, sondern nach Split-Power. Die breiten Leiterbahnen unten rechts 
könnten die Lautsprecher Versorung darstellen. Hier bräucht man dringend 
ein Datenblatt oder eine Anleitung. Vermutlich braucht man auch 
Koppel-Kondensatoren am Ausgang.

: Bearbeitet durch User
von Niklas (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Danke erstmal für die Antworten.

Hier ist nochmal ein Bild der Rückseite, die ja den eigentlichen 
Verstärker darstellt.

In keinem der Videos, Bilder etc. in denen dieser Verstärker angewendet 
wurde, waren zusätzliche Schaltelemente verbaut.

Und die wurden eigentlich auch immer mit nem 18650 Li-Ion Akku 
betrieben.


Und ich bin mir zu 100% sicher, dass ich nichts verpolt habe. Denn wie 
gesagt, ohne angeschlossene Lautsprecher hats ja zuerst funktioniert.

von Rufus Τ. F. (rufus) (Moderator) Benutzerseite


Bewertung
-1 lesenswert
nicht lesenswert
Das Bluetooth-Modul hat zwei differentielle Ausgänge (LP/LN und RP/RN) 
; Dein Verstärker aber hat keine differentiellen Eingänge, sondern 
bezieht sich jeweils auf das Massesignal.

Du darfst aber die differentiellen Ausgänge des BT-Moduls nicht auf 
Masse legen oder auch nur miteinander verbinden.

Mit einem Übertrager je Kanal sollte sich das Problem lösen lassen.

von Stefan ⛄ F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
Rufus, ich glaube du hast ihn missverstanden. Er hat die Module meines 
erachtens nach nicht miteinander vebunden, sonden einzeln ausprobiert, 
indem er Batterie und Lautsprecher angeschlossen hat.

Was hast du (Niklas) denn an den linken Verstärker als Signalquelle 
angeschlossen?

von Niklas (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Richtig, ich wollte die beiden Verstärker nicht verbinden, sondern hab 
sie separat getestet.

Dort hab ich mein Handy mittels Aux Kabel angeschlossen.
Da ich ja noch einen zweiten von dem linken hatte, der ohne Lautsprecher 
und Eingangssignal kühl geblieben ist, habe ich diesen gerade auch mal 
getestet.
Aber diesmal hab ich je zwei 4öhmer in Reihe geschaltet.

Also Spannung drauf und das Ding blieb kühl. Dann voller Zuversicht mal 
Musik vorsichtig auf geringer Lautstärke angemacht und es kam auch was 
raus. Die Freunde war aber nach unter 10sek weg. Plötzlich wieder 
Stille. Am Amp gefühlt und schon wieder heiß.

Ich verstehe nicht was das Problem ist?!

Und ich hab die Lautsprecher Paare mit nun 8Ohm auch mal an den 
vermeidlich kaputten rechten Amp gepackt. Die Chips wurden nur minimal 
warm, aber es hat sich mein Bluetooth aktiviert.

von Rufus Τ. F. (rufus) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Niklas schrieb:
> die beiden Verstärker

Das ist ein Verstärker und ein BT-Audio-Modul.

An das BT-Audio-Modul solltest Du keine 4-Ohm-Lautsprecher anschließen, 
das Ding hat keine Endstufe.

An seinen Ausgängen liegen (wie ich bereits erklärt habe) differentielle 
Signale an; Du kannst da einen hochohmigen Kopfhörer anschließen, sofern 
der keine gemeinsame Masse verwendet.

von Niklas (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Das rechte Dingen ist ein Verstärker, der sein Audio Signal aus dem 
BT-Modul bezieht. An das BT-Modul hab ich auch keine Lautsprecher 
angeschlossen, sondern an die Anschlüsse LP,LN,RP,RN des dahinter 
liegenden Amps (die grüne Platine, auf der das BT-Modul sitzt).

von Harald A. (embedded)


Bewertung
0 lesenswert
nicht lesenswert
Sende mal ein paar Infos zu dem rechten Bluetooth-Modul, Link auf Shop 
o.ä.

Edit: OK, ich habe es, da ist kein Verstärker nachgeschaltet sondern ein 
RC4558 OP, um das Signal aus dem CSR8645 von differentiell auf 
Masse-bezogen zu wandeln:

https://www.aliexpress.com/item/5-pcs-2015-New-CSR8645-4-0-Low-Power-Consumption-Bluetooth-Stereo-Audio-Module-Supports-APTx/32308115071.html

Da steht übrigens Versorgung max. 4.2V

Du müsstest beide Module also verbinden, sofern überhaupt noch 
funktionsfähig.

: Bearbeitet durch User
von Harald A. (embedded)


Bewertung
0 lesenswert
nicht lesenswert
Ah, sieht dein rechtes Modul von der Unterseite etwa so aus:
https://www.aliexpress.com/item/Bluetooth-4-0-CSR8645-Amplifier-Board-5W-5W-APT-X-Stereo-Receiver-Amp-Module/32774647341.html

Ja, dann ist tatsächlich ein Verstärker mit drauf.

Wie gut, dass du umfassende Infos geliefert hast, z.B. ein Bild von der 
Unterseite.

Hast Du die Lautsprecher irgendwie verbunden oder gegen Masse 
geschaltet? Das würde die Erhitzung erklären.

von Niklas (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Das ist der Verstärker: 
Ebay-Artikel Nr. 282082393375

von Harald A. (embedded)


Bewertung
0 lesenswert
nicht lesenswert
Und? Lautsprecher verbunden oder gegen Masse geschaltet?
Wenn nein bleibt noch der Step-Up als Fehlerquelle.

von Niklas (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Mit dem Step Up hab ich auch schon überlegt und es infolge dessen 
getauscht.
Lautsprecher habe ich sowohl mit 4, als auch mit 8Ohm angeschlossen.

Gegen Masse hab ich es noch nicht geschaltet. Was könnte das den 
verändern?

von Klaus R. (klaus2)


Bewertung
0 lesenswert
nicht lesenswert
...das CRxxxx modul läuft auch OHNE step up mit 3,7V und mit 2x 4Ohm, 
nutze ich selbst so. 5V versorgung geht auch, nix split power. Irgendwo 
machst du einen Fehler...

Klaus.

: Bearbeitet durch User
von Klaus R. (klaus2)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Bild

von Niklas (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Die Frage ist nur wo ich den Fehler mache?

Die Lautsprecher habe ich natürlich so angeschlossen wie auf der 
Abbildung zu sehen. Die ganzen Taster habe ich weg gelassen, dass sollte 
aber unerheblich für die Funktion sein denke ich.

Um die Lautsprecher als Fehlerquelle auszuschließen, hab ich sie an 
einem anderen Amp getestet und daran funktionieren sie einwandfrei.

von Klaus R. (klaus2)


Bewertung
0 lesenswert
nicht lesenswert
...nun, aufgrund deiner Vorkenntnisse ist leider nicht ganz 
auszuschließen, dass die Dinger schon hinüber sind. Elektronik die 
"heiß" wird, das ist selten gut (vor Allem, wenn sie es eigentlich nicht 
werden darf). Ich habe da nur die Boxen angelötet, 3,7V dran und GO!

Klaus.

von Niklas (Gast)


Bewertung
0 lesenswert
nicht lesenswert
An sich ist das ja wirklich kein Hexenwerk zwei Lautsprecher an eine 
Platine anzulöten, aber man weiß ja nie.

Habe noch zwei Stück davon: 
Ebay-Artikel Nr. 272466928041

Die werde ich morgen mal mit Lautsprechern testen. Ohne gehen die an und 
ich kann mein Handy mit dem Bluetooth koppeln. Habe natürlich Bedenken, 
dass da auch wieder was passiert.

Welche Lautsprecher verwendest du denn?

von Klaus R. (klaus2)


Bewertung
0 lesenswert
nicht lesenswert
...die weiße Platine nutze ich auch, alles ohne Probleme. 2x 4W in einem 
alten Ghettoblaster.

Klaus.

von Harald A. (embedded)


Bewertung
0 lesenswert
nicht lesenswert
Niklas schrieb:
> Gegen Masse hab ich es noch nicht geschaltet. Was könnte das den
> verändern?

Dann würde es heiß werden bzw. sogar die Endstufen Schaden nehmen. Also 
unbedingt so anschließen wie auf dem Bild.

Niklas schrieb:
> Die Frage ist nur wo ich den Fehler mache?
>

Nur "mal kurz einen Fehler machen" kann das Modul auch schon zerstören, 
z.B. Verpolung, Kurzschluss o.ä. - da reichen manchmal Mikrosekunden...

: Bearbeitet durch User
von Niklas (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Also ich habe jetzt gerade mal die weiße Platine getestet und um ein 
Step Up als Fehlerquelle ausschließen zu können, hab ich diesmal ein 
Handyladegerät verwendet und über den USB Port der Platine 
angeschlossen.

Und siehe da, endlich kommt Musik aus den Lautsprechern.
Leider begleitet von einem Rauschen, dass etwa proportional zur 
Lautstärke ab- und zunimmt.
Ich gehe mal davon aus, dass dies dem Bluetooth geschuldet ist.
Gibt es etwas, dass ich dagegen tun kann?

Danke schonmal für Eure Hilfe und schönen Samstag!

von Stefan ⛄ F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
Zum einen ist Audio über Bluetooth suboptimal. Ich hatte an meiner 
Stereoanlage mehrere Empfänger ausprobiert, war aber mit keinem 
zufrieden, so dass ich jetzt doch wieder ein 10m Kabel zum Schreibtisch 
liegen habe.

Zum Anderen erzuegen diese Miniatur Verstärker kein analoges 
Ausgangssignal, sondern ein digitales, mittels PWM. Ich glaube, das 
nennt man Class-D Endstufe. Eine analoge Endstufe mit 2x4 Watt würde in 
dieser Chip-Form einfach zu viel Abwärme bringen.

Eventuell hilt ein 16kHz Tiefpass vor dem Lautsprecher, aus 
handelsüblichen Spulen/Kondensatoren für Lautsprecher-Frequenzweichen.

von Rufus Τ. F. (rufus) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Stefan U. schrieb:
> Zum einen ist Audio über Bluetooth suboptimal.

Kommt auf den jeweiligen BT-Standard an. Die Technik, die vor zehn oder 
mehr Jahren erstmalig Stereoübertragung via BT hinbekommen hat, musst 
dafür noch massive mit Klangeinbußen und Laufzeitverzögerung 
einhergehende Kompression verwenden; mit BT 4.0 aber ist das Geschichte, 
die Audioqualität ist um Größenordnungen besser und allenfalls für 
"audiophile" noch ein Problem.

Was letztlich verwendet wird, hängt natürlich von beiden Enden der 
Übertragung ab; ein topaktuelles BT-Audiomodul bringt, wenn es von einem 
PC mit einem BT2.0-Stick beschickt wird, nichts besseres zustande, als 
es ein korrespondierendes altes BT2.0-Audiomodul hinbekäme.

Der hier verwendete CSR8645 ist mit BT4.1 ziemlich aktuell und klingt 
mit passenden Gegenstücken als Klangquelle auch gut genug für den 
anspruchsvolleren Kopfhörereinsatz.

Wenn da was rauscht, liegt es an der nicht ausreichend 
gefilterten/entkoppelten Stromversorgung -- oder einem veralteten 
BT-Gegenstück.

von Mark S. (voltwide)


Bewertung
0 lesenswert
nicht lesenswert
Stefan U. schrieb:
> Eventuell hilt ein 16kHz Tiefpass vor dem Lautsprecher, aus
> handelsüblichen Spulen/Kondensatoren für Lautsprecher-Frequenzweichen.

Eher nicht. Üblicherweise ist dieser Tiefpaß an Bord, und etwaige 
Taktreste des PWM-Trägers sind auch kaum die Ursache für hörbares 
Rauschen.

von Harald A. (embedded)


Bewertung
0 lesenswert
nicht lesenswert
Mark S. schrieb:
> Stefan U. schrieb:
>> Eventuell hilt ein 16kHz Tiefpass vor dem Lautsprecher, aus
>> handelsüblichen Spulen/Kondensatoren für Lautsprecher-Frequenzweichen.
>
> Eher nicht. Üblicherweise ist dieser Tiefpaß an Bord, und etwaige
> Taktreste des PWM-Trägers sind auch kaum die Ursache für hörbares
> Rauschen.

In diesem Fall fehlt tatsächlich der Filter, sowohl beim Board mit dem 
CSR Chipsatz (mit HT8672 Amp) und auch beim weißen Board mit 
JL-Chipsatz, offensichtlich mit PAM8403-Endstufe. Das Design mit dem CSR 
kannst du beim obigen Aliexpress-Link ganz gut erkennnen. Filter hin 
oder her, Rauschen sollte es deswegen nicht, höchstens keiner 
EMV-Prüfung standhalten. Da gebe ich Stefan absolut Recht.

Grundsätzlich würde ich den CSR bevorzugen, denn der kann auch AAC und 
APTX Codec (sofern im Configtool freigeschaltet, siehe 
https://bois083.wordpress.com/2016/10/08/playing-audio-files-with-csr8645-bluetooth-chip/)
Der JL (oder JT?) wird nicht mit AAC/APTX beworben, also würde ich mal 
davon ausgehen, das er nur den grässlich klingenden SBC-Codec kann.

Woher das Rauschen kommt, müsste man mal analysieren. Auf dem CSR-Board 
ist ja schon die Wandlung von Symmetrisch auf Unsymmetrisch mit dem 
8-Pin RC4558, da könnte auch schon Rauschen eingebracht werden (siehe 
mein Aliexpress-Link oben). Zumindest vom PAM8403 kann ich sagen, dass 
der nicht sonderlich stark rauscht. Beim HT8672 weiß ich es nicht. 
Vielleicht mal prüfen, ob an Pin 2 und 6 des HT8672 auch ordnungsgemäß 
1uF angebaut ist und nicht weniger aus Kostengründen. Man könnte man mal 
am Ausgang des CSR-Boards (das aufgelötete SMD-Board) mit einem 
32Ohm-Ohrhörer lauschen (gegen Masse in diesem Fall), der RC4558 sollte 
den Ohrhörer halbwegs treiben können. Mit diesem Test weiß man dann, an 
welcher Seite Rauschen entsteht.

: Bearbeitet durch User
von Harald A. (embedded)


Bewertung
0 lesenswert
nicht lesenswert
Muss mich korrigieren, das zweite IC auf dem CSR8645-Modul ist nicht der 
RC4558-OP. Ich hatte mich durch die Zeichnungen auf Aliexpress 
fehlleiten lassen, es handelt sich offensichtlich nur um Vorschläge zur 
externen Signalanpassung. Das zweite IC auf dem CSR-Board dürfte das 
EEPROM sein.
Also kommt es doch symmetrisch raus und genau aus diesem Grund ist 
vermutlich auch der HT6872 eingesetzt worden - der hat nämlich einen 
symmetrischen Eingang. Der Allerwelts-Verstärker PAM8403 hingegen nicht.

Jetzt könntest du trotzdem einen 32-Ohm Ohrhörer direkt am CSR-Modul 
anlöten (symmetrisch, nicht gegen Masse) und lauschen. Wenn es hier auch 
schon rauscht, liegt es vermutlich an mangelnder Entkopplung. Vielleicht 
kann man mit einem Kodensator über VCC/GND etwas nachhelfen.

: Bearbeitet durch User
von controllergirl (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Rufus Τ. F. schrieb:
> Stefan U. schrieb:
>> Zum einen ist Audio über Bluetooth suboptimal.
>
> Kommt auf den jeweiligen BT-Standard an. Die Technik, die vor zehn oder
> mehr Jahren erstmalig Stereoübertragung via BT hinbekommen hat, musst
> dafür noch massive mit Klangeinbußen und Laufzeitverzögerung
> einhergehende Kompression verwenden; mit BT 4.0 aber ist das Geschichte,
> die Audioqualität ist um Größenordnungen besser und allenfalls für
> "audiophile" noch ein Problem.
>
> Was letztlich verwendet wird, hängt natürlich von beiden Enden der
> Übertragung ab; ein topaktuelles BT-Audiomodul bringt, wenn es von einem
> PC mit einem BT2.0-Stick beschickt wird, nichts besseres zustande, als
> es ein korrespondierendes altes BT2.0-Audiomodul hinbekäme.
>
> Der hier verwendete CSR8645 ist mit BT4.1 ziemlich aktuell und klingt
> mit passenden Gegenstücken als Klangquelle auch gut genug für den
> anspruchsvolleren Kopfhörereinsatz.
>
> Wenn da was rauscht, liegt es an der nicht ausreichend
> gefilterten/entkoppelten Stromversorgung -- oder einem veralteten
> BT-Gegenstück.

Auch ich fand die früheren BT Audioteile gruselig (BT2.1 etc).
Du berichtest jetzt, daß BT4 hier wesentlich besser funktioniert.
Hast Du zufällig eine konkrete Konstellation bzw. eine Empfehlung für 
ein Modul zur Hand?
Wäre bestimmt für viele eine Hilfe :O)

von Niklas (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ok danke erstmal!

Der Einfachheit halber werde ich nachher mal einen Kondensator zwischen 
VCC und GND löten und dann berichte ich wieder.
Das hatte ich so oder so vor, also wäre es ja ganz schön wenn der auch 
noch das Rauschen mindern kann.

von Rufus Τ. F. (rufus) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
controllergirl schrieb:
> Hast Du zufällig eine konkrete Konstellation bzw. eine Empfehlung für
> ein Modul zur Hand?

Nö, aber ich habe verschiedene BT-Funkheadsets an einem aktuellen 
Smartphone getestet, und sowohl mit dem hier genannten CSR8645 als auch 
einem "Airoha AB1510" brauchbare Resultate gehabt. Wenn Headsets lausig 
klingen, liegt es oft an den miesen angeschlossenen Schallwandlern.

Entscheidend ist halt die Gegenstelle, der "BT-Sender". Der muss 
ebenfalls BT4.x unterstützen, dann lohnt es sich.

von Falko Wagner (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Dieses Modul kann ich nur empfehlen, da hat die Endstufe keine 
differenzierten Ausgänge, aber dafür läuft das Ding mit 12 Volt.

CSR8645 APT-X HIFI Bluetooth 4.0 12V Receiver Board for Car Amplifier 
Speaker
 https://s.click.aliexpress.com/e/bPjj9bzq

Aber damit ist das auch kein Problem...

5pcs DC-DC Step Down Converter Module LM2596 DC 4.0~40 to 1.3-37V 
Adjustable Voltage Regulator Hot sale
 https://s.click.aliexpress.com/e/bq4sidvQ

von Neverever (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Rufus Τ. F. schrieb:
> controllergirl schrieb:
>> Hast Du zufällig eine konkrete Konstellation bzw. eine Empfehlung für
>> ein Modul zur Hand?
>
> Nö, aber ich habe verschiedene BT-Funkheadsets an einem aktuellen
> Smartphone getestet, und sowohl mit dem hier genannten CSR8645 als auch
> einem "Airoha AB1510" brauchbare Resultate gehabt. Wenn Headsets lausig
> klingen, liegt es oft an den miesen angeschlossenen Schallwandlern.
>
> Entscheidend ist halt die Gegenstelle, der "BT-Sender". Der muss
> ebenfalls BT4.x unterstützen, dann lohnt es sich.


Das ist doch falsch. Für Audio ist bei Bluetooth das A2DP Profil 
(Bluetooth Advanced Audio Distribution) zuständig und das gibt es schon 
seit Bluetooth 2.0.
"Problematisch" ist dabei, dass A2DP nur einen lausigen Codec (SBC) 
voraussetzt. Alles andere wie MP3 ist optional. Gut wird es nur mit 
AptX.
Daher ist darauf zu achten, dass Bluetooth Sender und Empfänger AptX 
beherrschen. BT4 muss es nicht sein, es geht auch 2.0 mit AptX.
Der CSR8645 beherrsch AptX.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.