Forum: Analoge Elektronik und Schaltungstechnik L297/L298 - Sense Widerstände heiß und Kurzschluss


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Manuel C. (holzwurmmc)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo alle miteinander,

diese Forum hat mir schon des öfteren aus Problemen herausgeholfen, doch 
nun bräuchte ich euere Hilfe mal Persönlich.

Ich baue mir gerade einen Schrittmotortreiber auf mit dem L297/L298.
Mein problem ist jetzt nur das sobald ich diese Steuerung anschließe, 
gibt der Motor einen Ruck von sich und dann habe ich irgendwo einen 
Kurzschluss.
Wenn das Netzteil wieder einschaltet wiederholt sich dies genauso. Doch 
so jedes 10te-15te mal aus und anschalten läuft der Motor los und tut 
was er soll. Wenn der Motor dann im Stillstand ist und nur im 
Haltemoment ist rauchen mir die Sense-Widerstände ab.

Die Platinen hab ich schon 100mal auf Kurzschluss usw. getestet.

Ich hab im Anhang mal den Schaltplan und das Platinenlayout angehängt.

Ich hoffe ihr könnt mir weiterhelfen.
Vielen Dank schon einmal im voraus.

: Verschoben durch Moderator
von MiWi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Manuel C. schrieb:
> Hallo alle miteinander,
>
> diese Forum hat mir schon des öfteren aus Problemen herausgeholfen, doch
> nun bräuchte ich euere Hilfe mal Persönlich.
>
> Ich baue mir gerade einen Schrittmotortreiber auf mit dem L297/L298.
> Mein problem ist jetzt nur das sobald ich diese Steuerung anschließe,
> gibt der Motor einen Ruck von sich und dann habe ich irgendwo einen
> Kurzschluss.
> Wenn das Netzteil wieder einschaltet wiederholt sich dies genauso. Doch
> so jedes 10te-15te mal aus und anschalten läuft der Motor los und tut
> was er soll. Wenn der Motor dann im Stillstand ist und nur im
> Haltemoment ist rauchen mir die Sense-Widerstände ab.
>
> Die Platinen hab ich schon 100mal auf Kurzschluss usw. getestet.
>
> Ich hab im Anhang mal den Schaltplan und das Platinenlayout angehängt.
>
> Ich hoffe ihr könnt mir weiterhelfen.
> Vielen Dank schon einmal im voraus.

Schaltplan suboptimal
Layout grottenschlecht....

was soll der arme, antiquarische Motortreiber aus dem vorigen 
Jahrtausend  den machen wenn es ihm GND durch die Gegend pfeffert, die 
Versorgung nicht gepuffert ist und die Schleifen, die durch die 
Motorleitungen erzeugt werden lustig und fröhlich vor sich hin Felder 
induzieren, weil sie so groß sind?

Vesuch mal die GNDs mit kürzest möglichen Drähten zu verbinden, den 
Versorgungen an den entsprechenden Pins einen 100n//10u zu setzen...

MiWi

von Wolfgang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Manuel C. schrieb:
> Wenn der Motor dann im Stillstand ist und nur im
> Haltemoment ist rauchen mir die Sense-Widerstände ab.

Dann baue erstmal Sense-Widerstände mit einem größeren Widerstandswert 
ein und verwende eine kleinere Motorspannung. Dann kann da auch im 
Fehlerfall nichts mehr rauchen und du in ruhe messen, was los ist.

von Teo D. (teoderix)


Bewertung
0 lesenswert
nicht lesenswert
INHx und Enable_x vertauscht angescklossen?

von Wolfgang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Teo D. schrieb:
> INHx und Enable_x vertauscht angescklossen?

Guter Einwurf - bei dem Leitungsknoten kann man schon mal ins Grübeln 
kommen. Sieht aber wohl nicht so aus.

Die Motorwicklungen könnten natürlich ein noch verkreuzt angeschlossen 
sein.

von Teo D. (teoderix)


Bewertung
0 lesenswert
nicht lesenswert
Schaltplan hin o. her.
Ich hatte da auch nur die Brücken falsch eingelötet.

von eProfi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Und bestimmt sind die Sense-Rs drahtgewickelt. Sie müssen non-inductive 
sein.
Suche nach passenden Beiträgen, das hatten wir schon dutzende Male.

von eProfi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Und am DC-Eingang ist Gnd und 25V vertauscht beschriftet.
VCC25_1 ist Gnd.
Mach mal eine zusätzliche Gnd-Brücke von den unteren Dioden zum Gnd des 
C4.
Das ist sonst eine riesige Spule.

von Achim S. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Vref liegt auf 5V - dein Spannungsteiler zum Einstellen hat auf beiden 
seiten das selbe Potential.

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Achim S. schrieb:
> dein Spannungsteiler zum Einstellen hat auf beiden seiten das selbe
> Potential.
Das dürfte die Ursache für das "niemals abschalten" sein. Es kommt 
vorrangig davon, dass die Symbole +5V und GND nicht verwendet 
wurden...


Einen Dauerbrenner hätte ich auch noch: die Angstdiode über dem 7805 ist 
nicht nötig.

von Manuel C. (holzwurmmc)


Bewertung
1 lesenswert
nicht lesenswert
Danke für die Antworten.

Teo D. schrieb:
> INHx und Enable_x vertauscht angescklossen?

Leider nicht

Wolfgang schrieb:
> Die Motorwicklungen könnten natürlich ein noch verkreuzt angeschlossen
> sein.

Nö passt auch

Teo D. schrieb:
> Ich hatte da auch nur die Brücken falsch eingelötet.

Geprüft und alle am richtigen Fleck

eProfi schrieb:
> Und bestimmt sind die Sense-Rs drahtgewickelt. Sie müssen non-inductive
> sein.

Jop ich hab drahtgewickelte verwendet! Gut die fliegen raus und werden 
ersetzt. Danke

eProfi schrieb:
> Und am DC-Eingang ist Gnd und 25V vertauscht beschriftet.
> VCC25_1 ist Gnd.

Oh ja sorry war mir bewusst nur noch nicht im Plan geändert

eProfi schrieb:
> Mach mal eine zusätzliche Gnd-Brücke von den unteren Dioden zum Gnd des
> C4.
> Das ist sonst eine riesige Spule.

Cool Danke klar hast natürlich recht

Achim S. schrieb:
> Vref liegt auf 5V - dein Spannungsteiler zum Einstellen hat auf beiden
> seiten das selbe Potential.

Oh man natürlich!!!!!!!! Danke

So werde alle Vorschlage morgen dann umsetzen! Ich überlege auch das 
Layout auch nochmal zu überarbeiten um noch mehr Fehlerquellen 
auszuschließen.

Vielen Dank an euch alle!

von Manuel C. (holzwurmmc)


Bewertung
1 lesenswert
nicht lesenswert
Lothar M. schrieb:
> Das dürfte die Ursache für das "niemals abschalten" sein. Es kommt
> vorrangig davon, dass die Symbole +5V und GND nicht verwendet
> wurden...
>
> Einen Dauerbrenner hätte ich auch noch: die Angstdiode über dem 7805 ist
> nicht nötig.

Ja muss dir da natürlich recht geben. Habe es selbst schon bemerkt das 
es an Beschriftung fehlt. Werde mich da in Zukunft konsequenter daran 
halten.

Lothar M. schrieb:
> Einen Dauerbrenner hätte ich auch noch: die Angstdiode über dem 7805 ist
> nicht nötig.

;) Wie du sagst war eine Angstdiode

Vielen Dank

von Teo D. (teoderix)


Bewertung
0 lesenswert
nicht lesenswert
Manuel, es ist eine wahre Freude, Deine Antworten zu lesen!

 - Namaste -



PS: War ne harte Woche hier.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.