Forum: Analoge Elektronik und Schaltungstechnik Rauschen am MCP1702-3302E


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Terratrembel (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen

Ich bin dran eine kleine Spannungsreglerschaltung mit dem MCP1702-3302E 
zu bauen, und stosse auf ein Problem. Der Schaltplan ist im Anhang.

Wenn ich am Input 5V (DC - sauber am Oszi) anhänge, dann bekomme ich 
unter der Last von 1kOhm:

DC (mean): 3.34V
AC (RMS) : 0.11V
freq.    : 7.6kHz

Das Verhalten verschwindet, sobald ich entweder:
a) keine Last am Ausgang habe
b) die Input Spannung senke (getestet mit 3.48V, andere Messungen nicht 
möglich da ich im Moment kein Netzteil habe)

Die überlagerte periodische Spannung sieht etwa wie eine 
Sägezahn-Dreieck Mischform aus.


Besten Dank für eure Hilfe

Terratrembel

: Verschoben durch Moderator
von Jörg R. (solar77)


Bewertung
0 lesenswert
nicht lesenswert
C's direkt am Regler?
Unsauberer Breadboard-Aufbau?
Foto von Aufbau und Hardcopy vom Scope-Bildschirm?

: Bearbeitet durch User
von Terratrembel (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Die Kondensatoren sind direkt am Regler.
Meiner Meinung nach, sollte der Aufbau ok sein, Bilder sind angehängt

von Rufus Τ. F. (rufus) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Das sollen "1 uF"-Kondensatoren sein?

von Terratrembel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Da mein Kapazitätsmessgerät bei meinem Vater ist, kann ich dir den 
realen Wert nicht sagen. Gekauft sind sie bei Aliexpress, gemäss 
Kommentaren +-15%

https://www.aliexpress.com/item/100pcs-lot-Multilayer-ceramic-capacitor-1uF-105-50V-1000nF-105M-P-5-08mm/32621685652.html?spm=a2g0s.9042311.0.0.BFGbYp

von Konstantin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Rufus Τ. F. schrieb:
> Das sollen "1 uF"-Kondensatoren sein?

Ja, die gibt es wirklich. Ich meine natürlich die kleine Bauform. Das 
sind Keramik-Vielschichtkondensatoren, die gibt es bei Conrad: Best. Nr. 
453382 von 1nF bis 1µF groß. Für diese Schaltung wäre vielleicht noch 
ein 10µF Elko parallel dazu hilfreich.

von Konstantin (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Oder die LED mal Testweise überbrücken, weil sie evtl. das 
Regelverhalten beeinflusst.

von Terratrembel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Die LED überbrücken hat kein Effekt gebracht. Jedoch hat der 10uF 
Kondensator genügend Kapazität um die Kurve zu glätten.
Das Interessante ist jedoch, dass ganz ohne Kapazität am Ausgang, die 
Kurve absolut sauber erscheint... weiss jemand wieso?

von Jörg R. (solar77)


Bewertung
0 lesenswert
nicht lesenswert
Terratrembel schrieb:
> Da mein Kapazitätsmessgerät bei meinem Vater ist, kann ich dir den
> realen Wert nicht sagen. Gekauft sind sie bei Aliexpress, gemäss
> Kommentaren +-15%
>
> https://www.aliexpress.com/item/100pcs-lot-Multila...

Hast Du mal einen anderen Regler getestet?
Vielleicht taugen die billigen C's nichts.

von Terratrembel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Auch die anderen Regler weisen dieses Verhalten auf.

Die Kondensatoren habe ich auch getauscht, und festgestellt, dass die 
Frequenz zunimmt, wenn kleinere Kondensatoren verwendet werden..
Das Verhalten bleibt aber bestehen, auch wenn qualitativ hochwertigere 
Kondensatoren (Tantal-Elko und Aluminium-Elko) eingesetzt werden.

von Falk B. (falk)


Bewertung
0 lesenswert
nicht lesenswert
@ Terratrembel (Gast)

>Wenn ich am Input 5V (DC - sauber am Oszi) anhänge,

Auch unter Last? Wo komme die 5V her?

>b) die Input Spannung senke (getestet mit 3.48V, andere Messungen nicht
>möglich da ich im Moment kein Netzteil habe)

Mit was hast du getestet? Einer Batterie?

>Die überlagerte periodische Spannung sieht etwa wie eine
>Sägezahn-Dreieck Mischform aus.

Das ist aber kein Rauschen, sondern eine handfeste Störung.
Der Regler kann schwingen, wenn er die falschen oder gar keine 
Kondensatoren hat. Das Datenblatt sagt, daß 1uF ausreichen. Hmm.

>Die Kondensatoren sind direkt am Regler.

OK.

>Meiner Meinung nach, sollte der Aufbau ok sein, Bilder sind angehängt

Was ist das für ein Board? Kommen die 5V vom USB?

Merkwürdig. Vielleicht ein Kontaktproblem im Breadboard?

von Mikki M. (mmerten)


Bewertung
0 lesenswert
nicht lesenswert
Der Regler scheint zu schwingen. Einige Low Drop Regler kommen explizit 
nicht mit Low ESR Keramik Kondensatoren klar (z.B. TS1117). Sofern es 
sich um einen MCP1702 aus irgendwelchen dubiosen Quellen handelt, kann 
es durchaus sein das dieser im Gegensatz zum Microchip nicht mit Keramik 
C's klarkommt und schwingt.

von Jörg R. (solar77)


Bewertung
0 lesenswert
nicht lesenswert
Terratrembel schrieb:
> Wenn ich am Input 5V (DC - sauber am Oszi) anhänge, dann bekomme ich
> unter der Last von 1kOhm:

So richtig glatt (sauber) ist die Eisgangsspanung nicht. Es sind kleine 
rechteckige Einbrüche zu erkennen, in ungleichmäßigen Abständen mit 
unterschädlichen Zeiten.

Hast Du die Schaltung mal mit Batterien versorgt?

: Bearbeitet durch User
von MiWi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Terratrembel schrieb:
> Hallo zusammen
>
> Ich bin dran eine kleine Spannungsreglerschaltung mit dem MCP1702-3302E
> zu bauen, und stosse auf ein Problem. Der Schaltplan ist im Anhang.
>
> Wenn ich am Input 5V (DC - sauber am Oszi) anhänge, dann bekomme ich
> unter der Last von 1kOhm:
>
> DC (mean): 3.34V
> AC (RMS) : 0.11V
> freq.    : 7.6kHz
>
> Das Verhalten verschwindet, sobald ich entweder:
> a) keine Last am Ausgang habe
> b) die Input Spannung senke (getestet mit 3.48V, andere Messungen nicht
> möglich da ich im Moment kein Netzteil habe)
>
> Die überlagerte periodische Spannung sieht etwa wie eine
> Sägezahn-Dreieck Mischform aus.
>
>
> Besten Dank für eure Hilfe
>
> Terratrembel

Nimm einen anderen Regler.

Ich hab mit dem MCP1710 schon meine blauen Wunder erlebt die 
letztendlich auf einen Chipfehler seitens Microchip rückführbar waren 
(Latchup bei Lastsprung, Du kannst das irgendwo hier im Forum finden).

Da der MCP1702 aus dem gleichen Eck kommt - weg mit dem und andere 
ULP-Regler verwenden.


MiWi

von Harald A. (embedded)


Bewertung
0 lesenswert
nicht lesenswert
Der MCP1702 war bei mir bisher unauffällig, allerdings muss man seine 
Grenzen kennen: Der geringe Eigenverbrauch ist mit einem schlechteren 
Regelverhalten bezahlt. Da sind dem MCP1702 gegenüber anderen 
Standardtypen schon deutliche Grenzen gesetzt.

Allerdings sollte er hier in dieser gezeigten Testschaltung einwandfrei 
funktionieren!

Kannst du nochmal kurz sagen, wo du das Ding gekauft hast? Falls der aus 
China kommt ist eine Produktfälschung nicht unwahrscheinlich. Es gibt ja 
eine Menge ähnlicher Derivate, die vielleicht einfach umgelabelt wurden. 
Und da gibt es viele, die mit der gezeigten Ausgangskapazität eben nicht 
stabil wären. Vielleicht entlarvt eine Messung des Eigenverbrauchs einen 
Fake-Kandidaten.

: Bearbeitet durch User

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.