Forum: PC Hard- und Software OpenVPN - Zugriff auf's Heimnetzwerk


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Matthias S. (da_user)


Bewertung
0 lesenswert
nicht lesenswert
Hi,
ich habe für mein Problem zwar schon in einem anderen Forum angefragt, 
dort aber bis dato noch keine Tipps erhalten. Darum versuch ich es hier 
nochmal, und erlaube mir einfach, den Text, zumindest teilweise, zu 
kopieren:

Kurzfassung: VPN läuft soweit, ich kann aber nicht auf Rechner/Geräte im 
Heimnetz zugreifen

Ich möchte über meinen Pi von außen auf das Netzwerk zugreifen können. 
Dazu habe ich OpenVPN nach dieser Anleitung eingerichtet: 
https://www.kuketz-blog.de/pivpn-raspberry-pi-mit-openvpn-raspberry-pi-teil3/
Punkt 5 habe ich weggelassen, bzw. dahingehend geändert, dass ich die 
Zeilen so abgeändert habe:

push "dhcp-option DNS 192.168.178.1"
push "dhcp-option DNS 85.214.20.141"
push "dhcp-option DNS 213.73.91.35"

Um mal schnell einen IP-Überberlick zu bekommen:
fritz.box 192.168.178.1
Pi Heimnetzseitig: 192.168.178.28
Pi OpenVPN: 10.8.0.0
Client ("Lenovo" - Win10) über VPN: 10.8.0.2
Hauptrechner ("HTPC"1 - Win10): 192.168.178.36

Mein Windowstablet (Client Lenovo) kommt hierbei über den W-Lan-Hotspot 
meines Smartphones ins Internet.

Ich kann die VPN-Verbindung aufbauen. Nachdem ich in der Fritzbox eine 
statische IP-Route eingestellt habe (Netzwerk: 10.8.0.0, Subnet 
255.255.255.0, Gateway 192.168.178.28) kann ich auch die Fritzbox 
pingen. Ein  tracert www.google.de vom Clienten aus, verrät mir auch, 
dass die Route über das VPN läuft.

Ich kann aber nicht vom Clienten auf weitere Geräte im Heimnetzwerk 
zugreifen, weder über den Alias noch über die IP. Auch ein Ping bleibt 
unbeantwortet. Auch ein Ping aus dem Heimnetzwerk an die 10.8.[...] IPs 
bleibt unbeantwortet.

Einen Möglichen Fehlerpunkt habe ich jetzt ausgemacht: Wenn ich in das 
Netzwerk und Freigabencenter gehe, werden mir die beiden aktiven 
Netzwerke "Android AP3" (logischerweise mein SmartphoneHotspot) über die 
Verbindung "WLAN", und ein "Nicht identifiziertes Netzwerk" über die 
Verbindung "Ehternet 3" angezeigt.
Hier ist "Android AP3" als privates Netzwerk eingestuft, das nicht 
identifzierte, welches logischerweise die VPN-Verbindung sein müsste, 
als "öffentliches Netzwerk". Trotz Googeln, habe ich nicht 
herausgefunden, wie man das umstellt. Die dazugehörigen Links/Buttons, 
sind alle nicht da, wo sie laut Screenshot sein sollten, oder irgendwo 
anders zu sehen. Wahrscheinlich hat MS da doch was umgebaut...

Wer kann mir hier helfen?

VG
da_user

von TestX (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Dein setup ist nicht ganz klar...poste mal bitte eine skizze.

Angenommen dein raspberry spielt vpn gateway als client. Dann muss 
dieser zum einen als router konfiguriert sein (ip4 forward). Außerdem 
muss für den ausgehenden datenverkehr vpn->lokal ein nat masquerading 
aktiv sein.
Abschließend muss dem von server bekannt sein, dass hinter dem client 
ein netzwerk ist, dass erreichbar sein soll (iroute option). Ansonsten 
verwirft der server die pakete und leitet sie nicht an den client.

von Jim M. (turboj)


Bewertung
0 lesenswert
nicht lesenswert
Matthias S. schrieb:
> Ich kann aber nicht vom Clienten auf weitere Geräte im Heimnetzwerk
> zugreifen, weder über den Alias noch über die IP. Auch ein Ping bleibt
> unbeantwortet. Auch ein Ping aus dem Heimnetzwerk an die 10.8.[...] IPs
> bleibt unbeantwortet.

Sind das Windows Geräte? Windoof antwortet nur auf Pings im lokalen 
Netz,
das 10.8.x.y Netz müsstest Du IMO manuell im Firewall freischalten.

Alternative: Der RPi mach NAT. Dann sehen die Kisten nur die 
192.168.178.28 Addresse.

von vpn (Gast)


Bewertung
0 lesenswert
nicht lesenswert
a) der VPN-Server muss routen können
b) jeder zu erreichende Teilnehmer im Netz 192.168.178.0/24 MUSS eine 
statische Route für das Netz 10.8.0.0/16 über den VPN-Server bekommen 
(-> einfacher: VPN am default Gateway terminieren lassen)
c) die Route für 192.168.178.0/24 muss über VPN vom VPN-Server an die 
VPN-Clients gepusht werden.

von Martin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Pc mit der 28 hat keine Route für die Antwort auf ping. Wenn dessen 
Firewall offen ist sollte man den Empfang des ping mit Wireshark aber 
sehen.

von Matthias S. (da_user)


Bewertung
0 lesenswert
nicht lesenswert
TestX schrieb:
> Dein setup ist nicht ganz klar...poste mal bitte eine skizze.

Skizze ist jetzt übertrieben, prinzipiell aber ganz klassisch:

Internetverbindung per FritzBox. Dahinter sitzen mein Hauptrechner 
("HTPC") und der Raspberry. Der HTPC ist quasi meine Eierlegende 
Wollmilchsau und stellt div. Dienste und Freigaben für mein Heimnetz 
bereit. Auf diese will ich jetzt auch von außen zugreifen.
Darum hat der Pi einen OpenVPN-Server verpasst bekommen, mit dem ich 
mich auch von außen verbinden kann. Dies geschieht im Moment mit meinem 
Windowstablet "Lenovo". Der Vollständigkeit halber sei hier gesagt, dass 
das Tablet über mein Android-Smartphone ins Internet kommt, natürlich 
soll das Tablet die Verbindung aber später auch aufbauen, wenn es z.B. 
über ein Hotel-W-LAN ins Internet kommt.

TestX schrieb:
> Angenommen dein raspberry spielt vpn gateway als client. Dann muss
> dieser zum einen als router konfiguriert sein (ip4 forward). Außerdem
> muss für den ausgehenden datenverkehr vpn->lokal ein nat masquerading
> aktiv sein.
> Abschließend muss dem von server bekannt sein, dass hinter dem client
> ein netzwerk ist, dass erreichbar sein soll (iroute option). Ansonsten
> verwirft der server die pakete und leitet sie nicht an den client.

Und wie mache ich das?
Ich bin jetzt kein Computernoob, aber in Sachen Linux und Netzwerk doch 
noch ziemlich unerfahren, insbesondere in Kombination.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.