Forum: FPGA, VHDL & Co. Störung bei 1.8V Eingang


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von L. Beier (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe ein Bluetooth Modul, welches eine I/O Spannung von 1.8V hat und 
Audiodaten über i2s überträgt. Ich habe die I/O Bank auf 1.8V gestellt 
und das Modul angeschlossen. Als ich jetzt das Signal einsynchronisiert 
habe, sind jetzt viele Störungen im Signal (siehe ersten Channel), 
obwohl ich in dem eigentlichen Signal keine Störungen erkennen kann.
Anscheinend liegt es wohl an der geringen Spannung, weil nachdem ich das 
Signal durch einen Pegelwandler angeschlossen habe, waren diese 
Störungen weg.
Jetzt meine Fragen:
Woher kommen diese Störungen?
Wie kann ich sie beheben?

Danke im Voraus!

von Stefan P. (form)


Bewertung
0 lesenswert
nicht lesenswert
Fehlende Anhänge?
Falsches Forum?

Beitrag #5124934 wurde vom Autor gelöscht.
von L. Beier (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ah Sorry. Hier sind die Anhänge:
Ich habe dieses Forum gewählt, da der FPGA Probleme mit den Signalen 
hat.

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
L. Beier schrieb:
> Woher kommen diese Störungen?
Ich würde mal die Schaltschwelle des FPGA-Eingangs vermessen (Spannung 
linear von 0 bis 1,8V hoch und runter. Schaltet der Eingang dann 
wirklich bei 0,9V?

von Stefan P. (form)


Bewertung
0 lesenswert
nicht lesenswert
Vielleicht nur eine zu knapp eingestellte Triggerschwelle in Deinem LA?
Warum zeigst Du am Oszi einen anderen Kanal?

von L. Beier (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Stefan P. schrieb:
> Vielleicht nur eine zu knapp eingestellte Triggerschwelle in
> Deinem LA?
> Warum zeigst Du am Oszi einen anderen Kanal?

Bei dem SCK Signal waren noch am meisten Schwankungen. Hier noch ein 
Ausschnitt von dem WS Signal.

von L. Beier (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Egal wie ich in Quartus die I/O Bank Spannung einstelle, der FPGA 
schaltet immer bei 1.7V

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
L. Beier schrieb:
> der FPGA schaltet immer bei 1.7V
Das ist die Hälfte von 3.3V...

> Egal wie ich in Quartus die I/O Bank Spannung einstelle
Und wie stellst du die IO-Spannung auf der Hardware am FPGA ein? Welche 
Spannung musst du da anlegen, um 1.8V Eingänge zu bekommen? Was sagt das 
Datenblatt dazu?

von L. Beier (Gast)


Bewertung
0 lesenswert
nicht lesenswert

von L. Beier (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Und hier nochmal mehr dazu:
https://www.altera.com/en_US/pdfs/literature/hb/cyc/cyc_c51008.pdf
Ab 8-19 steht was zu Quartus

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
L. Beier schrieb:
> Ich hab mich an diesen Beitrag gehalten
> Set the I/O bank VCCIO to your preferred voltage value.
Ein simpler Klick in der Software reicht nicht aus! Das bedeutet auch, 
dass die Hardware entsprechend eingestellt bzw. versorgt werden muss. 
Wenn du die Bank weiterhin mit einer Spannung von 3,3V versorgst, dann 
ist das Essig mit den 1,8V. Siehe dazu die Tabelle 8-4: für 1,8V 
Eingangskompatibilität braucht die Bank eine Versorgung von 1,8V oder 
1,5V...

: Bearbeitet durch Moderator
von L. Beier (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
L. Beier schrieb:
> Ist es möglich da noch die Bank mit 1,8V zu versorgen?
Theoretisch: Ja, wenn du die Pin2 40 und 47 nach oben biegst und dort 
die 1,8V anlegst.
Praktisch: Nein, eher nicht.

von L. Beier (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ok alle VCCIOs sind mit 3.3V verbunden. Ich bin noch ziemlich neu bei 
FPGAs und bislang waren alle Bauteile 3.3V. Aber trotzdem danke, dass 
ich mal wieder was gelernt habe! (In der Schule lernt man nicht so viel 
über FPGA design)

von Duke Scarring (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Bei anderen Eval-Boards ist da geschickterweise ein Widerstand 
verbaut...
(Da kann man auch gleich die Stromaufnahme messen.)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [vhdl]VHDL-Code[/vhdl]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.