Forum: Platinen Target3001 Backplane routen mit Autorouter


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Andreas F. (bazo)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

wie kann man Target beibringen, das es einen Bus in einem gewissen 
Bereich so routet wie in dem Anhang (ist von Hand und noch nicht 
komplett).
Es gibt zwar den Menüpunkt Speicher vorab routen, aber der bewirkt bei 
den Steckverbinder nichts.

PS:
Der Rest der Platine besteht aus Sub-D/USB-Steckverbindern & 
Schraubklemmen. die teilweise Signale von den Pfostenleisten enthalten

von TK (Gast)


Bewertung
2 lesenswert
nicht lesenswert
Hallo,

ich arbeite schon seit knapp 20 Jahren mit TARGET - und bin für mich zu 
dem Schluss gekommen, dass es nichts unnützeres gibt, als einen 
Autorouter! Ich glaube, in den 20 Jahren habe ich den exakt 3mal benutzt 
- und zwar nachdem ich 99% der Leitungen von Hand geroutet habe und die 
letzten beiden Leitungen einfach für mich nicht mehr ersichtlich routbar 
waren. Da hat dann einmal der Autorouter einen freien Weg aufgezeigt.
Was ich damit sagen möchte:
In der Zeit, in der man den Autorouter so konfiguriert, wie man es haben 
möchte, ist die halbe Platine schon von Hand fertig geroutet. Und 
nachdem Du ebenfalls von Hand schon gezeigt hast, wie Du die Leitungen 
verlegen möchtest, wärst Du wahrscheinlich schon fertig gewesen, wenn Du 
Dich nicht mit dem Autorouter beschäftigt hättest.
Also - bleib einfach beim manuellen routen - das ist SCHNELLER.

Gruß
TK

von Falk B. (falk)


Bewertung
0 lesenswert
nicht lesenswert
@ Andreas F. (bazo)

>wie kann man Target beibringen, das es einen Bus in einem gewissen
>Bereich so routet wie in dem Anhang

Direkt wahrscheinlich gar nicht.

> (ist von Hand und noch nicht komplett).

Dann mach es per Hand fertig, ist ja nicht viel und auch nicht komplex.

>Der Rest der Platine besteht aus Sub-D/USB-Steckverbindern &
>Schraubklemmen. die teilweise Signale von den Pfostenleisten enthalten

Dito.

von Veit D. (devil-elec)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

darf ich mich mal reinhängen, wenn hier jemand schon Jahrelang mit 
Target Erfahrung hat? Ich habe häufig Probleme mit Abstürzen seitens 
Target. Ich mache irgendwelche Korrketuren mit viel Undo usw. und Target 
schmiert ab. Ich ändere Signalnamen, verschiebe Leitungen auf dem Board 
und Target schmiert ab. Flächen werden weiß und immer weißer bis nichts 
mehr geht. Beim öffnen von Projektdateien werde ich öfters gewarnt das 
andere Bentuzer daran gearbeitet hätten? Kann nicht sein, ich bin der 
einzigste auf meinen Rechner und nur auf meinen Rechner, zu Hause.

Support erzählt, ohne das man es reproduzieren kann ist die Fehlersuche 
schwierig. Ist mir schon klar, aber irgendwie darf das doch dennoch 
nicht sein.

Der Win10 Rechner selbst läuft ansonsten unauffällig. Mit anderen 
Programmen gibts keine Probleme.

Ich mag Target, allein schon von der einfachen Bedienung her, nur frage 
ich mich ob es vielleicht auch andere Target Nutzer gibt die mit 
unkontrollierten Abstürzen zu tun haben oder ob ich der einzigste bin 
und den Fehler doch bei mir suchen muss.

von Andreas F. (bazo)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,
eigentlich sollte man meinen, das nach 30 Jahre PCB-Software der stupide 
Teil nicht mehr von Hand gemacht werden muss...

Zur Stabiltät:
Unter Wine und Ubuntu kann ich mich nicht beschweren.

Gruß Andreas

von Hubert (Gast)


Bewertung
0 lesenswert
nicht lesenswert
@ Veit Devil    Ich arbeite schon sehr lange mit Target. Aktuell mit der 
V19 Professional. Derartige Abstürze und Fehler sind mir bisher auch in 
den Vorgängerversionen nicht aufgefallen.

>Beim öffnen von Projektdateien werde ich öfters gewarnt das
andere Benutzer daran gearbeitet hätten.

Dies kommt daher das nach einem Absturz die Projektdatei nicht regulär 
beendet wurde. Target legt beim öffnen eines Projektes eine Datei 
*.T3001OPEN an. Diese enthält den Namen des Benutzers der aktuell mit 
dem Projekt arbeitet. Wird das Projekt nicht ordentlich geschlossen 
existiert diese Datei weiterhin. Beim Neustart von Target kommt daher 
der Hinweis das andere Benutzer gerade an dem Projekt arbeiten. Diesen 
Hinweis kannst du ignorieren.

von Falk B. (falk)


Bewertung
0 lesenswert
nicht lesenswert
@Andreas F. (bazo)

>eigentlich sollte man meinen, das nach 30 Jahre PCB-Software der stupide
>Teil nicht mehr von Hand gemacht werden muss...

Mag sein, aber Target und Eagle sind halt nur Mittelklasseprogramme, die 
können keine Busse automatisch verlegen. Sowas können nur die Großen. 
Die kosten aber auch großes Geld.

von Veit D. (devil-elec)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

das mit der Benutzerwarnung kommt auch manchmal einfach so, auch wenn es 
während der letzten Benutzung keine Probleme gab. Würde bedeuten das 
saubere beenden wird auch hier manchmal im Hintergrund gestört. Oder so 
ähnlich.

Aber erstmal gut zu wissen das es bei euch keine Probleme gibt. Dann 
wird es wohl doch irgendwie an meinem Rechner liegen. Habe aktuell 
meinen Virenscanner G-Data im Verdacht. Werde den mal Testweise 
wechseln.

Habe übrigens auch vor kurzem auf v19 gewechselt.

Danke für die Antworten.

von bazo (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Der Autorouter kann das laut Wiki 
https://server.ibfriedrich.com/wiki/ibfwikide/images/9/9b/Router_4_1_d.jpg, 
nur wie stellt man das ein?. Mal schauen, wie schnell IBF reagiert.

Gruß Andreas

von Hubert (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Kannst du mal das T3001 File mit den Steckern und den Verbindungen 
hochladen, dann würde ich das mal testen.

von Veit D. (devil-elec)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich meinte natürlich v18.   :-)

Wegen dem Leiterbahn routen allgemein. Könnte nicht jemand eine 
Funkverbindung von Pin zu Pin erfinden. Quasi lokales WLAN auf der 
Leiterplatte. Das gibt der Bauteilplatzierung und Dichte völlig neue 
Möglichkeiten.   :-)

von Bernd T. (bastelmensch)


Bewertung
0 lesenswert
nicht lesenswert
Das Problem mit Abstürzen mit vielen Undo habe ich bei Projekten die 
schon älter sind und ich als Basis für was neues benutze.

ibf behauptet auch bei mir das sie es nicht nachvollziehen können.
Ob sie es wirklich nicht können entzieht sich natürlich meiner kenntnis.

Wenn mir so ein verhalten bei einem Projekt nochmal auffallen wird, dann 
werde ich ein Video daraus machen und es denen schicken damit sie es 
sich anschauen können.

von Uwe (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Veit D. schrieb:
> darf ich mich mal reinhängen, wenn hier jemand schon Jahrelang mit
> Target Erfahrung hat? Ich habe häufig Probleme mit Abstürzen seitens
> Target.

Habe mit Target V16/V17/V18 unter Windows 7/8.1/10 nie 
Stabilitätsprobleme gehabt. Es ist in all den Jahren vlt. ein oder 
zweimal abgestürzt. (Dabei ging aber nichts verloren.)

von Andreas F. (bazo)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hubert schrieb:
> Kannst du mal das T3001 File mit den Steckern und den Verbindungen
> hochladen, dann würde ich das mal testen.

Anbei das Projekt.

von TK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich kann auch ein Feedback zu Abstürzen geben:
Ja - die kommen immer wieder vor - und zwar bei vielen 
aufeinanderfolgenden Aktionen, bei denen man Dialogfenster öffnen und 
wieder schliessen muss. Wenn dann eine bestimmte Größe an "internem 
Speicher" überschritten wird, kommt eine Fehlermeldung - man kann aber 
weitermachen - am besten mit Projekt>Speichern. Ich hatte rausgefunden, 
dass ein regelmäßiges SPEICHERN und zwar nicht das AUTOSAVE BACKUP, 
sondern tatsächlich per Menü diesen "Speicherüberlauf" verhindert bzw. 
scheinbar eine interne GARBAGE COLLECTION durchführt. Seit dem habe ich 
keine Probleme mehr mit Fehlern. Liegt evtl. auch noch mit am OS. Ich 
arbeite immer noch mit XP und Target hat die V17. Kann also bei anderen 
OS keine Aussage treffen (aber scheinbar ist auch die RAM-Größe ein 
Kriterium - daher kommt der Fehler bei vielen einfach nicht vor).

Gruß
TK

von Veit D. (devil-elec)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

AV Deinstallation brachte keine Besserung. Gestern noch getestet. Ich 
merke jedoch das ich demnach nicht der einzigste bin mit dem Problem. 
Das Gefühl das echtes speichern hilft habe ich auch. Konnte es aber nie 
belegen. Meistens nicht immer erscheint dann dieses Hinweisfenster mit 
Fehlercode, irgendwelche Adressen usw. die mir als Anwender aber nichts 
bringen.

Gestern dachte ich, ich kann es provozieren. Ich entferne die kleinen 
krummen Leiterstücke der Teardrops an Lötaugen. Manche will er einfach 
mit "w" nicht einfangen. Nach einer Weile mehrfaches Taste drücken 
werden Flächen weiß. Alles ungespeichert geschlossen und wieder 
geöffnet. Gleiches Spiel. Beim nächsten Versuch fand er sofort den 
kleinen Rest. Keine Fehler. Überhaupt scheinen mir die meistens Probleme 
mit "w" und Undo zukommen. Kann das sein?

RAM habe ich mit 16GB genug. Win10 Pro. Mit Win7 vorher und älteren 
Targetversionen hatte ich auch schon Probleme. Bin mit v15 eingestiegen.

An eine Videoaufzeichnung dachte ich auch schon. Was kann man dafür 
verwenden? Ggibts Win Bordmittel?

von Stefan (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Andreas am besten machst du das von Hand. Geht auch schneller.
Nimmst am besten dafür den Electra Autorouter.
Dort die Bahnen von Hand verlegen. Dabei werden dann
auch automatisch die Leiterbahnen verschoben, die schon
geroutet sind, um deine Leiterbahn zu verlegen.
Damit hast du dann deine Leiterbahnen in ein paar Minuten
verlegt. Der Autorouter braucht länger, und es sieht
nicht so gut aus.

von Hubert (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
falls du nicht alles von Hand routen willst geht es auch mit dem 
Autorouter.

Im Contour Autorouter gibt es die Möglichkeit Busse vorab zu routen.
2 Leiterbahnen konnten aber nicht verlegt werden. Dafür habe ich 
nochmals den Elektra Router verwendet.

Das Ergebnis ist aber sicherlich noch an diversen Stellen 
verbesserungswürdig und mit der Hand nachzuarbeiten .

von Hubert (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hier nochmals zum schnellen Überblick

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.