mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR Studio und Olimex mit JTAGICE Problem


Autor: Michael Steinbauer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo liebe Kollegen,

ich bin nach Jahren vom 68hc11 auf den ATMEGA umgestiegen. Habe mir ein
Minimalsystem aufgebaut, das aktuelle AVR Studio installiert und von
Olimex den ARV-JTAG-USB gekauft.

Ich kann nun im AVR Studio Verbindung mit meinen ATMEGA32 aufnehmen,
kann die Fuses einstellen und Software runterladen und es funktioniert
auch (Testprogram stetzt Port mit LED) Kann also Flash und EEProm
programmieren.

Wenn ich nun aber online Debuggen will, dann geht das nicht. Es wird
keine Hardware gefunden. Habe die Orignalbeschreibung des Controllers
zu JTAG gelesen, habe gegoogelt - ohne Erfolg. Da gibt es nur die eine
Fuse.

Wie kann es sein, dass ich über JTAG einen Download machen kann, aber
nicht online debuggen?

Würde mich sehr über eine Antwort freuen, damit mir der Umstieg zu
Atmel auch wieder Spass macht :-)

Michael Steinbauer

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
on chio debugging fuse setzen und jtag interface sollte helfen

ach ja der controller sollte jtag unterstuetzen

Autor: Michael Steinbauer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Peter,

die fuse ist ja auf jtag, sonst könnte ich nicht beim AVR Studion unter
dem Punkt "connect to the selected ARV programmer" Verbindung mit dem
Controller aufnehmen, die Fuses, lesen und schreiben, Programme
runterladen und starten.

Nur wenn ich in den Debugg Modus will, meint AVR Studio, die Hardware
(spriche den JTAGICE Programmer nicht zu kennen).

Weisst Du was ich meine?

Michael Steinbauer

Autor: Michael Steinbauer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
:-) hab gefunden :-)

Der Fehler steckt im System:

AVR-Studio macht einen Unterschied in der Kontaktaufnahme zum JTAGICE.
Wenn man debuggen möchte, dann muss man für die USB Schnittstelle COM6
angeben, dann geht es. Beim normalen Programmieren reicht die
Einstellung Auto.

Grüße an alle,

Michael Steinbauer

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.