Forum: Analoge Elektronik und Schaltungstechnik LTSPICE lib - finde neue Bauelement nach update nicht


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Habe von LT eben einen Update gemacht und die Bauelemente-Library 
aktualisiert. Es sind tausende von Bauteilen runtergeladen worden, aber 
ich find nicht eines von den neuen (z.B. LT1764) in der Übersicht, wenn 
ich ein neues Device laden will.

Gehen die .lib Files nach lib? Würde man meinen, aber ich habe ein 
anderes Bauelement, das ich aus irgendeinem Git-Repo runtergeladen habe 
z.B. erst dann gefunden, nachdem ich die .lib ins LTSPICE 
Hauptverzeichnis kopiert hatte. Andererseits scheint der Update alle 
.libs ins Vzchns. SYM kopiert zu haben.

Also, da gibt's irgendwie keine Struktur oder ich habe was noch nicht 
kapiert.

Grüße
Christoph

von Helmut S. (helmuts)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Christoph,
ich nehme mal an du hast LTspiceXVII installiert und einen Update von 
LTspiceXVII auf die aktuelle version gemacht.

LTspiceXVII installiert sich in

C:\programs\LTC\LTspiceXVII


Anschließen kopiert es automatisch das komplette lib-Verzeichnis nach 
"Documents" des Benutzers. Im deutschen Winwows heißt dar Ordner "Eigene 
Dokumente".

C:\Users\USERNAME\Documents\LTspiceXVII\lib\sub

C:\Users\USERNAME\Documents\LTspiceXVII\lib\sym

C:\Users\USERNAME\Documents\LTspiceXVII\lib\cmp (.model definitions)

C:\Users\USERNAME\Documents\LTspiceXVII\Examples (example 
circuits/schematics)


LTspiceXVII sucht automatisch in den Ordnern "Documents", den zusätzlich 
definierten Ordnern(Control Panel setting) und im Schaltplanverzeichnis 
nach Symbolen und Modelldateien.

Gruß
Helmut

: Bearbeitet durch User
von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke, Helmut.

Nee, in c:\Program Files (x86)\LTC ist nichts neues hinzugekommen. Da 
steht nach wie vor nur LTspiceIV.

ABer ich habe jetzt den Download-Link auf der LTC Site aufgesucht und 
installiere jetzt erst mal besagte neuere Version.

von Helmut S. (helmuts)


Bewertung
0 lesenswert
nicht lesenswert
Ich konnte ja nicht ahnen, dass du noch mit der alten Version LTspiceIV 
arbeitest. Die wird seit über einem Jahr nicht mehr weitergepflegt. Das 
heißt die neuen Modelle der letzten 12 Monate fehlen dort und es wird 
auch keinen Update für diese Version geben. Das neue LTspiceXVII 
erfordert WIN 7, 8, 10 -  alternativ Linux mit Wine.

Hier der Link zur neuen aktuellen Version LTspiceXVII.
http://ltspice.linear-tech.com/software/LTspiceXVII.exe


Man kann die alte und die neue Version gleichzeitig auf dem Rechner 
haben. Die stören sich gegenseitig nicht.

: Bearbeitet durch User
von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke, hatte ich jetzt auch schon gefunden und installiert. Ist eine 
64bit Version.
Werde mal weiterschauen.
Grüße
Christoph

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Habe jetzt meine alte Schaltung mit 7805 in LTspiceXVII geöffnet und 
nach Umkopieren der 7805.asy Datei aus dem alten sym-Verzeichnis findet 
LTspice jetzt auch den 7805.

Auch die anderen Spannungsregler finde ich jetzt unter POWERPRODUCTS.

Erst mal erledigt.

Danke noch mal

--
Christoph

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich weiß jetzt nicht, ob ich einen neuen Thread aufmachen soll, aber ich 
bekomme, wenn ich einen

ltspice-export-setup in Eagle mache, eine Alert Box, die folgendes sagt:

Default LTspice simulation library found on:
C:/Program Files/EAGLE-7.7.0/lbr/ltspice/lt-spice-simulation.lbr

Gut, gefunden. Ist doch gut.

Was mich aber eher stört ist, daß in der dann folgenden Liste derr 
Setup-Parameter steht, daß das ULP LTspice in c:\program files 
(x86)\LTC\LTspiceIV
gefunden hat. Soweit zur Koexistenz von alter und neuer Versionb.

Grüße
Christoph

von Helmut S. (helmuts)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Christoph,

Vielleicht kannst du ja in EAGLE den Pfad setzen. Alternativ eine email 
an AutoCad schicken mit der Bitte das für LTspiceXVII anzupassen.

Gruß
Helmut

von ChristophK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Helmut S. schrieb:
> Hallo Christoph,
>
> Vielleicht kannst du ja in EAGLE den Pfad setzen. Alternativ eine email
> an AutoCad schicken mit der Bitte das für LTspiceXVII anzupassen.
>
> Gruß
> Helmut

Versuche im Moment, das ltspice.ulp entsprechend zu modifizieren. Das 
sucht die LTspiceIV - und findet sie natürlich auch.

Danke erstmal.

Christoph

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.