Forum: Analoge Elektronik und Schaltungstechnik LED Controller


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Farin U. (farin_u86)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hat hier vielleicht schon mal jemand mit einem Texas Instruments 
TPS92692 LED Controller gearbeitet?

http://www.ti.com/product/TPS92692

Ein Jungkollege hat einen Prototypen gebaut, aber so richtig laeuft das 
Ding nicht. Waere ueber jeden Tip gluecklich.

: Verschoben durch Moderator
von Christian S. (roehrenvorheizer)


Bewertung
0 lesenswert
nicht lesenswert
Und warum hat der Jung-Entwickler das nicht richtig hin bekommen?

MfG

von Wolfgang (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Farin U. schrieb:
> Ein Jungkollege hat einen Prototypen gebaut, aber so richtig laeuft das
> Ding nicht.

Hat er beim Aufbau am Layout etwas falsch gemacht oder hat er eine 
falsche Induktivität gewählt?

Beitrag #5190596 wurde von einem Moderator gelöscht.
von W.A. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Farin U. schrieb:
> Waere ueber jeden Tip gluecklich.

Am besten wäre es wohl, systematisch vorzugehen.
 - Was wird erwartet?
 - Was geht?
 - Was geht nicht/nur unbefriedigend?

Wenn das geklärt ist und man selbst in angemessener Zeit keine Lösung 
findet, könnte man den bisherigen Stand der Dinge verständlich 
formulieren und in einem Elektronik-Forum posten. Mit großer 
Wahrscheinlichkeit findet sich dort jemand, der anhand der geschildetern 
Symptome das Problem erkennt oder zur Klärung gezielt weitere Fragen 
stellen kann.

von Stefan ⛄ F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
> Waere ueber jeden Tip gluecklich.

Mein Tipp: Datenblatt lesen, Schaltung richtig aufbauen, und richtig 
programmieren?

Lies noch mal deine Frage und überlege dann, wie andere, die nicht am 
Projekt beteiligt waren, dazu vernünftig antworten können sollen.

von Farin U. (farin_u86)


Bewertung
0 lesenswert
nicht lesenswert
Entschuldigung fuer die langsame Antwort...

OK... ich bekomme unseren Prototypen am Mittwoch und hoffe das ich dann 
mehr sagen kann.

Soviel aber vorab.

Wie es aussieht flackern die LEDs die angesteuert werden sollen. Ich 
vermute das ein Fehler erkannt wird und der Chip einen Reset durchfuehrt 
und danach versucht neu zu starten.

Ich habe das Datenblatt mehrmals studiert und kann keinen Fehler 
erkennen.
Ein Sachverhalt koennnte eventuell eine Rolle spielen und zwar weisst 
das Datenblatt auf eine GND Plane hin und unser Prototyp hat dies nicht.

Ich bekomme diese Woche sogar ein Evaluation Board.

von Michael K. (Gast)


Bewertung
2 lesenswert
nicht lesenswert
Es gelten die allgemeinen Hinweise eines jeden Schaltregler designs.
Offensichtlich kennt die bei Euch keiner.
Taugliche GND Führung ist eines davon.
Darüber hinaus gibt es noch seeehr viel anderes das an falsch machen 
kann, aber das führt hier viel zu weit.

Deine Beschreibung des Fehlers ist: Geht nicht
Deine Frage: Warum
Deine Lösungsstrategie: Raten und herumstochern statt Messen

Zeig das Layout und mach ein paar grundlegende Messungen dann können wir 
auch helfen wenns immer noch hakt.

Wahres ist selten schön und Schönes ist selten wahr, also nimms nicht 
persönlich.

von TestX (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Wenn ihr euch nicht am besipiellayout orientiert habt ist es kein 
wunder...die wandler brauchen ein gnd plane...ansonsten gibt es 
lustigste effekte

von Farin U. (farin_u86)


Bewertung
0 lesenswert
nicht lesenswert
Hallo... Danke erstmal.

Ich nehme das nicht krumm denn unsere Firma / Firmenstruktur lässt das 
gar nicht anders zu.

Unsere Produkte werden in Niedriglohnländern entwickelt und produziert. 
Das Design ist und bleibt die Verantwortung unserer Herstellerfirma.

Meine Aufgabe ist schwerpunktmäßig die Steuerung des Projekts von Idee 
bis zur Verpackung. Da ist die Elektronik nur ein relativ kleiner 
Bereich.

Nun hätte ich schon die Frage was ich denn eventuell messen / testen 
könnte, denn Interesse habe ich schon da etwas zu lernen. Als Symptom 
kann ich schon mal sagen das das Gate von dem schaltenden Element 
(MOSFET) nicht angesteuert wird ...

Trotzdem Danke...

von Stefan ⛄ F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
Ohne Plan kann Dir hier immer noch niemand helfen.

von Michael K. (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Eigentlich läuft das anders herum.
Im Billiglohnland die Arbeiten für die man einfach viele flinke Hände 
braucht und in DE die Arbeit für die man gut ausgebildete Mitarbeiter 
benötigt.

Macht das Design in DE, schickt jemanden los der die Probleme vor Ort 
fixt oder bezahlt einen Entwickler in DE als Troubleshooter.
Könntest Du vollständige Informationen liefern und wüsstest wenigstens 
zu 80% was Ihr das habt 'entwickeln' lassen dann würde ich ja über 
dieses Stöckchen springen, aber so empfinde ich ehrlich gesagt eine 
gewisse Genugtuung das man auf den Pinsel fällt beim Versuch qualitativ 
hochwertige Arbeit fürn Appel und ein Ei im Billiglohnland zu machen.

von Farin U. (farin_u86)


Bewertung
1 lesenswert
nicht lesenswert
Stefan U. schrieb:
> Ohne Plan kann Dir hier immer noch niemand helfen.

Könntest du bitte genauer ausdrücken?
Möchtest du einen Schaltplan?

Unsere Firma ist mit diesem Businessmodel groß geworden und versucht 
diese Vorgehensweise zu wiederholen.

Ich muss dir jedoch Wiedersprechen das China "nur" für Arbeiten mit 
flinken Händen zu gebrauchen ist. Dort gibt es auch erfahrene 
Entwickler, jedoch sind diese in Firmen die wir nicht bezahlen wollen. 
Ist nicht schlimm, anscheinend ist der Leidensdruck nicht hoch genug.

Ich selber bin nur ein kleines Rad im Getriebe.

LG

von Stefan ⛄ F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
> Möchtest du einen Schaltplan?

Ja. oder zumindest eine detaillierte Beschreibung, WAS ihr WO mit dem 
Bauteil machen wollt, und unter welchen BEDINGUNGEN es stattfinden wird.

> in Jungkollege hat einen Prototypen gebaut, aber so richtig
> laeuft das Ding nicht.

Wie sollen wir irgendetwas zu dem Prototypen sagen, wenn wir ihn nicht 
einmal gesehen haben?

Ich habe auch einen Prototypen für eine messtation gebaut, da 
funktioniert die rechte Hälfte nicht. Sag du mir, was ich dort anpassen 
muss, damit es funktioniert.

Merkst du, was ich meine?

von Michael K. (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Farin U. schrieb:
> Ich muss dir jedoch Wiedersprechen das China "nur" für Arbeiten mit
> flinken Händen zu gebrauchen ist.

Das wollte ich auch nicht damit sagen.
Die sind ja nicht dümmer als wir.
Die Reibungsverluste bei Auftragsentwicklungen sind nur groß, gerade 
wenn man, so wie Ihr, zum billigsten geht, der ausser einem strahlenden 
Lächeln und vollmundigen Versprechungen nicht allzuviel von dem versteht 
was er da anbietet.

Was kostet eigentlich Deine Arbeitszeit, wenn Ihr noch nicht mal einen 
chinesischen Entwickler bezahlen wollt, der weiß was er tut?

Hier versuchst Du ja die Entwicklungsleistung für komplett NULL Euro zu 
bekommmen. Noch billiger als beim billigen Chinesen, ohne die 
Zeitverschiebung.
Muss jeder selbst wissen ob er das unterstützen will.

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Bewertung
1 lesenswert
nicht lesenswert
Farin U. schrieb:
> Als Symptom kann ich schon mal sagen das das Gate von dem schaltenden
> Element (MOSFET) nicht angesteuert wird ...
Warum flackern dann die LEDs? Wie sind die LEDs überhaupt angeschlossen? 
Und wie sieht das Layout aus.

Michael K. schrieb:
> Hier versuchst Du ja die Entwicklungsleistung für komplett NULL Euro zu
> bekommmen.
Ist ja an sich nicht schlimm.
Mich würde schon interessieren, was da falsch gemacht wurde (ich muss ja 
nicht jeden Fehler machen, den andere auch gemacht haben). Aber leider 
kann ich da anhand der gelieferten Informationen nichts lernen.

Farin U. schrieb:
> Nun hätte ich schon die Frage was ich denn eventuell messen / testen
> könnte, denn Interesse habe ich schon da etwas zu lernen.
Dann sind wir schon zu zweit. Mit einem Unterschied: DU hast einen 
Schaltplan und das Layout...

Stefan U. schrieb:
> Ich habe auch einen Prototypen für eine messtation gebaut, da
> funktioniert die rechte Hälfte nicht. Sag du mir, was ich dort anpassen
> muss, damit es funktioniert.
Du musst nur den Fehler raus machen. Dann geht das. War bei mir auch so!

> Merkst du, was ich meine?
Augenscheinlich merkt Farin es nicht...

von Ralf G. (ralg)


Bewertung
0 lesenswert
nicht lesenswert
Farin U. schrieb:
> Unsere Firma ist mit diesem Businessmodel groß geworden
> ...
> Dort gibt es auch erfahrene
> Entwickler, jedoch sind diese in Firmen die wir nicht bezahlen wollen.

Lothar M. schrieb:
> Michael K. schrieb:
>> Hier versuchst Du ja die Entwicklungsleistung für komplett NULL Euro zu
>> bekommmen.
> Ist ja an sich nicht schlimm.

Ich find's sogar sehr schlimm.

von Farin U. (farin_u86)


Bewertung
-1 lesenswert
nicht lesenswert
Wenn es denn gewünscht wird, werde ich etwas mehr Informationen zur 
Verfügung stellen... Müsst euch jedoch bis Morgen gedulden...

von Stefan ⛄ F. (stefanus)


Bewertung
1 lesenswert
nicht lesenswert
> Wenn es denn gewünscht wird, werde ich etwas mehr Informationen
> zur Verfügung stellen.

Oh ja bitte, herzlichen Dank, wie gnädig von Dir.

von Hugo (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Farin U. schrieb:
> Wenn es denn gewünscht wird, werde ich etwas mehr Informationen
> zur
> Verfügung stellen... Müsst euch jedoch bis Morgen gedulden...

Ich dachte, du möchtest etwas wissen?

Farin U. schrieb:
> Waere ueber jeden Tip gluecklich.

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Bewertung
1 lesenswert
nicht lesenswert
Farin U. schrieb:
> Wenn es denn gewünscht wird
Du solltest zwischen "gewünscht" und "nötig" unterscheiden lernen.
Ich wünsche mir sicher was anderes als deine Schaltungsunterlagen. 
Aber für eine brauchbare Antwort auf deine Fragen sind diese 
Unterlagen sicher nötig.

Oder um es anders zu sagen: DU bist der, dessen Schaltung nicht 
funktioniert. DU wünschst, dass dir einer hilft...

> werde ich etwas mehr Informationen zur Verfügung stellen...
Vergiss diese Salamitaktik. Stelle alle Informationen zur Verfügung, 
die zur Problemanalyse nötig sind: Schaltplan(auszug), Layout(auszug), 
realer aufbau und Messwerte (soweit vorhanden).

: Bearbeitet durch Moderator
von Farin U. (farin_u86)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Danke für eure Antworten...

Hier Schaltplan und PCB Layout.

Datenblatt gibt es hier: http://www.ti.com/lit/ds/symlink/tps92692.pdf 
und eine Tabelle die bei der Findung der Bauteilwerte helfen soll 
(http://www.ti.com/general/docs/lit/getliterature.tsp?baseLiteratureNumber=slvc686&fileType=zip).

Eingangspannungsbereich soll 9V.. 32V sein. Typisch 14V
Last sind 3 Strings mit jeweils 8 LEDs. LED forward voltage 3V
Maximum output power sollte 90W sein.
Schaltfrequenz 500kHz

Mehr kann ich zur Zeit noch nicht sagen da ich die Samples noch nicht 
habe. Angeblich flackern die LEDs nur.

LG

von Stefan ⛄ F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
Parallelschaltung von LEDs ist ein No-Go.

Q8,9,10 muss mir mal einer erklären. Für mich sieht es so aus, als ob 
sie hier vollkommen nutzlos beschaltet sind. Man hätte auch Drahtstücke 
verwenden können.

R27 und R28: Warum schaltet man einen 100 Ohm (?) Widerstand parallel zu 
0,03 Ohm? Solche Konstrukte sind über die gesamte Platine verstreut.

C42 in Reihe zum VCC Pin von dem IC unterbricht dessen Stromversorgung.

Warum hat R18 (Basis-Vorwiderstand von Q7) 0 Ohm?

> Maximum output power sollte 90W sein.
Mir dieser winzigen Spule? Ich lache mit tot"

Die ganze Schaltung ist von vorne bis hinten totaler Quatsch. Man kann 
gar nicht erkennen, wozu sie gut sein soll. Da gibt es nichts zu retten.

Du wurdest aus Strich und Faden verarscht.

: Bearbeitet durch User
von Äxl (geloescht) (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Stefan, geh frühstücken ....

Äxl

von Gerald B. (gerald_b)


Bewertung
0 lesenswert
nicht lesenswert
Bist du sicher, das das Temperaturprofil für die LEDs beim Löten passt? 
Die sitzen ja mit auf der Platine. Ich habe auch mal ein paar 3535 als 
Lehrgeld abhaken müssen. Bleifrei auf dem Ceranfeld gelötet, der 
Schmelzpunkt vom Lot und die Maximaltemperatur laut Datenblatt lagen nur 
10° auseinander. Mit bleihaltiger Paste hat es dann geklappt.
Daher guckt auch mal in die Richtung.

von Farin U. (farin_u86)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
> Parallelschaltung von LEDs ist ein No-Go.
Wirklich? Wie dann denn? Alle in Reihe?

> Q8,9,10 muss mir mal einer erklären. Für mich sieht es so aus, als ob
> sie hier vollkommen nutzlos beschaltet sind. Man hätte auch Drahtstücke
> verwenden können.
"Active Current Balancing"

> R27 und R28: Warum schaltet man einen 100 Ohm (?) Widerstand parallel zu
> 0,03 Ohm? Solche Konstrukte sind über die gesamte Platine verstreut.
For additional noise suppression connect an external low-pass RC filter 
with resistor values ranging from 100Ω to 500Ω and a 1000 pF capacitor.

> C42 in Reihe zum VCC Pin von dem IC unterbricht dessen Stromversorgung.
VCC (7.5 V) bias supply pin. Locally decouple to GND using a ceramic 
capacitor (with a value between 2.2-μF and 4.7-μF). Locate close to the 
controller

Ich hab mal den Schaltplan des Datenblatts hinzugefügt.

von Stefan ⛄ F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
Vergleiche mal den Schaltplan aus China mit dem Schaltplan von TI.

von Farin U. (farin_u86)


Bewertung
0 lesenswert
nicht lesenswert
Danke ich werde das mal pruefen...

Ich habe zur Zeit OVP im Verdacht... der Pfad hat 150k, Transistor und 
4.12k. Bei den zu erwartenden Spannungen fliessen da ~100uA.

Gruesse

von Farin U. (farin_u86)


Bewertung
0 lesenswert
nicht lesenswert
Stefan U. schrieb:
> Vergleiche mal den Schaltplan aus China mit dem Schaltplan von TI.

Schon gemacht... :)

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Farin U. schrieb:
> "Active Current Balancing"
Die seltsame Stromspiegelschaltung um Q8..10 leuchtet mir auch nicht 
ganz ein. Die funktioniert eigentlich nur auf dem Papier.

Farin U. schrieb:
> Angeblich flackern die LEDs nur.
Verbinde mal die Pins 13 und 14 direkt am Regler. Falls das Verhalten 
des Dings dann ändert, dann sieh dir mal an, wie diese Strommessung im 
Beispiellayout aussieht: dort sind diese Leitungen sehr hübsch 
beieinander geführt, dass nichts einkoppeln kann...

Man könnte sagen: es braucht einen sehr erfahrenen Designer und ein paar 
Loops, um ein einlagiges Design im oberen dreistelligen kHz Bereich zum 
Laufen zu bekommen, wenn der Hersteller des Controllers mindestens 2 
Lagen vorsieht.

: Bearbeitet durch Moderator
von Farin U. (farin_u86)


Bewertung
0 lesenswert
nicht lesenswert
Danke für die Antworten...

Ich bekomme nächste Woche die Prototypen und kann Messungen vornehmen.

Hat jemand vieleicht ein paar Tips nach was ich schauen könnte?

Die Strommessung ist ja schon genannt worden...

Grüße

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.