mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Selbstgebauter Klasse D Audio Verstärker ist stark am Rauschen


Autor: Felix Neumann (felix_n888)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Abend,
Ich habe ihr ein kleines Problem. Und zwar habe ich mir ein eigenen 
Class D Audio Amplifier gebaut. Dieser funktioniert im Punkt Verstärken 
auch. Nur er ist sehr stark am Rauschen.


Der Verstärker basiert auf einfache Komponenten in meinen Fall:

TLC555   - Als Dreiecks Generator für denn Komparator
LM393    - Als Komparator zwischen Vorverstärker und Dreiecke Generator
LM386N-1 - Als Vorverstärker eingestellt auf ein Gain von 20.
74HC04   - Um das Signal vom LM393 zu invertieren.
IR2113   - Als MOFSET Driver für die beiden Mosfets.

Der Schaltplan ist nicht von mir selbst sondern von GreatScott: 
Youtube-Video "DIY Class D Audio Amplifier"

Ich habe mal ein Bild von meinen Oszi angehängt ich habe dort direkt 
hinter der Audio Buchse gemessen. Das Signal wird von einen 
Funktionsgenerator generiert. Es hat 45 Hz mit ein Peak-Peak von 400 mV. 
Wenn man ein Audio Kabel anschließt, und dieses zb. mit mein Handy 
verbinde. Dann habe ich ein leises Rauschen. Sobald ich irgendwas mache 
mit mein Handy wird es lauter.


Wenn ich denn LM386N-1 aus seinem Sockel nehme. Verschwindet das 
Rauschen.
Das ganze ist an 15,2 Volt von mein Labornetzteil angeschlossen. Und 
nimmt circa. 60 bis 70 mA auf. Ohne denn Vorverstärker 20 bis 30 mA.


Ich weis das ich nicht die beste Audio Qualität erwarten kann, von 
diesen selbstgebauten Verstärker.


Kann mir jemand sagen wo durch dieses starke Rauschen entsteht?


Bild von vor und hinter Seite der Platine habe mit angehängt

Mfg Felix

Autor: Abdul K. (ehydra) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Rauschts den nach dem 386? Der soll nicht so dolle sein. Oder 
HF-Rückkopplung.

Autor: Mark Space (voltwide)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Felix N. schrieb:
> Wenn ich denn LM386N-1 aus seinem Sockel nehme. Verschwindet das
> Rauschen.

Genau das sollte Dir schon mal zu Denken geben.
Ein Lautsprecher-Verstärker zum Anheben des Audiopegels ist an dieser 
Stelle ziemlich unsinnig und liefert unnötig hohe Rauschpegel.
Ersetz den mal durch einen Operationsverstärker.

Ansonsten ist die zu erwartende Signalqualität eher bescheiden, weil:
Das "Dreieck"-Signal ist nicht linear, und damit eine Quelle 
nichtlinearer Verzerrungen.
Der LM393 ist einer der langsamsten Comparatoren mit deutlichem 
Phasenrauschen.
Fehlende Gegenkopplung usw.usf.
Aber das weißt Du ja wohl selbst.

: Bearbeitet durch User
Autor: Thomas (Gast)
Datum:

Bewertung
-2 lesenswert
nicht lesenswert
Felix N. schrieb:
> Ich habe mal ein Bild von meinen Oszi angehängt ich habe dort direkt
> hinter der Audio Buchse gemessen.

Hallo Felix,
Wo finden wir das Bild ???
Hinter welcher Audio-Buchse hast du gemessen, hinter In oder hinter Out 
?

Drei Hinweise:
Die Spannungsregler gehören auf einen Kühlkörper.

An die Ein-u. Ausgänge der Spannungsregler gehören je ein Kondensator
von 100nF o. 220nF nach Masse. Für C2 würde ich 470uF verwenden.

An jedes IC gehört, direkt am IC gelötet, jeweils ein 
Abblockkondensator,
von Massepin zum Pin, der die pos. Betriebsspannung führt.
Ich vermute, das sind die roten Kondensatoren oben rechts auf dem Foto.

Vielleicht schwingt die Schaltung, deswegen als erstes die
ICs mit den Abblockkondensatoren beschalten.


Wozu benötigt man in einer NF-Verstärkerschaltung einen
Timer und einen Komparator ?


Felix N. schrieb:
> Wenn ich denn LM386N-1 aus seinem Sockel nehme. Verschwindet das
> Rauschen.
Hast du eine Erklärung dafür ?

Gruß

Autor: Felix Neumann (felix_n888)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mark S. schrieb:
> Genau das sollte Dir schon mal zu Denken geben.

Mark S. schrieb:
> Ersetz den mal durch einen Operationsverstärker.

Hmm, stimmt wenn man jetzt mal nach denkt. ....


Okay. Ich habe jetzt mal denn LM386 raus genommen. Und würde denn durch 
ein LM358 ersetzten. Diesen wurde ich als Nicht Invertierenden 
Verstärker schalten. Mit folgenden Werten:

R1 = 1 kOhm
R2 = 10 kOhm

Dann kommt als Verstärkung 11 raus.

Wenn ich mein 45 Hz Signal mit Pk-Pk 400 mV anlege sollte er daraus 4400 
mV machen.

Nur ein Problem macht mir noch zu schaffen um diesen in die Praxis um zu 
setzten. Und zwar die Negative Spannung. Um 400 mV Pk-Pk ja zu haben, 
habe ich dann 200 mV positive Spannung und 200 mV negative Spannung.

Ich denke wenn ich denn OpAmp mit +5V und -5V versorge sollte die 
Verstärkung an sich mit dem OpAmp funktionieren. Jedoch bekommt der 
LM393 nur eine Signal Supply.

Der LM386 gab ja immer ein Postive Spannung aus. Also mit Offset.

Also müsste ich theoretisch ein Offset dem OpAmp beifügen?

Mfg Felix.

Autor: Schreiber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas schrieb:
> Wozu benötigt man in einer NF-Verstärkerschaltung einen
> Timer und einen Komparator ?

Weil es ein Klasse D-Verstärker ist?!

Felix N. schrieb:
> Der Verstärker basiert auf einfache Komponenten in meinen Fall:
Da liegt der Fehler. Bei sowas nimmt man ein passendes IC und hält sich 
peinlichst genau an das Referenz-Design im Datenblatt.

Autor: Jürgen Schuhmacher (engineer) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit welcher Frequenz läuft der Dreiecksgenerator?

Autor: Felix Neumann (felix_n888)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Schreiber schrieb:
> Da liegt der Fehler. Bei sowas nimmt man ein passendes IC und hält sich
> peinlichst genau an das Referenz-Design im Datenblatt.

Das wäre die andere Möglichkeit. Aber es wird ja auch wohl anderes 
gehen. Schließlich ist der IC innen auch wider aus denn einzeln 
Bauteilen die ich verwende in irgend einer Art wieder zu finden.

Jürgen S. schrieb:
> Mit welcher Frequenz läuft der Dreiecksgenerator?

Unfair mit einer Frequenz von 250 KHz. Ich habe ein Oszi Bild vom Signal 
angehängt.

Leider kann man die Werte nicht so gut lesen auf dem Foto:
Die Vertikale Linie des Kanal 1 liegt genau auf der Vertikalen Rater 
Linie

Frequenz: 251-256 KHz
Tastrate: ~50-51 %
Minimum Voltage: 1.28V(circa 1/3 der Vcc vom 555)
Maximum Voltage: 3.56V(circa 2/3 der Vcc vom 555)

Autor: Robert M. (r0bm)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Felix N. schrieb:

> Der LM386 gab ja immer ein Postive Spannung aus. Also mit Offset.

Der LM386 (V=20) wird mit einem Eingangssignal von 400mVss übersteuert 
und gibt ein Rechtecksignal aus (Ub nur 5V).

> Also müsste ich theoretisch ein Offset dem OpAmp beifügen?

Dazu dem invertierenden OP-Verstärker Ub/2 am nichtinvertierenden 
Eingang anbieten. Ein Rail-to-Rail OPV wäre von Vorteil. Der LM358 passt 
nicht.

Das invertierende Gatter hätte man sich sparen können, der LM393 verfügt 
ja über 2 Komparatoren.

: Bearbeitet durch User
Autor: Jürgen Schuhmacher (engineer) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Felix N. schrieb:
> Unfair mit einer Frequenz von 250 KHz. Ich habe ein Oszi Bild vom Signal
> angehängt.
Das wäre schon ok, allerdings bringt das verzerrte Dreieck natürlich 
Verzerrungen rein, allerdings kein Rauschen.

Autor: Felix Neumann (felix_n888)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Robert M. schrieb:
> Der LM386 (V=20) wird mit einem Eingangssignal von 400mVss übersteuert
> und gibt ein Rechtecksignal aus (Ub nur 5V).

Ja stimmt.

Robert M. schrieb:
> Dazu dem invertierenden OP-Verstärker Ub/2 am nichtinvertierenden
> Eingang anbieten. Ein Rail-to-Rail OPV wäre von Vorteil. Der LM358 passt
> nicht.

Meinst du das so? Wie im Bild?

mfg Felix

Autor: Joachim B. (jar)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Felix N. schrieb:
> Meinst du das so? Wie im Bild?

fast, Schaltung ist falsch

Robert M. schrieb:
> Dazu dem invertierenden OP-Verstärker Ub/2 am nichtinvertierenden
> Eingang anbieten.

Autor: Felix Neumann (felix_n888)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Joachim B. schrieb:
> fast, Schaltung ist falsch

Upps, Der IC ist falsch rum. Musste jetzt im diesen Bild passen oder?

Mfg Felix.

Autor: Schreiber (Gast)
Datum:

Bewertung
-3 lesenswert
nicht lesenswert
Felix N. schrieb:
> Schreiber schrieb:
> Da liegt der Fehler. Bei sowas nimmt man ein passendes IC und hält sich
> peinlichst genau an das Referenz-Design im Datenblatt.
>
> Das wäre die andere Möglichkeit. Aber es wird ja auch wohl anderes
> gehen. Schließlich ist der IC innen auch wider aus denn einzeln
> Bauteilen die ich verwende in irgend einer Art wieder zu finden.

Es gibt einen gewissen Unterschied zwischen geht und ist nachbausicher, 
serientauglich und ökonomisch vertretbar.
Daher das fertige IC.

Es gibt einfach Sachen, die man nicht baut, sondern fertig kauft.

Autor: Felix Neumann (felix_n888)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Schreiber schrieb:
> Es gibt einen gewissen Unterschied zwischen geht und ist nachbausicher,
> serientauglich und ökonomisch vertretbar.
> Daher das fertige IC.

Klar gibt es Schaltungen in denn sich ein fertiger IC ehr lohen würde. 
Aber es ist ja nicht so das meine Schaltung nicht funktioniert.

Klar kann ich mir ein TDA 7269A oder TDA 7266 etc.. kaufen. Und denn 
nachdem Datenblatt beschalten.

Nur bei meinen Aufbau verstehe ich wenigsten noch was die Schaltung 
einigermaßen macht, und kann an bestimmten Teilen auch noch mal Messen 
und Veränderung sehen. Beim Fertigen IC geht das ehr weniger.

Ich habe ja auch gesagt das ich nicht die beste Qualität erwarte vom 
meinen Verstärker. Wenn ich gute Qualität haben will kauf ich mir 
entweder ein richtigen Verstärker oder ein IC.

Autor: Robert M. (r0bm)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Felix N. schrieb:

> Upps, Der IC ist falsch rum. Musste jetzt im diesen Bild passen oder?

Fehlt noch ein Filter-C (10...47µ) für die Ub/2. Darauf achten den 
Verstärker nicht zu übersteuern, die Ausgangsamplitude des LM358 reicht 
nicht bis hoch zu 5V.

Autor: Felix Neumann (felix_n888)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Robert M. schrieb:
> Fehlt noch ein Filter-C (10...47µ) für die Ub/2. Darauf achten den
> Verstärker nicht zu übersteuern, die Ausgangsamplitude des LM358 reicht
> nicht bis hoch zu 5V.

OK. Also ein Elko um Ub/2 zu stabilisieren. Ich meine die maximale 
Spannung die der OpAmp nach oben fahren kann ist Vcc-1,5V also 3,5V.

Nur wie ist das jetzt mit der Sinus Welle? Ich habe ja immer noch ein AC 
Signal das im am 1K Ohm Widerstand anlege das dann auf denn invertieren 
Eingang geht. Wird dann nicht die Untere Halbwelle des Sinus 
abgeschnitten?

//EDIT: Also irgendwas scheint falsch zu sein. Wenn ich mein 200 mV 
Pk-Pk(bin ein bisschen runter gegangen) 45 Hz Sinus Signal anlege an 
denn invertierenden Verstärker und ein Kondensator mit 47µF zwischen 
2,5V und GND mache. Habe ich eine Spannung von 3,3 Volt am Ausgang des 
OpAmp.
Was ist falsch?
Aufbau ist genau so wie im zweiten Bild "Vorverstärker" nur mit einen 
Elko zwischen 2,5 Volt und GND

Mfg Felix.

: Bearbeitet durch User
Autor: Robert M. (r0bm)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Felix N. schrieb:

> OK. Also ein Elko um Ub/2 zu stabilisieren. Ich meine die maximale
> Spannung die der OpAmp nach oben fahren kann ist Vcc-1,5V also 3,5V.
>
> Nur wie ist das jetzt mit der Sinus Welle? Ich habe ja immer noch ein AC
> Signal das im am 1K Ohm Widerstand anlege das dann auf denn invertieren
> Eingang geht. Wird dann nicht die Untere Halbwelle des Sinus
> abgeschnitten?

Der Sinus "reitet" auf den Ub/2 und schwankt damit am Ausgang zwischen 
1,5V und 3,5V (V=10 / Uein=200mVss). Hättest du einen OPV mit R2R 
Ausgang zur Hand, könnte man bis fast 0V bzw. 5V aussteuern.

> //EDIT: Also irgendwas scheint falsch zu sein. Wenn ich mein 200 mV
> Pk-Pk(bin ein bisschen runter gegangen) 45 Hz Sinus Signal anlege an
> denn invertierenden Verstärker und ein Kondensator mit 47µF zwischen
> 2,5V und GND mache. Habe ich eine Spannung von 3,3 Volt am Ausgang des
> OpAmp.
> Was ist falsch?
> Aufbau ist genau so wie im zweiten Bild "Vorverstärker" nur mit einen
> Elko zwischen 2,5 Volt und GND

Trennkondensator am Eingang vergessen? Ohne Trennkondensator hängt der 
1k Eingangswiderstand, wegen des Funktionsgenerators, auf 0V. Es 
entsteht ein einfacher Komparator. Da die Gleichspannung am + Eingang 
(Ub/2) höher ist, hängt der Ausgang des OPV auf +Ub bzw. der max 
möglichen Ausgangsspannung.

: Bearbeitet durch User
Beitrag #5193569 wurde vom Autor gelöscht.
Autor: Mani W. (e-doc)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Anschluss 2 des LM 386 ist normal auf Masse, während Anschluss 3
als +Eingang beschaltet wird...

Autor: Felix Neumann (felix_n888)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Robert M. schrieb:
> Der Sinus "reitet" auf den Ub/2 und schwankt damit am Ausgang zwischen
> 1,5V und 3,5V (V=10 / Uein=200mVss).

Ah okay.

Robert M. schrieb:
> Hättest du einen OPV mit R2R
> Ausgang zur Hand, könnte man bis fast 0V bzw. 5V aussteuern.

Meine Auswahl an OpAmps ist nicht sehr groß habe nur denn lm358, tl081, 
tl074 und ein MC332xx die letzten beiden Zahlen kann man nicht mehr 
lesen.

Robert M. schrieb:
> Trennkondensator am Eingang vergessen?

Upps.

Mit dem Kondensator funktioniert es. Ich habe ein 100nF Vielschicht 
Kondensator genommen. Das Rauschen ist zwar noch da. Aber deutlich 
leiser. Allerdings wenn ich denn Ausgang des OpAmp an mein LM393 
anschließe werden die Signal wellen sehr verzerrt.

Das 45 Hz Eingangssignal ist fast gar nicht zu erkennen. Beim 
Ausgangssignal des OpAmp kann man noch erkennen das es ein Sinus ist. 
Ich habe mal zwei Oszi Bilder mit angehängt. Vertikale Skalierung ist 
-2,3V. Damit ich das Signal komplett im Oszibild habe.

Kann man das nochmal mit ein Kondensator zwischen OpAmp Output und LM393 
Input filtern?

Mfg Felix.

Autor: Felix Neumann (felix_n888)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,


Es scheint wohl so das meine Vorherige Audio Einspeisung mit dem OpAmp 
nicht funktioniert. Denn ich nehme ja beide Audio Kanäle jeder bekommt 
ein 10K Widerstand die danach beide auf ein 100 nF 
Vielschichtkondensator gehen. Das andere Ende des Kondensators war dann 
am LM386 invertieren Pin angeschlossen.

Wenn ich das direkt an den LM358 anschließe passiert nix.

Wenn ich aber nur ein Audio Kanal nehme dann auf 100nF Kondensator gehe 
und dann die Verstärker Schaltung mache. Funktioniert das mit dem OpAmp.

Das vorher laute Rauschen ist nun ein leises surren. Mit Kopfhörern auf 
hört man das nicht mehr. Das ist also schon mal gut.

Im Moment habe ich das ganze auf ein Breadboard aufgebaut. Mit ein paar 
10cm Steckkabeln für Breadboard.

Wie hoch ist die Wahrscheinlichkeit, wenn ich den LM358 Vorverstärker 
auf die Platine auflöte das das aktuelle surren noch leiser wird oder so 
gar ganz verschwindet?

Zudem kann ich leider nix an Oszilloskop messen. Da wenn ich die GND 
Verbindung vom mein Oszi an das GND von meiner Schaltung klemme das 
Rauschen wieder lauter wird.

Also irgendwie scheint mein Oszi damit reinzustören. Normal oder nicht?

//EDIT: Bilder von der Vorverstärkung hinzugefügt.

Mfg Felix.

: Bearbeitet durch User
Autor: Robert M. (r0bm)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Felix N. schrieb:

> Mit dem Kondensator funktioniert es. Ich habe ein 100nF Vielschicht
> Kondensator genommen. Das Rauschen ist zwar noch da. Aber deutlich
> leiser. Allerdings wenn ich denn Ausgang des OpAmp an mein LM393
> anschließe werden die Signal wellen sehr verzerrt.

Der 100nF bildet mit dem 10k Eingangswiderstand eine untere 
Grenzfrequenz von 160Hz. Bei 45Hz (warum überhaupt diese Testfrequenz?) 
liegt die Dämpfung schon bei ca. 10dB. Die recht hochohmigen Widerstände 
tragen, wie der OPV auch, zum Gesamtrauschen des Vorverstärkers bei.

> Das 45 Hz Eingangssignal ist fast gar nicht zu erkennen. Beim
> Ausgangssignal des OpAmp kann man noch erkennen das es ein Sinus ist.
> Ich habe mal zwei Oszi Bilder mit angehängt. Vertikale Skalierung ist
> -2,3V. Damit ich das Signal komplett im Oszibild habe.

Die Oszillogramme sehen gar nicht toll aus. Das sieht eher so als als ob 
du die Störungen über das Oszi selbst einkoppelst. Schon das 
Oszillogramm vom Messpunkt zwischen den 10k und 100nF am Eingang macht 
wenig Sinn.

> Kann man das nochmal mit ein Kondensator zwischen OpAmp Output und LM393
> Input filtern?

Wie im Anhang zu sehen, könntest du den Vorverstärker noch zu einem 
vollwertigen Bandpass (160Hz...25kHz) erweitern.


Felix N. schrieb:

> Es scheint wohl so das meine Vorherige Audio Einspeisung mit dem OpAmp
> nicht funktioniert. Denn ich nehme ja beide Audio Kanäle jeder bekommt
> ein 10K Widerstand die danach beide auf ein 100 nF
> Vielschichtkondensator gehen. Das andere Ende des Kondensators war dann
> am LM386 invertieren Pin angeschlossen.
> Wenn ich das direkt an den LM358 anschließe passiert nix.

Was heißt "nix"? Du kannst soviele Känäle addieren (weitere 10k + 100nF 
am Eingang) wie du magst. Man muss aber beachten dass die 
Ausgangsspannung dementsprechend auch steigt und schnell an den Grenzen 
des OPV stößt.

Sind 2 Eingangskanäle 180° gegeneinander phasenverschoben dann ist 
verständlicherweise die Ausgangsspannung 0Vss.

> Das vorher laute Rauschen ist nun ein leises surren. Mit Kopfhörern auf
> hört man das nicht mehr. Das ist also schon mal gut.
>
> Im Moment habe ich das ganze auf ein Breadboard aufgebaut. Mit ein paar
> 10cm Steckkabeln für Breadboard.
>
> Wie hoch ist die Wahrscheinlichkeit, wenn ich den LM358 Vorverstärker
> auf die Platine auflöte das das aktuelle surren noch leiser wird oder so
> gar ganz verschwindet?

Du hast dich streng an den Schaltplänen gehalten, auch z.B. wo die 
Bauteile auf der Platine platziert wurden. An keinem IC wurden 
Kondensatoren (100nF/47u o.ä.) zur NF und HF Entkopplung vorgesehen. 
Zwischen den Spannungsreglern und den ICs liegen lange dünnen Leitungen. 
Das trifft auch auf die Masseführung zu. Störungen haben damit die 
Möglichkeit sich relativ frei auszubreiten.

> Also irgendwie scheint mein Oszi damit reinzustören. Normal oder nicht?

Leider normal.

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Robert M. schrieb:
> Du hast dich streng an den Schaltplänen gehalten, auch z.B. wo die
> Bauteile auf der Platine platziert wurden. An keinem IC wurden
> Kondensatoren (100nF/47u o.ä.) zur NF und HF Entkopplung vorgesehen.
> Zwischen den Spannungsreglern und den ICs liegen lange dünnen Leitungen.
> Das trifft auch auf die Masseführung zu. Störungen haben damit die
> Möglichkeit sich relativ frei auszubreiten.


Hatte ich schon am Anfang geschrieben, als dritte Antwort !

Beitrag "Re: Selbstgebauter Klasse D Audio Verstärker ist stark am Rauschen"

Autor: Felix Neumann (felix_n888)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Robert M. schrieb:
> Bei 45Hz (warum überhaupt diese Testfrequenz?)

Weiß ich selber auch nicht genau.

Robert M. schrieb:
> Wie im Anhang zu sehen, könntest du den Vorverstärker noch zu einem
> vollwertigen Bandpass (160Hz...25kHz) erweitern.

Danke erst mal dafür. Dort befindet sich ja bereits ein R-C Filter mit 
470 Ohm und 10nF. Als Frequenz kommt dann dort ~33KHz raus. Also könnte 
ich noch ein Low-Pass R-C Filter hinzufügen der bei circa 160 Hz 
anfängt?

Robert M. schrieb:
> Du hast dich streng an den Schaltplänen gehalten, auch z.B. wo die
> Bauteile auf der Platine platziert wurden. An keinem IC wurden
> Kondensatoren (100nF/47u o.ä.) zur NF und HF Entkopplung vorgesehen.
> Zwischen den Spannungsreglern und den ICs liegen lange dünnen Leitungen.
> Das trifft auch auf die Masseführung zu. Störungen haben damit die
> Möglichkeit sich relativ frei auszubreiten.

Hmm, naja. Ich habe jetzt ein neuen Schaltplan gemacht mit 
Entstörkondensatoren für NF und HF an jeden IC. Löte zudem die ganze 
Platine nochmal neu auf und versuche Masse und Stromleitung so nah wie 
möglich beieinander zu halten.

Den Schaltplan habe ich angehängt. Nachdem würde ich später die 
Schaltung auch neu auflöten. Zudem habe ich das Inverter Gatter entfernt 
und das zweite Gatter des LM393 genutzt.

Robert M. schrieb:
> Leider normal.

Okay.

Mfg Felix.

Autor: Robert M. (r0bm)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Felix N. schrieb:
> Danke erst mal dafür. Dort befindet sich ja bereits ein R-C Filter mit
> 470 Ohm und 10nF. Als Frequenz kommt dann dort ~33KHz raus. Also könnte
> ich noch ein Low-Pass R-C Filter hinzufügen der bei circa 160 Hz
> anfängt?

Nicht notwendig. Die Schaltung bietet schon 3 Funktionen: 160Hz Hochpass 
(100nF + 10k am Eingang), 25kHz Tiefpass 2. Ordnung (100k/68pF/470/10nF 
am Ausgang) und Verstärkung (Verhältnis aus 100k/10k).


Felix N. schrieb:
> Hmm, naja. Ich habe jetzt ein neuen Schaltplan gemacht mit
> Entstörkondensatoren für NF und HF an jeden IC. Löte zudem die ganze
> Platine nochmal neu auf und versuche Masse und Stromleitung so nah wie
> möglich beieinander zu halten.

Es geht nicht darum Masse und Stromleitung nahe beeinander zu verlegen 
sondern die Masse kurz und breitflächig auszulegen oder zumindest 
sternförmig zusammenzuschalten.

> Den Schaltplan habe ich angehängt. Nachdem würde ich später die
> Schaltung auch neu auflöten. Zudem habe ich das Inverter Gatter entfernt
> und das zweite Gatter des LM393 genutzt.

Fehlen noch 470µF+100nF direkt am Drainanschluß des oberen MOSFET. Die 
FETs werden hart geschaltet und es fließt an dieser Stelle ein hoher 
Strom.

Man könnte zwar noch weitere Änderungen vornehmen wie z.B. 
Vorverstärker, Dreieckgenerator und Komparator aus 12V speisen, lineare 
Dreieckspannung erzeugen etc., doch man muss nicht unbedingt 
übertreiben.

Autor: Felix Neumann (felix_n888)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Robert M. schrieb:
> Nicht notwendig. Die Schaltung bietet schon 3 Funktionen: 160Hz Hochpass
> (100nF + 10k am Eingang), 25kHz Tiefpass 2. Ordnung (100k/68pF/470/10nF
> am Ausgang) und Verstärkung (Verhältnis aus 100k/10k).

Ja. Wenn man sich länger mit dem Schaltbild beschäftigt sieht man das.

Robert M. schrieb:
> Es geht nicht darum Masse und Stromleitung nahe beeinander zu verlegen
> sondern die Masse kurz und breitflächig auszulegen oder zumindest
> sternförmig zusammenzuschalten.

Hmm okay.

Robert M. schrieb:
> Fehlen noch 470µF+100nF direkt am Drainanschluß des oberen MOSFET. Die
> FETs werden hart geschaltet und es fließt an dieser Stelle ein hoher
> Strom.

Hart geschaltet ist wenn ein N-Channel Mosfet nicht mit Source auf GND 
liegt sondern DRAIN an eine positive Spannung? Ich habe nun ein 100nF 
Folienkondensator zwischen DRAIN und GND. Sowie ein 470µF 35V Elko auch 
dazwischen.

Robert M. schrieb:
> Man könnte zwar noch weitere Änderungen vornehmen wie z.B.
> Vorverstärker, Dreieckgenerator und Komparator aus 12V speisen, lineare
> Dreieckspannung erzeugen etc., doch man muss nicht unbedingt
> übertreiben.

Ja schon klar. Da war ich mir jetzt nicht mehr so sicher. Ich hatte vor 
ein Jumper auf die Platine zu machen wo ich zwischen 5V und 12V hin und 
her schalten kann. Nur ich weis nicht ob der IR2113 das mit macht. Weil 
im Moment ist VDD=5V und VCC=12V.

Im Datenblatt des IR2113 steht unter VDD Max: Vss + 20. Vss ist bei mir 
0V. Also kann ich maximal 20 Volt an VDD anlegen.

Mfg Felix.

Autor: dfg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Robert M. schrieb:
> Fehlen noch 470µF+100nF

...möglichst nahe an die / parallel zur Halbbrücke...
(nicht "über" einen der FETs, sondern "über" beide)

Robert M. schrieb:
> Die FETs werden hart geschaltet

Ja, klar. "Soft-Switching" findet nicht statt.
Das aber ist nicht der alleinige Grund:

> und es fließt an dieser Stelle ein hoher Strom.

...der ohne die Stützkondensatoren über die
Leitungsinduktivität beschränkt würde.

So dürfte das gemeint sein.

Autor: dfg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Felix N. schrieb:
> Hart geschaltet ist wenn ein N-Channel Mosfet nicht mit Source auf GND
> liegt sondern DRAIN an eine positive Spannung?

Nein. Hart schalten ist das Gegenteil von weich schalten.

(Beim Soft-Switching wird entweder Strom oder Spannung
nahe NULL, oder tatsächlich NULL sein.

Hart geschaltet bedeutet, daß dem nicht so ist -
es wird ein schneller Stromanstieg stattfinden.)

Felix N. schrieb:
> Ich habe nun ein 100nF
> Folienkondensator zwischen DRAIN und GND. Sowie ein 470µF 35V Elko auch
> dazwischen.

Ich hoffe, Du meinst Drain des High-Side-FETs. Dann paßts.

Autor: Felix Neumann (felix_n888)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
dfg schrieb:
> Nein. Hart schalten ist das Gegenteil von weich schalten.
>
> (Beim Soft-Switching wird entweder Strom oder Spannung
> nahe NULL, oder tatsächlich NULL sein.
>
> Hart geschaltet bedeutet, daß dem nicht so ist -
> es wird ein schneller Stromanstieg stattfinden.)

Danke.

dfg schrieb:
> Ich hoffe, Du meinst Drain des High-Side-FETs. Dann paßts.

Genau.

Autor: Robert M. (r0bm)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Felix N. schrieb:
> Hart geschaltet ist wenn ein N-Channel Mosfet nicht mit Source auf GND
> liegt sondern DRAIN an eine positive Spannung? Ich habe nun ein 100nF
> Folienkondensator zwischen DRAIN und GND. Sowie ein 470µF 35V Elko auch
> dazwischen.

Ein 470µF soll, wie schon von "dfg" erwähnt, als Stützkondensator 
dienen, der kurzfristig den notwendigen Strom liefern soll.

Der IR2113 Treiber soll die MOSFET "hart" schalten, d.h. die 
Feldeffekttransistoren möglichst schnell ein und ausschalten. Es ist ein 
beträchtlicher Strom notwendig um die Eingangskapazität der FET 
schnell aufladen zu können. Ein Stützkondensator (100...220µF) für den 
12V Anschluß des IR2113 wäre daher auch kein Fehler.

Felix N. schrieb:
> Ja schon klar. Da war ich mir jetzt nicht mehr so sicher. Ich hatte vor
> ein Jumper auf die Platine zu machen wo ich zwischen 5V und 12V hin und
> her schalten kann. Nur ich weis nicht ob der IR2113 das mit macht. Weil
> im Moment ist VDD=5V und VCC=12V.

Vorverstärker, Komparator, Dreieckgenerator lassen sich grundsätzlich, 
nach einigen Änderungen, auch an 12V betreiben. Die Ausgänge der 
Komparatoren (offene Transistorkollektoren) würden weiterhin an 5V 
arbeiten. Das lohnt sich m.M.n. nur wenn auch eine neue Schaltung für 
den Dreieckgenerator vorgesehen wird.

Autor: Felix Neumann (felix_n888)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Robert M. schrieb:
> Ein Stützkondensator (100...220µF) für den
> 12V Anschluß des IR2113 wäre daher auch kein Fehler.

Hi, ist im Schaltplan nicht eingezeichnet. Aber es befinden sich an Vcc 
und Vdd vom IR2113 zudem 100nF auch 47µF Elkos. Ich habe die erst nicht 
vorgesehen. Habe sie dann trotzdem eingelötet.

Robert M. schrieb:
> Das lohnt sich m.M.n. nur wenn auch eine neue Schaltung für
> den Dreieckgenerator vorgesehen wird.

Ich habe jetzt erst mal so schnell nicht vor wieder was zu ändern. Denn 
ich bin doch überrast was für ne einigermaßen gute Qualität der 
Verstärker doch hat. Wenn man nicht die Lautstärke zu hoch macht und 
denn somit nicht übersteuert(bezieht sich auf denn Vorverstärker), dann 
hört sich das gar nicht mal so schnell an. Das vorher starke Rauschen 
beim Vorgänger Modell ist zu diesen weg. Man hört wenn man ganz leise 
ist und denn Lautsprecher direkt neben sein Ohr hält ein ganz leises 
Rauschen.

Aber damit kann ich leben.

Mal ne andere Frage. Du hattest mal geschrieben:

Robert M. schrieb:
> lineare Dreieckspannung erzeugen

Wie meinst du das mit dem Dreieck Generator ? Könntest du mir mal ein 
Dreieck Generator aufzeichnen wie er nach deiner Meinung richtig wäre?

mfg Felix

Autor: Stefan Schmidt (chiefeinherjar)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Felix N. schrieb:
> Mal ne andere Frage. Du hattest mal geschrieben:
>
> Robert M. schrieb:
>> lineare Dreieckspannung erzeugen
>
> Wie meinst du das mit dem Dreieck Generator ? Könntest du mir mal ein
> Dreieck Generator aufzeichnen wie er nach deiner Meinung richtig wäre?

Naja die Ladekurve eines Kondensators hat bei konstanter Spannung eben 
keine konstante Steigung. Sodass das Dreieck eben keine geraden Seiten 
hat sondern die jeweils leicht "gebogen" sind - so ergeben sich 
Verzerrungen.
Was du brauchst ist eine Schaltung, die ein Dreieck mit komplett linear 
ansteigenden Flanken hat.
Dazu nutzt man gerne Konstantstromquellen mit einem Kondensator, denn so 
steigt die Spannung konstant bzw linear an.

Die Schaltung hier macht sich dieses Prinzip zu nutze.

http://all-electric.com/schematic/eticircuits/555-...

Es gibt sicherlich bessere Beispiele und Schaltungen - gerade für 
Audio-Anwendungen. Aber sie zeigt das Prinzip und bringt auch ganz 
brauchbare Resultate.

Autor: Martin HR (horo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Felix N. schrieb:
> Könntest du mir mal ein
> Dreieck Generator aufzeichnen wie er nach deiner Meinung richtig wäre?

Es gibt integrierte Funktionsgeneratoren, z.B. XR-2206 oder auch der 
ICL8038, wenn Du den noch in der Bastelkiste findest:
https://www.sparkfun.com/datasheets/Kits/XR2206_10...
https://www.intersil.com/content/dam/Intersil/docu...

Autor: Robert M. (r0bm)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Felix N. schrieb:
> Wie meinst du das mit dem Dreieck Generator ? Könntest du mir mal ein
> Dreieck Generator aufzeichnen wie er nach deiner Meinung richtig wäre?

Das war keine Aufforderung einen neuen Dreieckgenerator vorzusehen. Wenn 
der Verstärker gut klingt und du zufrieden bist würde ich es so 
belassen.

www.fingers-welt.de/info/klassed_facharbeit.pdf
http://www.ti.com/lit/pdf/slau508

Im PWM-Referenzdesign von TI wird ausführlicher auf die Berechnung des 
Dreieckgenerators eingegangen, wie auch darauf welche Spezifikationen 
der Komparator und Operationsverstärker erfüllen müssen damit die 
Dreieckspannung nicht verzerrt wird.

Autor: Felix Neumann (felix_n888)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Robert M. schrieb:
> Das war keine Aufforderung einen neuen Dreieckgenerator vorzusehen. Wenn
> der Verstärker gut klingt und du zufrieden bist würde ich es so
> belassen.

Nein so war das nicht gemeint. Alles gut ich bin damit sogar sehr 
zufrieden.

Nur eine Frage hätte ich da noch:

Im Moment muss man die Lautstärke ja über die Audio Quelle selber 
Regeln. Wenn ich jetzt eine Lautstärken Reglung noch hinzufügen möchte. 
Muss ich das vor denn 100nF Kondensatoren des Vorverstärkers machen? Ja 
oder, weil sonst würde die Verstärkung ja beeinflusst werden.

Kenne würde dann ein 10K Ohm Stereo Drehpoti vor den Kondensatoren 
setzten. So kenne ich das jetzt vom LM386.

Mfg Felix.

Autor: Robert M. (r0bm)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Felix N. schrieb:
> Wenn ich jetzt eine Lautstärken Reglung noch hinzufügen möchte.
> Muss ich das vor denn 100nF Kondensatoren des Vorverstärkers machen? Ja
> oder, weil sonst würde die Verstärkung ja beeinflusst werden.
>
> Kenne würde dann ein 10K Ohm Stereo Drehpoti vor den Kondensatoren
> setzten. So kenne ich das jetzt vom LM386.

Ja, am Eingang. Ein 1k Poti (mehr ist auch OK) ist ausreichend, die 
Quelle sieht dann immer eine Last von ca. 1k.

Autor: Felix Neumann (felix_n888)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Robert M. schrieb:
> Ja, am Eingang. Ein 1k Poti (mehr ist auch OK) ist ausreichend, die
> Quelle sieht dann immer eine Last von ca. 1k.

Super alles klar. Ich habe noch mal ein Schaltplan angehängt von dem was 
ich jetzt vor habe. Es ist ein einfacher 3 Band Equalizer mit ein VU 
Meter und der Lautstärken Reglung. Das ganze kommt vor denn Class D 
Verstärker.

Oder würde das zu viel Rauschen in das System bringen? Eigentlich ja 
nicht oder?

//EDIT: Der Obere 100K Ohm Widerstand ist an +12 Volt angeschlossen. Hab 
die Leitung dort vergessen

Mfg Felix.

: Bearbeitet durch User
Autor: Thomas Lötzinn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Felix N. schrieb:
> Super alles klar. Ich habe noch mal ein Schaltplan angehängt von dem was
> ich jetzt vor habe. Es ist ein einfacher 3 Band Equalizer mit ein VU
> Meter und der Lautstärken Reglung. Das ganze kommt vor denn Class D
> Verstärker.

Der Eingang vom VU-Meter gehört auf den Ausgang deiner Schaltung,
also auf JP2 / Pin1. Du möchtest doch den Ausgangspegel messen
und nicht den Input.

Gruß

Autor: Robert M. (r0bm)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Felix N. schrieb:
> Super alles klar. Ich habe noch mal ein Schaltplan angehängt von dem was
> ich jetzt vor habe. Es ist ein einfacher 3 Band Equalizer mit ein VU
> Meter und der Lautstärken Reglung. Das ganze kommt vor denn Class D
> Verstärker.

Soll das VU-Meter die Eingangsspannung der Quelle anzeigen oder wie 
stark der Leistungsverstärker ausgesteuert wird?
Man könnte auch darüber nachdenken das VU-Meter am Ausgang des 
Equalizers zu schalten um auch das Verstärkungsmaß des Tonreglers zu 
erfassen.
Das VU-Meter benötigt zur Vollausteureung über 1,2Vs, womit der 
Leistungsverstärker natürlich völlig übersteuert wäre. Hier sind noch 
verschiedene Anpassungen bei den Pegeln vorzunehmen.

> Oder würde das zu viel Rauschen in das System bringen? Eigentlich ja
> nicht oder?

Zwangsläufig, müsste aber akzeptabel sein. Bemerken wirst du es 
insbesondere wenn z.B. mit dem Treble-Regler die hohen Frequenzen betont 
werden.

> //EDIT: Der Obere 100K Ohm Widerstand ist an +12 Volt angeschlossen. Hab
> die Leitung dort vergessen

Die 2 x 100k sind ziemlich hochohmig. Man könnte an dieser Stelle auf 
z.B. 2 x 4,7k oder weniger setzen. Es fehlt noch ein großer C bei Ub/2. 
Der Eingangskondensator C2 ist verpolt.

Autor: Felix Neumann (felix_n888)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Robert M. schrieb:
> Die 2 x 100k sind ziemlich hochohmig. Man könnte an dieser Stelle auf
> z.B. 2 x 4,7k oder weniger setzen. Es fehlt noch ein großer C bei Ub/2.
> Der Eingangskondensator C2 ist verpolt.

Hi, hab hier auch 1K Ohm genommen. Denn Eingangskondensator habe ich 
umgepolt.

Robert M. schrieb:
> Bemerken wirst du es
> insbesondere wenn z.B. mit dem Treble-Regler die hohen Frequenzen betont
> werden.

Ja, das stimmt.

Robert M. schrieb:
> Zwangsläufig, müsste aber akzeptabel sein.

Naja, man hört so ein surren und brummen. Kann es daran liegen das ich 
die Potis mit circa. 10 cm Kabeln verlängert habe? Die sitzen nicht 
direkt auf der Platine.

Robert M. schrieb:
> Soll das VU-Meter die Eingangsspannung der Quelle anzeigen oder wie
> stark der Leistungsverstärker ausgesteuert wird?

Bin ich mir noch nicht so sicher. Habe das erstmal weg gelassen.

Das ganze ist ja Mono. Ich gehe mit dem Ausgang des EQ direkt auf dem 
Amp. Aber nur auf einen Eingang. Sollte ich denn Ausgang des EQ auf 
beide Eingänge des Amps legen? Also der Rechte Kanal ist im Moment nicht 
verbunden.

Mfg Felix.

Autor: Robert M. (r0bm)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Felix N. schrieb:
> Naja, man hört so ein surren und brummen. Kann es daran liegen das ich
> die Potis mit circa. 10 cm Kabeln verlängert habe? Die sitzen nicht
> direkt auf der Platine.

Hört sich wieder nach Masseschleife an. Was passiert wenn der 
Masseanschluß des Potis entfernt wird bzw. die Schaltung erstmal ohne 
Poti in Betrieb genommen wird? Wie weit sitzt der Tonregler vom 
Verstärker weg?

> Das ganze ist ja Mono. Ich gehe mit dem Ausgang des EQ direkt auf dem
> Amp. Aber nur auf einen Eingang. Sollte ich denn Ausgang des EQ auf
> beide Eingänge des Amps legen? Also der Rechte Kanal ist im Moment nicht
> verbunden.

Anschluß an nur einem Verstärkereingang ist richtig. Verbindest du beide 
Eingänge des Verstärkers dann ist dessen Vorverstärkung nicht mehr 10 
sondern 20.

Autor: Jürgen Schuhmacher (engineer) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das könnte man herausbekommen, indem man die Kabel mal verdrillt. Wenn 
die 10 cm so viel ausmachen, sehe Ich für das design allerding so oder 
so "schwarz".

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.