mikrocontroller.net

Forum: PC Hard- und Software Raspberry und matchbox-window-manager Screensaver deaktivieren


Autor: Markus Wi*** (kornbanane)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe einen Raspberry Pi3 mit Raspian Strech am laufen. Dort boote 
ich direkt ins Terminal mit Autologin. Anschließend wird per Autostart 
der Window-Manager matchbox ausgeführt und ein NodeJs Programm sowie ein 
Webbrowser geladen.

Das ganze sieht folgendermaßen aus:

Am Ende der Datei /home/pi/.bashrc

sudo node ASL_HMI_V1.0/start.js &
sudo xinit ./starten -- -nocursor -quiet


Das Skript starten:

#!/bin/sh
matchbox-window-manager &
xset s off
xset -dpms
xset s noblank
midori -e Fullscreen -a http://127.0.0.1:8080


Wie man sieht versuche ich bereits mit xset den Screensaver 
auszuschalten, jedoch habe ich nach ein paar Minuten ein schwarzes Bild 
:-o

Das gleichen Befehle habe ich auch schon in der Datei rc.local und in 
/etc/X11/xinit/xinitrc ausprobiert, aber auch ohne Erfolg.

Wenn ich direkt in die Oberfläche Strech boote und in der Datei 
/home/pi/.config/lxsession/LXDE-pi/autostart die Befehle einsetze 
funktioniert es, also der Scrensaver ist deaktiviert. Die 
x11-xserver-utils sind ebenfalls installiert.

Ich denke es geht deshalb nicht, da ich nicht die Oberfläche Strech 
aufrufe, sondern mit dem Matchbox window manager arbeite. Scheinbar muss 
ich den Screensaver dort an anderer Stelle deaktivieren?

: Verschoben durch Moderator
Autor: Rolf Magnus (rmagnus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht schaltet er den Screensaver beim Start ein, und die 
xset-Kommandos werden schon ausgeführt, bevor er dazu kommt. Also quasi 
eine Race-Condition. Füge mal nach dem Start ein sleep 1 ein und schaue, 
ob das was ändert.

Autor: Markus Wi*** (kornbanane)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe jetzt folgendes in meinem start Skript:

#!/bin/sh
matchbox-window-manager &
midori -e Fullscreen -a http://127.0.0.1:8080
sleep 5
sudo xset s off
sudo xset -dpms
sudo xset s noblank


Weiterhin habe ich die xset Befehle noch in der Datei 
/etc/X11/xinit/xinitrc und in der Datei /etc/rc.local. Jeweils mit 
vorangestelltem sudo.

In der Datei /etc/lightdm/lightdm.conf habe ich noch den Befehl
#xserver-command=X

durch
#xserver-command=X -s 0 -dmps

ersetzt. Dies ist alles was ich so im Netz dazu gefunden habe. Aber 
jedesmal wird der Bildschirm nach genau 10 Minuten schwarz.....

Autor: Tek (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht hilft das:

>I've resolved adding the following code into /etc/X11/xorg.conf (i've created 
this file)
Section "ServerFlags"
    Option         "blank time" "0"
    Option         "standby time" "0"
    Option         "suspend time" "0"
    Option         "off time" "0"
EndSection

hier gefunden:
https://www.raspberrypi.org/forums/viewtopic.php?t=82578

Autor: Markus Wi*** (kornbanane)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wow super vielen vielen Dank, so geht es.

Ich habe alle anderen Befehle aus allen Datein gelöscht und nur die 
Befehle in der xorg.cof stehen lassen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.