Forum: Analoge Elektronik und Schaltungstechnik PSpice Modell funktioniert nicht richtig in LTSpice


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Nacht E. (nachteule)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

anscheinend funktionieren manche PSpice Modelle nicht auf Anhieb in 
LTSpice richtig (was ich jetz schon öfter gelesen habe) nach 
erfolgreicher Einbindung.

Anbei mal die .asc Datei meiner Testschaltung mit einem TLV2370 OpAmps 
und das Bild der dazugehörigen Simulation.

Weiß jemand wie ich diesen/ diese Fehler evtl. mit Hilfe der Netlist 
Datei zum jeweiligen Modell ausmerzen kann?

Danke schonmal im Voraus!

Nachteule

von gnocchi (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Dafür, dass du einen offenbar nichtinvertierenden Verstärker mit 
Verstärkung 2 mit +/-5V betreibst und einen Sinus mit 5V Amplitude 
anlegst, sieht das Ergebnis zwar nicht schön, aber sinnvoll aus.

von Nacht E. (nachteule)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ok nehmen wir mal lieber diese Werte und die Simulation dazu.
Und das kann nicht stimmen..

Grüße!

von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ohne dein Modell vom TLV2370 kann hier niemand mitsimulieren ...

von Nacht E. (nachteule)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Da hast du wohl recht!

Anbei das Modell dazu.

Danke schonmal für die raschen Antworten!

von gnocchi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Shutdown muss beschalten werden. Aber wie, hab ich auch noch nicht 
geblickt.

von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
gnocchi schrieb:
> Shutdown muss beschalten werden. Aber wie, hab ich auch noch nicht
> geblickt.

could be left open ...

von Nacht E. (nachteule)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
War der Meinung, dass der Shutdown Pin nicht unbedingt beschaltet werden 
muss.

Aber hab im Datenblatt jetz noch etwas dazu gefunden:

siehe Bild im Anhang.

Im Anhang mal der dazugehörige Schaltplan plus Simulation.

Kann so auch nicht sein..

von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich kann dir bestätigen, dass irgendwas nicht stimmt. Was es ist, weiß 
ich leider auch nicht.
Die Verstärkung ist 1, obwohl sie 2 sein müsste und der Offset des 
Ausgangssignals ist ebenfalls abnormal. Beim Ändern von V (R1 oder R2) 
passiert auch nicht das Erwartete.
Fazit: Modell enthält Dinge, die nur PSpice ab ver. 8.0, Tina Spice V6 
and V7 verstehen.

von Nacht E. (nachteule)


Bewertung
0 lesenswert
nicht lesenswert
Gibt es wirklich keine Möglichkeit das Modell in LTSpice zum Laufen zu 
bekommen?

Werde mal mit TI in Verbindung treten.

Danke trotzdem!

Wenn wer noch einen Tipp hat, immer her damit! =)

Hab mal irgendwo etwas von so einem ählichen Problem gelesen.
Da half dann eine Änderung in der Netlist Datei..

Grüße!

von HildeK (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Kevin B. schrieb:
> Gibt es wirklich keine Möglichkeit das Modell in LTSpice zum Laufen zu
> bekommen?

Vielleicht schon, wenn Helmut S. den Thread finden sollte, ist die 
Chance recht groß.

von Helmut S. (helmuts)


Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Hallo Kevin,

Die richtige Netlist Order in deinem Symbol ist nicht die PINOUT 
ORDER(Kommentar) der Modelldatei sondern die Reihenfolge der 
PIN-Funktion zählt. Die 3, 4, 6, 2, 1 sind die Netznamen im Subcircuit. 
Die interessieren das Symbol nicht.

* BEGIN MODEL TLV2370
* PINOUT ORDER +IN -IN +V -V OUT EN
* PINOUT ORDER  3   4   6  2  1   5
.SUBCKT TLV2370 3 4 6 2 1 5

Der +IN pin hat die Netlist Order 1.
Der -IN pin hat die Netlist Order 2 u. s. w..

Bei spezifischen Symbolen setze ich die Attribute wie in dem angehängten 
Bild. Genau so macht es auch LTC bei fast allen Opamp-Symbolen.


Gruß
Helmut

von Nacht E. (nachteule)


Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen!

Und schon klappt es - recht herzlichen Dank dafür!

Einen schönen Tag noch!

Kevin

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.