Forum: Analoge Elektronik und Schaltungstechnik Mein erstes SNT


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Erik (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Moin,
ich probiere ein gerade SNT zu bauen. Mit einem LTC3786.
Dabei habe ich folgenden Plan nachgebaut:
http://www.linear.com/solutions/5038


Ich habe vor ein paar Stunden das zusammengelötete zum ersten mal 
getestet.
Dazu hab' ich zur Sicherheit ein 100 Ohm Widerstand in Reihe zur 
Stromquelle geschaltet.

Es funktioniert natürlich nicht :D. Egal was ich an der Stromquelle 
mache, ob ich einen 3s oder einen 2s Lipo nehme, oder ob ich einen 1k, 
100er oder 10er Widerstand nehme, die anliegende Spannung am Netzteil 
(hinter dem Widerstand) beträgt immer ca. 3,8V bis 3,9V. Der 
Stromverbrauch steigt entsprechend mit sinkendem Widerstand. Ich habe 
schon herausgefunden, dass von 40mA (an der Stromquelle) 38-39mA durch 
den Bottom-Mosfet fließen.
Seit knapp zwei Stunden versuche ich herauszufinden ob ich beim Löten 
einnen Fehler gemacht habe. Ich will es trotzdem nicht ausschließen - 
mein Konstrukt ist sehr unübersichtlich geworden.

Hat hier jemand vielleicht einen Hinweis? Z.B. womit das mit den 
konstanten 3,8-3,9 Volt zusammenhängen könnte?



Als Mosfets habe ich STP100N6F7 genutzt.
(http://www.st.com/content/ccc/resource/technical/document/datasheet/0c/00/07/52/6f/ec/45/9e/DM00148868.pdf/files/DM00148868.pdf/jcr:content/translations/en.DM00148868.pdf)

Den Softstart-pin habe ich freigelassen (das ist auf dem Plan anders).


Messgeräte: Ich habe zwei normale Multimeter, ein TrueRMS Multimeter und 
ein Oszi.


Und noch etwas:
Kann jemand Lektüre empfehlen mit der man lernen kann übersichtlichere 
Schaltungen zu erzeugen? Das ist doch bestimmt ein großes Thema 
eigentlich.


Beste Grüße
Erik

von Erik (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Habe noch was vergessen:
Hier ein Bild vom Oszi. Die Messspitze ist am Bottom-Mosfet-Gate und 
Ground am Sourcebein des selben Mosfets.
Y-Achse: 2V pro gestrichelter Linie
X-Achse: 100us pro gestrichelter Linie

von Christian S. (roehrenvorheizer)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Welche Frequenz hat denn der Oszillator?

Warum beschaltest Du den Softstart-Pin nicht?

Hast Du die FETs an sehr kurzen Anschlüssen an eine gute Masse 
angeschlossen? Hast Du den 8mOhm Widerstand als Vierleiter-Anschluß 
ausgeführt?

Welche Spule hast Du genommen? Passt sie zur Frequenz?

Die Strombegrenzung solltest Du eher nur hinten am Leistungsteil wirken 
lassen und dem IC die vorgesehene Betriebsspannung geben. Bei ungenügend 
hoher Eingangsspannung werden die FETs nicht öffnen.

Falls die Fets nicht die richtigen Schaltzeiten haben, könnten sie zu 
langsam sein und nicht als Synchronwandler wirken.

Welche Diode hast Du als Boost-Diode?

MfG

: Bearbeitet durch User
von Erik (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich will den Widerstand an der Quelle nicht entfernen, da ich erwarte, 
dass mir dann der Bottom-Mosfet durchbrennt.
Mit dem 10Ohm Widerstand fließen bereits 0,5A und dass, ohne, dass eine 
Last am Ausgang angeschlossen ist.
Am Ausgang lieen übrigens 6Volt an. 48 Sollten. 4V am Eingang.
Die Spule hat 15uF anstatt 16uF.


Der Messwiderstand ist nur 3mOhm um die max. Stromstärke zu erhöhen. Ist 
wie im Datenblatt beschrieben von mir berechnet worden. Und so eingebaut 
wie im gegebenen Plan. Ich lese gleich mal nach was ein 
Vierleiteranschluss ist...


Den Softstart-Pin habe ich freigelassen um die Schaltung nicht unnötig 
zu verkomplizieren.




Dein Ansatz mit dem zu langsamen Fet kommt mir gut vor. Darauf habe ich 
nicht geachtet.

Da der Freq. Pin auf GND liegt ist die Frequenz 350khz
Ich könnte sie auf 105khz einstellen ggf. die Spule wechseln und nochmal 
testen.

Wie finde ich heraus ob der Fet zu langsam ist?


Als Boost-Diode habe ich die gleiche verwendet wie im Plan: BAS170W. 
Winziges Teil... Vielleicht habe ich die beim Löten kaputt gemacht? Aber 
durchlassspannung ist immer noch 0,4V nach meinem Multimeter. 
Einbaurichtung habe ich auch schon gründlich geprüft.

von der schreckliche Sven (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Erik schrieb:
> Am Ausgang lieen übrigens 6Volt an. 48 Sollten. 4V am Eingang.
> Die Spule hat 15uF anstatt 16uF.

Laut Datenblatt will das IC mindestens 4,5 Volt. Mindestens.
Bei so niedriger Spannung brauchst Du dringend Logik-Level Mosfets.
Seit wann gibt es Spulen mit 15uF ?

von Michael B. (laberkopp)


Bewertung
0 lesenswert
nicht lesenswert
Erik schrieb:
> ich probiere ein gerade SNT zu bauen

Ein Netzteil hängt am Netz.

Deines ist bloss ein Schaltregler, boost, step up.

Aber recht kräftig.

Es gibrt ein Eval-Board https://www.youtube.com/watch?v=U5xL9FeeXPw

Leider keine Platinenvorschläge im Datenblatt.

Aber es ist klar: Das Layout ist extrem kritisch bei so hohen Frequenzen 
und Strömen.

Zu den Bauteilen hat Linear ja einige Vorschläge gemacht und 
Typennummern geliefert mit denen es (urgendwie) geht.

> Als Mosfets habe ich STP100N6F7 genutzt.

Was willst du denn mit dem Schrott ? Der ist ja nicht mal LogicLevel, 
wie im LTC Datenblatt gefordert.
"This voltage is typically 5.4V. Consequently, logiclevel
threshold MOSFETs must be used in most applications."

Erik schrieb:
> Dazu hab' ich zur Sicherheit ein 100 Ohm Widerstand in Reihe zur
> Stromquelle geschaltet.

Damit wird so ein Schaltregler kaum anlaufen. Dem sackt doch die 
Eingangsspannung weg, spätestens wenn der Eingangskondensator leer ist.

von Erik (Gast)


Bewertung
0 lesenswert
nicht lesenswert

von der schreckliche Sven (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Erik schrieb:
> Übrigens wird der
> Bottom-Mosfet nach 5 Sec. auch schon extrem heiß.

Weil er nicht richtig einschaltet. Ungeeignet.
Und wenn schon einen Widerstand, dann nur in den Lastkreis. Das IC 
braucht mehr Spannung als 3,8V.

von Erik (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Michael B. schrieb:
> Damit wird so ein Schaltregler kaum anlaufen. Dem sackt doch die
> Eingangsspannung weg, spätestens wenn der Eingangskondensator leer ist.

Habe jetzt mal den Widerstand durch eine 3A Sicherrung ausgetauscht.
Sie ist beim Einschalten sofort durchgebrannt. Reicht das um zu sagen 
das was falsch ist? Oder habe ich hier immer noch einen Denkfehler?

von Michael S. (mikel_x)


Bewertung
0 lesenswert
nicht lesenswert
Evtl. ist durch dein unsystematisches rumprobieren das IC schon übern 
Jordan.
Aber ein verpolter Fet (oder zwei) könnten, wegen der Freilaufdiode auch 
für "erhöhten Strombedarf" sorgen.

von der schreckliche Sven (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Erik schrieb:
> Reicht das um zu sagen
> das was falsch ist? Oder habe ich hier immer noch einen Denkfehler?

Es gab schon ein paar Hinweise darauf, was "falsch ist".
Wenn Du ein Foto posten würdest, gäbe es bestimmt mehr Hinweise.

von Erik (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Jetzt nochmal mit 10A.
Diese brennt nicht durch. Ich habs aber nach einer Sec. wieder 
abgemacht. Das Mutlimeter zeigte 6A.
Die Stromquelle ist ein 7s 4Ah Lipo die Spannung sollte nicht 
einbrechen. Die Kabel sind kurz und haben einen ordentlichen 
Querschnitt.

Wenn ihr weiter nichts sagt werde ich denke ich mal neue Mosfets 
besorgen.
Ich wusste nicht wo ich die RJK0652DPB herbekommen sollte. Deshalb habe 
ich die anderen genommen.

von Christian S. (roehrenvorheizer)


Bewertung
0 lesenswert
nicht lesenswert
"Als Mosfets habe ich STP100N6F7 genutzt.

Was willst du denn mit dem Schrott ? Der ist ja nicht mal LogicLevel, 
wie im LTC Datenblatt gefordert.
"This voltage is typically 5.4V. Consequently, logiclevel
threshold MOSFETs must be used in most applications.""


Das wird der Hauptgrund sein. Die Spule dürfte OK sein. Und der 
Softstart ist keine unnötige Dekoration, falls die Schaltung später 
richtig geht. Probier mal so um 80...100kHz einzustellen für die 
nächsten Versuche.

mfG

: Bearbeitet durch User
von DB (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Vor dem nächsten MOSFET-Kauf immer (!) Datenblatt checken. Bauteile 
werden nämlich teils auch mal in die falsche "Spalte" sortiert bei 
Distributoren und Händlern.

Im Datenblatt muß die R(DS)ON Spezifikation (Tabelle) auch für 4,5V 
gemacht worden sein. Soll heißen, es steht (teils beim Angebot des 
Verkäufers, aber manchmal nicht einmal auf dem Deckblatt des 
Datenblattes) nicht immer "Logic Level" dabei - und sogar, wenn, dann 
muß es nicht unbedingt korrekt sein.

Einzig diese Spezifikation ist SICHER, R(DS)ON bei <= 4,5V.

Das nur, um weitere Fallstricke zu vermeiden. Und: Ja, meistens stimmt 
die Einsortierung, und häufig steht auch "Logic Level" auf dem 
Deckblatt. Auch in Frage kommen "Ultra Logic Level" o. ä.

Und solltest Du um Deine FETs fürchten, dann erhöhe den SENSE Widerstand 
ein wenig - so weit es halt geht. (Berechnung laut Datenblatt für 
jeweiligen Ausgangsstrom.) Zu Testzwecken kannst Du diesen auch 0,1Ohm 
o.ä. machen (also höher halt) - und erst später anpassen. Aber Deine 
riesigen Widerstände am Eingang verhindern die gesamte Funktion der 
Schaltung. Keine Option.

von Erik (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Vielen vielen Dank!
Ihr habt mir richtig weitergeholfen. Auch unabhängig davon ob ich den 
Regler nun zum laufen bekomme oder nicht.

von uuu (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich wuerd mal mit etwas Einfacherem beginnen, und nicht gleich die 
Schaltung aus "Einfachheitsgruenden" abaendern.

von Peter M. (r2d3)


Bewertung
0 lesenswert
nicht lesenswert
Chris,

Guck' Dir mal den LM-2577 an, Zitat:
 "...Requires Few External Components..."

Das ist der Regler für das schnelle Erfolgserlebnis zwischendurch.

Das Datenblatt enthält eine Schritt-für-Schritt-Anleitung inklusive 
Erklärung der Bauteildimensionierung.

http://www.ti.com/lit/ds/snos658d/snos658d.pdf

Als Spule verwendest Du z.B. welche von Fastron, Reichelt-Bezeichnung 
L-PISR...

von Erik (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Könnte noch einmal jemand bestätigen? Solche müssten doch gehen oder?
http://www.mouser.com/ds/2/196/IPP_B084N06L3_Rev2.23-97310.pdf

Grüße
Erik

von der schreckliche Sven (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Kann ich bestätigen.
Wenn auch spannungsmäßig ein bißchen knapp, 48V - 60V.

von Erik (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Tag allerseits, da bin ich wieder.
Leider hat das Ersetzen der MOSFETS nicht den gewünschten Effekt 
gebracht :(.
Die Symptome sind die selben geblieben.

Wenn ich so drüber nachdenke könnte es eine ganze Reihe Ursachen haben.
Aber am wahrscheinlichsten ist wohl, dass der LTC3786 kaputt ist, oder 
was falsch zusammen gelötet habe, auch wenn ich das jetzt oft 
kontolliert hab. Wie schon erwähnt ist mein Aufbau sehr unübersichtlich 
geworden.

Folglich habe ich mich weiter damit befasst wie ich den Aufbau 
übersichtlicher bekomme und zukünftige Fehler eleminieren kann und habe 
mich schließlich mit dem Programm Eagle auseinandergesetzt (War leicht 
intuitiv zu verstehen).


Nun zu meinem Anliegen:
Könnte vielleicht nochmal jemand auf meinen Plan sehen um ggf. ein paar 
offensichtliche Fehler zu erkennen und zu nennen. Ich bin das Datenblatt 
vom LTC nochmal durchgegangen und habe probiert mich an die Vorgaben 
dort so gut es geht zu halten.
Außerdem hätte ich noch ein paar Fragen:

Der Schaltplan entspricht ürbigens bis auf, dass ich ein paar andere 
Bauteile ersetzt habe dem hier: http://www.linear.com/solutions/5038


Im Datenblatt stand, man solle in der Nähe vom Controller einen 
Kondensator zwischen die SENSE+/- Leitungen packen um Störungen zu 
kompensieren. Kann mir jemand sagen wie Groß? Kann ich da auch einen 
6,4uF nehmen? Oder ist das viel zu Groß?
Sind die Sensedinger eigentlich außschließlich für die Stromgbegrenzung 
oder haben die noch einen weiteren Nutzen?

R_ith mit 8,66kOhm wirkt mit diesem Wert nicht so as sei er willkürlich 
so gewählt worden. Leider finde ich im Datenblatt keinen Hinweis darauf, 
wie man diesen Wert berechnet. Ich habe ich noch nicht wirklich 
verstanden, was dieser macht... Kann mir da vielleicht jemand 
weiterhelfen?


Kann ich bei C_b anstatt 100nF auch 220nF nutzen?

von Stefan S. (chiefeinherjar)


Bewertung
1 lesenswert
nicht lesenswert
Ich hätte eher das etwas... ähem... suboptimale Layout im Verdacht.

Du solltest dir unbedingt beim Lothar Miller die Grundlagen zum Layout 
eines Schaltreglers anschauen. Du hast beispielsweise riesige Kreise 
bzw. Schleifen.

http://www.lothar-miller.de/s9y/categories/40-Layout-Schaltregler

von Kevin K. (nemon) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
nagut, wenn man so ein Layout für einen Schaltwandler dahinrotzt, kann 
es durchaus sein, dass das nicht gut funktioniert. Versuche mal, die 
Bauteile auf 50% des bisherigen Platz zu positionieren.

von MaWin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Erik schrieb:
> Aber am wahrscheinlichsten ist wohl, dass der LTC3786 kaputt ist, oder
> was falsch zusammen gelötet habe, auch wenn ich das jetzt oft
> kontolliert hab.

So lange zwischen Inductor und Rsense keine Verbindung besteht, wird es 
auch nicht funktionieren.

Die GND Leitung hat zu hohe Impedanz für die Schaltfrequenz.

von Klaus R. (klara)


Bewertung
0 lesenswert
nicht lesenswert
Erik schrieb:
> Leider hat das Ersetzen der MOSFETS nicht den gewünschten Effekt
> gebracht :(.
> Die Symptome sind die selben geblieben.

Also, für Dein erstes SNT hättest Du Dir vielleicht besser etwas 
einfacheres ausgesucht. Das Layout ist hierbei entscheidend. Ich habe 
mal nach "ltc3786 layout" gesucht. Der zweite Treffer ist schon etwas 
für Dich.

https://www.eevblog.com/forum/projects/boost-converter-pcb-layout-25319/

LT hat auch ein Demo Board.
http://www.linear.com/solutions/3771

Mit LTSpice kenne ich mich aus. Wenn Du das noch nicht für Dein Projekt 
genutzt hast, dann würde ich es schleunigst nachholen und deren 
Simulationen studieren.

Was LTpowerCAD macht weiß ich leider nicht. Es könnte sein das es Dich 
beim entwerfen eines Layouts unterstützt. Dann würde ich mich daran 
orientieren.
mfg klaus

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Erik schrieb:
> Der Messwiderstand ist nur 3mOhm
Und die paar mV, die dort anfallen, müssen kreuz und quer über die 
Platine? So wird das nix.

Erik schrieb:
> Aber am wahrscheinlichsten ist wohl, dass der LTC3786 kaputt ist
Mag sein. Aber dein wichtigstes Bauteil, die Platine, ist absolut 
unbrauchbar. Da lohnt sich kein herumbasteln. Das Ding wird nie 
brauchbar laufen.

Zum Test könntest du bestenfalls direkt am IC die Strommesseingänge 
kurzschließen.

Und gibt es eigentlich nicht eine wesentlich kleinere Spule, die die 
nötigen Daten hat?

Klaus R. schrieb:
> Es könnte sein das es Dich beim entwerfen eines Layouts unterstützt.
> Dann würde ich mich daran orientieren.
In den Designdaten zum Evalboard sind auch Layoutdaten. Die würde ich 
mir mal so lange anschauen, bis ich jede einzelne Leitung und deren 
Verlauf verstanden habe.

von Klaus R. (klara)


Bewertung
0 lesenswert
nicht lesenswert
Lothar M. schrieb:
> In den Designdaten zum Evalboard sind auch Layoutdaten. Die würde ich
> mir mal so lange anschauen, bis ich jede einzelne Leitung und deren
> Verlauf verstanden habe.

Dem kann ich nur nur noch einmal unbedingt zustimmen. Du arbeitest mit 
hohen Frequenzen!
mfg Klaus

: Bearbeitet durch User
von Lothar M. (lkmiller) (Moderator) Benutzerseite


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
@Erik: Ich habe mir das nochmal angeschaut und komme zum Schluss: 
vergiss es.
Das Referenzdesign hat 6 Lagen(!) und ist doppelseitig bestückt(!!).
Sowas bekommst du ohne Erfahrung niemals zum Laufen. Und mit deinem 
Layout eh' nicht. Schon der Toplayer zeigt in den Designdaten deutlich, 
welche Leitungsführung da anzustreben ist...

Ich würde mir zuallerserst das Evalboard beschaffen und damit mal ein 
wenig herumspielen.

von asdfjklö (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Prüfe mal die Verbindung Rsense und die Drossel (wurde von MaWin oben 
schon erwähnt), da ist eine Luftlinie im Layout eingezeichnet.

Bevor (!) du das Layout kübelst:
Es ist möglich, dass dein Regler einfach nur schwingt. Du hast 
Eingriffsmöglichkeeiten in die Kompensation, am PIN ITH. Da kann man an 
der Übertragungsfunktion des Reglers herumbasteln.
Setze mal die Zeitkonstante des RC am Pin ITH herab. Auf z.B. 1/10tel. 
Der Regler reagiert dann langsamer, neigt aber weiniger zum Schwingen. 
Siehe auch Kapitel 21. Du kannst Kombinationen vorher auch bequem in 
LTSpice testen.

wenn du wissen willst, wie deine Kompensation wikt, kannst du den Regler 
mit einem Lastsprung stimulieren. Die Art der Sprungantwort sagt dir, ob 
es richtig ist.

wenn das dann läuft, würde ich das Layout nochmal machen. Nach den 
Vorgaben aus dem Datenblatt.

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
asdfjklö schrieb:
> die Drossel
Wo wir es grade davon haben und ich schon die Bauform dieser Spule 
angemäkelt habe: laut Datenblatt ist diese Spule für 1kHz spezifiziert 
und dürfte mit dem drittel MHz des Schaltreglers überfordert sein.

Ich würde da eher sowas anpeilen:
https://de.rs-online.com/web/p/drahtgewickelte-smd-induktivitaten/7362099/
http://docs-europe.electrocomponents.com/webdocs/0f88/0900766b80f88807.pdf
Die ist wenigstens für 100kHz spezifiziert und ist damit in der 
richtigen Zehnerpotenz unterwegs...

BTW: Ist das eigentlich ein Autorouter-Design? Oder wie konnte das mit 
In+ passieren?

: Bearbeitet durch Moderator
von Erik (Gast)


Bewertung
0 lesenswert
nicht lesenswert
So, da bin ich wieder.
Vielen Dank auf jeden Fall für eure Mühen.

"BTW: Ist das eigentlich ein Autorouter-Design? Oder wie konnte das mit
In+ passieren?"
Tut mir leid, das habe ich vergessen zu erwähnen: Ich wollte das Layout 
als einseitiges designen und die Leiterbahnen die ich auf die Rückseite 
gezeichnet habe sollten frei fliegend werden.

Ich habe mir auch das Demoboard angesehen, aber das hat so viele Ebenen 
und ich habes es "auf die Schnelle" nicht verstehen können. Ich werde 
mich in ca. einem Monat nochmal länger mit dem Thema befassen ich habe 
bald Klausuren (Informatikstudium).

Ich muss auch gestehen, bei diesem Projekt treten Probleme auf, von 
denen ich echt keine Ahnung hatte. Ich dachte 350khz wären jetzt noch 
nicht so wild.

Ich habe mich für diesen Wandler so sehr interessiert, weil er so extrem 
effizient ist und ab 4,5Volt läuft. Unter anderem wollte ich den Wandler 
in einem Akkubetriebenen Selbstbauprojekt verwenden. 300Watt Leistung 
und kein Kühler, das ist schon was :).

Ich habe auch schon darüber nachgedacht die Frequenz zu senken. Der 
Regler lässt sich ja auf bis zu 50khz runterregeln. Allerdings würde ich 
gerne bei 100khz bleiben, damit die Spule nicht zuu Groß wird.

Das müsste das Problematik doch schon wesentlich entschärfen oder nicht?
Gruß Erik

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Erik schrieb:
> Ich dachte 350khz wären jetzt noch nicht so wild.
Das Spektrum steckt in der Flanke!

> Das müsste das Problematik doch schon wesentlich entschärfen oder nicht?
Probiers aus. Der Gaul ist eh' schon tot, da kannst du jetzt mal Reiten 
üben. Und wenn das Ding dann mal die ersten Zucker tut, dann lernst du 
und gewinnst die Ahnung, die dir beim nächsten Mal hilft.

> Allerdings würde ich gerne bei 100khz bleiben, damit die Spule nicht zuu
> Groß wird.
> 300Watt Leistung und kein Kühler, das ist schon was :)
Mit 2 Lagen statt mit 6? 300 Watt aus einem 3,7V Akku? Ein Stepup mit 
3,7V auf 48V bei 300W? Das ist schon überaus extrem.

Im Ernst: du solltest erst mal an kleineren Designs üben. So ein Projekt 
wie das hier, das bringt auch den Profi zum Grübeln...

von Christian S. (roehrenvorheizer)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Erik,

probiere doch mal zwischenzeitlich mit solch beherrschbaren ICs wie 
TL494, SG3524, SG3525, UC3843 beispielsweise einen brauchbaren Wandler 
aufzubauen. Das birgt für Anfänger bereits genügend Tücken und stellt 
eher einen gangbaren Weg dar. Außerdem lassen sich mit diesen bereits 
viele Erfahrungen sammeln. Die 4,5 Volt müßtest Du allerdings erst mal 
hoch setzen zum Betrieb.

Deinen Favoriten kannst Du danach im nächsten Anlauf wieder hervor 
holen.

MfG

von Rettung (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Erik schrieb:
> Ich habe auch schon darüber nachgedacht die Frequenz zu senken. Der
> Regler lässt sich ja auf bis zu 50khz runterregeln. Allerdings würde ich
> gerne bei 100khz bleiben, damit die Spule nicht zuu Groß wird.

Wenn Du die Frequenz auf 1/4 drückst, zusätzlich die Schaltvorgänge der 
FETs mit ausreichend großen Widerständen verlangsamst, eine Spule mit 
dem 4-fachen Induktivitäts-Wert einsetztest, und den Sense-R 4-fach 
vergrößertest, könnte es gehen.

Dann wäre die Leiterplatte vielleicht nicht dem absoluten Tode geweiht, 
sondern evtl. funktional. Nur halt weder mit der Frequenz, noch mit der 
Leistung, die Du zuerst anstrebtest. Das sehe ich als einzige 
"Rettungsmöglichkeit".

Selbstverständlich wäre die nötige Spule (L*4) höchstwahrscheinlich 
nicht so niederohmig, wie die bisherige. Weshalb dabei nicht ganz das 
"Wirkungsgradwunder" herauskäme, welches man bei den (für Strom/4) bei 
so niederohmigen Schaltern vielleicht erwarten würde. Sondern trotzdem 
nur "normaler" Wirkungsgrad, wie halt der originale Wandler auch hätte.

Aber trotzdem eine legitime Vorgehensweise, um dat Ding nicht komplett 
entsorgen zu müssen. Oder, Leute? Was meint Ihr dazu?

von Erik (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Glaubt ihr denn z.B. folgendes Konzept könnte was werden:
- Freq: 60khz
- Ich designe das Layout neu, sodass die Sense Leitungen wirklich so 
kurz wie möglich sind

Iout Max. (Spitze) 3A
Vout 48V
Vin 3s Lipo, ich rechne jetzt mal mit 10V für einen fast leeren Akku

Iin (Spitze) (Verluste&Iripple unberücksichtigt.) = 14,4A

Ich habe jetzt mal als Induktivität zum rechnen diesen hier genommen : 
https://de.rs-online.com/web/p/drahtgewickelte-smd-induktivitaten/7707183/
Der hätte dann:
 - Isat = 18A
 - Imax = 15A
 - L = 22uH
 - Rdc = 7mOhm

Iripple = 48V / (60000Hz  22H  10^-6) * (1 - 48V / 10V) = knapp. 6A
Prozentual wären das ca. 40%. Das Beispiel vom Datenblatt hat 30%

Imax = 14,4A + 6A / 2 = knapp 17,4A

Isat von der Spule sind 18A reich das noch?
Eigentlich hätte ich gerne eine mit höherer Induktivität und mehr 
headroom, was Isat angeht.

Rsense = 75mV / 17,4A = 4,31mOhm => 4 mOhm


Wenn ich jetzt noch das Layout zweiseitig mache, dabei die Leiter für 
RSense wirklich kurz werden und ich probiere mich mehr an das hier 
http://www.lothar-miller.de/s9y/categories/40-Layout-Schaltregler zu 
halten, glaubt ihr das hat dann eine Chance?

Gruß
Erik

von Michael R. (fisa)


Bewertung
0 lesenswert
nicht lesenswert
Ob das funktioniert oder nicht, mag ich nicht beurteilen.

Aber: vor deinen Strömen stehen so beunruhigend hohe zahlen, und ich 
befürchte du hast vor das alles gleich mit einem Lipo zu versorgen?

Das kann (im wahrsten Sinn des Wortes) ins Auge gehen.

Besorg dir doch wenigstens ein einfaches, billiges Labornetzteil mit 
Strombegrenzung... du schonst deine Schaltung, deine Bauteile, und deine 
Gesundheit.

Nebenbei hat speziell Linear wirklich jede menge guter, einfacher, 
harmloser Schaltregler im programm... probier wirklich mal was 
einfacheres!

Und lade dir SwitcherCAD/LTSpice  von denen runter, dann kannst du deine 
Schaltungen auch vorher simulieren.

von Christian S. (roehrenvorheizer)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

bei 15A am Eingang sollte Deine Spule mindestens das doppelte aushalten 
können.

http://www.sprut.de/electronic/switch/schalt.html#up

MfG

: Bearbeitet durch User
von Lothar M. (lkmiller) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Erik schrieb:
> Imax = 14,4A + 6A / 2 = knapp 17,4A
> Isat von der Spule sind 18A reich das noch?
Mal von der falschen Rechnung abgesehen: beim Sättigungsstrom hat die 
Spule schon deutlich weniger Induktivität. Denn der Übergang zur 
Sättigung ist ja nicht binär...

> Wenn ich jetzt noch das Layout zweiseitig mache
Wie gesagt: ich würde mir bei so einem Ding mit diesen Anforderungen 
das Evalboard beschaffen und es analysieren. Wenn du das nicht brauchst 
kannst du dir das Geld natürlich sparen.

> glaubt ihr das hat dann eine Chance?
Du säufst dir das irgendwie schön. Auch mit deinen "reduzierten" 
Anforderungen ist das Design absolut nichts für Anfänger. Das war echt 
kein Witz mit dem Hinweis, mal mit einem wirklich einfachen und leicht 
beherrschbaren Design zu üben.

Zum Verleich aus dem Leben:
Auch wenn es einfach aussieht wenn andere Hochrad fahren, ist klar, dass 
die das nicht beim ersten Mal konnten und sind sicher ein paar Mal auf 
die Nase gefallen sind.
Und dabei haben die sogar vorher mit einem kleinen Einrad geübt...


Das mit dem potenten Labornetzteil als sinnvolle, stabile und 
reproduzierbare Versorgung für den Prototypen wurde ja schon gesagt.

: Bearbeitet durch Moderator
von Erik (Gast)


Bewertung
0 lesenswert
nicht lesenswert
"Du säufst dir das irgendwie schön. Auch mit deinen "reduzierten"
Anforderungen ist das Design absolut nichts für Anfänger. Das war echt
kein Witz mit dem Hinweis, mal mit einem wirklich einfachen und leicht
beherrschbaren Design zu üben."

Ich dachte ich würde mit meinen reduzierten Anforderungen das Projekt so 
weit vereinfachen, dass es anderen Wandlern mit dieser Schaltfrequenz 
ähneln würde.
Ich verstehe nur nicht, warum das IC an sich so kritisch ist. Das hat 
nichts damit zu tun, dass ich den Vorschlag, einfacher anzufangen, nicht 
ernst nehmen würde.

Und keine Sorge: Ich benutze ein DF-3010 zum Testen.

Gruß
Erik

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Erik schrieb:
> Ich verstehe nur nicht, warum das IC an sich so kritisch ist.
Wenn schon das Evalboard sechslagig ist, dann ist das für mich /aus 
Erfahrung/ ein Alarmzeichen. Denn mit dem Evalboard möchte der 
Hersteller ja eigentlich zeigen, wie schön einfach sein Baustein 
einzusetzen ist...

> Ich dachte ich würde mit meinen reduzierten Anforderungen das Projekt so
> weit vereinfachen
Dein Ansatz ist eher der: ich fahre das Hochrad aus dem Beispeil zu 
Beginn nicht so schnell und mache es mir deshalb einfacher. Bewerte 
selber, ob diese Vorgehensweise gute Chancen bringt.

> Und keine Sorge: Ich benutze ein DF-3010 zum Testen.
Gut, aber neue Information, denn bisher war ausschließlich von 2s, 3s 
und 7s Lipo die Rede.

Nach wie vor empfehle ich, das Evalboard zu kaufen, wenn es eines gibt. 
Allein schon, dass man eine Referenz für Vergleichsmessungen hat.

: Bearbeitet durch Moderator
von voltwide (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Die Schwierigkeiten wachsen in dem Masse, wie die Betriebsspannung nach 
unten geht und der zirkulierende Strom nach oben geht.
Ich hatte mal einen Synchron-Abwärtswandler von 40V auf 5V/5A 
entwickelt.
Im fertigen Layout erwies sich dieser als instabil, obwohl ich die 
Dimensionierung vom Hersteller übernommen hatte.
Knackpunkt war unser 2-seitiges Leiterplatten-design, dass gegenüber dem 
4-lagigen Evaluierungsbord deutlich abfiel. Und diese Anforderungen 
waren ja noch harmlos im Vergleich zu Deinen!

von Erik G. (erik_g)


Bewertung
0 lesenswert
nicht lesenswert
Okay,
also ich werde mir wohl einen einfacheren Regler zum üben suchen. Das 
mit dem Evalboard ist mir ehrlich gesagt etwas zu teuer dafür, dass ich 
es wahrscheinlich auch mit diesem nicht gebacken bekäme.
Texas Instruments und Linear haben da ja eigentlich ziemlich nette 
Suchfunktionen. Ein Problem bleibt mir dabei aber noch: Ich verstehe 
leider immer noch nicht so wirklich was genau jetzt den LTC3786 zu so 
einem kritischen IC macht... Ich habe mir bereits einige andere 
angesehen, aber es fällt mir schwer zu erkennen, ob diese "einfacher" 
wären.
Ansonsten werde ich mir die bereits vorgeschlagen nochmal genauer 
ansehen.

von Michael R. (fisa)


Bewertung
0 lesenswert
nicht lesenswert
ich würde einen monolithischen empfehlen (der hat den Switcher MOSFET 
schon an Bord) und je nach deinen Platinen- und Lötkünsten was 
bedrahtetes (TO-220 oder so)

Ich hab meine ersten gehversuche mit LT1170 gemacht, der ist recht 
gutmütig

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Erik G. schrieb:
> Ich verstehe leider immer noch nicht so wirklich was genau jetzt den
> LTC3786 zu so einem kritischen IC macht...
Das Kritische an diesem Regler ist die Bauteilplatzierung und das 
Layout. Das hast du aber schon selber herausgefunden. Du glaubst es nur 
noch nicht, stimmts?

Aber sogar ich hatte vor Kurzem einen Schaltregler mit dem LM5088, der 
letztlich ein Redesign brauchte, um auf das erwartete Ergebnis zu 
kommen. Und ich hatte eigentlich mit dem ursprünglichen Layout gar kein 
allzu schlechtes "Gefühl". Aber dann machte der statt bei erwarteten 10A 
schon bei 3A dicht. Ursache: unglücklicher Verlauf der Sense-Anschlüsse. 
Und dabei ging es eigentlich nur um ein paar mm...

von Rettung (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Erik G. schrieb:
> ich verstehe leider immer noch nicht so wirklich was genau
> jetzt den LTC3786 zu so einem kritischen IC macht...

Es liegt an der gesamten Kombination.

Spannung und Strom (hier extrem niedrige mögliche V_in - dadurch extrem 
hoher maximaler Strom), mit der  Schaltfrequenz und zugehörigen 
Schaltflanken (dU/dt und hier vor allem dI/dt), zusammen mit dem dazu 
nötigen Umfeld bei genau diesem IC und seiner Beschaltung.

Da gibt es - außer dem von Voltwide genannten: "Wenn der Strom und/oder 
die Spannung sehr hoch, dann schwieriger" - kaum einfache 
Unterscheidungs-Grundlagen, welches IC in welcher Beschaltung einfacher 
funzt.

"Kompliziertere" Beschaltung, bzw. eine komplexere Topologie (mehr Meß- 
und Schutzfunktionen) kann, wenn perfekt ausgeführt (!), die Performance 
eines Schaltreglers extrem steigern - WENN.

Das Ganze ist nicht unbedingt einfach. Und genau deshalb ist es 
sinnvoll, sich ans Thema "heranzutasten", Schritt für Schritt von einem 
z.B. LM25XX mit 20V / 1A = 20W Output bei 10V Eingang zu "härteren" 
Sachen.

von Rettung (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Rettung schrieb:
> "Wenn der Strom und/oder
> die Spannung sehr hoch, dann schwieriger"

Die Kombi extrem niedrige Spannung und hoher Strom ist deshalb besonders 
Anspruchsvoll, weil alles (!) extrem wenig DC- und v. a. AC-Widerstand 
(Impedanz bei Frequenz) haben soll - a.) um nicht die Effizienz stark zu 
drücken, b.) aber auch, um überhaupt zu funktionieren. Denk mal an 
diverse Potentialverschiebungen über ohmschen R bei wechselnden Strömen, 
dazu natürlich diverse Reaktionen parasitärer Induktivitäten darauf... 
(genannte Probleme mit Millimetern!) ---> alles besonders schwierig bei 
niedrigster Spannung und hohem Strom.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.