Forum: Analoge Elektronik und Schaltungstechnik Verständnisproblem bei Schaltung/Ersatzbauteile finden und Co.


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Jochen K. (jochen3030)


Bewertung
0 lesenswert
nicht lesenswert
Moin!

Da dies mein erster Beitrag (und dann direkt mit einer Frage, sorry!) 
wird, ganz kurz zu mir und dem was ich an Vorkenntnissen habe.

Mein Name ist Jochen, habe die 30 Lenze schon abgehakt und habe ein 
wenig Erfahrung mit Elektrik, Elektronik und Schaltungen im Allgemeinen. 
Mein Großvater war (bzw. theoretisch ist er es noch, er sieht nur nix 
mehr...) Elektriker-Meister, durch Ihn habe ich rudimentäre Kenntnisse. 
Einen Schaltplan kann ich mehr oder minder gut lesen, aber danach wird 
es schon "eng". Meine Heimat ist normalerweise mehr die EDV 
(Systemadministration) und auch die Modelbahn.
Soviel zu mir.

Dann zu meinem "Problem"(en). Ich möchte eine Schaltung nachbauen, die 
als "Kern" einen Arduino Mega 2560 hat, aber eine ganze Menge an 
zusätzlichen Schaltungen beinhaltet. Da der Schaltplan nicht mein 
eigener ist, trau ich mich auch nicht, hier ein Bild hochzuladen. Daher 
die Verlinkung:

http://pgahtow.de/wiki/images/Arduino_MEGA_Zentrale.png

Dort ist der Schaltplan zu finden, auf den ich mich im folgenden 
beziehen werde. Es handelt sich dabei um einen nachbau einer Digitalen 
Steuerzentrale (um die Modellbahn steuern zu können).
Der Begleittext dazu ist hier zu finden: 
http://pgahtow.de/wiki/index.php?title=Z21_Arduino_Zentrale_(Atmega2560)

Die Bauteile sollten möglichst über Reichelt.de zu bekommen sein, ich 
will nicht wegen 20 Cent 8 Euro Versandkosten von 9 Händlern zahlen 
müssen. Kann man sicher verstehen ;-).

Kommen wir zu meinen Problemen. Für manchen sicher ein "Klacks" und 
nicht der Rede wert, für mich ein Berg (den ich versuche zu erklimmen, 
aber auch akzeptiere, es nicht allein zu schaffen)!

Problem 1: Mitte Unten

Dort wird ein WIFI-Modul namens "ESP01" verbaut. Dieses Modul läuft mit 
3.3 VDC, der AtMega mit 5V. Auf der rechten Seite ist dafür offenbar ein 
Spannungsteiler verbaut worden (WIFI_RX). Für den WIFI-TX wurden 
keinerlei Vorkehrungen getroffen. Mein Gedanke war, auf den IC3 
(LD117AV33), der die benötigte Betriebsspannung liefern soll, zu 
verzichten und stattdessen einen Logic-Level-Shifter zwischen 3.3V- und 
5V-Logik zu verwenden. (Den hier: 
Ebay-Artikel Nr. 172396805784
Soweit ich das sehe, müsste das ja gehen, oder?

Problem 2: Rechts Mitte/Unten

Es wird dort als IC2 der TLE5205-2 verbaut. Dieser Motortreiber wird 
aber nicht mehr hergestellt. Den TLE5206-2G gibt es noch, die SMD 
Variante. Aber die Kühlung (und bei 5A sollte das Teil meiner Meinung 
nach gekühlt werden) ist in der SMD-Variante so nicht umsetzbar (für 
mich). Was man hier als Ersatz nehmen könnte, weiß ich nicht, damit kenn 
ich mich nicht aus. Ggf. würde man aber das Teil noch aus China im 5er 
Pack bekommen, wenn sich nichts finden lässt.

Problem 3: Schaltung lesen...

Ich habe hier 2 Punkte, aus denen ich nicht schlau werde.

a.) Mitte Rechts

Dort gibt es den Anschluss J2 (direkt unter dem Wort "Booster"). Links 
davon, am Pin 5 steht direkt daneben +12V. Darf ich davon ausgehen, dass 
damit gemeint ist, dass auch auch diesem Pin 12V anliegen sollen? (Ich 
weiß, ich schwer ohne nähere Angaben... .) Aber vom Schaltbild her, was 
würde Sinnvoll klingen?

b.) Links Unten

Es gibt dort in dem "Bereich" den Anschluss "LN_IN". Nur taucht der 
sonst nirgends mehr auf. In anderen Bauten des Entwicklers hat er den 
LN_IN auf den Pin 48 des AtMega gelegt, auf dem hier der LN-RECEIVE 
liegt. DAS ist so natürlich schwer nachzuvollziehen, ggf. ist das Teil 
überflüssig? Oder muss beides auf Pin 48 gelegt werden? Was würde (von 
der Schaltung her) denn Sinn machen?

Problem 4: Links Oben

Der Bereich stellt die Stromversorgung dar. Nun für die angegebenen 
Bauteile gibt es "Ersatz" (MC 7805 ACTG und MC 7812 CTG hab ich 
gefunden), aber das Kernproblem ist meiner Meinung nach, das die Teile 
einfach nur bis 1 A jeweils belastet werden können... . Der oben 
genannte ICS (TLE5205-2) hängt am +20V und hat selbst schon 5 A 
Belastbarkeit (und bei der Modellbahn braucht man die auch, sogar ggf. 
zusätzliche Booster!!!), die beiden Anschlussbereiche J7 "LocoNet" 
(Links Unten) und J2/6 "XNet" (Rechts Mitte) hängen beide am +12V und 
brauchen sicher noch mal so viel! (Dort kommen diverse Handregler dran, 
tlw. mit eigenen Displays, also auch ne Menge Stromverbrauch!) Die 
verzeichnete Stromversorgung ist jedenfalls ratzfatz durchgebrannt!

Ideen hätte ich (in meinem Leichtsinn) nun einige.

Z.B. ein eigenes Netzteil für die +20VDC (altes Laptop-Netzteil, in der 
Bucht für 10 Euro zu bekommen) und dann ein 2. Netzteil für +12V.
Oder "irgendwelche" Spannungswandler. Bin hier für gute Ideen und 
Vorschläge offen. Der MC 7805 ACTG kann vermutlich bleiben, die +5V für 
den AtMega und alles andere (VCC) wird vermutlich nicht sooo viel 
ziehen. Zzt. habe ich nicht vor den J5 "S88" (Links Mitte) zu verwenden, 
der bräuchte wohl die +5V als Versorgungsleitung (und damit entsprechend 
hohe Last) beim Rest braucht man es offenbar nur für die Schaltung 
(soweit ich das verstehe).

Den Brückengleichrichter direkt am Stromeingang J8 sehe ich bei der 
Verwendung von Netzteilen dann als überflüssig an. Er hat wohl 
ursprünglich 16VAC verwendet (normale Modellbahn"Licht"Spannung).

Der Temperatursensor an der Stelle ist sicher als "Sicherung" gedacht, 
aber dann wohl auch hinfällig (normaler Widerstand mit 15k rein und gut 
ist?).


Soweit was bisher an Fragen offen ist und ich nicht selbst 
herausgeknobelt habe. Solche Details wie den IC4 74HC244N durch die 
Variante ohne N zu ersetzen (sehe auch den Unterschied nicht wirklich), 
darauf bin ich selbst gekommen. Das Relais Rechts oben, nun, da ist es 
nun ja komplett egal, Hauptsache ein 12V Relais (einfach ein Wechsler, 
und gut)! Der Anschluss 47 "TASTER", nun, ich gehe davon aus, dass das 
einfach auf GND gezogen wird. Eingezeichnet ist jedenfalls nix! (Und den 
Sketch vom Arduino hab ich noch nicht weit genug kapiert, hab erst so 
ein "Starterset" hier um in die Programmierung rein zu kommen... . Ich 
weiß, erst ein Anfang, aber jeder fängt klein an.)

Natürlich hab ich den Entwickler schon versucht zu erreichen (sogar 
schon im Sommer) aber da meldet sich wohl niemand... . Daher wäre ich 
wirklich, wirklich, WIRKLICH sehr dankbar, wenn sich jemand meiner 
Probleme annehmen könnte! Ich brüte hier nun auch schon wieder seit ein 
paar Tage und versuche mein Wissen aufzufrischen/zu ergänzen, aber ich 
weiß auch, dass ich hier einfach viel zu wenig weiß!

Daher mein Dank für jede Hilfe und liebe Grüße an alle, die das hier bis 
hier hin durchgelesen haben ;-).

Euer Jochen

: Bearbeitet durch User
von Stefan ⛄ F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
Oha, da hast Du Dir warscheinlich zu viel auf einmal vorgenommen.

> Die Bauteile sollten möglichst über Reichelt.de zu bekommen sein

Kannst du vergessen. Das ESP-01 Modul gibt es dort z.B. nicht, das 
bekommst du IMO nur aus China. Aber immerhin ohne Versandkosten, wenn du 
bei Aliexpress mit Kreditkarte bestellst.

> Mein Gedanke war, auf den IC3 (LD117AV33) ... zu verzichten

Den Spannungsregler darfst du auf gar keinen Fall weg lassen. Das modul 
verträgt maximal 3,6 Volt.

> für den WIFI-TX wurden keinerlei Vorkehrungen getroffen.

Das ist Ok, es ist ja die Signalleitung vom ESP-01 Modul zum AVR. Sie 
wird also 3,3V Pegel haben, was für den AVR in Ordnung ist.

> Booster J2 ... Darf ich davon ausgehen, dass damit gemeint ist,
> dass auch auch diesem Pin 12V anliegen sollen?

Scheint so, R1 und R3 passen dazu. Aber ich habe keine Ahnung, was da 
angeschlossen werden soll.

> LN_IN verwaist

Da musst du wohl den Autor des Schaltplans fragen. Wenn der nicht 
erreichbar ist oder nicht antwortet, würde ich das sowieso nicht 
nachbauen. Die vielen Bauteile und der Arbeitsaufwand wären mir dann zu 
schade.

> Der oben genannte ICS (TLE5205-2) hängt am +20V und hat selbst
> schon 5 A Belastbarkeit

Ja und, was interessiert das die Spannungsregler? Der Strom fließt ja 
nicht durch sie hindurch.

> Die verzeichnete Stromversorgung ist jedenfalls ratzfatz durchgebrannt!

Nein, richtig gekühlt sind die Spannungsregler kurzschlussfest. Aber 
mehr als im Datenblatt versprochen kommt da natürlich nicht raus.

> Der Temperatursensor an der Stelle ist sicher als "Sicherung" gedacht

Frage das den Autor der Software.

> Und den Sketch vom Arduino

Du hast erwähnt, dass es sich um eine alte Schatugn handelt. Bei Arduino 
kommt es öfters vor, dass alte Sketche mit neuer IDE nicht compilierbar 
sind. Kontrolliere das, bevor Du Geld aus dem Fenster wirfst.

> Natürlich hab ich den Entwickler schon versucht zu erreichen
> aber da meldet sich wohl niemand

Mein Rat: Lass es bleiben. Weder Schaltplan noch Software sind klar, und 
einige Bauteile bekommst du nicht mehr. Das Risiko, dass du auf für dich 
unlösbare Probleme stoßen wird schätze ich auf 90% ein.

von Na ja... (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Stefan U. schrieb:
> Mein Rat: Lass es bleiben. Weder Schaltplan noch Software sind klar, und
> einige Bauteile bekommst du nicht mehr. Das Risiko, dass du auf für dich
> unlösbare Probleme stoßen wird schätze ich auf 90% ein.

Da hat er nicht unrecht, der Stefan.

Es wäre wohl besser, sich an einem aktuell(er)en Projekt zu orientieren. 
Oder gar selbst (mit der Community) Gesamt- und Einzellösungen 
auszuarbeiten. Alles erfolgversprechender als obiges.

von Jochen K. (jochen3030)


Bewertung
0 lesenswert
nicht lesenswert
Guten Abend!

Zunächst einmal mein Dank für die Antworten, auch wenn Sie nicht 
unbedingt wie erhofft sind, möchte ich hiermit meinen Dank ausdrücken, 
dass man sich die Mühe gegeben hat!

Ich fange erst einmal rückwärts an, mit dem letzten Beitrag ;-).

Na ja... schrieb:
> Stefan U. schrieb:
>> Mein Rat: Lass es bleiben. Weder Schaltplan noch Software sind klar, und
>> einige Bauteile bekommst du nicht mehr. Das Risiko, dass du auf für dich
>> unlösbare Probleme stoßen wird schätze ich auf 90% ein.
>
> Da hat er nicht unrecht, der Stefan.
>
> Es wäre wohl besser, sich an einem aktuell(er)en Projekt zu orientieren.
> Oder gar selbst (mit der Community) Gesamt- und Einzellösungen
> auszuarbeiten. Alles erfolgversprechender als obiges.

Nun, ich habe sehr lange gesucht um überhaupt dieses Projekt zu finden. 
Es gibt also nichts aktuelleres, das ist schon aktuell! Der Entwickler 
macht da auch weiter, es gibt Software-Updates. Warum nun so lange keine 
Antwort kam, ich weiß es nicht... . Vermutlich hat Er einfach viel zu 
tun!

Das selbst komplett neu zu entwickeln ist von meinem Standpunkt her 
unmöglich. Und mithilfe der Community, das kann ich nicht einschätzen. 
Ich weiß nicht ob Ihr euch direkt freiwillig melden wollt? Wenn ich mir 
das ansehe, seh ich die Chancen für eine Community-Lösung aber als sehr 
gering an.

Der Eine meint, dass die Erfolgswahrscheinlichkeit nur 10 % ist, der 
andere, dass alles erfolgversprechender sei als das. "Alles andere" wäre 
es überhaupt nicht erst zu versuchen oder mit der Community hier. Aber 
nun, ich glaub nicht recht daran dass ich so viel Unterstützung bekommen 
werde, aber ich kenne hier ja auch niemanden! Für mich ist das weniger 
erfolgsversprechend... . Leider!

Ganz ehrlich: Dann nehm ich doch lieber die 10% als 0% und das Ganze von 
vorn herein aufzugeben. Ich hoffe weiterhin, dass mir hier jemand 
weiterhelfen kann, zumindest zum Teil (z.B. die Stromversorgung) sind es 
ja doch Fragen, die nichts mit dem Projekt direkt zu tun haben und bei 
jedem eigenen "Versuch" genauso auftreten werden!

Wie man ja herauslesen kann, bin ich (mindestens) seit dem Sommer da 
dran (mit Unterbrechungen, klar, aber nicht erst seit ein paar 
Tagen...). Wenn es etwas anderes gäbe, irgendeine Alternative oder ich 
mir anders zu helfen wüsste, wär ich nicht hier. Ich sehe keine andere 
Möglichkeit... .

Nun zu den anderen Beiträgen:

Stefan U. schrieb:
> Kannst du vergessen. Das ESP-01 Modul gibt es dort z.B. nicht, das
> bekommst du IMO nur aus China. Aber immerhin ohne Versandkosten, wenn du
> bei Aliexpress mit Kreditkarte bestellst.

Ok, dass ich z.B. das ESP-01 nicht von Reichelt.de bekommen kann war mir 
auch klar, ich meinte die benötigten Einzelteile, das kam wohl nicht 
ganz so gut heraus, bzw. nicht wie ich es meinte. Aber deswegen hatte 
ich dort ja auch den eBay-Link eingefügt, war wohl trotzdem nicht 
eindeutig... .

Stefan U. schrieb:
>> Mein Gedanke war, auf den IC3 (LD117AV33) ... zu verzichten
>
> Den Spannungsregler darfst du auf gar keinen Fall weg lassen. Das modul
> verträgt maximal 3,6 Volt.

Nun, so wie ich das verstanden hatte (im eBay-Artikel ist wiederum der 
heise.de Bereicht zum ESP und zum Logic-Level-Shifter verlinkt) wandelt 
dieser Logic-Level-Shifter eben auch die Versorgungsspannung! Auf die 
benötigten 3,3 Volt. Wie gesagt, so hab ich das verstanden!
Hier der Artikel separat: 
https://www.heise.de/developer/artikel/Arduino-goes-ESP8266-3240085.html

Stefan U. schrieb:
>> Booster J2 ... Darf ich davon ausgehen, dass damit gemeint ist,
>> dass auch auch diesem Pin 12V anliegen sollen?
>
> Scheint so, R1 und R3 passen dazu. Aber ich habe keine Ahnung, was da
> angeschlossen werden soll.

Gut! Dann passt das für mich. Danke!
(Dieser Booster J2 Anschluss ist genau dafür da, was auch dran steht: 
Für einen Booster am XNet (ausführlich: XpressNet) einem 
Kommunikationsprotokoll im Bereich der Modelleisenbahn ;-).
Man kann es so abkürzen: Es ist ein Datenanschluss nach einem bestimmten 
Protokoll. Wüsste auch nicht, wie ich es noch erklären könnte, sorry!)

Stefan U. schrieb:
>> LN_IN verwaist
>
> Da musst du wohl den Autor des Schaltplans fragen. Wenn der nicht
> erreichbar ist oder nicht antwortet, würde ich das sowieso nicht
> nachbauen. Die vielen Bauteile und der Arbeitsaufwand wären mir dann zu
> schade.

Nun, den Teil kann ich zur Not testen. Im Sinne von: "Nix anschließen 
und schauen was passiert". Und wenn es nicht geht, dann eben anklemmen, 
an den Port, den ich dafür im Verdacht habe (siehe oben). Soweit ich das 
sehe, kann da nicht zu viel schief gehen. Wäre eben schön gewesen, wenn 
ich es vorher schon wissen würde, ein Restrisiko ist ja immer!

Stefan U. schrieb:
>> Der oben genannte ICS (TLE5205-2) hängt am +20V und hat selbst
>> schon 5 A Belastbarkeit
>
> Ja und, was interessiert das die Spannungsregler? Der Strom fließt ja
> nicht durch sie hindurch.
>
>> Die verzeichnete Stromversorgung ist jedenfalls ratzfatz durchgebrannt!
>
> Nein, richtig gekühlt sind die Spannungsregler kurzschlussfest. Aber
> mehr als im Datenblatt versprochen kommt da natürlich nicht raus.

Nun, die Frage bleibt ja doch die Gleiche und bestehen: Ich brauche eine 
alternative Stromversorgung, habe dazu Ideen (siehe oben) und weiß nicht 
ob das so geht, was es an alternativen gäbe und ob es nicht besser geht!

Stefan U. schrieb:
>> Der Temperatursensor an der Stelle ist sicher als "Sicherung" gedacht
>
> Frage das den Autor der Software.

Nun, ich schrieb doch schon, dass ich da bisher keine Antwort bekommen 
habe, wurde ja auch darauf Bezug genommen... . So komm ich da jedenfalls 
nicht weiter. Ob meine "Lösung" funktioniert weiß ich leider so auch 
nicht... . Zur Not ist eben der Temperatursensor verbaut und misst die 
Raumtemperatur.

Stefan U. schrieb:
>> Und den Sketch vom Arduino
>
> Du hast erwähnt, dass es sich um eine alte Schatugn handelt. Bei Arduino
> kommt es öfters vor, dass alte Sketche mit neuer IDE nicht compilierbar
> sind. Kontrolliere das, bevor Du Geld aus dem Fenster wirfst.

Eigentlich hab ich nur alte Bauteile erwähnt, die es eben so nicht mehr 
gibt. Ist auch nachvollziehbar, der Entwickler hatte die vermutlich 
einfach noch in der Kiste... . Der Sketch, also die Software selbst, 
wird aktuell gehalten, sollte kein Problem darstellen! Dennoch danke 
dafür!!!

Stefan U. schrieb:
>> für den WIFI-TX wurden keinerlei Vorkehrungen getroffen.
>
> Das ist Ok, es ist ja die Signalleitung vom ESP-01 Modul zum AVR. Sie
> wird also 3,3V Pegel haben, was für den AVR in Ordnung ist.
>

Hierzu kann ich mich bedanken, hab wieder was gelernt!

Es ist zwar ein wenig schade, aber im Prinzip bin ich nur wenig schlauer 
als ich es vorher war. Die Antworten haben mir leider nicht wirklich 
weitergeholfen, die relevanten Fragen sind ja noch offen. Das es nicht 
einfach ist, ist mir auch klar. Deswegen bin ich ja hier! Eben weil ich 
weiß, das mein Wissen begrenzt ist (siehe oben).

Ich würde mich wirklich sehr über Antworten freuen, die mir 
weiterhelfen! Das die Chancen nicht "perfekt" sind, ok, wurde ja gesagt. 
Aber wie ich ja auch sagte, besser geringe Chancen als es überhaupt 
nicht zu versuchen! (Mut hat es leider auch keinen gemacht, aber so 
schnell lass ich nicht locker ;-).) Nach der Menge an Arbeit die ich 
schon im Hintergrund hier rein gesteckt habe, könnt Ihr sicher auch 
verstehen, dass ich jetzt nicht einfach so aufgeben möchte! Nicht so.. .

Soweit wünsche ich jedenfalls allen noch einen schönen Abend und bedanke 
mich nochmals für die Mühe, die sich bisher gegeben wurde!

Gruß Jochen

: Bearbeitet durch User
von Stefan ⛄ F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
> Warum nun so lange keine Antwort kam, ich weiß es nicht.
> Ich weiß nicht ob Ihr euch direkt freiwillig melden wollt?

Aber selbstverständlich antworte ich immer zügig bei Fragen meinen 
Projekten! Auch wenn es um Sachen geht, deren unterlagen ich selbst 
längst weg geworfen habe. Manche Fragen gehen zu weit, was den 
Zeitaufwand angeht, aber wenigstens das kann man ja zurück melden.

> Nun, so wie ich das verstanden hatte... wandelt
> dieser Logic-Level-Shifter eben auch die Versorgungsspannung!

Nein, defintiv nicht. Der ESP Chips benötigt sauber geregelte 3,3V mit 
400mA.

Tu Dir selbst einen Gefallen und baue die GESAMTE Stromversorgung exakt 
so wie im Plan. Nachbessern und Umbauen kannst du später immer noch. 
Wenn du schon am Anfang an 10 Stellen abweichst und es dann am Anfang 
nicht funktioniert, stehst du blöd da. Dann wird die Fehlersuche extrem 
schwierig. Die Erfolgs-Change sinkt dadurch meiner Meinung nach auf 5% 
ab.

Und dann wird das hier eine never ending Story, auf die nur wenige Leute 
Lust haben. Ich glaube Dir,d ass dieses Projekt für Dich sehr 
interessant ist und das Du auch das nötige Durchhaltevermögen hast. Nur 
brauchst du auch das Durchhaltevermögen einiger Helfer, und dessen bin 
ich mir keineswegs sicher.

von oszi40 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Stefan U. schrieb:
> brauchst du auch das Durchhaltevermögen einiger Helfer

Kurz gesagt, die Baustelle ist zu groß. für den 1.Schritt.

von Jochen K. (jochen3030)


Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen zusammen!

(Noch ist ja morgen, zumindest als ich mit der Nachricht angefangen hab 
;-).)

Und wieder mein Dank für die Nachricht, zumindest für eine. Ich fang 
wieder rückwärts an:

oszi40 schrieb:
> Stefan U. schrieb:
>> brauchst du auch das Durchhaltevermögen einiger Helfer
>
> Kurz gesagt, die Baustelle ist zu groß. für den 1.Schritt.

@ oszi40: Sorry, aber dazu hatte ich schon gesagt: Das hilft nicht!
Es mag Deine Meinung und Deine Einschätzung sein. Ok. Aber ich hab dazu 
auch schon ein wenig geschrieben ;-). Ganz so unbeholfen bin ich auch 
nicht... . Einfach mal durchlesen!

So, dann zum Beitrag von Stefan Us ;-).

Stefan U. schrieb:
>> Warum nun so lange keine Antwort kam, ich weiß es nicht.
>> Ich weiß nicht ob Ihr euch direkt freiwillig melden wollt?
>
> Aber selbstverständlich antworte ich immer zügig bei Fragen meinen
> Projekten! Auch wenn es um Sachen geht, deren unterlagen ich selbst
> längst weg geworfen habe. Manche Fragen gehen zu weit, was den
> Zeitaufwand angeht, aber wenigstens das kann man ja zurück melden.

So wirklich kapier ich den Sinn leider nicht (liegt vielleicht am 
Sonntagmorgen oder sonstewas...).

Ich kann jetzt auch nicht herauslesen, ob es sarkastisch/ironisch 
gemeint ist, oder sonstwie. Ich hatte ja in dem Zitat der "lange keine 
Antwort" (das ja sehr zusammengewürfelt ist) den Entwickler 
angesprochen, nicht Dich. Das ist eigentlich ganz klar!
Zumindest dem Namen nach scheinst Du nicht der Entwickler zu sein, Du 
sagst ja selbst, dass Du nicht weist, wozu die einzelnen Anschlüsse 
sind, wieso dann Dein Projekt? Wieso also solltest Du Unterlagen haben 
(die Du dann weggeworfen hast?!?). Der Entwickler selbst entwickelt 
daran offenbar noch weiter, der hat also die Unterlagen. Kapier die 
Aussage leider überhaupt nicht, außer, dass es irgendwie 
rückwärts/vorwärts sarkastisch/ironisch gemeint sein könnte... .
Das wäre dann aber wenig hilfreich, sorry!

Stefan U. schrieb:
>> Nun, so wie ich das verstanden hatte... wandelt
>> dieser Logic-Level-Shifter eben auch die Versorgungsspannung!
>
> Nein, defintiv nicht. Der ESP Chips benötigt sauber geregelte 3,3V mit
> 400mA.

Ok, danke! Dann bleibt der IC3 (LD117AV33) drin, bzw. ein anderer, denn 
den gibt es auch nicht mehr. Der LM 2937 ET3,3 
(https://www.reichelt.de/index.html?ARTICLE=39452) erscheint mir als 
passend! Passt er auch?

Stefan U. schrieb:
> Tu Dir selbst einen Gefallen und baue die GESAMTE Stromversorgung exakt
> so wie im Plan. Nachbessern und Umbauen kannst du später immer noch.
> Wenn du schon am Anfang an 10 Stellen abweichst und es dann am Anfang
> nicht funktioniert, stehst du blöd da. Dann wird die Fehlersuche extrem
> schwierig. Die Erfolgs-Change sinkt dadurch meiner Meinung nach auf 5%
> ab.
>
> Und dann wird das hier eine never ending Story, auf die nur wenige Leute
> Lust haben. Ich glaube Dir,d ass dieses Projekt für Dich sehr
> interessant ist und das Du auch das nötige Durchhaltevermögen hast. Nur
> brauchst du auch das Durchhaltevermögen einiger Helfer, und dessen bin
> ich mir keineswegs sicher.

Ok, das war grundsätzlich verständlich. Dennoch möchte ich ein "aber" 
ergänzen:
Das Thema wird ja sowieso kommen! Soviel ist sicher... . Gerade bei der 
Stromversorgung, also ein Multimeter hab ich (nicht so ein billiges 
"Schätzeisen" aus dem Baumarkt, sondern ordentliches Material und kann 
auch damit umgehen...) und Spannungen kann ich auch noch messen ;-) (so 
weit ist mein Gedächtnis noch in Ordnung). Wieso also die Aufregung um 
die Stromversorgung, wieso nicht gleich richtig und ordentlich?

Die Stromversorgung sehe ich als unkritischsten Punkt, ich kenne mich 
nur nicht gut genug mit den Teilen aus, als dass ich Erfahrungen hätte, 
welche gut oder gar ideal sind. Und nach dem was ich auf der originalen 
Homepage sehe (hat die überhaupt jemand angesehen?) verbaut da sowieso 
jeder seine eigene Lösung. Warum Du nun die Erfolgschancen (aus Deiner 
Sicht) deswegen weiter senken willst, nun, Deine Meinung, deine 
Einschätzung, ganz klar!
Aber direkt Unkenrufe von wegen "Neverending Story" und Co., wenn nicht 
einmal die relevanten Fragen geklärt sind? Es schlecht machen, bevor man 
damit angefangen hat? Sorry, aber wieso?!
Ich teile Deine Ansicht hier nicht, erst recht nicht wegen der 
Stromversorgung, gerade hier kann man problemlos messen. Selbst die 10% 
sehe ich als deutlich übertrieben, das ist meine Meinung ;-). Es wäre 
sehr schade, wenn Du mir nicht weiterhelfen möchtest, aber Einfluss kann 
ich nicht darauf nehmen.

So hoffe ich hier dennoch weiter auf Hinweise, was für Bauteile ich 
idealerweise verwenden kann, und/oder ob meine Ideen dazu gut sind 
und/oder ob jemand einen besseren Vorschlag hat!

Was als Problem definitiv bleibt: Problem Nr. 2!

Ich könnte die China-Teile verwenden um am Original zu beleiben. Oder 
die SMD-Version... . Oder ein anderes Bauteil, wie gesagt, mit 
Motortreibern kenn ich mich nicht aus! Das Original selbst ist 
jedenfalls so nicht zu bekommen (außer eben aus China im 5er Pack).


Somit folgender Status:

Problem Nr. 1: geklärt (falls der andere Spannungsregler geht)

Problem Nr. 2: noch offen!

Problem Nr. 3a: geklärt (offenbar ja, +12VDC dran!)
Problem Nr. 3b: offen, kann ggf. durch testen geklärt werden

Problem Nr. 4: noch offen!

Sonstiges: jein, teils/teils größtenteils noch nix...

Aber dennoch: Mein Dank soweit für die Antworten!

Ok, eigentlich haben mich nur die von Stefan ein wenig voran gebracht. 
Der Rest war mehr "wird ja eh nix"... . Sorry, aber das bringt mich mit 
den Problemen nicht voran und es motiviert auch nicht! Versteht mich 
nicht falsch, aber auf "das wird eh nix" und ähnliches möchte ich gern 
verzichten. Ich bin kein blauäugiger Anfänger.
(Ich stehe wieder ziemlich am Anfang, sagte ich ja, aber es liegt auch 
daran, dass ich in den letzten 10 Jahren nichts damit zu tun hatte... . 
Und ich bin ja hier, gerade WEIL ich Rat suche. Wenn ich lesen will, 
dass das eh nix wird, kleb ich mir nen Zettel an den Bildschirm, um es 
mal deutlich zu sagen! Interessant ist, dass Diese "Bemerkungen" 
hauptsächlich von "Gast-Usern" kommen, nicht von angemeldeten, aber 
egal.)

Ich suche Rat und Lösungen, wo ich nicht weiterkomme und hatte 
eigentlich die Hoffnung, hier Hilfe zu bekommen. Im Prinzip doch 
einfach, oder?

Es geht gar noch weiter, ich komme nicht mit einem "Hilfe, Hilfe, was 
mach ich bloß", sondern ich investiere Zeit und Mühe um selbstständig 
alternative Bauteile zu finden, anstatt zu warten, dass mir alles 
"mundgerecht" serviert wird. Ich hab nur zu wenig Ahnung, also schlage 
ich die Bauteile vor und frage ich nach. Doch selbst das wird wieder 
schlecht geredet und/oder es kommt gar nix. Wenn ich jetzt unhöflich 
oder unverschämt oder einfach nur kompletten und unmotivierten Blödsinn 
produzieren würde, würde ich es ja (mit ein wenig schlechter Laune) 
verstehen. Aber so kapier ich es nicht, ehrlich nicht!
Wenn mich jemand um Hilfe fragt, dann versuche ich zu helfen. Ob ich das 
Projekt jetzt besonders gut finde oder nicht ist erst mal egal. Ich 
helfe, weil ich um Hilfe gebeten werde. Aber das bin ja nur ich.

(Das musste jetzt auch mal gesagt werden, kam ja noch kein einziges 
positives Wort oder gar ein "Hallo, willkommen hier..." oder ein "Freue 
mich, dass du fragst, das meine ich...". Finde ich schon schade!)


So, ich hoffe aber weiterhin auf Lösungen/Antworten die mich weiter 
bringen und wünsche Euch allen (ja, ALLEN!) noch einen schönen Sonntag!

Gruß und Dank,

Euer Jochen

: Bearbeitet durch User
von Stefan ⛄ F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
>>> Ich weiß nicht ob Ihr euch direkt freiwillig melden wollt?
>> Aber selbstverständlich antworte ich immer zügig bei Fragen...
> So wirklich kapier ich den Sinn leider nicht

Dann nochmal kürzer: Ja

von Jochen K. (jochen3030)


Bewertung
0 lesenswert
nicht lesenswert
Stefan U. schrieb:
>>>> Ich weiß nicht ob Ihr euch direkt freiwillig melden wollt?
>>> Aber selbstverständlich antworte ich immer zügig bei Fragen...
>> So wirklich kapier ich den Sinn leider nicht
>
> Dann nochmal kürzer: Ja

Danke ;-).

von Stefan ⛄ F. (stefanus)


Bewertung
0 lesenswert
nicht lesenswert
> Der LM 2937 ET3,3 ... Passt er auch?

Ja

> Die Stromversorgung sehe ich als unkritischsten Punkt

Du kennst den ESP-8266 nicht. Außerdem ist Stromversorgung für µC + Funk 
+ Motoren alles aus einem Trafo alles andere als unkritisch.

Fasse Dich kürzer, ich habe keine Lust, so viel nichts sagenden Text zu 
lesen, um die eigentlichen Fragen dazwischen zu suchen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.