mikrocontroller.net

Forum: Platinen Altium Anfängerfragen


Autor: Andreas (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,
ich arbeite mich zur Zeit in Altium Designer ein. Konnte bisher etwas 
Erfahrung mit Eagle und PCB selbst fräsen sammeln. Jetzt wollte ich 
einen kleinen selbstschwingenden Step-Down Wandler in Altium Layouten 
und testweise bei elecrow bestellen.

Die erste Frage, die ich habe, lautet: Ich habe über den gesamten 
Top-Layer ein Polygon gezogen und diesen mit GND(NetC1_2) verbunden. 
Trotzdem bekomme ich die Fehlermeldung, dass ein Kondensatorpin keine 
Verbindung zu NetC1_2 hat. Woran kann das liegen?

Des Weiteren bekomme ich beim DRC den Fehler, dass die Beschriftung der 
meisten Beiteile zu nah an der Lötstopmaske ist. Mich wundert diese 
Fehlermeldung, da ich die Bauteile aus den Standardbibliotheken 
verwendet habe.

Für Tips bin ich dankbar.

Gruß
Andreas

Autor: Werner H. (pic16)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas schrieb:
> Ich habe über den gesamten
> Top-Layer ein Polygon gezogen und diesen mit GND(NetC1_2) verbunden.

Also was nun, GND oder NetC1_2?

> Beschriftung der
> meisten Beiteile zu nah an der Lötstopmaske ist

C2, R1 und P2 sind ausserhalb bzw auf dem Keep out, R2 ist auf dem 
Lötauge. Einfach auf günstigere Positionen verschieben.

> da ich die Bauteile aus den Standardbibliotheken
> verwendet habe.
Da ist Vorsicht geboten!

Autor: Wühlhase (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nimm NICHT die Standardbauteile. Die sehen nicht nur scheiße aus, 
sondern machen auch sonst wenig Freude.

Dann vergib deinen Netzen im Schaltplan mal ein paar aussagekräftige 
Netlabels. GND sollte dann auch GND heißen, alles andere ist Murks.

Warum machst du die Polygonverbindungen so schmal? An einigen Pads ist 
das OK, geht bei einigen Pads dürfen die ruhig breiter sein (eine 
weitere Polygon-Connect-Style-Regel erstellen und dann kannst du dich 
mal mit der Query beschäftigen. Wenn du deine Footprints selber machst 
anstatt diesen Standardschrott, sind z.B. Padklassen deine Freunde).

Zu deiner Frage: Ist bei den Lötaugen der Haken bei 'plated' drin? Und 
ist das Absicht, daß der Restring oben weg ist? (Falls beide Antworten 
nein lauten hast du grad gesehen warum die Standardbauteile scheiße 
sind. Du kannst ja mal schauen ob die auch alle noch lieferbar sind.)

Und ich hab auch noch ein paar Fragen: Warum ist das GND-Polygon auf der 
Top-Seite, warum ist die Bottom-Seite leer? Wenn das eine einlagige 
Platine werden soll, warum sind dann die THT-Bauteile auf der 
Kupferseite? Macht man normalerweise doch anders herum. Aus gutem Grund.

Autor: georg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas schrieb:
> Mich wundert diese
> Fehlermeldung, da ich die Bauteile aus den Standardbibliotheken
> verwendet habe.

Man muss praktisch immer die Beschriftung einer Leiterplatte am Ende 
zurechtschieben. Wo auf der Leiterplatte gerade Platz ist kann man beim 
Erstellen des Symbols ja nicht wissen. Genausowenig wie lang der Name 
ist.

Georg

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.