Forum: Analoge Elektronik und Schaltungstechnik SSR-Schaltung


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von andy32 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich bin noch Anfänger und hoffe ihr könnt mir helfen. Ich möchte mittels 
Mikrocontroller eine SSR steuern. Später möchte ich damit ein 
Heizelement steuern. Vorerst habe ich zu Testzwecken eine Glühlampe mit 
der SSR verbunden. Mein Problem ist, dass wenn im Schaltkreis ein Strom 
fließt und auch die LED der SSR leuchtet, dennoch die Lampe nicht 
leuchtet. Ohne SSR funktioniert sie allerdings. Wenn ich den Schaltkreis 
nun unterbreche, leuchtet die Lampe ganz kurz auf. Was mache ich falsch? 
Die SSR ist von Fotek (SSR-40 DA).
Ich hoffe ihr könnt mir helfen.
Danke im voraus!

: Verschoben durch Moderator
von Arduino Fanboy D. (ufuf)


Bewertung
0 lesenswert
nicht lesenswert
Ich weiß nicht was du falsch machst.
Sehe ja auch weder einen Schaltplan, noch ein Programm.


Kann dir aber sagen, dass diese SSR recht zuverlässig arbeiten.
Die Chance ist also groß, dass du einen Fehler machst.

Aber was?
KA!

von Gerald B. (gerald_b)


Bewertung
0 lesenswert
nicht lesenswert
Wie hoch ist der Eingangsstrom in den Eingang, wieviel Strom am Ausgang 
bei Last?
In den Eingang müssen schon mal minimal 7,5 mA.
Was für eine Glühlampe hast du am Ausgang? Noch eine richtige Glühbirne, 
oder eine LED Birne? Letztere hat wahrscheinlich eine zu geringe 
Stromaufnahme, so das der intern verbaute TRIAC seinen Haltestrom nicht 
erreicht. Nimm mal einen Halogenstrahler mit mindestens 150W, dann wird 
das SSR schon gehen.

von andy32 (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Zurzeit verwende ich gar kein Programm. Ich hab die SSR einfach an ein 
Netzteil angeschlossen. Ich weiß nicht genau wie ich den Schaltplan 
zeichnen muss. Ich hoffe du kannst mit der Skizze etwas anfangen.

von andy32 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Das Netzteil liefert bis zu 0,6A am Eingang. Es war tatsächlich eine 
Energiesparlampe. Ich habe als einfach das Heizelement mit dem SSR 
verbunden. Leider funktioniert die Schaltung immer noch nicht. Wenn ich 
statt SSR das Kabel direkt verbinde funktioniert das Heizelement.

von Dietrich L. (dietrichl)


Bewertung
0 lesenswert
nicht lesenswert
andy32 schrieb:
> Ich hoffe du kannst mit der Skizze etwas anfangen.

Da fehlen noch alle Werte der verwendeten Teile und die 
Anschlussbezeichnung des SSR.

von Ahnungs Looser (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
Was ist SSR?

Kann man SSR essen?

von andy32 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Im Schaltkreis ist es doch egal wie ich das Kabel anschließe oder? Es 
handelt sich ja um Wechselstrom. Im Steuerkreis kann auch kein Fehler 
sein, da die LED leuchtet. Das Netzteil liefert 3V und ich habe einen 60 
Ohm Widerstand verbaut. Könnte das SSR defekt sein?

von Michael H. (mueckerich)


Bewertung
1 lesenswert
nicht lesenswert
OMG

Du lieferst der Schaltung 3V, jetzt miss mal wie viel Spannung da nach 
dem Widerstand an dem SSR (Klemme 3 und 4) ankommmt. Danach lies die 
Spezifikationen des SSR und denk mal drüber nach.

von Dietrich L. (dietrichl)


Bewertung
0 lesenswert
nicht lesenswert
andy32 schrieb:
> Im Steuerkreis kann auch kein Fehler
> sein, da die LED leuchtet.

Das muss nicht unbedingt sein, da lt. Blockschaltbild die LED parallel 
zum Optokoppler liegt. Sie kann danach also schon etwas leuchten, obwohl 
es für den Optokoppler noch zu wenig ist.

> Das Netzteil liefert 3V und ich habe einen 60
> Ohm Widerstand verbaut.

Dann erhöhe mal die Spannung.

Das Datenblatt sagt 3...32V, eine Widerstand brauchst Du nicht. In 
deiner Schaltung hast Du mit den 60Ω noch einen Spannungsabfall, sodass 
am SSR-Eingang weniger als 3V anliegt.

> Könnte das SSR defekt sein?

Ausgeschlossen ist das natürlich nicht...

von Michael H. (mueckerich)


Bewertung
0 lesenswert
nicht lesenswert
Dietrich L. schrieb:
> Dann erhöhe mal die Spannung.
>
> Das Datenblatt sagt 3...32V, eine Widerstand brauchst Du nicht. In
> deiner Schaltung hast Du mit den 60Ω noch einen Spannungsabfall, sodass
> am SSR-Eingang weniger als 3V anliegt

Mann, lass ihn doch mal selbst nachdenken. ;)

@andy32: Ein Tipp, man betreibt Bauteile im allgemeinen nicht an der 
Kante. Da reicht ein kleiner negativer Einfluss und die Schaltung 
funktioniert nicht mehr. Besser ist es sich immer ein wenig von den 
spezifizierten Grenzen entfernt zu halten.

: Bearbeitet durch User
von Lothar M. (lkmiller) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
andy32 schrieb:
> Im Steuerkreis kann auch kein Fehler sein, da die LED leuchtet.
Vielleicht "leuchtet" sie nicht hell genug. Warum probierst du es nicht 
einfach mal mit einer höheren Spannung?

andy32 schrieb:
> Das Netzteil liefert 3V und ich habe einen 60 Ohm Widerstand verbaut.
Wo wir es vom Messen haben: welche Spannung kannst du am SSR 
Schalteingang messen? Denn dem SSR reichen eben nicht 3V vor 
irgendeinem Widerstand, sondern es will die 3V direkt an seinen Pins.

Dietrich L. schrieb:
> Da fehlen noch alle Werte der verwendeten Teile und die
> Anschlussbezeichnung des SSR.
Und die Bestellnummer!
Aber eigentlich ist auch so klar, wie das Ding verschaltet ist, oder 
nicht?


EDIT: hoppla, Dritter. Fenster zu lange offen gehabt... ;-)

: Bearbeitet durch Moderator
von Arduino Fanboy D. (ufuf)


Bewertung
0 lesenswert
nicht lesenswert
andy32 schrieb:
> Das Netzteil liefert 3V und ich habe einen 60
> Ohm Widerstand verbaut. Könnte das SSR defekt sein?

Gehe mal mit 5 bis 30 V DC da drauf.
Einen Widerstand brauchst du da nicht.

von Tany (Gast)


Bewertung
0 lesenswert
nicht lesenswert
andy32 schrieb:
> Wenn ich den Schaltkreis
> nun unterbreche, leuchtet die Lampe ganz kurz auf

Wenn du mit Energiesparlampe getestet hast, dann ist es normal.

von Dietrich L. (dietrichl)


Bewertung
0 lesenswert
nicht lesenswert
Michael H. schrieb:
> Mann, lass ihn doch mal selbst nachdenken. ;)

Du hast ja recht! Aber andy32 machte einen so hilflosen Eindruck, dass 
ich mein Mitleid nicht unterdrücken konnte...

von Einhart P. (einhart)


Bewertung
0 lesenswert
nicht lesenswert
Tany schrieb:
> Wenn du mit Energiesparlampe getestet hast, dann ist es normal.

Ich würde das auch ersteinmal mit einer Glühlampe testen.

von andy32 (Gast)


Bewertung
2 lesenswert
nicht lesenswert
Hey ihr,

vielen Dank für eure Antworten! Ich hätte nicht gedacht, dass es soo 
einfach ist! Habe die Spannung erhöht und schon funktioniert es. Darauf 
hätte ich eigentlich selbst kommen müssen. Naja, ich hoffe in Zukunft 
passiert mir sowas nicht mehr. Danke für die Hilfe!

von Gerald B. (gerald_b)


Bewertung
0 lesenswert
nicht lesenswert
Zwei ungewöhnliche Dinge sind passiert:
- es ist nicht eskaliert
- ein Anfänger der Rückmeldung gibt und sich bedankt
:-)

von dolf (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Gerald B. schrieb:
> Zwei ungewöhnliche Dinge sind passiert:
> - es ist nicht eskaliert
> - ein Anfänger der Rückmeldung gibt und sich bedankt
> :-)

es geschehen halt noch wunder!
mfg

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.