Forum: Mikrocontroller und Digitale Elektronik Bauteiletyp gesucht


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Jutec (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen
Steuerungsplatine einer Kaffemaschine (Melitta Caffeo Gourmet).
Schaltregler ist futsch. Was war das für ein Typ? Habe kein Schaltplan 
gefunden.
Print nennt sich:  EF675-Mainboard-PCB-005-A
Artikel: E146890

Gruss roland

von Rufus Τ. F. (rufus) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Der Rest der Beschriftung und die 7polige Bauform lassen auf einen 
Schaltregler des Herstellers Power Integration schließen, die 
Typenbezeichnung beginnt vermutlich mit -TNY- ...

Die Dinger sind dafür bekannt, gerne für das vorzeitige Ableben von 
Haushaltselektrik zu sorgen.

(was die Forensuche belegt, wenn man sie mit "TNY" füttert).


--

hab' mich wohl vertan, s.u.

: Bearbeitet durch Moderator
von Jens G. (jensig)


Bewertung
1 lesenswert
nicht lesenswert
Der "Deckel" des IC sollte sich doch noch in der Kaffemaschine finden 
lasse ...

von Rufus Τ. F. (rufus) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Ich muss mich korrigieren. Wieso komme ich auf TNY?

Tatsächlich meine ich LNK.

von Jim M. (turboj)


Bewertung
0 lesenswert
nicht lesenswert
Jens G. schrieb:
> Der "Deckel" des IC sollte sich doch noch in der Kaffemaschine finden
> lasse ...

Auf den kleinen Bröseln dürfte man kaum was erkennen können.

Ich hätte ehrlich gesagt lieber geschaut was hinter dem Trafo so los 
ist.

Wenn man da nur 5V braucht, käme die Elektronik aus einer USB Wandwarze 
als Spannungserzeuger in Frage. Dann bräuchte man sich nicht um einen 
neuen Chip bemühen.

von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Scheint ein Tinyswitch von Power Integrations zu sein. Leider gibts da 
einige.

von Schlaat Plaan Lääsa (Gast)


Bewertung
1 lesenswert
nicht lesenswert
hinz schrieb:
> Scheint ein Tinyswitch von Power Integrations zu sein.

Rufus Τ. F. schrieb:
> Ich muss mich korrigieren. Wieso komme ich auf TNY?
>
> Tatsächlich meine ich LNK.

Stimmen wir ab, wer ist für TNY, wer für LNK?

[ ]  TNY
[ ]  LNK

von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Rufus Τ. F. schrieb:
> Tatsächlich meine ich LNK.

Gibts denn einen in DIP ohne Pin 3?


Und Drain ist offensichtlich an PIN 4, das spricht doch sehr für TNY...

von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Schlaat Plaan Lääsa schrieb:
> Stimmen wir ab, wer ist für TNY, wer für LNK?

Man kann sogar einen Rest des Querbalkens des T erkennen.

von Kurt A. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Jim M. schrieb:
> Jens G. schrieb:
>> Der "Deckel" des IC sollte sich doch noch in der Kaffemaschine finden
>> lasse ...
>
> Auf den kleinen Bröseln dürfte man kaum was erkennen können.

Das ist mehr als die hälfte der Chipoberfläche. Vielfach bleibt der 
Deckel ganz an einem Stück. Diesen zu finden, könnte das Rätsel lösen.

Beitrag #5302853 wurde vom Autor gelöscht.
von Jutec (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke für die Antworten...
Vermute mal es handelt sich tatsächlich um einen Power Int. TNY Typ.
Der LNK scheint mir für den Schaltungsaufbau nicht passend.
Habe einen Optokoppler zur Rückmeldung.

Das Weggesprengte IC Gehäuse habe ich bis jetzt nicht gefunden.

Nehme mal den stärksten, weiss die Leistung nicht genau.
Dann noch ein paar neue Gleichrichterdioden, bis auf eine alle 
Kurzschluss...

Sonst müsste ich dann Melitta Service anfragen oder ein Bild des Prints 
finden.
Nur eines gefunden mit genau demselben Fehler mit weggesprengtem 
Gehäuse.

Gruss

von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Jutec schrieb:
> Nehme mal den stärksten,

Das ist nicht klug, dann kann der Trafo in Sättigung gehen bevor die 
Schutzschaltung greift.

von hinz (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Miss mal den Trafokern aus!

von Michael B. (laberkopp)


Bewertung
0 lesenswert
nicht lesenswert
Jutec schrieb:
> Nur eines gefunden mit genau demselben Fehler mit weggesprengtem
> Gehäuse.

Da die Trottel den primären Elko weggelassen haben, ist das kein Wunder, 
der siebt nicht nur, sondern fängt auch surge Spannungsspitzen ab.
Ich finde, das ist Pfusch ab Werk. Sollte wohl nur 2 Jahre halten.



ICExxxxx etc. passt nicht weil bei denen Pin 6 fehlt,
den Viperxx von ST fehlt gar kein Pin,
TEA1733 auch keiner,

von MG (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hier 
https://komtra.de/forum/index.php/Thread/11503-Melitta-Caffeo-CI-E-970-102-Beim-Einschalten-ist-sofort-die-Sicherung-gefallen/
ist ein ähnliches Board zu sehen. man kann entziffern:

(erste Zeile nicht erkennbar)
?NY280PN
84630A

von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Michael B. schrieb:
> Da die Trottel den primären Elko weggelassen haben,

Den hat der TE ausgelötet.

von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
MG schrieb:
> Hier
> https://komtra.de/forum/index.php/Thread/11503-Mel...
> ist ein ähnliches Board zu sehen. man kann entziffern:
>
> (erste Zeile nicht erkennbar)
> ?NY280PN
> 84630A

Also doch ein TNY280PN.

von der schreckliche Sven (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Jutec schrieb:
> Habe einen Optokoppler zur Rückmeldung.

Du hast den Unterschied zwischen LNK und TNY messerscharf analysiert.

von Jutec (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Den TNY280 habe ich mal bestellt.
Den Primärelko hatte ich schon ausgelötet zum Ausmessen, deswegen fehlt 
er auf dem Foto.
Das ist ein 33uF / 400V Elko

Ich werde auch eine Sicherung verwenden und nicht nur eine Kupferbahn, 
welche sich aufgelöst hat :-)

Keine Ahnung wie gut ich das analysiert habe mit dem TNY und LNK Typ, 
aber auch die Pin's sind anders und der LNK würde nicht passen, wenn ich 
mich nicht irre.

Sekundärseitig sieht eigentlich alles gut aus.

Den Trafo habe ich mittlerwelen auch ausgelötet und mit LCR Meter 
gemessen.
Tu mich aber schwer in der Beurteilung ob der noch gut ist.

von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Primärseite hat noch Durchgang? Dann ist der Trafo wohl in Ordnung.

Du solltest aber das Clampingnetzwerk prüfen, die beiden Dioden und der 
Widerstand direkt neben dem TNY280.

von der schreckliche Sven (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Jutec schrieb:
> Tu mich aber schwer in der Beurteilung ob der noch gut ist.

Was soll mit dem sein?
Das robusteste Teil, oder das stärkste Glied in der Kette.

von c-hater (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Jutec schrieb:

> Den Trafo habe ich mittlerwelen auch ausgelötet und mit LCR Meter
> gemessen.
> Tu mich aber schwer in der Beurteilung ob der noch gut ist.

Ich habe in meinem ganzen Leben noch nie einen defekten Schaltwandler 
gesehen, bei dem der Übertrager abgeraucht wäre. Ausnahme sind natürlich 
"Hochspannungs-Inverter". Kann mir aber nicht vorstellen, was eine 
Kaffeemaschine mit >1kV anfangen sollte...

Sprich: Ich würde aus der Erfahrung heraus davon ausgehen, dass der 
Trafo keinen Schaden erlitten hat. Du kannst das natürlich durch 
inkompetente Reparaturen durchaus noch ändern...

von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
c-hater schrieb:
> Ich habe in meinem ganzen Leben noch nie einen defekten Schaltwandler
> gesehen, bei dem der Übertrager abgeraucht wäre.

Ich schon einige.


> Ausnahme sind natürlich
> "Hochspannungs-Inverter".

Auch solche.

von Jens G. (jensig)


Bewertung
2 lesenswert
nicht lesenswert
@ der schreckliche Sven (Gast)

>Jutec schrieb:
>> Tu mich aber schwer in der Beurteilung ob der noch gut ist.

>Was soll mit dem sein?
>Das robusteste Teil, oder das stärkste Glied in der Kette.

Naja - irgends so ein Dunzel hat doch hier empfohlen:

> Miss mal den Trafokern aus!

Daß das nix bringt, und der TO sowieso nicht die erforderlichen 
Meßmittel dafür hat, noch überhaupt weis, was man an Meßwerten zu 
erwarten hat, sollte eigentlich dem "Ratschläger" klar sein .... war 
aber wohl ein Troll.

von hinz (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Jens G. schrieb:

>> Miss mal den Trafokern aus!
>
> Daß das nix bringt, und der TO sowieso nicht die erforderlichen
> Meßmittel dafür hat, noch überhaupt weis, was man an Meßwerten zu
> erwarten hat, sollte eigentlich dem "Ratschläger" klar sein .... war
> aber wohl ein Troll.

Du glaubst der TE hat keinen Zollstock?

von Roland J. (roland_j867)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Die Kaffemaschine läuft wieder.
Danke allen die mir mit konstruktiven Antworten geholfen haben.
Neuer primär Elko noch eingesetzt.
Das Logo von PI hat sich wohl verändert.

von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Roland J. schrieb:
> Das Logo von PI hat sich wohl verändert.

Ja.

von Holztransistor (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Bei meiner Kaffeemachine mit gleichem Mainboard ist die gleiche Ic 
frittiert worden. Welche Sicherung hast du statt der Kupferbahn 
installiert und sollte die blaue Komponente daneben durch sich leiten 
lassen?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.