Forum: Mikrocontroller und Digitale Elektronik Zwei IRF7401 sind überlastet trotz 2.2A Last, PWM und Freilaufdiode


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Kevin I. (kevin_i)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen,

Als stiller Mitleser habe ich nun ein Problem, welches ich nicht 
nachvollziehen kann. Ich habe eine Schaltung aufgebaut wie sie im Anhang 
zu sehen ist. Das Ziel ist, dass ich mit dem Attiny85 welcher in der 
Schaltung verbaut ist, eine Aquariumpumpe 
(https://www.comet-pumpen.de/fileadmin/pdf/pumpen_datenblaetter/12vtauchpumpen/Datenblatt_ELEGANT_1300.01.00.pdf) 
einen simulierten Herzschlag machen lassen kann. Das heißt ich pumpe 
Wasser und ändere die Drehzahl der Pumpe, so dass ich schöne 60 
Wasserschläge pro Minute habe. Eingesetzt wird das ganze für sowas: 
https://youtu.be/N25fMXFfrMw?t=2m16s.


Nun zu meinem Aufbau:
Die Aquariumpumpe zieht maximal 2.2A bei 12V. Ich speise meine Schaltung 
mit einem 12V Netzteil mit 3A von XP-Power oder mit 5A von Meanwell.
Ich habe zwei IRF7401 
(https://www.infineon.com/dgdl/irf7401.pdf?fileId=5546d462533600a4015355fa03d91b94) 
verbaut. Diese sollten ja jeder für sich 7A schalten können, trotzdem 
habe ich zur Sicherheit mal zwei verbaut. Die FETs sind für logic level 
von 5V ausgelegt, soweit ich das beurteilen kann. Ebenfalls verbaut habe 
ich eine zusätzliche Freilaufdiode 
(https://www.mouser.com/ds/2/315/DB3X317K0L_E-1141997.pdf), da ich 
dachte dass die FETs vielleicht deshalb warm werden...


Mein Problem:
Wenn ich die Pumpe einfach mit PWM 100% laufen lasse, also der uC legt 
dann 5V ans Gate von den FETs, dann werden die FETs nicht einmal warm. 
Wenn ich jetzt aber ein PWM anlege, beispielsweise 0,8 Sekunden 40% und 
0.2 Sekunden 90% dann werden die FET's extrem heiss. Habe mit dem Oszi 
auch überprüft ob aus dem uC wirklich 5V ans Gate gelegt werden. 
Natürlich war das so, auch ist die Kurvenform schön Rechteckig, also 
0->5V in uS Bereich. Der Attiny85 taktet das PWM mit 500Hz.

Was kann mein Problem sein, dass die FET's so extrem heiss werden. Wenn 
ich die Schaltung mehr als 1 Minute rennen lasse, dann brennen die FETs 
durch...

Danke für eure Tipps,
Gruss
Kevin

von Flo (Gast)


Bewertung
2 lesenswert
nicht lesenswert
Dein Freilaufpfad ist falsch.
Die Mosfets gehen bei PWM Betrieb in den Avalance mode und verheizen die 
Energie.

von Kevin I. (kevin_i)


Bewertung
0 lesenswert
nicht lesenswert
Danke für die Rückmeldung.

Flo schrieb:
> Dein Freilaufpfad ist falsch.

Auch ohne bestückte Freilaufdiode verheizen sich die FET's...

: Bearbeitet durch User
von Εrnst B. (ernst)


Bewertung
2 lesenswert
nicht lesenswert
R6 ist mit 330 Ohm gefühlt viel zu groß und falsch.

Der Widerstand soll nicht den Gate-Strom begrenzen, sondern Schwingungen 
dämpfen. Dazu: Pro Gate einen Widerstand, so klein wie möglich, so groß 
wie nötig dass das Radio nicht ausfällt.
Wichtig: Pro Gate einen Widerstand. Sonst schalten sich die FETs über 
ihre Miller-Kapazität gegenseitig ein, wenn sie nicht exakt gleich sind.

von ArnoR (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Kevin I. schrieb:
> Flo schrieb:
>> Dein Freilaufpfad ist falsch.
>
> Auch ohne bestückte Freilaufdiode verheizen sich die FET's...

Natürlich, die Freilaufdiode muss über die Last (den Anschlußblock 
oben).

von Kevin I. (kevin_i)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Ernst,
Danke für das Feedback werde meine Schaltung entsprechend anpassen und 
nochmals testen.

von Εrnst B. (ernst)


Bewertung
0 lesenswert
nicht lesenswert
Teste erstmal nur mit einem kleineren Wert für R6, dann musst du das 
Layout nicht ändern. So verschieden werden zwei FETs aus einer Charge 
schon nicht werden.

von Kevin I. (kevin_i)


Bewertung
0 lesenswert
nicht lesenswert
ArnoR schrieb:
> Kevin I. schrieb:
>> Flo schrieb:
>>> Dein Freilaufpfad ist falsch.
>>
>> Auch ohne bestückte Freilaufdiode verheizen sich die FET's...
>
> Natürlich, die Freilaufdiode muss über die Last (den Anschlußblock
> oben).

Ich sehe es... Umlöten und testen.

von Kevin I. (kevin_i)


Bewertung
1 lesenswert
nicht lesenswert
Εrnst B. schrieb:
> Teste erstmal nur mit einem kleineren Wert für R6, dann musst du das
> Layout nicht ändern. So verschieden werden zwei FETs aus einer Charge
> schon nicht werden.

Hab jetzt 100ohm für R6 eingesetzt und habe die Freilaufdiode umgesetzt.

UND:

ES LÄUFT!!! VIELEN VIELEN DANK! IHR SEID DER HAMMER!!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.