Forum: Analoge Elektronik und Schaltungstechnik 1W LED schalten


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Vooki V. (dennis_r485)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Tag,

ich möchte an meinem uC eine LED mit 1W schalten und habe mir dafür 
einen Mosfets herausgesucht. Ich habe aber keinerlei Erfahrung was 
Mosfets angeht und bin mir sehr unsicher ob die Schaltung so 
funktioniert und ob das Bauteil überhaupt passt
Die LED wird über eine KSQ mit 350mA betrieben.

Diesen Mosfet würde ich verwenden:
http://www.produktinfo.conrad.com/datenblaetter/1200000-1299999/001263451-da-01-en-MOSFET_N_CH_100V_8_FDD86102_TO_252_3_ONS.PDF

MfG
Dennis

: Verschoben durch Moderator
von Martin S. (sirnails)


Bewertung
1 lesenswert
nicht lesenswert
Schau Dir mal Logic Level Mosfet an. Deiner hier hat einen recht hohen 
RDSon bei 5V UGS. Unter 5V tut er gar nichts. Warum Du unbedingt nur 
10/11tel Deiner Spannung am Gate haben willst, verstehe ich auch nicht 
so recht.

von dgg (Gast)


Bewertung
2 lesenswert
nicht lesenswert
Die Frage ist auch, ob die Konstantstromquelle bei MOSFET-Ein
den Strom so schnell begrenzen kann, dass die LED nicht beschädigt wird.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
1 lesenswert
nicht lesenswert
R6 kannst du deutlich kleiner machen, z.B. 100 Ohm, da ein MOSFet keinen 
Strom benötigt. Im Gegenteil ist es hilfreich, wenn man so viel Spannung 
wie der MC liefert, auch ans Gate bringt. Der Spannungsteiler aus R6 und 
R8 ist also kontraproduktiv.

Das PDF öffnet sich hier als ein leeres Dokument.
Du benötigst einen 'Logiklevel' N-Kanal MOSFet, der bei etwa 2-3V am 
Gate schon voll durchschaltet. Bei MC, die nur 3,3V liefern, sogar einen 
LowLogikLevel MOSFet, der schon bei 1,5V - 2V voll durchschaltet.

: Bearbeitet durch User
von Εrnst B. (ernst)


Bewertung
0 lesenswert
nicht lesenswert
Vooki V. schrieb:
> Ich habe aber keinerlei Erfahrung was
> Mosfets angeht

Sollte eigentlich logisch sein, wird aber von Anfängern gerne immer 
wieder übersehen:

Der FET schaltet, wenn er eine Spannung zwischen Gate und Source sieht. 
Nicht zwischen "Gate und GND", denn wo du dein GND-Symbol im Schaltplan 
hingemalt hast, weiß er nicht.

Also, um Missverständnissen vorzubeugen, zeichne unter die 
GPIO-Verbindung noch eine GND-Verbindung zu Source, so wie du deinen 
RasPi/Arduino/µC da auch verkabeln musst.

von Martin S. (sirnails)


Bewertung
-2 lesenswert
nicht lesenswert
Matthias S. schrieb:
> Im Gegenteil ist es hilfreich, wenn man so viel Spannung
> wie der MC liefert, auch ans Gate bringt.

Oder noch besser ausgedrückt: Ein zu niedriger Gatestrom kann im 
schnellen Schaltbetrieb den Mosfet töten, weil er dann schnell außerhalb 
der SOA getrieben wird. Aber das dürfte hier egal sein, da das nur hohe 
Schaltfrequenzen betrifft.

von Vooki V. (dennis_r485)


Bewertung
0 lesenswert
nicht lesenswert
vielen dank schon mal


wenn ich das richtige verstehe muss ich auf die "Gate to Source 
Threshold Voltage" achten oder?

Im Datenblatt stehen:
VGS(th): Min 2V | Typ 3.1V | Max 4V
Das heißt bei 2V müsste der Mosfet schon durchschalten?

von Joachim B. (jar)


Bewertung
0 lesenswert
nicht lesenswert
Matthias S. schrieb:
> Der Spannungsteiler aus R6 und
> R8 ist also kontraproduktiv.

stört doch nicht wenn R8>>R6 ist

Matthias S. schrieb:
> R6 kannst du deutlich kleiner machen, z.B. 100 Ohm

und wenn R8 10k-100k hat störts nicht.

von Vooki V. (dennis_r485)


Bewertung
0 lesenswert
nicht lesenswert
meint ihr dieser wäre besser geeignet:

http://www.produktinfo.conrad.com/datenblaetter/1200000-1299999/001264136-da-01-en-MOSFET_N_CH_60V_FQD13N06LTM_TO_252_3_ONS.PDF


Wie sieht es denn aus mit der Leistung? Ich möchte ja 1W Schalten dieser 
hier kann Max. 2.5W das sollte ja kein Problem sein oder?

von M.A. S. (mse2)


Bewertung
0 lesenswert
nicht lesenswert
Vooki V. schrieb:
> Wie sieht es denn aus mit der Leistung? Ich möchte ja 1W Schalten dieser
> hier kann Max. 2.5W das sollte ja kein Problem sein oder?

Ähm... nein, ein Problem ist es nicht. Er ist aber wohl unnötig 
überdimensioniert.

Du schaltest keine Leistungen, Du schaltest Ströme. Dein Transistor 
setzt nicht die Leitsung in Wärme um, die Deine Last (bei Dir: LED) 
aufnimmt, sondern die Leistung U_ds * I_d. Das sollte, wenn Du alles 
richtig machst, relativ wenig sein.

Wenn Du den MOSFET als Schalter verwendest, dann sperrt er entweder. => 
I_d ist 0, also ist die Leistung, die der MOSFET aufnimmt ebenfalls 0.
Oder er leitet, dann ist die Spannung an ihm U_ds sehr dicht bei 0, also 
ist es die aufgenommene Leistung ebenfalls.

Lediglich beim Übergang zwischen diesen Zuständen wird nennenswert viel 
Leistung aufgenommen, dieser Übergang sollte jedoch relativ schnell und 
in Deiner Anwendung vermutlich auch relativ selten (also nicht mehrere 
tausend oder gar millionen mal pro Sekunde) passieren.

von Karl (Gast)


Bewertung
2 lesenswert
nicht lesenswert
Was ist das für eine KSQ?

Sollte das was Fertiges sein: Einige KSQ haben am Ausgang einen 
Kondensator. Wird da sekundärseitig ausgeschalten, lädt sich dieser auf 
die Maximalspannung auf, beim Einschalten entlädt er sich ungebremst in 
die LED und diese ist hinüber. Diese KSQ dürfen nur primärseitig 
geschaltet werden. Selbst ein Wackelkontakt sekundärseitig kann für die 
LED tödlich sein. Selbst erlebt.

von Markus E. (markus_e176)


Bewertung
0 lesenswert
nicht lesenswert
1)
Wenn das wirklich eine STROMquelle ist, musst du die LED mit dem Mosfet 
kurzschließen, um die Led abzuschalten.

In deiner Schaltung erhöht die Stromquelle so lang ihre 
Ausgangsspannung, bis der eingestellte Strom fließt (in der Theorie). In 
der Praxis eben so hoch, wie sie kann. Diese volle Spannung liegt dann 
beim Einschalten (Mosfet durchsteuern) voll an der Led an und grillt 
diese eventuell.

2)
Die 1W Leistung deiner Led hat nichts mit den 2,5W Leistung des Mosfet 
zu tun.
Die 2,5W sind das, was der Mosfet selbst an Verlustleistung verträgt. 
Diese Verlustleistung ist Strom^2 * On-Widerstand, also in deinem Fall 
350mA^2 * Rdson.
Das ist in deinem Fall deutlich weniger.

3)
Der verlinkte Mosfet ist nicht geeignet, du benötigst einen, der schon 
bei 5V Gate-Spannung komplett eingeschalten ist. Dieser ist erst bei 10V 
spezifiziert.

Suche nach der Angabe "Logic Level" in den Datenblättern.

von Bullenrassler (Gast)


Angehängte Dateien:

Bewertung
-3 lesenswert
nicht lesenswert
Hi,
versuch es mal hier mit. KSQ durch eine Spannungsquelle ersetzen; ist 
nicht super konstant, aber für eine 1W LED ausreichend.
 Grüße

von Vooki V. (dennis_r485)


Bewertung
0 lesenswert
nicht lesenswert
Ich glaube ich habe komplett falsch angefangen ....
Also nochmal von vorne

Ich habe testweise folgende Bauteile verwendet

Stromquelle:
https://www.led-genial.de/mediafiles//Sonstiges/datenblatt_ksq300_v2.0.pdf
Mosfet:
http://cdn-reichelt.de/documents/datenblatt/A100/AO3418_SPEC.pdf

Das ganze wird von einem Atmega328p mit 5V geschallten.
Ich hab dann einfach einen 1k "Vorwiderstand" zwischen uC Ausgang und 
Gate gehängt und den Positiven Ausgang der KSQ über den Mosfet 
geschallten.
Dieser Aufbau hat anfangs wunderbar funktioniert. Der Mosfet ist mir 
aber heute Nacht (LED war dauerhaft an) ab geraucht.
Ich dachte Anfangs das der Mosfet zu wenig Leistung ab kann und deswegen 
ab geraucht ist. Was offensichtlich ja falsch ist.

In zwischen weiß ich das ich einen recht kleinen "Vorwiderstand" 
zwischen uC Ausgang und Gate benötige. Außerdem muss ein recht großer 
Widerstand zwischen Gate und GND.
Auch sollte ich den GND der Eingangsspannung der KSQ schalten.

Wenn ich dies beachte sollte das dann Funktionieren? auch mit dem 
verlinkten Mosfet?

von Bullenrassler (Gast)


Angehängte Dateien:

Bewertung
-2 lesenswert
nicht lesenswert
Hi,
mal mal so.
Grüße

von Karl (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Vooki V. schrieb:
> Ich habe testweise folgende Bauteile verwendet
> Stromquelle:
> https://www.led-genial.de/mediafiles//Sonstiges/datenblatt_ksq300_v2.0.pdf

Wozu bitte glaubst Du hat diese KSQ EXTRA einen Dimmereingang? Weil der 
Hersteller noch zwei Lötpunkte übrig hatte?

Manmanman, wenn Du schon so schlau bist eine dimmbare KSQ zu kaufen, 
warum nutzt Du dann ihre Dimmfunktion nicht?

von Manfred (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Vooki V. schrieb:
> Ich glaube ich habe komplett falsch angefangen ....

Ja.

> Stromquelle:
> https://www.led-genial.de/mediafiles//Sonstiges/datenblatt_ksq300_v2.0.pdf

Scheißding, aus dem .pdf: "Der Minus-Eingang darf nicht mit dem 
Minus-Ausgang verbunden werden! Es besteht KEINE gemeinsame Masse 
zwischen diesen beiden Anschlüssen. Das Verbinden beider Anschlüsse 
zerstört die KSQ sofort!"

Du bekommst also Ärger mit den Bezugspunkten, µC und LED brauchen eine 
galvanische Trennung.

Nochmal aus dem pdf: "Dimm-Funktion

Der Ausgangsstrom kann zwischen 0 und 100% des Nennstroms der KSQ 
eingestellt werden. Dafür kann entweder ein PWM-Signal verwendet werden 
oder eine Gleichspannung zwischen 0V und 2,5V angelegt werden. Über 2,5V 
hält die KSQ den Strom auf 100% ihres Nennstroms konstant. Der Eingang 
ist gegen höhere Spannungen bis 12V geschützt. Unter ca. 0,3V schaltet 
die KSQ den Ausgangsstrom ab und über 0,5V wieder ein."

Vooki V. schrieb:
> Das ganze wird von einem Atmega328p mit 5V _geschallten_

Aber bitte nicht so laut!

Hänge Deine LED direkt an die Stromquelle und schalte den Dimmer-Eingang 
des Moduls mit einem Optokoppler. Der FET im Leistungszweig erübrigt 
sich.

von Vooki V. (dennis_r485)


Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank!
Daran hatte ich gar nicht gedacht ....
das macht das ganze viel einfacher


Für was benötige ich den Optokopler? Wenn ich die Spannungsteiler 
Schaltung mit den zwei 10k Widerständen benutze kann ich ja direkt die 
LED über den uC Ausgang schalten und hab dann am DIM
Eingang entweder 0V oder 2,5V Anliegen.

Das ich -Led mit der „normalen“ Masse nicht verbinden darf hatte ich 
gesehen :-) meine KSQ lebt noch.

von Karl (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Manfred schrieb:
> Scheißding, aus dem .pdf: "Der Minus-Eingang darf nicht mit dem
> Minus-Ausgang verbunden werden!

Das machen die meisten Schaltregler-KSQs so, weil erstens die Diode in 
Reihe zur Induktivität liegt und deren Stromfluss nutzt und zweitens 
low-side der Strom gemessen wird.

Das machen auch die "Scheissdinger" von LT oft so.

Und das ist auch normalerweise kein Problem, wieso sollte eine einzelne 
LED zwingend auf GND liegen?

von Bullenrassler (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
LED zum Dritten.
Diese KSQ ist kein "Scheißding"; Optokoppler ist überflüssig.
Grüße

von Harry (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Genau: nimm ne KSQ mit Enable-Eingang (z.B. PT4115).

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.