Forum: Analoge Elektronik und Schaltungstechnik Verständnisfrage Mosfet Gatestrom


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Noah A. (noan)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

mein Verständnis zur angehängten Schaltung bisher:

- Mosfet sind spannungsgesteuert
- Sie brauchen nur einen kleinen/kurzen Strom zum Umladen des Gates
- Danach wird nur noch der Strom zur Erhaltung benötigt, der sich aus 
der Gate-Source Leakage ergibt (Igss hier +/- 100nA)


Mein Problem mit der Realität:

- Eine Messung des Stromverbrauchs obiger Schaltung ergibt im Leerlauf 
2mA (STM32 MCU) was den Erwartungen entspricht.
- Sobald ich den Mosfet mit 3v3 durchschalte springt der Stromverbrauch 
dauerhaft auf ca. 42mA hoch. (Es ist keine Last angeschlossen)

Meine Frage:

- Wo ist mein Denkfehler?


Danke und Grüße
Noah


Link zum Datenblatt des Mosfet:
https://www.mouser.com/ds/2/115/DMN3042L-537782.pdf

: Verschoben durch Moderator
von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
MOSFET kaputt, Oxid isoliert nicht mehr.

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Noah A. schrieb:
> mein Verständnis zur angehängten Schaltung bisher:
Eis vorneweg: der IGBT in dieser Schaltung ist verpolt. Das wird so 
sicher nix, der Emitter muss hier positiver sein als der Kollektor.

EDIT: achso, das ist gar kein verpolter IGBT, sondern lediglich ein 
völlig falsches Schaltplansymbol...

: Bearbeitet durch Moderator
von Wolfgang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Noah A. schrieb:
> - Sobald ich den Mosfet mit 3v3 durchschalte springt der Stromverbrauch
> dauerhaft auf ca. 42mA hoch. (Es ist keine Last angeschlossen)

Hast du versuchsweise mal einen heilen MOSFET richtig angeschlossen?
Das von dir verwendete Schaltsymbol ist, um es vorsichtig auszudrücken, 
etwas "ungewöhnlich".

von Wolfgang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Lothar M. schrieb:
> der IGBT in dieser Schaltung ist verpolt.

Ein DMN3042L ist zum Glück nur ein ziemlich normaler MOSFET - meint 
jedenfalls der Hersteller ("N-CHANNEL ENHANCEMENT MODE MOSFET") ;-)

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Noah A. schrieb:
> - Sobald ich den Mosfet mit 3v3 durchschalte springt der Stromverbrauch
> dauerhaft auf ca. 42mA hoch. (Es ist keine Last angeschlossen)
Du hast den uC an die Source und GND an Drain angeschlossen.

Wolfgang schrieb:
> Ein DMN3042L ist zum Glück nur ein ziemlich normaler MOSFET - meint
> jedenfalls der Hersteller
Ja, schon blöd, wenn man jetzt noch jeden Schaltplan auf die Korrektheit 
der Schaltsymbole kontrollieren muss...

: Bearbeitet durch Moderator
von Noah A. (noan)


Bewertung
0 lesenswert
nicht lesenswert
Hm ja,

ich tausch das Symbol mal aus. Und tausche grad auch mal den Mosfet, mal 
gucken was ich dann messe.

von Jens G. (jensig)


Bewertung
0 lesenswert
nicht lesenswert
>- Eine Messung des Stromverbrauchs obiger Schaltung ergibt im Leerlauf
>2mA (STM32 MCU) was den Erwartungen entspricht.
>- Sobald ich den Mosfet mit 3v3 durchschalte springt der Stromverbrauch
>dauerhaft auf ca. 42mA hoch. (Es ist keine Last angeschlossen)

Was für ein Stromverbrauch? Wie und wo gemessen? Soll das die 
Stromaufnahme des STM32 sein?
Wenn Du schon den Gatestrom beobachten willst, dann solltest Du das 
direkt in  der Gateleitung (bzw. vor dem Spannungsteiler) messen, und 
nicht an irgendeinem Versorgungspin des treibenden Teils. Denn woher 
sollen wir den wissen, ob der Strom jetzt der STM32-Verbrauch ist, oder 
vielleicht doch richtung Gate geht.

von Wolfgang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Jens G. schrieb:
> Was für ein Stromverbrauch? Wie und wo gemessen? Soll das die
> Stromaufnahme des STM32 sein?

Bis auf die genannten 2mA wird das wohl der Ausgangsstrom des STM32 
sein. Um den Strom in die im Datenblatt angegebenen Grenzen zu verweisen 
(Absolute maximum ratings), könnte man zwischen uC-Ausgang und "Gate" 
(erstmal) einen Widerstand von 150Ω einfügen.

von Noah A. (noan)


Bewertung
0 lesenswert
nicht lesenswert
Wolfgang schrieb:
> Bis auf die genannten 2mA wird das wohl der Ausgangsstrom des STM32
> sein. Um den Strom in die im Datenblatt angegebenen Grenzen zu verweisen
> (Absolute maximum ratings), könnte man zwischen uC-Ausgang und "Gate"
> (erstmal) einen Widerstand von 150Ω einfügen.

Aber das bezieht sich nur auf den Strom der zum Umladen des Gates nötig 
ist, nicht auf den Erhaltungsstrom Igss.

von Wolfgang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Noah A. schrieb:
> Aber das bezieht sich nur auf den Strom der zum Umladen des Gates nötig
> ist, nicht auf den Erhaltungsstrom Igss.

Wie?
Beim STM32 darf IMHO ein maximaler Ausgangsstrom (Sink oder Source) von 
25mA fließen - und nicht mehr. Da ist es egal, was am Ausgang dran 
hängt.

von Noah A. (noan)


Bewertung
0 lesenswert
nicht lesenswert
Ja.

Aber zum einmaligen Laden des Gates reicht das locker. Die Frage war, 
warum bleibt der Strombedarf hoch.

von Wolfgang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Noah A. schrieb:
> Die Frage war, warum bleibt der Strombedarf hoch.

Weil der MOSFET defekt oder falsch eingebaut ist.

Trotzdem ist der Widerstand zur Schonung des STM32 kein Fehler.

von Noah A. (noan)


Bewertung
0 lesenswert
nicht lesenswert
So,

ich habe jetzt alles sorgfältig auf einem Breadboard aufgebaut: Alles 
funktioniert so wie es soll! Strommessung erfolgte direkt am Gate.

Ich dachte schon ich bin zu blöd ein Mosfet anzuschließen...

Ich vermute nun das das Board irgendwo einen Fehler hat.

Danke an alle!

von nachtmix (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Noah A. schrieb:
> Ich vermute nun das das Board irgendwo einen Fehler hat.

Evtl. hat das Layout einen  Fehler, wenn du dieses falsche Symbol eines 
IGBT anstelle des MOSFET verwendet hast.
Ich kenne überhaupt keine IGBT im SOT-23 Gehäuse.

von Alles Humbug (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Noah A. schrieb:
> ich habe jetzt alles sorgfältig auf einem Breadboard aufgebaut: Alles
> funktioniert so wie es soll! Strommessung erfolgte direkt am Gate.

Ein Bild davon hier einstellen ist wohl mal wieder zu viel verlangt 
oder?

von Noah A. (noan)


Bewertung
0 lesenswert
nicht lesenswert
Alles Humbug schrieb:

> Ein Bild davon hier einstellen ist wohl mal wieder zu viel verlangt
> oder?

Ist schon wieder alles abgebaut, sorry.

von Noah A. (noan)


Bewertung
0 lesenswert
nicht lesenswert
Fehler gefunden, ein Messpunkt war falsch verbunden.... my bad

Schönen Sonntag noch allen!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.