mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik LTSPICE: Time step too small


Autor: time_step_noob (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich möchte die angehängte Schaltung simulieren und bekomme den "time 
step too small error".
V3 ist sozusagen die treibende Quelle.
Hat jemand eine Idee woran es a. liegen könnte und b. wie man dem 
beikommen könnte?
Danke schon mal!

: Verschoben durch Moderator
Autor: time_step_noob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach ja: Die Fehlermeldung lautet auf "problem with node 'Vp' ".

Autor: sumo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
time_step_noob schrieb:
> Ach ja: Die Fehlermeldung lautet auf "problem with node 'Vp' ".
WARNING: Node N002 is floating.

WARNING: Less than two connections to node S.  This node is used by E1.
WARNING: Less than two connections to node F_OFF.  This node is used by B5.
WARNING: Less than two connections to node F_ON.  This node is used by B6.
Direct Newton iteration for .op point succeeded.
Singular matrix:  Check node vn
   Iteration No. 1
Fatal Error: Singular matrix:  check node vn
   Iteration No. 1

This circuit has floating nodes.

Autor: time_step_noob (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ja, hab das GND vergessen. B5, B6 kann man auch löschen, sind nur zur 
'Visualisierung von f_on, f_off.

Autor: time_step_noob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auch mit beseitigten floating nodes bekomme ich
"Fatal Error: Analysis:  Time step too small; time = 1e-007, timestep = 
1.25e-019: trouble with node "vp" "

Autor: Egon N. (egon2321)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
time_step_noob schrieb:
> Auch mit beseitigten floating nodes bekomme ich
> "Fatal Error: Analysis:  Time step too small; time = 1e-007, timestep =
> 1.25e-019: trouble with node "vp" "

Stell doch mal bitte ein Bild von deinem Schaltplan ein, ich hab jetzt 
gerade nicht die Motivation fremde LTspice Dateien zu öffnen.

Ansonsten: Definier bei Kondensatoren/Induktivitäten/etc. Initialwerte 
und setz die step size ggf. manuell (das hilft bei undefinierten 
Kondensatoren aber in der Regel auch nicht).

Autor: time_step_noob (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Initialwerte sind gesetzt, step size habe ich immer manuell.

Autor: Michel M. (elec-deniel)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
time_step_noob schrieb:
> Initialwerte sind gesetzt, step size habe ich immer manuell.

Vc  Wert etwas gr. 0 setzen.
V3 t rise 1f ->  timestep kl. als V3 rise einstellen ..

: Bearbeitet durch User
Autor: time_step_noob2 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vc auf 1u, rise time auf 2n (max time step auf 1n) funktioniert noch 
nicht.

Autor: Michel M. (elec-deniel)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
? Woher kommt diese Zusammenstellung ?
Wie weit darf Vc verändert werden ....
ab 0.01 scheint es zu laufen

Autor: time_step_noob2 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist ein Modell für ein experimentielles Halbleiterbauteil.

Naja, 10mV kommt schon in eine Größenordnung wo man's nicht mehr 
vernachlässigen kann.
Wieso ist Vc überhaupt relevant? Soll ja nur eine "Strommessquelle" 
sein.

Autor: Michel M. (elec-deniel)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mal Vc 0 lassen und Rser=1p setzen und testen

: Bearbeitet durch User
Autor: time_step_noob2 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ändert leider nichts.

Autor: Michel M. (elec-deniel)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michel M. schrieb:
> mal Vc 0 lassen und Rser=1p setzen und testen

und Werte der .tran-Anweisung den Anforderungen anpassen.
.tran 0 1n 0 1u funktioniert.

Autor: time_step_noob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
end time 1ns und max time step 1us?

Das entspricht ganz und gar nicht der Anwendung. Ich kann mir die 
Simulationszeit doch nicht aussuchen!?

Autor: time_step_noob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat also niemand mehr einen Vorschlag warum meine Simulation nicht 
funktioniert?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.