mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Woher kommt das Störgeräusch? Netzteil Korg 01/Wfd


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Matthias H. (homa)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe meinen alten Synthesizer Korg 01/Wfd reaktiviert. Nun macht er aber 
beim einschalten dieses Geräusch. Höre Dir bitte die Aufnahmedatei an. 
Es ist direkt zuhören, also nicht über den Ausgang. Dieser ist 
einwandfei.
Hat einer eine Idee welches Bauteil der Verursacher ist?

Grüße Matthias

Autor: Stefan P. (form)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Das Spektrum zeigt einen Peak bei 617 Hz - Daraufhin würde ich den 
großen gelben Netztrafo schonmal ausschließen.

Kannst Du erkennen was der kleinere Trafo auf der rechten Seite macht?
Macht der vielleicht "Hochspannung" für irgendwelche 
Hintergrundbeleuchtungen?

Autor: ● J-A V. (Firma: FULL PALATINSK) (desinfector) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich denke mal:
Da es noch weitere Platinen im Gerät gibt (mindestens die grüne),
könnte ein Bild davon auch nicht schaden.

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Stefan P. schrieb:
> Das Spektrum zeigt einen Peak bei 617 Hz - Daraufhin würde ich den
> großen gelben Netztrafo schonmal ausschließen.

So eine Frequenz könnte ein EL Generator fürs EL Backlight eines 
Displays sein.
Es kann aber auch eine Rückwirkung des anlaufenden Motors der Floppy 
Disk sein. Beides deutet daraufhin, das ein paar der alten Elkos nicht 
mehr die Kapazität haben, mit der sie mal verbaut wurden.

Autor: Matthias H. (homa)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Danke für die Hinweise. Jetzt fällt mir ein, das Ding hat im Display mal 
geleuchtet. Und ich hab mich schon gewundert, warum ich das nicht so 
schlecht in Erinnerung hatte. Das lesen im Display ist momentan echt 
schlecht :-)
Ich werde heute Abend mal weitere Bilder machen und sehen wie ich an das 
Display komme ...
Jetzt schonmal die Frage: Weiß einer wie ich das am besten repariere?

Matthias S. schrieb:
> Es kann aber auch eine Rückwirkung des anlaufenden Motors der Floppy
> Disk sein.

Ich habe mir die neue ROM ver 62 und ein USB Stick Floppy Emulator 
eingebaut. Das alte Floppy war nach über 25 Jahren defekt. Jetzt kann 
ich auch STM Midi Files einlesen bzw. speichern!

Es überfiel mich die Nostalgie das Gerät für meinen mittlerweile Klavie 
spielenden Sohn zu reaktivieren.

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias H. schrieb:
> Jetzt fällt mir ein, das Ding hat im Display mal
> geleuchtet.

Das kann man auch im Internet sehen - eigentlich ist das Display 
beleuchtet. Es ist bloss nicht so einfach herauszufinden, ob es EL Folie 
oder LED ist. Scheint dann aber wirklich EL zu sein, denn 400-600Hz ist 
die typische Frequenz für die Wandler.
Vorsicht, das sind hunderte von Volts, mit denen die Folie angetrieben 
wird.

Stefan, Top Aktion übrigens mit dem Spektrum! +1

: Bearbeitet durch User
Autor: Michael W. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das 'Fiepen' kommt mit hoher Wahrscheinlichkeit vom Spannungswandler für 
die (offenbar nun ausgefallene) Display-Beleuchtung (EL-Folie). Ist bei 
den alten Synths ein oft anzutreffender Fehler - nebst des 
(Teil-)Ausfalls des Displays selbst. Dauerhafte Abhilfe schafft der 
Einbau eines neuen Grafik-Displays (240x64 Dots) mit 
LED-Hintergrundbeleuchtung. Auf Größe und HD44780-Kompatibilität achten, 
ebenso auf 5V Versorgungsspannung!
Erhältlich z.B. bei:

https://www.buydisplay.com/default/graphic-display

Dieses hier habe ich in meinem Yamaha SY99 anstelle des defekten 
Original-Displays (Optrex DMF 5005) eingebaut:

https://www.buydisplay.com/default/5-2-inch-arduino-display-240x64-t6963-lcd-controller-module-white-on-blue

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael W. schrieb:
> Grafik-Displays (240x64 Dots) mit
> LED-Hintergrundbeleuchtung. Auf Größe und HD44780-Kompatibilität achten,

HD44780 ist für alphanumerische Displays.

Autor: Michael W. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Autsch! - da hat mein Fehlerteufel zugeschlagen - es muß heißen: 
Kontroller T6963C oder kompatibel. Mea culpa...

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Laut Servicemanual ist dieses Display verbaut:

http://www.beyondinfinite.com/lcd/Library/Optrex/DMF5005.pdf


Also 240x64 mit T6963C und EL-Backlight.

Autor: Michael W. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Genau wie in meinem SY99 - war defekt (Display def. & EL-Folie 
'ausgebrannt'), und darum Ersatz mit LED-Beleuchtung. Den Inverter habe 
ich (beim SY99 problemlos möglich) durch 'Klauen' seiner Stromversorgung 
totgelegt, diese befeuert nun meine (einstellbare) Stromversorgung für 
die LED-Beleuchtung :-)

Autor: Matthias H. (homa)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja es muss das Backlight sein.

Ich habe das hier gefunden:
https://hajo.kessener.net/electronics/freshmans-01w-refurb/#freshman_01w-53

Kann ich einfach den Stecker hinter dem kleinen Trafo abziehen und das 
Gerät betreiben? Oder laufe ich Gefahr dabei etwas zu zerstören? Das 
Geräusch müsste dann ja verschwinden, wenn die alte Folie der 
Verursacher ist.
Ich würde ersteinmal das Keyboard ohne BL betreiben wollen. Man kann das 
Display ja ablesen (zwar erschwert aber immerhin). Nur dieser Dauerton 
nervt!

Neue Folie hätte ich hier gefunden:
http://www.midi-rakete.de/ger/preise.htm

Oder gibt es da bessere Quellen, bzw. kann man die Folie selber 
schneiden? Kenne mich damit garnicht aus.

Stefan P. schrieb:
> Das Spektrum zeigt einen Peak bei 617 Hz - Daraufhin würde ich den
> großen gelben Netztrafo schonmal ausschließen.
Dafür auch +1 von mir.

Aber: Danke an alle hier!

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias H. schrieb:
> Kann ich einfach den Stecker hinter dem kleinen Trafo abziehen und das
> Gerät betreiben? Oder laufe ich Gefahr dabei etwas zu zerstören? Das
> Geräusch müsste dann ja verschwinden, wenn die alte Folie der
> Verursacher ist.

Das hoffst du, es kann aber auch sein, das der Generator weiter quäkt. 
Wenn du ihn nicht reparieren willst, dann solltest du ihn komplett 
lahmlegen - also z.B. den Trafo oder den Treiber des Trafos ausbauen.
Es muss übrigens nicht die Folie selber, sondern es kann genauso gut der 
Generator defekt sein bzw. seine Versorgung.

: Bearbeitet durch User
Autor: Michael W. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias S. schrieb:
> Es muss übrigens nicht die Folie selber, sondern es kann genauso gut der
> Generator defekt sein bzw. seine Versorgung.

Genau - dann hast Du zwar eine neue Folie, brauchst aber anschließend 
noch einen  passenden Inverter. Gibt es zwar alles:

https://www.backlight4you.com/Leuchtfolien/Ersatzleuchtfolien/Leuchtfolie-azur-blau-43mm-x-155mm-laminiert::924.html

https://www.backlight4you.com/Leuchtfolien/EL-Inverter/elektronisch/3-Volt-Inverter-fuer-EL-Folien-bis-60cm2-Flaeche::915.html

..., jedoch würde ich eine Lösung mit LED-Hintergrundbeleuchtung immer 
vorziehen, da ich schon selbst einen derartigen Umbau hinter mich 
gebracht habe:

https://yamahamusicians.com/forum/viewtopic.php?f=55&t=5973#p29642

Gern auch den ganzen Faden lesen...

Autor: Matthias H. (homa)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So, ich nochmal. Konnte leider nicht früher Rückmeldung geben.

Habe den Stecker einfach abgezogen. Klappt einwandfrei. Das Störgeräusch 
ist einfach weg.
Sieht dann wie in den Bildern aus.

Jetzt habe ich schon eine Menge an dem Korg gemacht.
1. Neue Batterie und alle default Einstellungen wiederhergestellt
2. Neue FW ROMs eingebaut - ver62, kann jetzt auch Standard Midi Files 
schreiben und lesen. Sehr cool!
3. Das defekte Floppy durch einen Floppy-Emulator ersetzt. Kann jetzt 
auf USB-Stick schreiben und lesen! Die Midi Files sind direkt am PC in 
Ordnern zu lesen und auch zu schreiben.
4. Störgeräusch beseitigt.

ToDo: Hintergrundbeleuchtung wiederherstellen.

Hier noch ein paar Fragen. Ich würde gerne das original LCD erhalten und 
nur die EL-Folie tauschen. Habe aber bisher noch nicht den Synthesizer 
weiter zerlegt und ein Bild von dem Displaybereich.
Habe aber das Serviceheft gefunden:

http://www.deepsonic.ch/deep/docs_manuals/korg_01wfd_01w_service_manuals.pdf

Seite 14
Auf dem P.C.Board KLM-1530 der Stecker CN16A --> LCD EL
Kabel Seite 16 NHS-1589

Ist das Kabel, da mit offenen Enden gezeichnet, direkt an der EL-Folie?
Oben habt ihr immer von dem Inverter geschrieben. Wie viel Volt kommt 
aus diesem Stecker CN16A. Leider schweigt sich das Manual aus.

Ich könnte auf jeden Fall sonst 5V von dem Floppy Stecker darunter 
abgreifen und einen eigenen Inverter versorgen (wie auf 
www.backlight4you.com) falls das Störgeräusch mit einer neuen EL-Folie 
wiederkommt.
Ich finde die Folien im Verhältniss ganz schön teuer ...
Aber so ist auch doof, habe das jetzt ein paar Tage genutzt.

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias H. schrieb:
> Ist das Kabel, da mit offenen Enden gezeichnet, direkt an der EL-Folie?

Ja.


> Oben habt ihr immer von dem Inverter geschrieben. Wie viel Volt kommt
> aus diesem Stecker CN16A. Leider schweigt sich das Manual aus.

Typisch 100V/400Hz.


> Ich finde die Folien im Verhältniss ganz schön teuer ...

Ebay-Artikel Nr. 311819406726

Wenns denn unbedingt sein muss kannst du ja die EL-Folie 
transplantieren.

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

der EL-Inverter ist ja auf dem Netzteil mit drauf. Hast Du mal die 
Spannung gemessen an den Stiften des Steckers? Übliches Multimeter 
reicht erstmal, sollen eben um die 100V sein, allerdings ist die 
Schaltung etwas tricky, kann sein, daß die ohne EL-Folie völlig daneben 
schwingt.
Da ist ein 10µF Elko drin, C11. Den würde ich mal auf Veracht tauschen, 
nicht daß der keine Kapazität mehr hat. Auf die Spannung des alten Elkos 
achten!
Der ist ja gut erreichbar neben dem El-Trafo und soviele Schrauben hat 
die Netzteilplatine ja nicht. ;)

Gruß aus Berlin
Michael

: Bearbeitet durch User
Autor: Michael W. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe auch schon bei meinem Roland D-550 die EL-Folie (von 
backlight4you) getauscht. Anschlüsse von der Platine losgelötet - geht 
mit Unterstützung eines kleinen Uhrmacher-Schraubendrehers prima - dann 
die Folie VORSICHTIG entfernt (rausgezogen), wobei ich nicht mehr weiss, 
ob sie irgendwie 'verklebt' war - neue Folie wieder eingeschoben und 
verlötet - fertsch! Erster! :-)

Wenn sich die Folie nicht so ohne weiteres rausziehen lässt, kann man 
mit einem geeigneten Werkzeug (z.B. dünnes Stahllineal, abgerundete 
Seite!) VORSICHTIG versuchen, sie zu lösen. Oder - man lässt sie drin, 
knipst die Anschlußdrähte ab, schiebt die neue Folie ZWISCHEN die alte 
Folie und das Display, lötet deren Anschlüsse an und fertsch! Aber bitte 
VOR dem Wiedereinbau auf fehlerfreie Funktion testen - so eine Operation 
will man nicht jeden Tag durchführen... ;-)

Autor: Michael W. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hier noch mal 2 Uh-Tube-Videos, in denen ein Austausch gezeigt wird.

Youtube-Video "Korg Wavestation A/D - Replacing Backlight by Davide Solurghi (Morpheus2027)"

Youtube-Video "Fixing Korg Wavestation A/D  display"

Im 2. Video wird allerdings das eigentliche Display (nach dem Entfernen 
des schwarzen Metallrahmens!) abgenommen, um die mittig etwas verklebte 
Folie zu entfernen - KANN man machen, sollte man aber, wenn's irgend 
geht, vermeiden. Denn der Spaß beginnt (unter Umständen) nach dem ersten 
Test, wenn die Anzeige dann nicht korrekt arbeitet. Das genaue 
Ausrichten könnte etwas nervig werden... :-(

Daher lieber versuchen (wenn verklebt), die Folie zu lösen.

Autor: Matthias H. (homa)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag 2

So habe mal testweise EL Folie in rot von Conrad für 2,70€ zum testen 
gekauft. Mit mal eben tauschen war nicht. Man muss alles zerlegen um an 
das Display zu kommen. Aus der halben Stunde wurden dann 3h. Da sind zig 
Schrauben drin. Zum Glück habe ich es zerlegt, denn da war auch noch ein 
defekter Kondensator. Wollte eigentlich beide tauschen, hatte aber nur 
den einen passenden da. C2 hat aber laut Messgerät noch die Kapazität.
C1 16V 10µF und C2 35V 4,7µF
Das Display ist für den Preis nun besser als vorher zu lesen.
Folie war geklebt. Konnte die neue Folie aber ohne Probleme dazwischen 
schieben.
Leider pfeift der Inverter immer noch, wenn auch jetzt sehr leise. Beim 
spielen stört es nicht mehr (so wie vorher). Aber fürs Zimmer immer noch 
nervend. Wenn ich mir passende neue Folie hole, dann brauch ich auch 
noch einen neuen Inverter.
Bilder anbei.

: Bearbeitet durch User
Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem bei EL Folie ist, das die wie ein grosser Plattenkondensator 
wirkt und die Inverter alle im Hörbereich arbeiten. Selbst wenn man also 
einen Inverter bekommt, der in sich lautlos arbeitet (der Trafo pfeift 
auch ab und zu) macht die Folie selber ein Piepsen.
Das war schon bei den Palm Organizern so und es gibt nur die 
Möglichkeit, die alte EL komplett durch was anderes zu ersetzen, wenn 
man es ganz lautlos haben will. Nun ist die Folie aber so dünn, das man 
meistens nicht mal einen Lichtleitblock mit LED unter das LCD bekommt - 
dumm gelaufen.

Autor: Michael W. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Genau dieses Optrex-Display hatte ich auch in meinem Yamaha SY99 - die 
rechte Bildhälfte wurde schließlich nicht mehr angezeigt - rausgeflogen. 
Und dabei stellte ich fest, daß (neben der Leuchtfolie) eben diese 
beiden C's bei mir auch defekt sind. Ich werde sie mal bei Gelegenheit 
auswechseln, dann sollte es wieder zur Gänze funktionieren. Aber seit 
dem Umbau auf ein Display mit LED-Beleuchtung absolute Ruhe - kein 
'wimmernder' Inverter, keine pfeifende Leuchtfolie.

Autor: Patrick (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hinweise:

Wenn Ihr die Folie ausbauen wollt, ohne den schwarzen Rahmen abzunehmen:

Verwendet nie einen spitzen Gegenstand und auch nie einen metallischen 
Gegenstand. Verwendet immer einen Gegenstand aus Kunststoff. Unter der 
Folie, wo sie geklebt ist, befinden sich kleine Leitungen auf der 
Platine. Diese gehen bei der Verwendung von spitzen oder metallischen 
Gegenständen kaputt. Dann ist das Display ein Fall für den Müll.

Auch der Tipp mit einer neuen Folie über die alte Folie schieben und 
dann die neue anlöten, funktioniert nicht. Es passen keine zwei Folien 
in das Display. Sollte man es dennoch schaffen, so wird das Display 
gewölbt und funktioniert nur noch teilweise.

Wer einen Synth mit diesem Piepgeräusch hat, wird um den Austausch des 
kompletten Displays nicht herumkommen. Ich habe bestimmt schon bei 30 
Displays die Folie getauscht, das Piepgeräusch bleibt (bis auf 
vielleicht mal eine Asnahme). Entweder tauscht man den Trafo (sofern man 
einen bekommt) oder baut ein Display mit LED Beleuchtung ein. Hier aber 
die Spezifikation des Displays beachten, ob man noch einen Vorwiderstand 
braucht. Auf der Netzteilplatine baut man denn den Trafo aus und lötet 
eine Drahtbrücke (oder auch Vorwiderstand) von 5V zur Stiftleiste ein, 
an die die Spannungsversorgung des Displays angesteckt wird.

Es gibt zwar elektronische Stromversorgungen mit IC an Stelle des 
Trafos, doch diese liefern nicht die Helligkeit, die ein Trafo liefert 
(nachzulesen bei Backlight4U). Diesen Baustein hatte ich selber hier. 
Das Display hat damit etwa eine Helligkeit, die zwischen ganz hell und 
dunkel liegt. Man kommt auf ca. 2/3 der Gesamthelligkeit.

Falls Fragen sind, so bin ich jederzeit dafür offen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.