mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Symmetrischer Filter, FilterPro, THS4531


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Ivo B. (ivvooooo)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe den Filter, welcher im Anhang zu sehen ist, nachgebaut.

Es soll ein symmetrisches Audiosignal mit einem Tiefpass zweiter Ordnung 
(800HZ) gefiltert werden.

Ich verwendete das Programm FilterPro von TI, um den Filter zu designen 
und den Differentialverstärker THS4531. Im Anhang befindet sich auch das 
Pinout des Verstärkers. Hier Habe ich PD auf Vs gelegt, wie im 
Datenblatt beschrieben.

Das Ausgangssignal meines selbst gebauten Filters ist verzerrt und wird 
durch ein Piepsen und Knacken untermauert. Vielleicht habt ihr eine Idee 
woran das liegen könnte. Habe ich womöglich grundlegende Regeln 
vernachlässigt?

Für jede Hilfe wäre ich sehr dankbar.

Ivo

Autor: Dergute W. (derguteweka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin,

Mach' doch noch ein Bild von deinem Aufbau.
Wie sieht deine Spannungsversorgung aus?
Gibt's irgendwelche Gleichstrompfade aus dem Eingang raus?
Was haengt am Ausgang?

Gruss
WK

Autor: Ivo B. (ivvooooo)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Die Spannungsversorgung ist eine 3,7V LiIo Zelle.

Das Audiosignal kommt von einem Bluetooth Modul CSR8645, dessen Masse 
die selbe wie die der Stromversorgung des Filters ist (Vs-).

Am Ausgang habe ich bis jetzt nur einen Kopfhörer zum abhören 
angeschlossen, da das auch zum Abhören des direkten Signals vom 
Bluetooth Modul funktioniert hat.

Was genau meinst du denn mit Gleichstrompfaden?

Gruß Ivo

Autor: Dergute W. (derguteweka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin,

Ivo B. schrieb:
> Das Audiosignal kommt von einem Bluetooth Modul CSR8645, dessen Masse
> die selbe wie die der Stromversorgung des Filters ist (Vs-).

Hm - naja, da musste halt genau gucken, wie das Signal in deinem 
Bluetoothdingens erzeugt wird. Ist da ein definerter 
Gleichspannungsoffset an beiden Ausgaengen oder sind da Koppel-Cs 
eingebaut?
>
> Am Ausgang habe ich bis jetzt nur einen Kopfhörer zum abhören
> angeschlossen, da das auch zum Abhören des direkten Signals vom
> Bluetooth Modul funktioniert hat.

Ich weiss nicht, ob dein Verstaerker so ohne weiteres auf einen 
(Stereo)Kopfhoerer arbeiten kann. Wie ist der denn dann angeschlossen
>
> Was genau meinst du denn mit Gleichstrompfaden?

Wenn du den OpAmp aus einer einfachen Spannungsquelle betreibst, sollten 
die Eingaenge auf der halben Betriebsspanung liegen.

Ein paar Abblock-Cs in der Betriebsspannung nahe am Chip sind auch nicht 
verkehrt. Sollen das die 2 gelben (Tantal-El)kos auf dem Bild sein oder 
gehoeren die zum Filter selber?


Gruss
WK

Autor: Ivo B. (ivvooooo)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Dergute W. schrieb:
> Hm - naja, da musste halt genau gucken, wie das Signal in deinem
> Bluetoothdingens erzeugt wird. Ist da ein definerter
> Gleichspannungsoffset an beiden Ausgaengen oder sind da Koppel-Cs
> eingebaut?

Also ich konnte nur das Pinout im Anhang für das Modul finden und keinen 
Schaltplan vom Modul. Leider weiß ich auch nicht, was Koppel 
Kondensatoren sind.

Dergute W. schrieb:
> Ich weiss nicht, ob dein Verstaerker so ohne weiteres auf einen
> (Stereo)Kopfhoerer arbeiten kann. Wie ist der denn dann angeschlossen

Den Kopfhörer habe ich wie auf dem Bild im Anhang angeschlossen.

Dergute W. schrieb:
> Wenn du den OpAmp aus einer einfachen Spannungsquelle betreibst, sollten
> die Eingaenge auf der halben Betriebsspanung liegen.

Das heißt ich muss Vin+ und Vin- Ops des beide auf ca. 1.85V legen?

Dergute W. schrieb:
> Ein paar Abblock-Cs in der Betriebsspannung nahe am Chip sind auch nicht
> verkehrt. Sollen das die 2 gelben (Tantal-El)kos auf dem Bild sein oder
> gehoeren die zum Filter selber?

Die Kondensatoren gehören zum Filter.

Vielen Dank für deine Hilfe, auch wenn meine begrenztes Wissen recht 
hinderlich sein muss.

Gruß Ivo

Autor: Jürgen W. (Firma: MED-EL GmbH) (wissenwasserj)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du ernsthaft die differentiellen Ausgänge wie am Bild 1 
kurzgeschlossen?

Autor: Ivo B. (ivvooooo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jürgen W. schrieb:
> Hast Du ernsthaft die differentiellen Ausgänge wie am Bild 1
> kurzgeschlossen?

Nein, das habe ich nicht gemacht. Habe auch nicht verstanden, warum 
FilterPro das anzeigt.

: Bearbeitet durch User
Autor: Dergute W. (derguteweka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin,

Ok, hab' ich befuerchtet: Den Kopfhoerer kannst du so nicht anschliessen 
-bzw. kommt dann aus mindestens einem Kanal nicht das raus, was du 
willst.

Nach irgendeinem Datenblatt aus dem Netz sind die Ausgaenge des 
BT-Moduls zum direkten Anschluss von 2 Lautsprechern gedacht, also 
koennte das mit deinem Verstaerker von den Gleichspannungspegeln her so 
hinhauen.

Nur wird der OpAmp wahrscheinlich keine Lautsprecher/Kopfhoerer direkt 
treiben koennen und sicher kann er nix treiben, wo R und L einen 
gemeinsamen Masseanschluss haben.
Ist jetzt die Frage: Was soll denn dabei ueberhaupt mal rauskommen? Soll 
das an einen Subwoofer gehen oder so? Wenn ja, was hat der fuer 
Eingaenge?

Ansonsten ist auch immer eine gute Idee, die Versorgungsspannung 
moeglichst nahe am Chip durch einen Kondensator so um die 100nF zu 
puffern.
Haengt der Bluetoothteil auch an dem selben Akku?

Gruss
WK

Autor: Ivo B. (ivvooooo)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Okay danke.

Dergute W. schrieb:
> Ist jetzt die Frage: Was soll denn dabei ueberhaupt mal rauskommen? Soll
> das an einen Subwoofer gehen oder so? Wenn ja, was hat der fuer
> Eingaenge?

Es soll eine Verstärker mit einem symmetrischen Eingang betrieben 
werden. Nämlich der TDA7498E. Im Anhang hab ich das Datenblatt 
beigefügt.

Dergute W. schrieb:
> Haengt der Bluetoothteil auch an dem selben Akku?

Ja das Bluetooth Modul hängt auch an diesm Akku.

Grüße Ivo

Autor: Dergute W. (derguteweka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin,

Ivo B. schrieb:
> Es soll eine Verstärker mit einem symmetrischen Eingang betrieben
> werden.

Ok, dann koennt' zumindest die Schaltung fuer diesen Zweck passen.

Ivo B. schrieb:
> Dergute W. schrieb:
>> Haengt der Bluetoothteil auch an dem selben Akku?
>
> Ja das Bluetooth Modul hängt auch an diesm Akku.

Das wird problematisch, weil die Stoerungen aus dem Digitalteil des 
BT-Moduls sehr leicht ueber die Batteriespannung in den Rest der 
Schaltung verschleppt werden koennen.
Weiss nicht, ob du das dann stoerungsarm genug hinbekommst.
Hat das schon mal ohne deinen Tiefpass gut funktioniert (also nur 
BT-Modul + dicker Verstaerker)?

Du kannst probieren, jeweils in die + Leitungen vom Akku zum BT-Modul 
und zu deinem TP-Filter kleine Widerstaende vielleicht 1..3.3  Ohm zu 
haengen, und nach den Widerstaenden dann jeweils nahe am Modul einen 
Kondensator ca. 100nF und einen Elko ca. 100µF nach Masse zu schalten. 
Damit "sehen" sich Tiefpass und BT-Modul nicht mehr so gut ueber die 
Versorgung und die Stoergeraeusche sollten weniger werden.


Gruss
WK

Autor: Ivo B. (ivvooooo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dergute W. schrieb:
> Hat das schon mal ohne deinen Tiefpass gut funktioniert (also nur
> BT-Modul + dicker Verstaerker)?

Ja, das hat gut funktioniert.

Nochmal danke für deine Hilfe. Werde es bald ausprobieren.

Autor: Ivo B. (ivvooooo)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Das mit dem Tiefpassfilter hat soweit ganz gut geklappt.

Jetzt wollte ich nach dem gleichen Prinzip einen symmetrischen Hochpass 
bauen. Allerdings rauscht das Signal nach dem Filter unglaublich stark, 
auch wenn ich den Filter an eine separate Stormquelle hänge.

Ich habe Metallschicht-Widerstände und MKS Kondensatoren verwendet.

Hat jemand eine Idee, woher das Rauschen kommen könnte?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.