mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Triac austauschen durch?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Daniel B. (scotx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,
ich habe folgendes Problem: Bei einer Steuerung einer Fußbodenheizung 
werden die Ausgänge durch einen Triac angesteuert. Da die Ausgänge bei 
unserer Versuchsanlage dauerhaft beschaltet waren, obwohl keine 
Anforderung anlag, haben wir nach Rücksprache mit dem Hersteller 
herausgefunden, dass das anschließen von zu vielen thermischen 
Stellantrieben an den Triac-Ausgang diesen angeblich überlastet und 
zerstört haben. Mittlerweile gibt die Herstellerfirma eine max. Belegung 
von zwei Stellantrieben mit jew. 2W vor - angeschlossen waren vier je 
Triac. Nun aber zu meiner Frage: Ich bin des löten mächtig und würde mir 
auch zutrauen, das Teil umzulöten. Kann man einen Triac einfach so 
austauschen um evtl. dann auch mehr Schaltleistung zu bekommen ? Auf dem 
Verbauten Triac steht "C12 AC 4DLMG (ON)" Das ganze Teil wird mit 230V 
betrieben. Wäre toll, wenn mir einer einen Tipp geben könnte, womit ich 
den Triac austauschen kann, um zum einen das Teil wieder funktionsfähig 
zu kriegen und evtl. sogar die Schaltleistung zu erhöhen.

Vielen Dank schonmal vorab !!

Autor: Michael B. (laberkopp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist ein MAC4DL für 600V, Triggerstrom sicher unter 5mA, Haltestrom 
unter 15mA, aber er schaltet 4A, sollte also für 4x2W problemlos 
reichen.

Entweder ist er mit 600V an Überspannung gestorben, oder an sehr 
schlechter Wärmeableitung.

Eigentlich nimmt man für so kleine Leistungen einen Z0107N, der sogar 
nur 1A verträgt, aber 800V.

Mehr bringt MAC8SNG, bis 8A, auch mit 5mA Gate-Strom, von Littlefuse.

Autor: Harald W. (wilhelms)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Daniel B. schrieb:

> auch zutrauen, das Teil umzulöten. Kann man einen Triac einfach so
> austauschen um evtl. dann auch mehr Schaltleistung zu bekommen ?

Meist reicht der Einbau eines kleinen Kühlblechs.

Autor: Daniel B. (scotx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke schon mal für eure Hilfe!!

Michael B. schrieb:
> Mehr bringt MAC8SNG, bis 8A, auch mit 5mA Gate-Strom, von Littlefuse.

— Und diesen MAC8SNG könnte ich einfach 1:1 tauschen ? Aktuell ist der 
mittlere Leiter nicht belegt bzw. abgeknipst !?



Harald W. schrieb:
> Meist reicht der Einbau eines kleinen Kühlblechs.

— Wenn der Triac getauscht ist - der jetzige ist hin - verstehe ich doch 
richtig -oder ??

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Daniel B. schrieb:
> Kann man einen Triac einfach so
> austauschen um evtl. dann auch mehr Schaltleistung zu bekommen ?

Könnte man. Allerdings haben die meisten Triacs wichtige Kennbuchstaben, 
die über ISOLATION!!!, Ansteuerstrom usw. entscheiden. Deshalb genauer 
hinsehen!
http://www.alldatasheet.com/view.jsp?Searchword=MAC4DL&sField=2

Michael B. schrieb:
> Entweder ist er mit 600V an Überspannung gestorben, oder an sehr
> schlechter Wärmeableitung.

Deswegen weitere Beschaltung ansehen! Snubber ok? 
https://www.mikrocontroller.net/articles/Relais_mit_Logik_ansteuern#L.C3.B6schglieder

Autor: Jim Beam (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Daniel B. schrieb:
> Aktuell ist der mittlere Leiter nicht belegt bzw. abgeknipst !?

Der mittlere Anschluss ist ab Werk "abgeknipst", der Kontakt wird über 
die kleine Kühlfahne hergestellt.

Dass der bei 8Watt Last stirbt halte ich für schlechtes Design der 
nachfolgenden Schaltung, z.B. Stichwort "snubber", wurde ja schon 
genannt.

Erschreckend oft wird darauf (auch bei industr.Design) verzichtet oder 
es ist unglaublich schlecht dimensioniert.
Ich nehme an, die Stellglieder sind stark induktiv, da spielt das eben 
eine Rolle!

Autor: Michael B. (laberkopp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jim Beam schrieb:
> Ich nehme an, die Stellglieder sind stark induktiv

Wahrscheinlich gar nicht, er sagte thermische Stellantriebe, also rein 
ohm'sch.

8W an 230V wären gerade mal 34mA, 2W sogar nur 8mA, da bleiben TRIACs 
nicht unbedingt eingeschaltet, und es entstehen nur 10mW bzw 45mW 
Verlustleistung.

Weder Überhizuung noch Überlastung klingt wahrscheinlich, bleibt nur 
Überspannung aus dem Netz.

Autor: Jim Beam (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael B. schrieb:
>> Ich nehme an, die Stellglieder sind stark induktiv
>
> Wahrscheinlich gar nicht, er sagte thermische Stellantriebe, also rein
> ohm'sch.

Ok, stimmt. Hatte ich wohl überlesen.

Wenn aber Überspannung das Problem ist,

WARUM wird es dann besser, wenn weniger Steller angeschlossen sind...?

WO kommt die her? Millionenfach hergestellt Dimmer hatten üblicherweise 
TIC226D eingebaut, der kann "nur" 400V, nur mal als Beispiel.
Kaum, dass die täglich abgeraucht wären.

Autor: Scotx (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So sieht das Layout und die Ansteuerung ums Triac aus...

Autor: Dieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gibt es ein Bild an dem zu sehen waere, dass der Triac ohne Kuehlkoerper 
auf der Platine steht...

Autor: Dieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein paar hundert mW Verlustleistung sollte dieser Aufbau vertragen. 
Snubberschaltung auf der Platine sucht man auf der Platine vergeblich. 
Daher ruehrt wohl wesentlich die Leistungsgrenze.
Den Ausgang koennte man verwenden um einen externen Dimmer zu Triggern, 
der 20+ solcher Lasten schalten koennte.

Autor: Scotx (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ohh ha, an der Stelle steigt mein gefährliches Halbwissen der 
Elektrotechnik aus... Heißt also, das ich das Ding nicht einfach gegen 
was "besseres" tauschen kann ?

Autor: Christian K. (christian_rx7) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Beim Einschalten der Antriebe ziehen diese ein vielfaches an Strom, so 
kann ein Antrieb, der im Normalbetrieb nur 2W benötigt, im kalten 
Zustand leicht bis zu 60W verbraten. Die Antriebe brauchen etwa 3-5 
Minuten, bis sie auf ihrer Nennleistung sind.

Christian_RX7

Autor: Scotx (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da ich da keine Ahnung von habe, mal ne ganz blöde Frage: Kann ich denn 
nicht einfach ein Relais da auf die Platine drauf "braten" oder schafft 
das IC den Schaltstrom nicht und würde mir dann ebenfalls abdanken ?
Ansonsten wäre der MAC8SNG Triac eine Lösung um das auszuprobieren ?

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Scotx schrieb:
> Kann ich denn
> nicht einfach ein Relais da auf die Platine drauf "braten" oder schafft
> das IC den Schaltstrom nicht und würde mir dann ebenfalls abdanken ?

Der jetzt verbaute Triac zeichnet sich durch einen sehr geringen 
Zündstrom aus, der vermutlich kein Relais treiben könnte. Du kannst aber 
mit dem Triac ein kleines 230V~ Relais anziehen lassen, welches wiederum 
die Steller schaltet.
Zur Schaltung: Die Triacs werden über Optotriacs (MOC) gezündet, die auf 
der Primärseite von einer LED angetrieben werden. Auch das reicht im 
Allgemeinen nicht für ein Relais.

Z0405 sollte als Triac übrigens auch klappen.

: Bearbeitet durch User
Autor: Michael B. (laberkopp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Scotx schrieb:
> So sieht das Layout und die Ansteuerung ums Triac aus...

Kein Snubber oder VDR.

Kannst du mal die Bauteilwerte des Optokopplers und Widerstands 
vorlegesen ?

Ich erkenne MOC3017, passt wohl nicht, und der Widerstand 4700 ?

Die Schaltung ist also recht blöd wenn es wirklich nur um die Steuerung 
von 8 Watt geht, die kann eher 0.5 bis 1A schalten, auch ohne Kühlung 
für den TRIAC.

Der MOC jagt mehr Strom in den TRIAC als die Last verbraucht, kann es 
aber nicht weil die Last ja den Strom begrenzt.

Bei kleinen Leistungen von unter 10W (wie bei dir) kann ein IL4108 (das 
ist der 800V zero cross MOC von Vishay/Siemens) die Last direkt 
schalten, der Snubber kommt dann sogar in Reihe

http://pdf.datasheetcatalog.com/datasheet/vishay/83627.pdf
   +-----+--R--+-------Last-------o
   |     |     |        
 Triac  VDR    C                 230V~
   |     |     |        
   +-----+-----+--Thermoschalter--o

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael B. schrieb:
>> So sieht das Layout und die Ansteuerung ums Triac aus...
>
> Kein Snubber oder VDR.

Das ist wirklich ärgerlich. Welcher Hersteller macht denn sowas? Und 
baut dann eine Alibi-Feinsicherung ein...

Autor: Scotx (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Afriso macht sowas.... das schlimmste ist, dass mir das jetzt schon zum 
zweiten mal passiert ist und dieses Teil jetzt „nur“ zwei Monate 
effektiv gehalten hat. In den neuen VPEs ist angeblich ein 
Beipackzettel, auf dem steht, das max. zwei Stellantriebe an die vier 
möglichen Klemmen angeschlossen werden können - lächerlich... die ch 
hatte nur leider die alte Bedienungsanleitung in der Kiste... Aber 
selbst das Teil in neu wäre ja nutzlos, da ich die vier Stellantriebe ja 
Kanal ja nunmal habe... also - kein Afriso mehr...!

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du kannst (wenn deine 2 Watt ohmsch pro Stellantrieb stimmen) ziemlich 
sicher davon ausgehen, dass deine TRIACs nicht überlastet wurden. Im 
Gegenteil, ein nicht-zündender bzw. wieder unter Haltestrom fallender 
könnte den 470 Ohm (du hast trotz Nachfrage den Wert nicht bestätigt) 
Widerstand zerstören. Es könnte also der Haltbarkkeit zuträglich sein, 
eine ca. 0.1A = 23 Watt Grundlast parallel zu den Stellantrieben zu 
schalten. 0.14W sind immer noch wenig für den ungekühlten TRIAC.

Ich würde die Schaltung so umbauen, wie im IL4108 Datenblatt gezeigt.
Zumindest aber einen 250V~ VDR spendieren (bei vorhandenen 600V 
Bauteilen, bei neuen 800V Bauteilen normkonforme 275V~), und eine 63mA 
flink Sicherung einsetzen (die hat auch gleich einen hohen 
Serienwiderstand).

Autor: Scotx (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo & vielen Dank für die ausführliche Antwort!

Das ich die 470 Ohm nicht bestätigt habe, liegt nicht an meiner puren 
Böshaftigkeit, sondern eher an meiner Ahnungslosigkeit... :-) Ich 
versuche, dazu nochmal was rauszubekommen und meld mich... Kann ich denn 
irgendwie ausprobieren, ob ein Triac zündet oder einfach nur so 
durchgehauen ist ?
Danke nochmal & viele Grüße

Autor: batman (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Evt. gibts dafür einen passenden "snubberless" Triac, also mit 
eingebautem Snubber?

Autor: Dieter W. (dds5)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es wäre sicher nicht verkehrt, mal den Kaltwiderstand eines dieser 
thermischen Stellantriebe zu messen.

Um die Ansprechzeit zu verkürzen, könnte ein Hersteller auf die Idee 
kommen, Widerstände mit PTC-Verhalten zu verwenden. Dann ist im 
Einschaltmoment schon eine Überlastung vorstellbar.

Autor: batman (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Heizelemente sind meistens PTC, wie Glühbirnen, die aber auch keine 
übermäßigen Triac zum Dimmen brauchen.

Autor: Scotx (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, es ist ein 47 Ohm Widerstand - es steht 47R0 drauf.
Was ich nicht wirklich verstehe, ist die Tatsache, dass so ein Ding doch 
sicher zig tausendfach verscheuert worden ist, da darf doch bei so einem 
Hersteller und einem Massenprodukt nicht so ein dummer Fehler drin sein? 
Naja, wie schon geschrieben, habe ich von der Elektrotechnik nicht viel 
Ahnung, ich wäre aber in der Lage dort was anderes drauf zu bruzeln. Ich 
habe noch Z0405MF hier liegen, macht das Sinn, die dort mal 
auszuprobieren oder werde ich da sicher auch nicht glücklich mit ??

Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Scotx schrieb:
> Ich habe noch Z0405MF hier liegen,

Von den Eckdaten Steuerstrom, Haltestrom und Spannung her sollten die 
geeignet sein.

Autor: Dieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Scotx schrieb:
> ... Kann ich denn irgendwie ausprobieren, ob ein Triac zündet oder einfach nur 
so durchgehauen ist ?

Das sollte mit einer 9V Blockbatterie, zwei (oder 3 für das Gate) 
Widerständen und einer LED bereits gehen.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dieter schrieb:
> und einer LED bereits gehen.

Kommt auf den Strom an (Datenblatt). Ganz allgemein sollte ein kaputter 
Triac entweder total hochohmig oder total leitend sein (durchlegiert), 
außer es stimmt was am Gate nicht. 
https://www.elektronik-kompendium.de/sites/bau/0411081.htm

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.