mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik LED für Ladestatus (Strom > 150mA => LED soll leuchten)


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Maddin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin Forum,

heute ist Sonntag und es regnet - was gibt es da besseres als in den 
Keller zu gehen und auszumisten. ;)

Dabei ist mir ein Zettel in die Hand gefallen, der mich daran erinnert 
hat, dass ich ja noch eine kleine Herausforderung zu lösen habe...

Es geht um folgendes:

Ein E-Roller (ähnlich Kickboard, nur mit E) hat einen 16-Zellen Li-Ion 
Akku.
Der Akku selbst hat ein eingebautes BMS. Allerdings ohne irgendwelche 
Möglichkeiten der Statusanzeige.

Das Ladegerät ist extern.

Mein Ziel ist es, den Roller zu laden und nach Abschluss des 
Ladevorgangs die 230V Steckdose auszuschalten.

Die Ladespannung beträgt 67.2V,
der Ladestrom - abhängig vom Ladestand, zwischen 2.0A (wenn leer) und 
<0.1A (wenn voll).

Ich würde also gerne erkennen, ob der Ladestrom des Akkupacks kleiner 
100mA ist. Wenn der Strom geringer ist, soll symbolisch eine LED 
leuchten.

In Wirklichkeit wird das später ein Optokoppler mit dahinter liegender 
Schaltung für das Abschalten der Steckdose.

Hat hierzu jemand eine Idee?

Freue mich auf Vorschläge und wünsche einen schönen Sonntag,

der Maddin

Autor: Maddin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Maddin schrieb:
> LED für Ladestatus (Strom > 150mA => LED soll leuchten)

Hach - es sollte natürlich heißen:
Strom < 100mA => LED soll leuchten...

:/

Autor: Michael B. (laberkopp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn du wzischen LAdegerät und Akku den Strom misst, hast du bei 
Strommmesswiderständen immer einen Spannungsabfall.
Daher würde man wegen Gleichstrom wohl besser Hallsensoren wie ACS710 6A 
verwenden, die 100mA zwar ungenau sind, aber das stört in deiner 
Anwendung eher nicht.
Der ACS710KLATR-6BB-NL hat einen FAULT Ausgang der bei HOHEM Strom aktiv 
ist und bei niedrigerem Strom inaktiv wird, der kann direkt deinen 
Optokoppler schaltern.
Oder man muss das Ladegerät intern anzapfen.

Autor: Maddin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Michael,

interessanter Tip - klingt nach einer Lösung.
Ich schau' mir den mal an.

Da müsste ich nur mal schauen, wo ich die 3-5.5V herkriege. Z-Diode 
vielleicht?

Autor: Maddin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi nochmal,

ich habe mir das Ladegerät nochmal genauer angesehen und das 
Kunstoffgehäuse aufgeknackt.

Siehe da - auf der Platine sitzt eine Dual-Color (R/G) LED.
rot = lädt volle pulle
orange = lädt so mittel
grün = fäddisch

Daraus kann ich mittels Optokoppler+Logikgatter was zaubern.

Trotzdem vielen Dank nochmal für den Tip mit dem Hallsensor.
Hab ich gebookmarked ;)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.