mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Seltsamer Signalverlauf beim Testen einer TVS-Diode


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Hnsi95 (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

folgende Situation:

Ich habe einen Eingangsschutz realisiert, der so aussieht, wie im 
Anhang.

Nun wollte ich die Schaltung testen, indem ich einen Load-Dump 
simuliere. Die Simulation in LT-Spice war erfolgreich. Danach wollte ich 
die Schaltung in der "realen Welt" testen und habe festgestellt, dass 
ich natürlich kein passendes Gerät zur Verfügung habe, um das Signal 
abzubilden. (Load-Dump Bild im Anhang)

Aus der Not heraus habe ich mir überlegt, dass ich einen 
Funktionsgenerator nehme. Der Aufbau sieht folgendermaßen aus (siehe 
Anhang). Ich weiß, dass der Aufbau mehr schlecht als recht ist.

Dennoch hat es einigermaßen funktioniert. Ich habe ein 1ms 
Rechtecksignal ausgewählt, um die Schaltung zu testen. Dabei wurde die 
Diode recht warm, was ja auch zu erwarten war (mehrere Durchläufe im 3s 
Takt). Die Spannung wurde von 58V auf ca. 36.2V begrenzt (Netzgerät kann 
aber nur 3A liefern). Eventuell wäre die Diode sogar kaputtgegangen, 
wenn das Netzgerät mehr Strom liefern könnte.

Aber darum geht es mir nicht. Ich würde gerne wissen, wieso der 
Spannungsverlauf so aussieht? Wieso sinkt die Spannung nicht sofort 
(bzw. Schneller) auf 0V an, sondern braucht mehr als 30ms? Im Bild ist 
sogar zu sehen, dass es 1ms auf High war und danach langsam abfällt


Datenblätter:

NMOS in der Gate-Treiber-Schaltung: 
https://www.onsemi.com/pub/Collateral/NTD5867NL-D.PDF
Gate Treiber MCP1416: 
http://ww1.microchip.com/downloads/en/DeviceDoc/20002092G.pdf

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Belaste mal deine Schaltung.

Wo ist der GND vom Scope angeschlossen ?

Autor: Hnsi95 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
karadur schrieb:
>
> Belaste mal deine Schaltung.
>

Okay mit Belastung sieht es schon mal viel besser aus. Das reicht mir 
sogar jetzt

> Wo ist der GND vom Scope angeschlossen ?

An BAT+ und BAT-

Autor: soul e. (souleye)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hnsi95 schrieb:

> Ich habe einen Eingangsschutz realisiert, der so aussieht, wie im
> Anhang.

Du hast ein 24 V-Bordnetz?

Bei 12 V gibt es eigentlich keinen OEM mehr, dessen Loaddump über 36 V 
liegt. Nach LV-124 (VW, Daimler, BMW) reichen 27 V.


> Dennoch hat es einigermaßen funktioniert. Ich habe ein 1ms
> Rechtecksignal ausgewählt, um die Schaltung zu testen.

Ein Loaddump-Puls dauert 300 ms. Üblicherweise wird der von einem 
Arbiträrgenerator erzeugt, der einen Leistungsverstärker treibt. Der 
Verstärker sollte mindestens 50 A liefern können.

> Dabei wurde die
> Diode recht warm, was ja auch zu erwarten war (mehrere Durchläufe im 3s
> Takt). Die Spannung wurde von 58V auf ca. 36.2V begrenzt (Netzgerät kann
> aber nur 3A liefern). Eventuell wäre die Diode sogar kaputtgegangen,
> wenn das Netzgerät mehr Strom liefern könnte.

Davon ist auszugehen. Man kann Loaddump-Pulse nicht mit (realen) Dioden 
klemmen, dafür steckt zuviel Energie drin. Der Strom wird ja quasi nur 
durch den Kabelbaum begrenzt, der mit 30 cm Länge auch nicht wirklich 
hochohmig sein kann.


> Aber darum geht es mir nicht. Ich würde gerne wissen, wieso der
> Spannungsverlauf so aussieht? Wieso sinkt die Spannung nicht sofort
> (bzw. Schneller) auf 0V an, sondern braucht mehr als 30ms? Im Bild ist
> sogar zu sehen, dass es 1ms auf High war und danach langsam abfällt

Weil am Ausgang der Schaltung keine Last sitzt? Wo soll die Energie hin?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.