mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Reparatur High Side Treiber VND810


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Martin H. (martin_h74)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo an alle,

bin auf der Suche nach Infos bzw Unterstützung beim Austausch
eines VND810.
Dieses sitzt auf der Platine der Zentral Elektrik meines Mercedes und 
hat sich wohl mit ordentlich Knall verabschiedet.
Aktuell funktionieren meine Standlichter nicht bzw teilweise.
Das linke geht gar nicht, das rechte flackert.
Laut Doku wird die Beleuchtung komplett elektronisch geschaltet.
Das VND810 schaltet zwei Kanäle, gemäß Datenblatt betrifft es den Output 
1 teilweise, Output 2 komplett.
Das deckt sich mit meinem aktuellen Fehler Bild.

Ich bin kein Profi, eher Hobby Bastler mit soliden Grundkenntnissen.
Daher würde ich mich sehr freuen, wenn mir jemand mehr zum VND810 sagen 
kann.
Könnte ein Austausch mein Problem lösen, vielleicht Bezugsquellen für 
das IC nennen?

Super wäre wenn jemand im PLZ 90 mir beim Tausch helfen kann.
SMD Bauteile habe ich bisher nicht verlötet.
Ich lege ein Bild der Situation bei.

Vielen herzlichen Dank schon Mal

mheiner74

Autor: jikol (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Martin,

auf den ersten Blick (#) scheint das IC nur bei den großen Distributoren 
(Mouser, Digikey, RS, ...) zu bekommen zu sein. Aber frag doch mal den 
Threadersteller von hier, ob er noch was auf Vorrat hat:

Beitrag "[V] VND810, VNQ810 MOSFET-Leistungschalter / Highside-Driver"

Schreib ihm doch einfach mal eine PN (Klick auf das zusammengeschriebene 
blaue "(souleye)", das ist ein Link auf seine Benutzerseite, mit der 
einfachen Möglichkeit für eine PN).

Viel Glück!

(#) Habe nicht exzessiv gesucht.

Autor: Martin H. (martin_h74)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe ihn schon angeschrieben. Den Beitrag hatte ich als erstes gefunden 
und trotz Alter des Beitrags mal einen Versuch gestartet.

Hab auch nirgends eine Quelle gefunden außer AliExpress.
Da weiß ich nicht was man tatsächlich bekommt 😉

Viele Grüße

: Bearbeitet durch User
Autor: Martin H. (martin_h74)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
An dieser Stelle ein großes Dankeschön an souleye.
Bekomme von ihm 2 IC's zugesendet.

😀😀

Autor: jikol (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Martin H. schrieb:
> Bekomme von ihm 2 IC's zugesendet.

:)

Autor: Martin H. (martin_h74)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

jetzt ist die komplette Platine ausgebaut. Auf der Rückseite sind wohl 
auch zwei Widerstände defekt.

Kann jemand sagen ob das 5w oder tatsächlich 50w Widerstände sind?

VG

Autor: hinz (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Martin H. schrieb:
> Hallo zusammen,
>
> jetzt ist die komplette Platine ausgebaut. Auf der Rückseite sind wohl
> auch zwei Widerstände defekt.
>
> Kann jemand sagen ob das 5w oder tatsächlich 50w Widerstände sind?

Das sind Folienkondensatoren.

Autor: Martin H. (martin_h74)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK und was sagt mir 2.2K 50?
Welchen Ersatz muss ich da nehmen?
Ich kenne Kondensatoren nur im Micro Farad Bereich.

VG

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Martin H. (martin_h74)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Martin H. schrieb:
> Super wäre wenn jemand im PLZ 90 mir beim Tausch helfen kann.
> SMD Bauteile habe ich bisher nicht verlötet.

Knips den alten Chip mit einem feinen Seitenschneider Pin für Pin 
vorsichtig am Gehäuse ab und entlöte dann einzeln die Überbleibsel. Mit 
ein wenig Vorsicht hast du saubere Pads und kannst den neuen wieder gut 
löten, wenn du eine Lötspitze <1mm Spitze hast.
Am besten die Pads mit ein wenig Kolophonium vorbehandeln, dann fliesst 
alles richtig. Erst zwei Eckpins löten.

: Bearbeitet durch User
Autor: Martin H. (martin_h74)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

hab mit Lötwasser und Entlötlitze erstmal das gröbste entfernt. 
Anschließend die Pins abgeknipst.
Und dann alles schön gereinigt.
Durch den Schaden am IC hast es ein Pad abgerissen. Mit Kupferfolie ein 
neues zugeschnitten.
Jetzt trocknet das neue Pad und morgen geht's weiter.
Löthonig geht auch oder?
Zum Löten wollte ich eigentlich eine 2mm abgeschrägte Spitze nehmen. Ist 
eine <1mm Spitze nicht zu punktuell erhitzt?

VG

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Martin H. schrieb:
> Lötwasser

Pfui!


> Löthonig

Kanonen auf Spatzen!

Autor: Martin H. (martin_h74)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aber Chip ist verpflanzt ;-)
Und der löthonig hat echt geholfen, die Pads waren ziemlich korrodiert 
und das Zinn kaum flüssig zu bekommen.
Platine ist mindestens 14 Jahre alt.

Das selbe mit den Kondensatoren, das Zinn ist kaum weg zu kriegen. :-(

Der örtliche Anbieter mit dem großen C hatte die passenden 
Folienkondensatoren leider nicht auf Lager.
Könnte ich ein Elko nehmen? Habe da noch ein Sortiment auf lager, 
wahrscheinlich ist da eine passende Kapazität vorhanden.

VG

Autor: hinz (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Martin H. schrieb:
> Könnte ich ein Elko nehmen?

Nein.

Autor: Martin H. (martin_h74)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: hinz (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Martin H. schrieb:
> Zum Löten wollte ich eigentlich eine 2mm abgeschrägte Spitze nehmen. Ist
> eine <1mm Spitze nicht zu punktuell erhitzt?

Du hasts ja offensichtlich hingekriegt, also alles bestens. Ja, eine 
feine Lötspitze erhitzt punktueller, aber das ist ja auch der Sinn der 
Sache :-)

Autor: Martin H. (martin_h74)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias S. schrieb:
> Martin H. schrieb:
>> Zum Löten wollte ich eigentlich eine 2mm abgeschrägte Spitze nehmen. Ist
>> eine <1mm Spitze nicht zu punktuell erhitzt?
>
> Du hasts ja offensichtlich hingekriegt, also alles bestens. Ja, eine
> feine Lötspitze erhitzt punktueller, aber das ist ja auch der Sinn der
> Sache :-)

Ja ging besser als gedacht. Hab eine feine Spitze genommen und Pin für 
Pin gelötet.

Leider kann ich das Ergebnis nicht testen wegen den Kondensatoren.
Mir stellt sich die Frage welchen genauen Zweck sie haben?
Sie sind beide in Reihe auf Masse geschaltet.
Könnte man unter Umständen andere nehmen?
Hab in meinem Bestand lediglich zwei KNB1560 gefunden. 0,22 µF +- 10% 
275VAC

VG

Autor: hinz (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Martin H. schrieb:
> Könnte man unter Umständen andere nehmen?

Klar, und in den Motor passen auch Mofakolben.

Autor: Martin H. (martin_h74)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Martin H. schrieb:
>> Könnte man unter Umständen andere nehmen?
>
> Klar, und in den Motor passen auch Mofakolben.

Mein Lehrer hat mir früher mal beigebracht, es gibt keine dummen Fragen, 
nur dumme Antworten.
Deine zählt für mich dazu ;-)

Autor: Martin H. (martin_h74)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Diese drei Varianten hat der Shop vor Ort auf Lager.
Ist jemand so nett und kann mir sagen ob eines davon verwendet werden 
kann?

Vielen Dank

VG

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Martin H. schrieb:
> Diese drei Varianten hat der Shop vor Ort auf Lager.
> Ist jemand so nett und kann mir sagen ob eines davon verwendet werden
> kann?

Elektrisch gesehen könntest du alle drei verwenden, aber mechanisch 
wirds wohl Probleme geben.

Autor: Martin H. (martin_h74)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Martin H. schrieb:
>> Diese drei Varianten hat der Shop vor Ort auf Lager.
>> Ist jemand so nett und kann mir sagen ob eines davon verwendet werden
>> kann?
>
> Elektrisch gesehen könntest du alle drei verwenden, aber mechanisch
> wirds wohl Probleme geben.

Danke für deine Rückmeldung. Hab die Abstände gemessen. 6,5mm da könnte 
ich evtl. den MKS 250V nehmen. Die langen Beinchen könnte ich passend 
biegen.

VG

Autor: Martin H. (martin_h74)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So eine kurze Rückmeldung und ein Dank an alle die mich mit Tipps und 
Ratschlägen unterstützt haben.
Die Reparatur hat weitgehend funktioniert.
Zwar funktionieren die Standlichter nicht, aber das flackern des einen 
Standlichts ist weg. Und vor allem erhalte ich keine ständigen und 
nervigen Fehlermeldungen mehr im Bordcomputer mehr.
Alle anderen Funktionen sind nach wie vor gegeben

Viele Grüße

Autor: ich wer sonst (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Martin H. schrieb:
> Die Reparatur hat weitgehend funktioniert.
> Zwar funktionieren die Standlichter nicht

Ähhh....ja. Sehr gelungen.

Martin H. schrieb:
> Durch den Schaden am IC hast es ein Pad abgerissen. Mit Kupferfolie ein
> neues zugeschnitten.

Watt? Kupferfolie? Oh man... Ein Stückchen feinen Draht als Ersatz 
anlöten und ggf. mech. fixieren.

Autor: nachtmix (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Martin H. schrieb:
> Die Reparatur hat weitgehend funktioniert.

Wenn du tatsächlich Lötwasser verwendet hast, wird die Freude nicht 
lange dauern...

Warum hast du dir nicht einfach solch eine Platine vom Schrottplatz 
geholt?

Damit hättest du vermutlich auch diesen Fehler behoben:

Martin H. schrieb:
> Zwar funktionieren die Standlichter nicht,

Bei der nächsten HU wird das auf der Mängelliste stehen.

Autor: Wahl der Mittel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich wer sonst schrieb:
> Kupferfolie? Oh man... Ein Stückchen feinen Draht
> als Ersatz anlöten und ggf. mech. fixieren.

Das wäre auch meine Wahl (oder ein dünnes Cu-Blech-Streifchen, wer so 
etwas hat und bearbeiten kann). Hast Du gar nichts brauchbares 
herumliegen, das Du abisolieren könntest? Und seien es nur irgendwelche 
Reste?

nachtmix schrieb:
> Wenn du tatsächlich Lötwasser verwendet hast, wird die Freude nicht
> lange dauern...

Das steht zu befürchten, meistens geht das echt nicht (lange) gut.

Für Elektronik ist imho nur ein Stoff sinnvoll --> Kolophonium.
(Zu lösen bevorzugt in Isoprypylalkohol = Isopropanol = C3H8O,
der bei Erwärmung sogar völlig restlos verdunstet/-dampft.)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.