mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Analoge Signale aus Verstärker summieren


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich bin gerade an einem Punkt in meinem Projekt, wo meine 
elektrotechnischen Kenntnisse an ihre Grenzen stoßen.
Ich möchte 4 analoge Spannungssignale aufsummieren.
Die analogen Signale kommen aus einem Peekel Instruments Picas:
http://www.peekel.de/produkte-messverstaerker-picas-und-signalog-6000-traegerfrequenz-kompakt-und-universell.html?1

Daran sind 4 DMS angeschlossen, also jeder DMS 1 analoges Signal. Ich 
will also die Summe aller DMS bilden.
Ich habe mir jetzt gedacht, dass ich jeden analogen Ausgang am Picas 
auch als eigene Spannungsquelle betrachten kann, die wenn in Reihe 
geschaltet ein summiertes Signal bilden müssten. Nur meine ich im 
Hinterkopf zu haben, dass das bei Signalen mit hoher Frequenz zu 
Problemen führen kann. Nur was sind hohe Frequenzen in diesem Fall?
Also, wird das so funktionieren? Was wären die Alternativen?

Wäre schön etwas Aufklärung zu bekommen. Bitte korrigiert mich, wenn ich 
mit etwas falsch liege.

Danke schon einmal

Autor: Jack (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Grundschaltung ist einfach 
https://de.wikipedia.org/wiki/Operationsverst%C3%A4rker#Invertierender_Addierer/Summierverst%C3%A4rker 
- nur muss man seine Signale kennen und wissen was man tut um einengut 
arbeitenden  Addierer zu entwerfen und zu bauen.

Autor: Michael B. (laberkopp)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Jonas schrieb:
> Ich habe mir jetzt gedacht, dass ich jeden analogen Ausgang am Picas
> auch als eigene Spannungsquelle betrachten kann, die wenn in Reihe
> geschaltet ein summiertes Signal bilden müssten.

Du kannst die Ausgänge nicht in Reihe schalten, weil sie nicht 
galvanisch unabhängig sind. Die Sensoren sind galvanisch getrennt, von 
den 0-10V Ausgängen steht da nichts. Die Masse (Abschirmung) alles BNC 
Buchsen wird elektrisch verbunden sein.

Übrigens sind 2000Hz quasi Gleichstrom.

Der echte Addierer ist so aufgebaut:
                    +48V
                     |
In1 --10k--+--10k----(----+--10k--+--10k---+
           |         |    |       |        |
In2 --10k--+  GND --|+\   | GND --(--|+\   |
           |        |  >--+       |  |  >--+--
In3 --10k--+--------|-/           +--|-/
           |         |
In4 --10k--+         |
                    -48V

Allerdings bringt es nichts, 4 mal 0-10V so zu addieren, daß 0-40V 
rauskommen. Also addiert man besse nur 1/4.
                    +12V
                     |
In1 --10k--+--2k5----(----+--10k--+--10k---+
           |         |    |       |        |
In2 --10k--+  GND --|+\   | GND --(--|+\   |
           |        |  >--+       |  |  >--+--
In3 --10k--+--------|-/           +--|-/
           |         |
In4 --10k--+         |
                    -12V
Das gibt es als Messverstärker mit 0.1% Präzision sicherlich 
kommerziell, kann man aber auch preiswert selber aufbauen, wenn man auf 
genaue 0.5% Widerstände und OpAmps mit geringer Ofsetspannung unter 1mV 
achtet (OP07), Gesamtpreis unter 1 EUR.

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, also was ich möchte, ist demnach ein nicht invertierender Addierer. 
Sind diese Vorwiderstände zwingend notwendig, oder können sie auch 
weggelassen werden, wenn die Gewichtung gleich ist?

Die einzelnen Signale können voll aufsummiert werden, das Summensignal 
ist nicht größer als 7V (einzeln gemessen mit ner Messkarte und in 
Matlab als summierter Plot dargestellt.)

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Jonas (Gast)
Datum: 27.04.2018 11:27
Bewertung
0   ▲ lesenswert
▼ nicht lesenswert

>Ok, also was ich möchte, ist demnach ein nicht invertierender Addierer.
>Sind diese Vorwiderstände zwingend notwendig, oder können sie auch
>weggelassen werden, wenn die Gewichtung gleich ist?

Die können natürlich nicht weggelassen werden, denn die bestimmen ja die 
Verstärkung der Schaltung, bzw. der einzelnen Eingänge.
Ein OPV lebt nunmal von Widerstandsnetzwerken, die damit seine 
Eigenschaften vorgeben (ohne Widerstände ist ein OPV ein totes Tier 
(Ausnahme vielleicht der reine Spannungsfolger)).

Man könnte das ganze auch passiv komplett ohne OPV bauen:

In1 --10k--+-------
           |
In2 --10k--+
           |            Summe/4
In3 --10k--+
           |
In4 --10k--+

GND ---------------

Allerdings kommt es dabei auf den Ausgangswiderstand des Meßverstärkers 
an, da jeder einzelne Eingang über das Widerstandsnetzwerk auf die 
jeweils anderen Eingänge Rückwirken kann, und damit deren Spannungen 
verfälschen kann, wenn die Meßverstärkerausgänge zu hochohmig und 
gleichzeitig unterschiedlich sind (andererseits kürzt sich der dadurch 
entstehende Fehler raus, wenn alle vier Ausgänge gleich hochohmig sind, 
und konstant über den Ausgangsspannungsbereich).

: Bearbeitet durch User
Autor: Jobst Q. (joquis)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jonas schrieb:
> Ok, also was ich möchte, ist demnach ein nicht invertierender Addierer.

Dann schaltest du einen zweiten OpAmp als Inverter dahinter.

> Sind diese Vorwiderstände zwingend notwendig, oder können sie auch
> weggelassen werden, wenn die Gewichtung gleich ist?

Ohne diese Vorwiderstände wäre es ein gegenseitiger Kurzschluß der 
angeschlossenen Ausgänge. Was bei dem Gemetzel übrigbleibt, wird dann 
extrem hoch verstärkt.

Gleiche Widerstände bewirken auch eine gleiche Verstärkung aller 
Eingänge.

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alles klar.
Ich habe jetzt mal in LTspice das ganze aufgebaut und simuliert. Kann es 
sein, dass die summierte Spannung einbricht, wenn sie in die Nähe des 
Bereiches der Versorgungsspannung des OPAmps kommt?

Dann gibt es im Datenblatt zum OP07 ein Beispiel für einen Summierer 
(Seite 11):
http://www.analog.com/media/en/technical-documentation/data-sheets/OP07.pdf
Dort ist zwischen Pin 3 und Ground noch ein 2,5k Ohm Widerstand verbaut, 
was bewirkt der?


Jetzt stellt sich mir die Frage, auf welchen OpAmp ich setzen sollte und 
dementsprechend auch auf welche Versorgungsspannung, da gibt es ja 
gefühlt 1000 verschiedene Modelle. Meine Eingangssignale schwanken in 
der Regel zwischen -1 und +3 Volt, das summierte Signal kommt aber nie 
über 7-8 V hinaus, da niemals alle DMS gleichzeitig gedehnt werden.

Ist der hier schon erwähnte OP07 dafür gut geeignet?

Autor: Michael B. (laberkopp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jonas schrieb:
> was bewirkt der?

Ausgleich des input bias current, er hat genau so viel wie die 5 anderen 
10k Widerstände parallel, bei dir also 2k.

Jonas schrieb:
> Kann es
> sein, dass die summierte Spannung einbricht, wenn sie in die Nähe des
> Bereiches der Versorgungsspannung des OPAmps kommt?

Ja.

Ein OpAmp kann nicht exakt bzw. sogar über der Versorgung liefern und 
messen. Der OP07 kommt bei 10k typisch bis 2V an die Versorgung.

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, ich habe jetzt den Summierer ausgelegt. Jetzt stellt sich mir nur 
noch die Frage, wie ich am besten die -15V bereitstelle für die OpAmp. 
Ich habe ein Labornetzteil zur Verfügung und kann 15V bereitstellen, die 
ich dann ja nur noch invertieren muss. Wie mache ich das in diesem Fall 
am besten, über eine Ladungspumpe?

Autor: Michael B. (laberkopp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jonas schrieb:
> Ich habe ein Labornetzteil zur Verfügung und kann 15V bereitstellen, die
> ich dann ja nur noch invertieren muss. Wie mache ich das in diesem Fall
> am besten, über eine Ladungspumpe?

Ein zweites Labornetzteil. (Daher gibt es so viele 
Doppel-Labornetzteile).

Autor: Harlekin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Warum nicht passiv lösen?

Beitrag "Re: Analoge Signale aus Verstärker summieren"

Wie hoch ist der Eingangswiderstand des Messinstrumentes?

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael B. schrieb:
> Ein zweites Labornetzteil. (Daher gibt es so viele
> Doppel-Labornetzteile).
Danke! Soeben habe ich mich an den Physikunterricht aus der Schule 
erinnert, in dem mein Lehrer den Plus-Pol des einen mit dem Minus-Pol 
des anderen verbunden hatte. Da war doch was :D
Harlekin schrieb:
> Warum nicht passiv lösen?
Ich hatte Lust auf Neues, und da ich noch nie mit OpAmps gearbeitet 
habe...

Harlekin schrieb:
> Wie hoch ist der Eingangswiderstand des Messinstrumentes?

Ehrlich gesagt keine Ahnung. Zu dem Ding findet man nichts im Netz und 
die zugehörige Anleitung ist verloren gegangen.



Es sollte doch kein Problem darstellen, wenn ich direkt vor meinem 
Eigenbau das Signal mittels T-Brücke splitte und die DMS einzeln messe 
und auch das Summensignal, was dann aus der OPAmp Schaltung herauskommt, 
oder? Dann sollte ich ja, wenn ich die Summe der Einzelsignale wieder 
mit Matlab bildeein relativ gleiches Ergebnis erhalten, oder?

Autor: Jonas (Gast)
Datum:
Angehängte Dateien:
  • preview image for 2.png
    2.png
    6,32 KB, 91 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Hi, ich bin es mal wieder.
Der Addierer ist gebaut und funktionierte auf Anhieb, allerdings habe 
ich ein Problem (s. Bild).

Folgendes: DMS Signale (einzeln) werden vor dem Addierer mittels 
T-Brücke gesplittet und gehen zum einen in die Messkarte, zum anderen in 
den Addierer. In der Messkarte werden somit auch alle DMS einzeln 
gemessen. Der Ausgang vom Addierer geht dann ebenfalls an die Messkarte.
Im Bild ist jetzt die Summe der DMS zu sehen (blau) sowie der Addierer 
(rot).
Optimalerweise sollten sich natürlich beide Linien überlagern, aber das 
ist schon ok so. Was aber nicht so toll ist, sind die Ausschläge beim 
Addierer. Der im Peak beträgt immerhin gute 0,5 V.

Wodurch können diese Ausschläge entstehen?

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja, wenn Du uns mal sagen würdest, welchen zeitlichen Abstand die Peaks 
haben, dann könnten wir schon eher eine Idee haben (bzw. eine von vielen 
Ideen herausgreifen).
Und der konkrete Schaltplan, und Bild vom Aufbau wäre auch nicht 
schlecht, ebenso wie Angaben zum verwendeten Netzteil.

: Bearbeitet durch User
Autor: Dieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jens G. schrieb:
> ... (bzw. eine von vielen Ideen herausgreifen). ...

Andernfalls könnten wir Dich jeden Tag mit einer neuen Idee und Belegen, 
dass diese schon zutraf versorgen, und dies ein viertel Jahr lang.

Autor: Wolfgang (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jonas schrieb:
> Wodurch können diese Ausschläge entstehen?

Die blauen Kurve ist vermutlich erheblich kräftiger gefiltert als die 
orange. Kläre mal deinen Signalverarbeitungsweg.

Welche Frequenz haben deine Spikes?
Ist die Versorgungsspannung von deinem Addierer vernünftig abgeblockt?
Fließen auf einer der Masseleitungen Impulsströme?

Autor: Hirnschaden, H. (Firma: Happy Computing MDK Inc.) (hirnschaden)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Ainen gudden!

Jonas schrieb:
> Wodurch können diese Ausschläge entstehen?

Erstmal mußt Du Wackelkontakte ausschließen.

Kannst Du überhaupt anständig löten?

Dwianea
hirnschaden

Autor: Jonas (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Danke, dass ihr mir so gerne helfen wollt, aber aufgrund mangelnder 
Kommunikation von mir nicht könnt, das weiß ich sehr zu schätzen!
Ich hatte gestern einfach nicht die Zeit für einen längeren Beitrag, 
hatte mir aber erhofft, dass vielleicht schon jemand den einen Hinweis 
liefern kann.
Nun denn, ich versuche mal so gut es geht eure Nachfragen zu 
beantworten.

Jens G. schrieb:
> Tja, wenn Du uns mal sagen würdest, welchen zeitlichen Abstand die Peaks
> haben, dann könnten wir schon eher eine Idee haben (bzw. eine von vielen
> Ideen herausgreifen).
Die im oberen Bild gezeigten Peaks (sie treten aber nicht jedes mal auf) 
haben eine ungefähre Frequenz von 2 kHz, also ca. der Frequenz der 
Verstärker der DMS. Die Abstände zwischen den Peaks sind aber nicht 
konstant! (s. 2. Bild)

Jens G. schrieb:
> Und der konkrete Schaltplan, und Bild vom Aufbau wäre auch nicht
> schlecht, ebenso wie Angaben zum verwendeten Netzteil.
Schaltplan s. Bild. Vor den Versorgungsspannungseingängen für die OP's 
sind noch KIA 7809 bzw 7909 geschaltet, die die Versorgungsspannung für 
diese auf +9 und -9 V begrenzen.
Ein Bild vom Aufbau kann ich ohne Rücksprache leider nicht 
veröffentlichen, weiß nicht ob ich das so ohne weiteres darf. Denn alle 
angefertigten Bilder gehören nicht mir.
Das Netzteil ist ein Voltkraft VLP-2403 PRO, über dass ich +12 und -12 V 
bereit gestellt habe.

Wolfgang schrieb:
> Ist die Versorgungsspannung von deinem Addierer vernünftig abgeblockt?
> Fließen auf einer der Masseleitungen Impulsströme?
Wie genau meinst du ersteres? Das Netzteil ist normal am Strom 
angeschlossen und die Verbindung zwischen meiner Schaltung und dem 
Netzteil mit gewöhnlichen Kabeln mit Bananensteckern.
Zweitere Frage kann ich so nicht beantworten, keine Ahnung.

Hirnschaden, H. schrieb:
> Erstmal mußt Du Wackelkontakte ausschließen.
>
> Kannst Du überhaupt anständig löten?

Wackelkontakte halte ich für unwahrscheinlich. Habe mir beim Verlöten 
Mühe gegeben und so gut wie alles überprüft mit meinem Multimeter. Bin 
zwar kein Profi im Löten, aber die Schaltung habe ich gut hinbekommen. 
Die Lötstellen sahen alle zufriedenstellend aus.

Noch zu meiner Schaltung:
Ich habe das Gehäuse der Box (Kunststoff) mit Aluminium von innen 
verklebt, Deckel und Boden separat. Die Schaltung sowie alle Buchsen 
sind im Deckel untergebracht und dort dient die Alufolie gleichzeitig 
als Masse. Ich habe also nicht die Masse jedes BNC Steckers extra 
verlötet, sondern ist verbunden über die Alufolie zur Bananenbuchse für 
Masse. Nur das Board ist mit Bananenbuchse Masse über ein Telefonkabel 
verlötet. (Hoffe das war verständlich :D). Was ich noch definitiv 
erwähnen möchte: Deckel und Boden sind einzeln abgeschirmt, aber es gibt 
kleine Bereiche, die nicht abgeschirmt sind, wenn beide miteinander 
verschraubt sind. Da muss ich noch eine Lösung für finden.

Autor: Hirnschaden, H. (Firma: Happy Computing MDK Inc.) (hirnschaden)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Ainen gudden!

Jonas schrieb:
> Wackelkontakte halte ich für unwahrscheinlich. Habe mir beim Verlöten
> Mühe gegeben und so gut wie alles überprüft mit meinem Multimeter. Bin
> zwar kein Profi im Löten, aber die Schaltung habe ich gut hinbekommen.
> Die Lötstellen sahen alle zufriedenstellend aus.

Hast Du ein Problem oder ich?

Ich seh' hier weit und breit keine anonyme Meßkarte und auch keinen 
selbstgebastelten Analog-Addierer. 🐴

Dwianea
hirnschaden

Autor: Achim B. (bobdylan)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jonas schrieb:
> allerdings habe
> ich ein Problem

Jens G. schrieb:
> Netzteil

Bingo.

Autor: Hirnschaden, H. (Firma: Happy Computing MDK Inc.) (hirnschaden)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ainen gudden!

Achim B. schrieb:
> Jens G. schrieb:
>> Netzteil
>
> Bingo.

Wenn Du die einzige verwertbare Information als Fehlerquelle ausmachst, 
bist Du einem ganz billigen Trick auf den Leim gegangen und mußt 
dringend zum Psychotroniker. 🐴

Dwianea
hirnschaden

Autor: Michael L. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,


> Wodurch können diese Ausschläge entstehen?

Hat Deine Schaltung eine Massefläche?
Sind beide Versorgungsspannungen in der unmittelbaren Nähe des OPV mit 
100nF (Keramikkondensator 0805) gegen Masse entstört?
Sind beide Versorgungsspannungen auf dem Board mit je 47uF oder 100uF 
gegen Masse entstört?

Viele Grüße
Michael

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael L. schrieb:
> Hat Deine Schaltung eine Massefläche?
In Form der Alufolie, die das Gehäuse abschirmt.

Michael L. schrieb:
> Sind beide Versorgungsspannungen in der unmittelbaren Nähe des OPV mit
> 100nF (Keramikkondensator 0805) gegen Masse entstört?
> Sind beide Versorgungsspannungen auf dem Board mit je 47uF oder 100uF
> gegen Masse entstört?

Ich hatte bisher nur 0,1uF Elkos, die die Ausgangsspannung der 
Spannungswandler gegen Masse entstören. Habe das jetzt um je einen 0,33 
uF Elko erweitert vor den Spannungsreglern (s. 
http://cdn-reichelt.de/documents/datenblatt/A200/TS7900%23TSC.pdf) und 
um die von dir genannten 100nF Keramikkondensatoren direkt an den beiden 
OP.

Das Signal ist jetzt nahezu perfekt.

Ein dickes Danke für alle Hilfe.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.