Forum: PC Hard- und Software Was ist denn mit mmc.exe passiert ?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Uwe (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen,

es ist mal wieder zum Haareraufen!

Seit vorgestern spinnt mein Rechner (Win10, 64 Bit, Updates sollten 
aktuell sein). Wenn ich versuche

Gerätemanager, oder
Datenträgerverwaltung, oder
Computerverwaltung aufzurufen

dann bekomme ich dieses Fehlerfenster (s. Angang) knallrot auf schwarzem 
Hintergrund formatfüllend angezeigt. Andere Apps habe ich noch nicht 
versucht.

Außer mir gibt es keinen anderen Admin, der eine Blockierung 
eingerichtet haben könnte und ich selbst ganz sicher auch nicht.

Im Netz habe ich nichts zielführendes gefunden und die angeführten 
Dateien mmc.exe und (hier) devmgmt.msc hatte ich zu Virustotal 
hochgeladen, sie wurden aber als "sauber" eingestuft.

Ich möchte nicht den Rechner neu aufsetzen müssen, das dauert wieder 
ewig. :-(

Kennt jemand diese Falle?

Danke,
Uwe

von Cyblord -. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Update auf 1803 ausgeführt? Musst im Sicherheitscenter nachschauen, 
welche Files er im Zuge dessen als verdächtig ansieht und im Zweifel 
wieder freigeben.

von Zeno (Gast)


Bewertung
8 lesenswert
nicht lesenswert
Typisch Win10! Mit so etwas ärgere ich mich täglich auf meinem 
Firmemlaptop rum. Im Produktiveinsatz ist das System unbrauchbar, 
zumindest mein Fazit nach einem guten dreiviertel Jahr.

Zu Deinem Problem:
Auch wenn Du selbst der Admin bist, versuch es mal mit einem Rechtsklick 
auf das Gerätemanagersymbol und wähle dann als Administrator ausführen. 
Du wirst dann nach einen "Reason" gefragt, wähle irgend einen aus, dann 
sollte es weiter gehen.
Wenn es mit dem Gerätemanager direkt nicht funktioniert, dann öffne mit 
dem beschriebenen Weg zuerst ein Konsolenfenster und gebe dort mmc ein. 
DAs hat bei mir immer funktioniert.

von bluppdidupp (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Prüfen kann man auch die Einstellungen unter:
mmc.exe gpedit.msc
"Benutzerkonfiguration" - "Administrative Vorlagen" - 
"Windows-Komponenten" - "Microsoft Management Console"
...dort steht normalerweise alles auf "Nicht konfiguriert"

Wenn mmc.exe über als Admin gestartetes "cmd.exe" sich noch öffnen 
lässt, hat  vor dem Windows-Update mit ziemlicher Sicherheit mal 
irgendeine Software Mist in der Registry veranstaltet ;D

von Uwe (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Abradolf L. schrieb:
> Update auf 1803 ausgeführt?

War 1709, habe das Update geladen, aber bei der Installation bleibts 
(gefühlt) ewig stehen bei 83%.

Zeno schrieb:
> Rechtsklick
> auf das Gerätemanagersymbol

Kommt sofort oben angehangene Fehlermeldung.

bluppdidupp schrieb:
> Wenn mmc.exe über als Admin gestartetes "cmd.exe" sich noch öffnen
> lässt,

Nee, leider nicht.

von Uwe (Gast)


Angehängte Dateien:

Bewertung
3 lesenswert
nicht lesenswert
Uwe schrieb:
> ewig stehen bei 83%

Nee, Irrtum, ging jetzt doch weiter und fordert mich auf, den Rechner 
neu zu starten.

Habe ich versucht per Button "Jetzt neu starten" und was passiert, s. 
Anhang.

Grrr.

von Michael R. (fisa)


Bewertung
6 lesenswert
nicht lesenswert
Man kann gegen die sagen was man will, aber Humor haben sie in Redmond 
;-)

von bluppdidupp (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Was man noch versuchen kann:
mmc.exe umbenennen (z.B. nach "mmc.exe.renamed")
dann cmd.exe starten (Achtung: per rechtsklick "Als Administrator 
ausführen", nicht nur als Admin doppelklicken)
und dann defekte Systemdateien reparieren lassen:
sfc /scannow
ggf. noch gefolgt von:
dism /Online /Cleanup-Image /RestoreHealth

...mit etwas Glück wird das Paket mit mmc.exe drin durch Windows dann 
neu installiert und korrigiert dabei was auch immer nicht passt (ggf. 
fehlt ein Sicherheitskatalog (*.cat-Datei) auf dem System)

...oder ein neues Benutzerprofil mit Admin-Rechten anlegen und schauen, 
ob da alles läuft oder darüber den eigentlichen Benutzer zu einem 
Standarduser und nach Reboot wieder zurück zu einem Admin-User machen.

von Cyblord -. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
https://www.windowscentral.com/windows-10-april-2018-update-common-problems-and-fixes

Schau mal ob dein Problem dabei ist, ich hatte auch eins, da ich die Pro 
N Version habe und dort das Media Feature Pack das Update blockiert 
hatte.

von Uwe (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
bluppdidupp schrieb:
> ...mit etwas Glück wird das Paket mit mmc.exe drin durch Windows dann
> neu installiert und korrigiert

Nee, leider nicht, habe kein Glück.


@bluppdidupp (Gast):

Ich danke dir für deine Tipps. Ich selbst habe solche tieferen 
Detailkenntnisse gar nicht.
Habe das von dir Vorgeschlagene durchgeführt (s.Anlage), aber es hat 
sich nichts geändert.

Werde wohl doch das System neu aufsetzen müssen, schade
Uwe

von Uwe (Gast)


Angehängte Dateien:

Bewertung
4 lesenswert
nicht lesenswert
Abradolf L. schrieb:
> Schau mal ob dein Problem dabei ist

Auch das habe ich eben versucht, Ergebnis: s. Anhang.

Michael R. schrieb:
> aber Humor haben sie in Redmond
> ;-)

Stimmt genau....  :-((

von Gustav K. (hauwech)


Bewertung
2 lesenswert
nicht lesenswert
> Die Problembehandlung kann aufgrund eines Problems nicht gestartet werden

Die Meldung hat was, ebenso wie die Empfehlung, sich an den 
Systemadministrator zu wenden. Verarsche pur.

Würde auch zu einer Neuinstallation raten und auf zweifelhafte Aktionen, 
zu denen es noch "viel Glück" braucht, von vorne herein verzichten.

von Cyblord -. (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Das 0x80070241 Problem hatte ich mal bei einem älteren Update, dort hat 
es bei mir geholfen, das Media Creation Tool zu nutzen und die darin 
enthaltene Reparaturfunktion zu nutzen, dann gingen die Updates durch.

https://www.downloadsource.net/how-to-fix-windows-error-0x80070241/n/9964/

von bluppdidupp (Gast)


Bewertung
2 lesenswert
nicht lesenswert
Fehlercode 0x80070241 sagt quasi, dass eine digitale Signatur nicht 
validiert werden konnte*.
Also im Prinzip wohl das gleiche Problem wie beim Starten der mmc.exe
Unter Win10 kann man noch im Startmenü nach "Problembehandlung" suchen 
und dann in der "Problembehandlung" den Punkt "Windows Update" 
ausführen, das korrigiert solche Probleme manchmal.
Direkt manuell auf das nächste Release updaten könnte man auch 
probieren: https://go.microsoft.com/fwlink/?LinkID=799445
...die Update-Installer fixen solche Probleme häufig ebenfalls ;D
Ich würde aber vermutlich auch eher mit dem Media Creation Tool 
(https://go.microsoft.com/fwlink/?LinkId=691209) einen aktuellen 
Installer erstellen und Windows damit eher komplett neu installieren 
statt weiter eventuell funktionierende Tipps durchzuprobieren ;D

(*typische Ursachen: Irgendwelche Cleanup-Tools haben wichtige 
*.cat-Dateien gelöscht, die Windows-Update Datenbank ist beschädigt oder 
Rechneruhrzeit stimmt nicht, usw...)

von Uwe (Gast)


Bewertung
4 lesenswert
nicht lesenswert
Abradolf L. schrieb:
> dort hat
> es bei mir geholfen, das Media Creation Tool zu nutzen

Es ist vollbracht...

Hat zwar lange gedauert, aber jetzt kommt dieses verfluchte 
Fehlerfenster nicht mehr und die Apps lassen sich wieder starten. Das 
Media Creation Tool hatte ich runtergeladen und damit wurde dann quasi 
Win10 (1803) neu installiert, aber ohne Verlust der vorher installierten 
Programme und Einstellungen. Vielen Dank, Abradolf Lincler, für den Tipp 
mit dem Download. :-) Das hat mir offenbar ein zeitraubendes 
Neuaufsetzen des Rechners erspart.

@ bluppdidupp:

Tja, was die Ursache gewesen sein könnte, das wird sich wohl nicht mehr 
feststellen lassen. Aber ich habe etwas gelernt, denn von diesem 
Creation Tool hatte ich vorher nichts gewusst. Sollte wieder so ein 
Problem auftauchen, weiss ich was zu tun ist und werde nicht Tage mit 
erfolgloser Sucherei vergeuden.

Rundherum ein grosses  D A N K E  an alle, die sich für mich bemüht 
haben,

tschüss Uwe

von Cyblord -. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Uwe schrieb:
> Vielen Dank, Abradolf Lincler, für den Tipp
> mit dem Download. :-)

Gern geschehen :-)

von Michael R. (fisa)


Bewertung
0 lesenswert
nicht lesenswert
Uwe schrieb:
> Das hat mir offenbar ein zeitraubendes
> Neuaufsetzen des Rechners erspart.

Schade, wieder eine gelegenheit verpasst, endlich ein Betriebssystem 
aufzusetzen ;-)

von Äxl (geloescht) (Gast)


Bewertung
4 lesenswert
nicht lesenswert
kein einziges beleidigendes Wort in diesem Thread und keine dummen 
Kommentare.
Ganz großartig! so, wie früher...
sehr schön
Äxl

von guest (Gast)


Bewertung
-5 lesenswert
nicht lesenswert
Äxl (geloescht) schrieb:
> kein einziges beleidigendes Wort in diesem Thread und keine dummen
> Kommentare.
> Ganz großartig! so, wie früher...
> sehr schön
> Äxl

Leider zu früh gefreut

von Toaste (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Moin zusammen,

habe den Beitrag wegen eines ähnlichen Problems gelesen, welches durch 
das Update auf 1803 endstanden ist.
Mein befehl "runas" funktionierte vorher einwandfrei danach halt nicht 
mehr.

Also habe ich zunächst eine CMD mit dem neuen User gestartet und den -- 
start --- befehl genutzt welchen ich über "/c" an die neue CMD übergeben 
konnte.


runas /user:domain\Benutzername /savecred "cmd.exe /c start Programm"


Gruß
Henri

von Markus Weber (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich habe auch zusätzlich zur manuellen Umstellung in der Registry die 
UAC deaktiviert
Aus chip.de:

* Öffnen Sie den Ausführen-Dialog über die Tastenkombination [Windows] + 
[R].

* Geben Sie den Befehl "regedit" ein und klicken Sie auf "OK".

* Anschließend wechseln Sie in den Pfad
  "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\S 
ystem".

* Klicken Sie doppelt auf den Eintrag "EnableLUA" und setzen Sie den 
Wert auf Null.

* Schließen Sie den Registrierungs-Editor und starten Sie Ihren Rechner 
abschließend neu.

Das hat bei mir geholfen.

von Manfred (Gast)


Bewertung
3 lesenswert
nicht lesenswert
Markus Weber schrieb:
> Aus chip.de:

Wer Chip liest und Beiträge beantwortet, die 20 Monate alt sind, sollte 
besser Holzpferdchen schnitzen und / oder Kuchen backen.

von Christian R. (supachris)


Bewertung
0 lesenswert
nicht lesenswert
Markus Weber schrieb:
> Das hat bei mir geholfen

Genial! Lässt du bei dir zu Hause auch immer die Haustür offen, weil das 
mit dem Schlüssel so nervig ist?

von Franz E. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,
hatte selbiges Problem.

Mit dieser Aktion von Hr. Weber, dankenswerter Weise, als "Laie" gelöst.


Geben Sie den Befehl "regedit" ein und klicken Sie auf "OK".

* Anschließend wechseln Sie in den Pfad
  "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\S
ystem".

* Klicken Sie doppelt auf den Eintrag "EnableLUA" und setzen Sie den
Wert auf Null.


Dankeschön
Franz E.

von MaWin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Christian R. schrieb:
> Markus Weber schrieb:
>> Das hat bei mir geholfen
>
> Genial! Lässt du bei dir zu Hause auch immer die Haustür offen, weil das
> mit dem Schlüssel so nervig ist?

Hat meine Oma gemacht.

Zumindest tagsüber waren die Türen immer offen, egal ob jemand zu Hause 
war.

Sehr praktisch, Nachbarn konnten Eier holen oder Kuchen hinlegen, auch 
weiss man im Alter ja nicht ob man mal die Treppe runterfällt und eine 
zugeschlossene Haustür dem Helfer den Zugang versperren würde, er ohne 
das Problem zu bemelrne vorbei gehen würde.

Aber heute habnen ja alle Leute Angst vor dem Leben daß ihnen der Arsch 
auf Grundeis geht. Sie fühlen sich erst sicher wenn sie im Panic-Room 
sitzen.

von chrissi_410 (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Ich habe auch dieses Problem.
Wenn ich jedoch die WindowsPowerShell(Administrator) klicke und dann 
devmgmt.msc eingebe, macht der GeräteManager wieder klaglos auf.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.