mikrocontroller.net

Forum: PC Hard- und Software Rechner Absturz nach F1


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Bernhard F. (1atmel2)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auf einem aelteren 386er Rechner erscheint die Meldung "checksum error"
resume mit "F1". Nach druecken von F1 stuerzt der Rechner ab.
LCD Display dunkel, mit ctrl-alt-del laeuft er wieder hoch bis zum 
checksum-
error. Soweit ich weiss koennte den checksum error eine defekte 
Pufferbatterie sein.
Hat irgend jemand eine Idee?

Folientastatur und IO-Board abgesteckt.

: Verschoben durch Moderator
Autor: hinz (Gast)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Bernhard F. schrieb:
> Soweit ich weiss koennte den checksum error eine defekte
> Pufferbatterie sein.

Dann prüf die doch einfach.

Autor: Michael U. (amiga)
Datum:

Bewertung
3 lesenswert
nicht lesenswert
Hallo,

Bernhard F. schrieb:
> Soweit ich weiss koennte den checksum error eine defekte
> Pufferbatterie sein.

Ist zumindest sehr wahrscheinlich.

> Hat irgend jemand eine Idee?

Statt F1 erstmal rechtzeitig ins BIOS gehen (meist mit DEL/Entf).
Wenn vorhanden Defaults laden, wenn nicht, sinnvolle Werte von Hand 
setzen.
Falls es ein richtig alter 386SX mit Neat-BIOS ist: viel Vergnügen...

Gruß aus Berlin
Michael

Autor: S. R. (svenska)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bernhard F. schrieb:
> Auf einem aelteren 386er Rechner erscheint die Meldung "checksum error"
> resume mit "F1". Nach druecken von F1 stuerzt der Rechner ab.

Kenne ich von einem 486er Acer-Notebook. Wenn die Batterie leer ist, 
bestehen Datum und Uhrzeit aus zufälligen Werten (z.B. dem 65. im Monat 
48 des Jahres 2265 um 76:35 Uhr) und das BIOS stürzt beim Zugriff darauf 
sofort ab.

Defaults laden bringt nichts, weil die RTC nicht vom Akku bzw. Netzteil 
gepuffert wird, sondern ausschließlich von der Pufferbatterie (ziehe ich 
dort im Betrieb die Speisung ab, zeigt das BIOS sofort ungültige Daten 
an).

Bernhard F. schrieb:
> Soweit ich weiss koennte den checksum error eine defekte
> Pufferbatterie sein.

Ja, äußerst wahrscheinlich. Mach das Teil auf und suche die Batterie. 
Wenn du sie gefunden hast, löte sie aus und löte eine neue ein; der Typ 
ist aufgedruckt.

Wenn du keine Batterie findest, suche nach einem Chip mit 
"DALLAS"-Aufdruck. Wenn du den gefunden hast, dann entscheide dich, 
wieviel Aufwand du in das Gerät stecken möchtest - diese Chips haben die 
Batterie fest eingebaut und werden nicht mehr hergestellt. Alte Chips 
haben also auch leere Batterien. Es gibt Anleitungen, wie man dort 
extern eine Spannung einspeisen kann oder die Batterie ersetzen kann - 
mit Feile und Lötkolben.

Autor: S. R. (svenska)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael U. schrieb:
> Falls es ein richtig alter 386SX mit Neat-BIOS ist: viel Vergnügen...

Meinst du, weil der so viele Einstellmöglichkeiten hat? Die Defaults 
sollten ja immer laufen... hab leider nie einen NEAT-286er gefunden. ;-)

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

S. R. schrieb:
> Meinst du, weil der so viele Einstellmöglichkeiten hat? Die Defaults
> sollten ja immer laufen... hab leider nie einen NEAT-286er gefunden. ;-)

ich hatte sowas mal... Nix mit Default, Ram-Bestückungen (DIL-ICs) 
konnten variabel gemischt werden. Für jede Bank den Typ (256kBit/1MBit) 
und die Timings einstellen. Ich glaube, es würde heute ewig dauern wenn 
ich sowas wieder in Gnag bringen müßte. War ja zum Glück ziemlich 
schnell wieder vreschwunden, obwohl man es als wohl als das erste 
Overclocking-BIOS-bezeichnen könnte.

Gruß aus Berlin
Michael

Autor: michael_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
S. R. schrieb:
> Wenn du keine Batterie findest, suche nach einem Chip mit
> "DALLAS"-Aufdruck. Wenn du den gefunden hast, dann entscheide dich,
> wieviel Aufwand du in das Gerät stecken möchtest - diese Chips haben die
> Batterie fest eingebaut und werden nicht mehr hergestellt.

Ja, aber man konnte da oft einen normalen C-MOS und eine ext. Batterie 
einsetzen und einen Jumper umstecken.

Autor: Harry L. (mysth)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Vorteil der NEAT-Board (Chips&Technology-Chipsatz - später von Intel 
aufgekauft) war die extrem flexible Speicherverwaltung.
Das war so ziemlich die erste Möglichkeit trotz Real-Mode mehr als 1MB 
RAM auf 286-Boards sinnvoll zu nutzen.

Und ja, der Checksum-Error ist zu >99% auf eine verbrauchte 
Pufferbatterie zurück zu führen.

Dummerweise waren die häufig in dem Uhrenbaustein vergossen. (zu 
erkennen an dem ca. 1cm hohen Gehäuse)

Autor: Timmo H. (masterfx)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Bei alten 386er Mainboards war es noch oftmals ein NiMH/Cd Akku und 
keine CR2032 o.Ä. die sterben halt einfach irgendwann.

Autor: michael_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und haben die Leiterzüge weggefressen!

Autor: Teo D. (teoderix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn der Akku ö.ä. leer ist, sollt er er aber mit default Einstellungen 
hoch laufen, wenn nicht Krudeszeug verbaut ist.

Michael U. schrieb:
> Statt F1 erstmal rechtzeitig ins BIOS gehen (meist mit DEL/Entf).
> Wenn vorhanden Defaults laden, wenn nicht, sinnvolle Werte von Hand
> setzen.

Autor: michael_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Natürlich kann auch der EPROM defekt sein.
Mal beide neu in die Fassung drücken.

Autor: Teo D. (teoderix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
michael_ schrieb:
> Natürlich kann auch der EPROM defekt sein.

Bei meinem ersten PC (HP250/80286), war sogar einmal das Rom hin.
Rep. hat ~6Wochen gedauert (Interner Prozess). Das ich mit meiner 
Vermutung recht hätte, konnte ja nicht sein. "Sowas geht nicht kaputt, 
basta". Also erst mal alles andere akribisch geprüft....

: Bearbeitet durch User
Autor: michael_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab ich auch erlebt. Gab es.

Machmal konnte man das BIOS damals von anderen Rechnern nutzen.

Autor: Bernhard F. (1atmel2)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Der Akku hat noch 2,8 Volt?! Koennte eine gebrauchte Li-Ion Zelle (evtl 
Diode -0,7V) eingeloetet werden?

Bilder vom Board und Batterie im Anhang.

Autor: Teo D. (teoderix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
michael_ schrieb:
> Machmal konnte man das BIOS damals von anderen Rechnern nutzen.

'87 standen da noch nich so viele in der Gegend rum. :)

Bernhard F. schrieb:
> Der Akku hat noch 2,8 Volt?!

Die könnte sogar noch gut sein... zumindest ausreichend gut. 
Aufladen...?

Aber egal, ins BIOS solltest du kommen. Wenn nicht is wirklich was hin.

: Bearbeitet durch User
Autor: Bernhard F. (1atmel2)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welche Bausteine werden von der Batterie versorgt?
Zur Sicherheit wollte ich mal nach dem Ausloeten die Leiterbahnen 
klingeln.

Autor: Teo D. (teoderix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eigentlich nur der MM6818p.

Weil ich da auch Federkontakt-Sockel sehe.
michael_ schrieb:
> Mal beide neu in die Fassung drücken.

!!!
Nur mal draufdrücken, so das es sehr leise knackt, reicht schon.

Bernhard F. schrieb:
> Zur Sicherheit wollte ich mal nach dem Ausloeten die Leiterbahnen
> klingeln.

Welche Sicherheit?
Kurzschluss wird das sicher nicht haben.
Und wenns den doch sein muss. Durchklingeln, ankommen müsste es ja, 
irgendwo am EPROM.

Autor: Bernhard F. (1atmel2)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Habe BIOS und MM6818p aus dem Sockel genommen und neu eingesetzt.
Nach Abstecken des Keyboards erscheint <DEL> um ins Setup zu gelangen.
Dies funktioniert leider nicht.

Siehe Screenshot.

Um die Ecke habe ich einen Elektronikshop der alte PC verkauft, macht es 
mehr Sinn das ganze Board zu tauschen oder BIOS bzw CMOS Bausteine?

Autor: Teo D. (teoderix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bernhard F. schrieb:
> Nach druecken von F1 stuerzt der Rechner ab.

Hat doch vorher funktioniert?

Alle 3 gesockelten, auch den IO/Tastatur Chip (P8042?)? Wenn nichts mehr 
hilft, sollte er die Ursache sein.
Völlig vergessen, auch schon das CmosRAM gelöscht? Könnte der Jumper 
neben dem Akku sein. 2-3min. lang mal abziehen.


[OT]
Der Monitor ist aber heftig eingebrannt. 8-0

Autor: Icke ®. (49636b65)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bernhard F. schrieb:
> Der Akku hat noch 2,8 Volt?! Koennte eine gebrauchte Li-Ion Zelle (evtl
> Diode -0,7V) eingeloetet werden?

Prinzipiell ja. Es muß aber sichergestellt sein, daß sie nicht vom Board 
geladen wird. Also nicht dort anschließen, wo der Akku verlötet ist, 
sondern über den 4-poligen Jumper daneben. Der ist üblicherweise für den 
Anschluß externer Primärbatterien vorgesehen.

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

sieht ja erstmal normal aus, 386SX mit Ami-BIOS.

Bernhard F. schrieb:
> Nach Abstecken des Keyboards erscheint <DEL> um ins Setup zu gelangen.
> Dies funktioniert leider nicht.

Den Satz verstehe ich nicht. Was für eine Tastatur hast Du dran? Alte 
DIN-Tastatur? PS/2 mit Steckeradapter oder was?

Klapper mal gleich beim Einschalten auf der DEL-Taste rum oder halte die 
fest (ausprobieren).
Andere Tstatur testet, ohne Tastatur dran könnte bei dem BIOS eigentlich 
die geniale Ausschrift "Keyboard not found! Press F1 to continue" 
kommen.

Gruß aus Berlin
Michael

Autor: michael_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Teo D. schrieb:
> michael_ schrieb:
>> Machmal konnte man das BIOS damals von anderen Rechnern nutzen.
>
> '87 standen da noch nich so viele in der Gegend rum. :)

Klar!
Aber man konnte den Inhalt mausen und neu brennen.
War so 1992.

Teo D. schrieb:
> [OT]
> Der Monitor ist aber heftig eingebrannt. 8-0

Kann auch Schmutz sein.
Aber Vorsicht. Solche Monitore hatten manchmal eine äußere Beschichtung!

Autor: soul e. (souleye)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
michael_ schrieb:

> Natürlich kann auch der EPROM defekt sein.

Oder vergesslich geworden sein. EPROMs sind zwar haltbarer als 
FlashROMs, aber nach 30-40 Jahren wird es auch da eng. Oft lassen sie 
sich dann im (langsamen) EPROMMer noch auslesen, kommen aber beim 
schnellen CPU-Takt nicht mehr mit. In diesem Fall hilft es eine Kopie 
auf einen neuen Baustein zu machen. Wenn diese funktioniert kannst Du 
den originalen neu beschreiben (löschen und Aufkleber abreissen ist 
nicht nötig, es kommt ja dasselbe rein wie vorher).

Wenn EPROMs Ladung verlieren kippen die Bits von Null nach Eins.

Autor: Thomas (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Also da steht doch "Keyboard Error" - imho hat der wohl das Keyboard 
garnicht erkannt.

Autor: Brummbär (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Thomas schrieb:
> Also da steht doch "Keyboard Error" - imho hat der wohl das
> Keyboard
> garnicht erkannt.

Daran wird es wohl auch liegen, dass F1 nicht erkannt wird ;-)

Autor: S. R. (svenska)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
michael_ schrieb:
> Ja, aber man konnte da oft einen normalen C-MOS und eine ext. Batterie
> einsetzen und einen Jumper umstecken.

Wenn ein Dallas-Chip verbaut ist, geht das in der Regel nicht - sonst 
wäre das Problem ja einfach zu lösen gewesen. In diesem Fall ginge das 
aber.

Teo D. schrieb:
> Wenn der Akku ö.ä. leer ist, sollt er er aber mit default Einstellungen
> hoch laufen, wenn nicht Krudeszeug verbaut ist.

Naja, die Dinger erkennen nur recht wenig automatisch. Zumindest 
Festplatte und Diskettenlaufwerke muss man manuell eintragen, je nach 
Board auch mehr.

michael_ schrieb:
> Machmal konnte man das BIOS damals von anderen Rechnern nutzen.

Wäre tatsächlich einen Versuch wert: Der "Chipsatz" sieht ziemlich 
uninteressant aus, und passende Images für 386SX findet man problemlos 
im Netz. Mir fällt auch spontan nichts ein, was auf dem Board durch eine 
Fehlkonfiguration kaputtgehen könnte.

Bernhard F. schrieb:
> Der Akku hat noch 2,8 Volt?!

Wenn er 3.6 V haben sollte, würde ich ihn als "ziemlich leer" 
betrachten. Lag das Board ewig rum, bis es nicht mehr funktionierte, 
oder war das System öfter im Betrieb?

Autor: michael_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
S. R. schrieb:
> michael_ schrieb:
>> Machmal konnte man das BIOS damals von anderen Rechnern nutzen.
>
> Wäre tatsächlich einen Versuch wert: Der "Chipsatz" sieht ziemlich
> uninteressant aus, und passende Images für 386SX findet man problemlos
> im Netz.

Nach dem letzen Bild hätte es da einen Checksum-Error für das BIOS geben 
müssen. Ist aber i.O.
386SX BIOS habe ich in Rerserve :-)

Beitrag #5416626 wurde von einem Moderator gelöscht.
Autor: S. R. (svenska)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Männo schrieb im Beitrag #5416626:
> Was soll das alles?

Spaß machen. Und ja, Retro-Technik kann das.

Autor: Icke ®. (49636b65)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
S. R. schrieb:
> michael_ schrieb:
>> Ja, aber man konnte da oft einen normalen C-MOS und eine ext. Batterie
>> einsetzen und einen Jumper umstecken.
>
> Wenn ein Dallas-Chip verbaut ist, geht das in der Regel nicht - sonst
> wäre das Problem ja einfach zu lösen gewesen.

Wo ein Wille ist und invasives Werkzeug...

Autor: ● J-A V. (Firma: FULL PALATINSK) (desinfector) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Timmo H. schrieb:
> Bei alten 386er Mainboards war es noch oftmals ein NiMH/Cd Akku und
> keine CR2032 o.Ä. die sterben halt einfach irgendwann.

wenn man sowas noch benötigt:

Batterie/Akku auslöten, woanders hin platzieren
und am besten auch in einen Plastikbeutel rein geben
und dicht schnüren.
Man glaubt sonst nicht,
wie zielsicher diese sch... Sosse den Weg auf die Platine findet.
Dafür würde ich auch das Neueinstellen des BIOS in Kauf nehmen.
Oder man brückt erstmal mit einer Leitung und schneidet
nach dem Verlegen der Batterie dann durch.
Diese Bretter dürften bestimmt noch so einige neue MoBos überleben.

Mir sind auch bei den BIOS-Gehirnen
gelegentlich verschmutze Kontakte vorgekommen.
zum Reinigen den Chip entnehmen und die Kontakte
auf einem Blatt Papier sauber streichen.
Die Kontakte der Fassungen mit einem Glasfaserpinsel.

Die ESD-Problematik sollte bekannt sein.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.