mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik EA DOGL 128-6+ attiny 2313


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: alt21 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich Habe ein kleines Problem ,mit meinem Display EA DOGL 128-6
hat einer von euch das Teil schon mal Angeschlossen?

Meines Tut nicht! Gibt es da was worauf man achten muss beim 
Zusammenbau?
beim Hersteller im Beiliegenden Datenblatt.

Waren nur die Belegungen der Pins mit den Keramik Kondensatoren
das habe ich soweit alles gemacht.

Das Einzige was Funktioniert ist die Hinter Grund Beleuchtung.

Um Hilfe u. Tipps wird gebeten!,Links tun es auch schon.
Danke im Voraus.

Einen Schönen Feiertag!

Autor: Curby23523 N. (nils_h494)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zeige zuerst deinen Schaltplan und den dazugehörigen Aufbau (z.B. 
Steckbrett, PCB).

Autor: alt21 (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So das ist meine Zeichnung...inkl. Platinen Bilder..

Autor: alt21 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Freien Anschlüsse auf der Lochraster Platine sind mit Draht Brücken 
auf
der Isolierten Rückseite Der Platine mit Drahtbrücken Verbunden.

Autor: S. Landolt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Display kenne ich nicht, mich irritiert jedoch zweierlei:
- hier steht ATtiny2313, auf dem karierten Blatt 4113 (nb., kenne ich 
auch nicht)
- angenommen, es sei doch der 2313, weshalb ist dessen Pin17 = DI mit 
dem Display verbunden und nicht Pin18 = DO?

Autor: alt21 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Beide Controller sind identisch, der 4313 hat nur einen Größeren 
Speicher.
 Die sind so Angeschlossen weil die Anschlüsse so im Orginal Verdrahtet 
sind.

Ich wollte die Org. Software, benutzen= Gleicher Display Controller= 
Gleicher Prozessor mit mehr Speicher.

Da muss ich die Software nicht Ändern. Zumindest nicht Großflächig .

Autor: S. Landolt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
4113 != 4313

Das heißt, dass diese 'Org. Software' nicht USI benutzt? Merkwürdig.
  (oder war mein Tag heute zu lang, könnte natürlich auch sein)

Autor: Klug Schwätzer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
alt21 schrieb:
> Gibt es da was worauf man achten muss beim Zusammenbau?

Auf saubere Lötstellen. Deine sind verkrustet, kalt, manche
Kondensatoren haben auf den ersten Blick keinen Kontakt.
Wenn das an anderen Stellen auch so ist dann kann ja nichts
funktionieren.

Die Bilder selbst sind fast so schlecht wie der Aufbau.

Alles nochmal von vorne, mit sauberen Lötstellen. Oder
erst mal einen Lötkurs machen und gutes Werkzeug/Löt-
material kaufen.

Autor: nix weis aber viel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
alt21 schrieb:
> Ich Habe ein kleines Problem ,mit meinem Display EA DOGL 128-6

Mit welcher Spannung betreibst du dieses Modul??

Es müsssen 3,3V sein.
Falls du mit 5V betreibst könnte er schon schaden genommen haben.

Bei 5V Versorgung brauchst du auf jedenfall einen 3,3V Regulator
sowie ein 74HC4050 für die Datenleitungen.

Ich selber habe ein DOGM 128-6 also den kleinen Bruder.
Ich Empfehle dir  nach einem DOG-L Schild zu suchen.

Autor: alt21 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Festspannungregler mit 3,3V ist vorhanden.
von einem 74HC4050 steht aber nix im Daten Blatt ,wenn ich mich nicht 
irre.

einfach die Verdrahtung vom Controller zum Display ist nicht Möglich?

Autor: nix weis aber viel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
alt21 schrieb:
> einfach die Verdrahtung vom Controller zum Display ist nicht Möglich?

Wenn dein uC auch mit 3,3V betrieben wird brauchst du den 74HC4050 
nicht.

Autor: Alt21 (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!
Wollte mich mal wieder zurückmelden, habe mein Problem mit dem EA DOGL 
128-6
mit meinem Attiny 2313 in den Griff= Beendet.

Der Grund warum es nicht so wollte wie ich es wollte, war ein NICHT 
Gesetzter sog. Fusebit.

Mir ist es durch Literatur eines Attiny Craschkurses aufgefallen.
dort Stand, das die Teile mit einer Werks Einstellung ausgeliefert 
werden.
Und sich Merkwürdig verhalten oder gar nicht Funktionieren ,bis man 
ihnen durch Setzen des Fusebits mitteilt das man einen Externen Quarz 
angeschlossen hat.

Warum steht sowas in Büchern und nicht beim Händler in der Techn. Info?
Dann hätte ich mir Tage/Monate nicht sinlos (aber Lehrreich!) geopfert.
Aber nun laufen beide Module mit beiden Prozessoren.

Man kann auch das Conrad (C-Control) LCD Dispaly DUINO damit betreiben 
man
muss nur auf die Anderen Spannungen achten.

danke für eure Geduld mit mir
wünsche allen ein Ruhiges Fest und einen Guten nach 2019!

Autor: Christian S. (roehrenvorheizer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na, dann hat der Kraschkurs ja ordentlich geholfen.

Man sollte eben zuerst das englische original Datenblatt zum 
Mikrocontroller durchgearbeitet haben bevor man aufbaut. Allerdings ist 
dies ein schwieriger Weg, weil das Datenblatt sehr umfangreich ist. Der 
Händler wird sich damit kaum auskennen, der "händelt" nur.

Mit einer speziellen Bauanleitung oder einem Tutorial geht es leichter. 
Nur sollte die Aufklärung bezüglich solcher Nebensächlichkeiten wie 
Fuse-Bits nicht fehlen. Mikrocontroller sind eben komplizierte Gesellen.

MfG

: Bearbeitet durch User
Autor: Alt21 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
habe hier Hilfe erhalten und will anderen auch mal Helfen können!

wer es gebrauchen kann....

kann es sich runter ziehen!!!

https://www-user.tu-chemnitz.de/~heha/viewchm.php/hs/ATmegaX8.chm/

viel Spaß beim Arbeiten!!!

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alt21 schrieb:
> Mir ist es durch Literatur eines Attiny Craschkurses aufgefallen.
> dort Stand, das die Teile mit einer Werks Einstellung ausgeliefert
> werden.
> Und sich Merkwürdig verhalten oder gar nicht Funktionieren ,bis man
> ihnen durch Setzen des Fusebits mitteilt das man einen Externen Quarz
> angeschlossen hat.

Da verhält sich nichts 'merkwürdig', sondern der Controller läuft mit 
den Werkseinstellungen. Abgesehen von einer niedrigen Taktfrequenz um 
1MHz ist der Controller ganz normal operabel.

Autor: Alt21 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mag sein,
Es Funktionierte NICHT!

erst nach dem Fusebit Einstellen klappte es.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.