mikrocontroller.net

Forum: PC Hard- und Software Synergy auf Raspberry


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Johannes S. (jojos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
benutzt hier jemand Synergy auf dem RPi? Ich habe es als Client auf dem 
RPi3 installiert, noch die Version 1.4.16. Der Server ist ein Windows7 
PC, das läuft auch soweit. Nach ein paar Tagen wird die Bedienung des 
RPi über die Maus aber immer ruckeliger, die Last beim Bewegen der Maus 
auf dem RPi Desktop geht auf 25%. Nach einem Neustart des RPi ist alles 
wieder gut, Last beim Maus bewegen 2-4 %. Auf dem RPi läuft nur das 
Raspian mit Desktop ohne weitere eigene Programme.
Kennt hier jemand das Problem? Es gibt mittlerweile ein Synergy 2, aber 
über die Installation habe ich auch noch nichts gutes gelesen, oder 
läuft das besser?

Autor: Joachim B. (jar)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
läuft astrein auf dem PI3

ich habe eine Version von 1.4.x - 1.5 keine Ahnung wieder vergessen

Server ist der winXP mit v1.5
mein win7 client mit v??? vermutlich auch 1.5
mein raspbianSTRETCH Pixel Client mit v1.4.16.

Kommen alle prima klar mit.

: Bearbeitet durch User
Autor: Johannes S. (jojos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok, danke. Habe weiter geforscht, auf dem RPi werden fürchterlich viele 
Sachen geloggt, in /var/log/debug stehen z.B. Unmengen 
Verbindungsversuche drin. Wo kann ich den Loglevel für den synergyc 
ändern?

Edit:
ich denke ich habe es gefunden, hatte nach dieser Anleitung den 
Autostart eingebaut:
https://learn.adafruit.com/synergy-on-raspberry-pi/setup-synergy-client-autostart
Da wird aber die config nicht benutzt und default ist wohl debuglevel = 
debug, mit dem '--debug FATAL' im Aufruf ist Ruhe.

: Bearbeitet durch User
Autor: Joachim B. (jar)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wenns bei dir nun läuft muss ich ja nicht suchen :)

Autor: Johannes S. (jojos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
es wurde nach ein paar Tagen wieder alles langsam, syngeryc hat auf 
einem CPU Kern 100% Last erzeugt, auch ohne Logging.
Ich habe hier noch einen Hinweis gefunden das es ein alter Fehler sein 
könnte: https://github.com/symless/synergy-core/issues/55
Habe Synergy jetzt nicht in dem LXSession Autostart sondern über den 
Desktop gestartet, seit zwei Tagen läuft es gut. Das ist natürlich 
suboptimal, der Rechner soll ja ohne eigene Tastatur auskommen. Über den 
Desktop gestartet bekommt synergyc noch die Argument '-f --no-tray' mit, 
werde die auch mal in das Startscript reinpacken wenn es jetzt noch ein 
paar Tage gut läuft.

Das neuere Synergy 2 ist wohl noch beta, oder benutzt das hier jemand 
schon auf dem RPi?

Autor: Joachim B. (jar)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Johannes S. schrieb:
> Habe Synergy jetzt nicht in dem LXSession Autostart sondern über den
> Desktop gestartet, seit zwei Tagen läuft es gut.

hmmm 1.4.16 läuft bei mir länger auch mit Autostart.

Was klemmt ist immer wieder Chromium, das müllt einfach den freien 
Speicher zu bis nichts mehr geht.
Auch deswegen komme ich kaum über 2-3 Tage Laufzeit.

: Bearbeitet durch User
Autor: Johannes S. (jojos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
auch wenn ich Synergy über den Desktop starte wird es nach einigen Tagen 
langsamer und frisst mehr CPU. Wenn ich die Maus über den RPi Desktop 
bewege geht die CPU Last beim RPi für einen Kern auf 100 % hoch. Nach 
einem Neustart von Synergy auf dem RPi kostet die gleiche Aktion max. 10 
% auf dem RPi.
Kontrolliert habe ich das mit htop, was sagt die Lastanzeige bei dir?

Autor: Joachim B. (jar)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
vielleicht morgen besser oder übermorgen,

nach Neueinrichtung (microSD verstorben) gerade 21:24 uptime
synergy cpu 0,7% aber ich bin ja jetzt per x11vnc drauf nicht per 
synergy

Autor: Johannes S. (jojos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok, danke.
Im Ruhezustand braucht synergyc bei mir auch nix, nur beim Mausschubsen.

Autor: Joachim B. (jar)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
so auf dem PI3 mit wieder jessiePIXEL

50%-98% wenn ich die Maus vom winXP nach PI schubse

aber den PI juckt das scheinbar nicht, downlowad bricht nicht ein und 
auch sonst ist nichts zu bemerken

Autor: Johannes S. (jojos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nochmal ein Update,

Joachim B. schrieb:
> so auf dem PI3 mit wieder jessiePIXEL
>
> 50%-98% wenn ich die Maus vom winXP nach PI schubse

also wie bei mir, nur Server ist Win7. Die Last ist ein Kern volle Kanne 
ausgelastet beim Maus bewegen und die Bewegung ist dann ruckelig.
Wenn Synergy auf dem Pi neu gestartet wird ist es wieder ok, 7 - 10 % 
Last und flüssige Bewegung. Der Fehle tritt nach meiner Beobachtung auf 
wenn der Server einige Zeit nicht mehr vorhanden ist, dann geht beim 
Client (nicht nur beim RPi) die CPU Last hoch.
Ich habe dann die Installation des neuen Synergy gewagt. Auf dem Windows 
wenige Klicks, fertig, läuft.
Auf dem Pi: Grausam! kann nicht über apt-get installiert werden, aber 
immerhin ist ein debian package bei Symless im Downloadbereich. Mit dpkg 
-i ... installiert, reichlich Fehlermeldungen weil nur Qt 5.3 statt 5.7 
vorhanden ist. Nach Qt 5.7 Install gesucht, warum kann es sowas nicht 
einfach fertig geben? Ellenlange Anleitungen wie es kompiliert (am 
besten cross compiliert) werden könnte. Nach ein paar Stunden 
aufgegeben. Im neueren Raspbian Image 'Stretch' ist das Qt 5.7 drin, 
also nach Anleitungen ein Update auf Stretch durchgeführt. Dauert 
Stunden, zwischendurch müssen Fragen beantwortet werden. Danach ging 
erstmal das Netzwerk nicht mehr, meine Änderungen waren weg. Immerhin 
liess sich das neue Synergy Package installieren, allerdings auch noch 
mit fehlender Abhängigkeit die mit einem Zauberkommando aufgelöst werden 
musste.
Das gute Ende: es läuft endlich wieder und die CPU Last ist auch im 
grünen Bereich. Nur mit der deutschen Tastatur hat Synergy2 noch 
Probleme, aber man kann nicht alles haben...

Autor: Joachim B. (jar)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich bin vom stotternen stretch 18.4.2018 reuemutig wieder zurück zu 
jessie, das läuft wenigstens und synergy stört überhaupt nicht, da 
stottert nix.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.