mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ESP nach Elkotausch instabil - Tipps?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Basti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich bastle immernoch an meinem ESP-12 Platinchen. Ich hatte die 
Stromaufnahme unterschätzt und zunächst 2x220µF an 3.3V und 3x330µF an 
5V gelötet. Das ganze sah natürlich ordentlich abenteuerlich aus. 
(Regler ist ein LF33 LDO)

Ich habe mir beim C 470µF für die 3.3V und 3300µF für die 5V Seite 
bestellt, mit dem Oszi hat sich der Ripple von 100mV auf ca 50mV 
reduziert. (Falls das Oszi das halbwegs genau anzeigt)

Jedenfalls habe ich aber bei dem ESP-12 Modul wieder die gleichen 
Probleme wie zu beginn ohne Elkos. Die alten Elkos waren schon ca 15 
Jahre alte aus der Bastelkiste, die will ich eigentlich nich mehr 
hernehmen.

Gibt es eine Möglichkeit die Kapazität zu prüfen?? (Mit dem Multimeter 
wird immer fast der korrekte Wert angezeigt, selbst bei defekten Elkos, 
das scheint keinen großen Wert zu haben)

Autor: Basti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag:

- mit einem zweiten 470µF an 3.3V läuft es,
- mit einem 3300µF an 3.3V nicht
- löte ich zu dem 3300µF 2x220µF parallel hinzu, läuft es wieder

UND mit den 2x220µF verbessert sich die Ping-Zeit dramatisch

Ich denke es liegt an den Elkos - evtl zu großer Innenwiderstand?
Low ESR Elkos für die Anwendung verwenden?

Autor: Joachim B. (jar)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Basti schrieb:
> 3300µF 2x220µF parallel hinzu, läuft es wieder

dann liegt es vermutlich am ESR und auch an der Wickelinduktivität, zu 
groß gewickelt ist auch selten gut, nicht immer hilft viel auch viel, es 
muss passen(angenommen die Kapazitäten sind real)

Bei KerKo SMD auch an voltage derating denken!

PS. 3300µ sind schon sehr übertrieben, also ich denke eher in 470µ - 
1000µF als Elko, vermutlich ideal sind deine beiden 220µF

: Bearbeitet durch User
Autor: Basti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich habe 10µF auf der Trägerplatine zum stützen, der Elko ist direkt am 
VCC Eingang des ESP gelötet um einen möglichst kurzen Weg (Niedrigen 
Widerstand) zu gewährleisten.

Confirmed: Im laufenden Betrieb die 2x200µF abgeschnitten (Nur 3300µF) 
-> Ping-Zeit von immer unter 20ms auf 50-200ms angestiegen. ich kann das 
gar nicht fassen.

Autor: Markus M. (adrock)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die fertigen Boards mit dem ESP8266 haben doch auch nicht so viele und 
so große Kondensatoren.

Was ich so sehe, z.B. auf dem NodeMCU, sind hinter dem Spannungsregler 
(1117-3.3 nehme ich an) ein kleiner Keramikkondensator und ein großer 
(10µF) Tantalelko.

Evtl. ist das eher der richtige Ansatz? Ein kleiner Keramikkondensator 
mit sagen wir mal 100nF und parallel dazu ein Elko mit 10..100µF?

Am Eingang des LDO sollten doch 0,1µF reichen, es sei denn Du hast eine 
sehr schlechte Versorgung. Zumindest im Datenblatt wird in den 
Beispielschaltungen auch nicht mehr verwendet.

Autor: Stefanus F. (Firma: Äppel) (stefanus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich kann aus Erfahrung berichten, dass folgende Kombination 100% 
Zuverlässig funktioniert:

Handy-Netzteil 5,1V 500mA -> 100nF -> LF33CV -> 100nF+2,2µF -> 100µF -> 
ESP8266 Modul

Der 100µF ist direkt auf die Anschluss-Pins des ESP Moduls gelötet. So 
laufen meine Basteleien zuverlässig. Ein Gerät läuft seit April 2017 
ohne eine einzige Fehlfunktion im Dauerbetrieb. Ohne die 100µF fiel es 
vorher mehrmals pro Woche aus.

Wenn du mehr als 100µF brauchst, stimmt etwas nicht. Vielleicht ist 
deine Leitungsführung schlecht. Dein Hinweis, dass die Ping Zeiten sehr 
variabel sind scheint dies zu bestätigen.

Hast du alle GND Anschlüsse Sternförmig an einem Punkt zusammengeführt? 
Verläuft eventuell eine Leitung der Spannungsversorgung um das Modul 
herum in einem Kreis oder Bogen?

: Bearbeitet durch User
Autor: Sebastian H. (sebastian1234)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Masse füllt ein komplettes layer auf der Unterseite der 
Trägerplatine. (Das mach ich eigentlich immer so)

Evtl ist 0.75mm Trace für VCC ein bisschen wackelig für die 
spitzenströme (so weit ist der lf33 nicht vom ESP weg, der sitzt nämlich 
genau drunter.

Bei mir sieht es so aus:

5V ein -> 100nf+10µF -> 100nf LF33 100nf -> 100nF 10µF ESP12
Die elkos löte ich direkt an VCC des ESP, das habe ich schon öfters 
gelesen bietet sich in meinem Fall sowieso an, weil die Trägerplatine 
nur wenig größer ist als das ESP modul..

Ich denke es kommt auf den ESR des Elkos an, deshalb bring es 
parallelschalten der Elkos. Hab gestern abend beim reichelt mal ein paar 
low esr und very low esr elkos bestellt. Hab irgendwo gelesen das 
normale Elkos eher für 50-100hz ausgelegt sind - wenn ich die impulse 
auf dem oszi sehe ist das seeehr weit davon entfernt.

Ich werde berichten.

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich kann das so nur bestätigen. Mehrere Handy-Netzteile verschiedener 
Werte, Spannungsregler meist China-Schnipsel mit AMS1117, aber auch 
LF33CV.
Am Eingang 100n bzw. bei den China-Sachen meist 1µ drauf. Am ESP-Modul 
dicht einen 100-220µ Elko, meist direkt aus der Wühlkiste. Leitungen 
zwischen ESP und Regler sind ohnehin max. 5cm.

Der ESP will während der kurzen Spitzen beim WLAN (mehrere ms-Bereich, 
bis 350mA) unbedingt eine stabile Spannung. Sonderlich große Elkos 
helfen da also ohnehin nicht. Ich hatte auch bei einem reinem 
Batterietest (2x AA-Alkali) und DeepSleep nur einen 100µ am ESP, nichts 
weiter.

Gruß aus Berlin
Michael

: Bearbeitet durch User
Autor: AlterHase (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Junge, Du brauchst Kerkos, so 100nF

Autor: Basti (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
@Alter hase. hab ich. hab ich auch geschrieben...

so hab jetzt mal geschaut wie die kommerziellen boards das machen.

Da sehe ich beispielsweise beim wimos d1 mini als Regler RT9013 bei dem 
im Datenblatt folgende interessante Formulierung zu finden ist:

"Ultra-Fast Response in Line/Load Transient"

Hab mir gleich mal welche bestellt - es sieht aber so aus als wäre der 
besonders "schnell" beim nachregeln. Es wird hervorgehoben das er für 
Wireless communications besonders geeignet ist.

Autor: Checker (Gast)
Datum:

Bewertung
-2 lesenswert
nicht lesenswert
ESR ist bei der Anwendung völlig LATTE!

Das ist doch kein Schaltnetzteil...;-(((

Autor: Sebastian H. (sebastian1234)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Checker, vielleicht könntest du deine Gedanken mit uns teilen?

Autor: Stefanus F. (Firma: Äppel) (stefanus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wir haben Schwankungen der Stromstärke bei ca 500mA. Multipliziert mit 
einem ESR von z.B. 1 Ohm ergibt das 500mV Ripple. Weniger ist sicher 
besser.

: Bearbeitet durch User
Autor: Teo D. (teoderix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Checker schrieb:
> ESR ist bei der Anwendung völlig LATTE!

Warum steht dann bei den LDOs immer der ESR Bereich bei, bei dem sie 
zuverlässig arbeiten?
Hier einfach so niedrig wie möglich wählen, ist auch nicht das gelbe vom 
Ei. Da sollte man sich schon am Dabla orientieren. Die Mistdinger sind 
da ziemliche Sensibelchen!

Autor: H.Joachim S. (crazyhorse)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Richtig. Weder sollte der ESR zu niedrig sein noch die Kapazität zu 
hoch.
Den schwankenden Strombedarf muss/soll eh der Regler sicherstellen und 
nicht der Ausgangselko "zubuttern".

Autor: Teo D. (teoderix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
H.Joachim S. schrieb:
> Weder sollte der ESR zu niedrig sein noch die Kapazität zu
> hoch.
> Den schwankenden Strombedarf muss/soll eh der Regler sicherstellen und
> nicht der Ausgangselko "zubuttern".

Jup. Das hatte noch gefehlt. :)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.