mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Kurzschluß auf dem Board


Autor: Stefanie (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
auf meiner Platine hat es einen richtigen Kurzschluß gegeben, d.h. in
meinem 3.3V Teil bin ich von VCC auf GND gekommen.
Ich habe 2 Board und es ist auf beiden passiert :-(

Ein Bild vom Spannungsteil habe ich angefügt. Punkt 1 ist nach den
Dioden, Punkt 2 ist nach dem 5V Festspannungsregler und Punkt 3 ist
nach dem 3.3V Festspannungsregler

Nun habe ich beide Board vermessen:
Hier die Ergebnisse von Board 1:
Eingangsspg    5V       6.1V      7V       8V
Punkt 1        3.5V     4.6V      5.5V     6.4V
Punkt 2        2.5V     3.6V      4.5V     5V
Punkt 3        2.5V     3.3V      3.3V     4.17V!!!

Hier die Ergebnisse von Board 2:
Eingangsspg    4.8V     5.4V      6V       6.9V
Punkt 1        4.1V     4.8V      5.2V     6.3V
Punkt 2                 3.8V      4.2V     5V
Punkt 3                 3.3V      3.3V     4.1V!!!!

Beim Board 2 habe ich den 3.3V Festspannungsregler schon vor der
Messung ausgetauscht!!

Was glaubt ihr, was welche Bauteile kaputt sein könnte??

Autor: Benedikt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eigentlich dürfte garnichts kaputt sein.
Immerhin gibt es eine Sicherung und die Spannungsregler haben eine
Strombegrenzung.

Mess mal den Widerstand zwischen Punkt 2 und 3.

Autor: Dietmar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Den Meßwerten nach scheint der 5V-Regler in Ordnung, aber die 3,3V nicht
mehr:

Wenn der Kurzschluß von +5V gegen Masse war, also hinter dem 5V-Regler,
hat der voll aufgeladene 3,3V Kondensator hinter dem 3,3V Regler diesen
womöglich in Rückwärtsrichtung zerschossen.

An einem der beiden Boards hat es wohl auch den Brückengleichrichter
erwischt.

Gruß

Dietmar

Autor: AxelR. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wo ist deine Multimeter Masse (schwarze messschnur) angeschlossen?
Betreibst Du deine Boards mit wechselspannung, oder aus deinem
Labornetzteil?

Autor: Stefanie (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für euere Antworten.
-mein Board betreibe ich mit Gleichspannung mit einem Labornetzteil
-als Messgerät verwende ich ein Voltcraft VC506 dass ich auf VDC/LOGIG
gestellt habe und die schwarze Messschnur ist in COM und die rote in
uA*V
-zwischen 2 und 3 messe ich (rot an 3) messe ich einen Widerstand von
7,1 kOhm
-beim 2. Board habe ich schon den 3.3V Regler getauscht und der Fehler
tritt immer noch auf!!
Kann man eigentlich auch einen Kondensator zerstören??

Autor: Dietmar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Möglich ist auch folgendes:

Aus dem Datenblatt des LM3940 (von National Semiconductors):

MINIMUM CAPACITANCE:
The minimum output capacitance required to maintain stability
is 33 μF (this value may be increased without limit).
Larger values of output capacitance will give improved transient
response.

Das bedeutet für diesen Regler, daß er mit dem Wert aus dem Schaltplan
(10µF) evtl. nicht stabil läuft, vielleicht als Hinweis darauf, wonach
es auch mit dem neuen Regler nicht geht.

Ist der 3,3V Ausgang eigentlich offen, d.h. unbelastet? Dann belaste
den mal mit einem Widerstand von etwa 1k Ohm bis 5k Ohm und miß die
Spannung.

Ansonsten hat eine der 4 Dioden des Brückengleichrichters von Board 2
einen Kurzschluß, da nur eine Diodenspannung abfällt. Bei echtem
Wechselstrombetrieb läuft der als Einweggleichrichter und schließt die
2. Halbwelle kurz, wonach dann irgendwann die Sicherung auslösen wird.

Gruß

Dietmar

Autor: Dietmar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das griechische my mag er wohl nicht, sollte 33 uF heißen.

Autor: Wupp Derjall (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
O ja, und wie. Drollig ist es Elkos zu verpolen, die eksplodieren dann
ganz nett. Tantalse spritzem mit flüssig Metal, das macht auch Spas.

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Masseproblem->Graetzgelichrichter.
Fehlmessung würde ich tippen. Das der schwarze im COM steckt und der
rote bei VDC irgentwas, war ja klar. Habe ich wieder zu dämlich
gefragt, sorry :-))
Welches ist dein Massebezug zum Board?
Minus vom Labornetzteil?
Sowas hatte ich schonmal...

Autor: Stefanie (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bezug ist GND am Board!

Ich habe an den 3,3V noch einen Datenflash den AT45DB hängen.

Was ebenfalls sehr komisch ist, wenn ich zudem meinen Max3008
Pegelwandler(5V --> 3,3V)dranhänge, dann messe ich sporadisch mal 1,8V
und mal 4,17V, wenn ich kurz mit der Messspitze weg gehe und wieder
dran.

Autor: Michael Jungnickl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Stefanie,

es sieht für mich eher so aus, als ob keine Gegenregelung am 2.
Spannungsregler erfolgt. Deshalb steigt die Spannung möglicherweise bis
zum geregelten Betriebspunkt linear an. Kann auch sein, dass der Regler
2 vom falschen Typ ist (z.b. 5 V). Immerhin erhältst du mehr als 3,3 V
an Punkt 3.

Ist es richtig, dass am 1. Regler TAB an der Ausgangsspannung und am 2.
Regler TAB auf Masse liegt? Im Datenblatt habe ich diesen Pin nicht
gesehen. Ist das die Rückseite am Gehäuse des Reglers? Das Kühlblech
sollte meist auf Masse liegen.

Ob deine Spannungsregelung stabil ist, kannst du am besten mit einem
Oszilloskop prüfen. Bei Belastung sollte die geregelte Spannung nur um
ca. 0,1 V schwanken. Da dies Längsregler sind, noch weniger. Vielleicht
hast du hochfrequente Störungen durch die hintereinander geschalteten
Regler?

Tschüß

Michael

Autor: Alex Trusk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
zum thema ruecklaufdiode ueber spannungsreglern:
http://www.elektronik-kompendium.de/public/schaere...

ich baue die in jede schaltung mit ein; andere halt in keiner...

gruss, alex.

Autor: Wolfram (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im Datenblatt des lm3940 ist kein TAB Ausgang zu finden, den du laut
Schaltplan verwendest. Was ist das?

Autor: Dennis Kleine-Beck (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
TAB = (Kühl)Fahne.

Hatte ich für den 3,3V-Regler auch schon im Datenblatt geprüft und für
OK befunden.

Dennis

Autor: Stefanie (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab nochmal nachgemessen und mit 1kOhm belastet. Am Ausgang des 3.3V
Festspannungsreglers messe ich nun bei beiden Boards 3.8V (unbelastet
4.14V).

Wie kann das denn sein, es ist doch ein neuer 3.3V-Regler

Autor: Dennis Kleine-Beck (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

die Zuordnung der Pins bei den Reglern ist ganz sicher richtig?

Der LM1086 hat GND - OUT - IN
der LM3940 hat IN  - GND - OUT

Jeweils Draufsicht und von links nach rechts.

Dennis

Autor: Christoph Kessler (db1uq) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dennis hat recht, die Anschlußreihenfolge ist wirklich verwirrend.
Aus der Bezeichnung im Schaltplan geht auch nicht hervor, ob es
tatsächlich die 5V und 3,3V-Versionen sind. Die "-ADJ"-Versionen
sollten auf 1,25V regeln, das kann nicht sein, aber wenn es Regler für
höhere Spannungen wären, könnten sie sich so verhalten.

Autor: ecslowhand (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn der Schaltplan ja soweit stimmt, was ist mit der Platine ?

LG EC

Autor: ecslowhand (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Beim LM3940 würde ich noch einen 47nF-100nF zwischen Eingang und GND
setzen.
Denke daran, das die Gehäuse der beiden Spannungsregler
unterschiedliches Potential haben (GND und Vout) !

Autor: Dietmar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im Datenblatt steht:

The LM3940 is a 1A low dropout regulator designed to
provide 3.3V from a 5V supply.

Dann wird es wohl nicht verschiedene Versionen geben, sonst hätte es
den Meßwerten nach durchaus ein 5V-Typ sein können.

Kann es denn sein, daß über die doch noch angeschlossene
Nachfolgeschaltung (hab was von Datenflash gelesen, ist das auch
irgendwie an 5V gekoppelt?), und ein Defekt dieser, eine höhere
Spannung in den Ausgang des 3,3V-Reglers wieder eingekoppelt wird? Der
Ausgang des 3,3V-Reglers muß zur Überprüfung des Reglers dann mal
getrennt werden.

Gruß

Dietmar

Autor: Christoph Kessler (db1uq) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stimmt, die anderen Spannungen gibts nur beim älteren LM2940, der 3940
ist pinkompatibel, heißt aber noch "-3.3", vielleicht sind andere
Spannungen geplant.

Kann es sein, dass der Multimeter-Eingang irgendwelche Schwingungen
gleichrichtet, und die Gleichspannung tatsächlich ihren Sollwert nicht
überschreitet? Einem Oszilloskop würde ich eher trauen. Die
low-drop-Regler brauchen wirklich einen größeren Elko als normale 78er,
sonst können Regelsachwingungen auftreten.

Autor: Dietmar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es geht doch nichts über ein Oszi. Schwingungen wollte ich auch
ausschließen, da im Datenblatt ein größerer Kondensator, ab 33 uF,
dringend empfohlen wird.

Aber, wenn die Schaltung vor dem Kurzschluß schon eine Weile
einwandfrei funktionierte???

Gruß

Dietmar

Autor: Stefanie (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich werd morgen mal mit dem Oszi nachmessen und auch den größeren
Kondensator einlöten.

Könnt ihr ein Oszi empfehlen, dass man sich für zu Hause leisten kann??

Autor: Dennis Kleine-Beck (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was ist eigentlich draus geworden?

Dennis

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.