Forum: Mikrocontroller und Digitale Elektronik Raspberry Pi Kamera-Modul v2


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Pascal (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hi Leute,

ich habe wie in einem "Raspberry Pi Geek"-Heft gelesen, und dies dann 
auch getan, wie man vom Kameramodul die Linse entfernt und sie dann mit 
einem Teleskop zur Astrofotografie nutzt.

An sich funktioniert es ganz gut, aber:

wenn ich direkt mit einer Taschenlampe in das Teleskop, welches fokal 
als Objektiv wirkt, leuchte, oder
wenn ich direkt auf den freiliegenden Chip leuchte,
dann sehe ich mit weißem Hintergrund Flecken.

Diese "Flecken" sind rund, gräulich bis schwarz und haben teils einen 
Ring in einem helleren grauton um sich herum.

Mit einem Wattestäbchen aus einem Reinigungsset gingen diese nicht weg. 
sie befinden sich immer exakt an derselben Position.


Kann es sein, dass die Chips oben direkt auf der Oberfläche einen nicht 
enfernbaren Dreck haben? oder unter einer Art Schutzschicht auf dem 
Chip? Ich habe immerhin 40€ für das Raspi Kameramodul bezahlt.

Den Mars habe ich schon aufgenommen. Allerdings sind da keine Flecke 
beim Bewegen des Mars durch das Bildfeld zu sehen...

von Pascal (Gast)


Bewertung
0 lesenswert
nicht lesenswert
ach ja: wenn ich den Winkel, mit dem die Taschenlampe leuchtet, ändere, 
dann bewegen sich die Flecke leicht...

von Harry L. (mysth)


Bewertung
0 lesenswert
nicht lesenswert
Pascal schrieb:
> wenn ich direkt mit einer Taschenlampe in das Teleskop, welches fokal
> als Objektiv wirkt, leuchte, oder
> wenn ich direkt auf den freiliegenden Chip leuchte,
> dann sehe ich mit weißem Hintergrund Flecken.

Der Effekt ist typisch für verschmutzte Sensoren.

Mit einem Wattestäbchen dürfte das eher schlimmer als besser werden.
Professionelle Sensorreinigung geht anders, und bei diesen winzigen 
Sensoren im Prinzip auch nur noch im Reinraum.

von Md M. (Firma: Potilatormanufaktur) (mdma)


Bewertung
0 lesenswert
nicht lesenswert
Pascal schrieb:
> Den Mars habe ich schon aufgenommen.

Zeig doch mal her. Würde mich interessieren, was das Modul daraus macht.

von Pascal (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Md M. schrieb:
> Pascal schrieb:
> Den Mars habe ich schon aufgenommen.
>
> Zeig doch mal her. Würde mich interessieren, was das Modul daraus macht.

Nun ja, das seeing war nicht besonders gut. Aber ich werde es noch 
hochladen (ich schreibe vom Handy)

von oderso (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Pascal schrieb:
> un ja, das seeing war nicht besonders gut. Aber ich werde es noch
> hochladen (ich schreibe vom Handy)

und? Wann sehen wir nun das Bild?
Bin neugierig.

oderso

von Pascal (Gast)


Bewertung
0 lesenswert
nicht lesenswert
oderso schrieb:
> Pascal schrieb:
>
> und? Wann sehen wir nun das Bild?
> Bin neugierig.
>
> oderso

gleich ... leider musste ich mich erstmal damit herumschlagen, das .h264 
Format in einzelne .png's zu wandeln

von Pascal (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
leider muss ich dich enttäuschen: der Mars ist nicht drauf (hatte keine 
Nachführung, die Vergrößerung bei einer Brennweite von 1200 ist dafür zu 
groß, hat zu sehr gewackelt). Aber ich habe mit dem Handy ein Bild vom 
Display, an dem der Raspi hängt, wo Mars leider überbelichtet und wegen 
des Verwackelns leicht deformiert drauf ist..

Ich werde es nächstes Mal mit Nachführung machen. dann habe ich die 
Ruhe, die Belichtung korrekt einzustellen, und er wird statt weiß 
orange/rot.

Übrigens ist das Bild durch ein Balkongeländer hindurch, weil das 
Teleskop (Dobson) zu flach war ;)

von Pascal (Gast)


Bewertung
0 lesenswert
nicht lesenswert
die vollen 8MP sieht man hier natürlich nicht. Das Display ist nicht 
einmal HD-fähig... nächstes Mal, wenn der Mars auf einem Video vom rpi 
drauf ist (nicht nur live Anzeige), dann lade ich die vollen 8 MP hoch. 
Wird aber noch dauern...

von oderso (Gast)


Bewertung
0 lesenswert
nicht lesenswert
OK. Danke erst mal.
Hab auch noch eine Raspi Cam rumliegen und werde das auch mal probieren.
Gute Idee.

Gruß
oderso

von Pascal (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ein paar Tips zum Nachbauen:

- eine Filmdose von früher passt perfekt in die 1 1/4 Zoll Aufnahme des 
Teleskops. Alles andere was passt geht natürlich auch.
- Das Loch, welches in der Mitte des Bodens der Dose entstehen soll, 
kann gut mit einem über einem Teelicht erhitzten Nagel "eingeschmolzen" 
werden, muss aber mind. 7mm Durchmesser haben. Denn das runde Teil des 
RPI Kamerasensors muss dadurch passen, sodass nachher alles gerade ist.
- 1-2m Kabel für das Modul ist Pflicht! Sonst ist es sehr schwer den 
Raspi an die Öffnung am teleskop zu stellen
- "raspivid -t 0" reicht schonmal zum sehen des Livebildes aus. Dann 
kann man fokussieren
- beim Original wird das Bild über WiFi gesendet. Ich mache es lieber 
auf dem raspi selbst. Am besten ein Programm schreiben, vielleicht ein 
.sh script, das:

    - das Livebild beim Starten zeigt (raspivid -t 0)
    - und wenn man dann strg+c drückt, also das Livebild weg ist, 
automatisch ne Aufnahme startet

das vereinfacht vieles

von Pascal (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ein paar Tips zum Nachbauen:

- eine Filmdose von früher passt perfekt in die 1 1/4 Zoll Aufnahme des 
Teleskops. Alles andere was passt geht natürlich auch.
- Das Loch, welches in der Mitte des Bodens der Dose entstehen soll, 
kann gut mit einem über einem Teelicht erhitzten Nagel "eingeschmolzen" 
werden, muss aber mind. 7mm Durchmesser haben. Denn das runde Teil des 
RPI Kamerasensors muss dadurch passen, sodass nachher alles gerade ist.
- 1-2m Kabel für das Modul ist Pflicht! Sonst ist es sehr schwer den 
Raspi an die Öffnung am teleskop zu stellen
- "raspivid -t 0" reicht schonmal zum sehen des Livebildes aus. Dann 
kann man fokussieren
- beim Original wird das Bild über WiFi gesendet. Ich mache es lieber 
auf dem raspi selbst. Am besten ein Programm schreiben, vielleicht ein 
.sh script, das:

    - das Livebild beim Starten zeigt (raspivid -t 0)
    - und wenn man dann strg+c drückt, also das Livebild weg ist, 
automatisch ne Aufnahme startet

Das vereinfacht vieles.

Viel Glück!!

von Pascal (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sorry, 2* dasselbe gesendet ;)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.