Forum: Platinen Target: Wie Beschriftungen im Schaltplan ausblenden


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Gustav K. (hauwech)


Lesenswert?

Hallo,

sehe eben vor lauter Beschriftungen (Bauteil-Nummern und Bauteil-Werte) 
meine Schaltung kaum noch. Um mich zwischendurch mal wieder kurz zu 
orientieren, würde ich diese Lagen (wenn die Werte denn in Lagen 
verwaltet werden) mal kurz ausblenden. Beim Suchen fand ich nur die 
Möglichkeit, die Pin-Namen auszublenden (Einstellungen/Optionen).

Hat mir jemand einen Tipp?

Gustav

von Stefan (Gast)


Lesenswert?

Wenn du nix verstellt hast ,dann findest
du die auf Lage 21. Einfach ausblenden.

von Jörg R. (solar77)


Lesenswert?


: Bearbeitet durch User
von Gustav K. (hauwech)


Lesenswert?

Stefan schrieb:
> dann findest du die auf Lage 21. Einfach ausblenden.

Das gilt für die Platinenansicht, ich bin beim Schaltplan.

Jörg R. schrieb:
> 
https://server.ibfriedrich.com/wiki/ibfwikide/index.php/Bauteilname#Bauteilname_und_-wert_im_Schaltplan_anzeigen
> Ich meine dass Target eine sehr gute Onlinehilfe hat.

Perfekt - vielen Dank !
Manchmal sieht man den Wald vor Bäumen nicht

von Gustav K. (hauwech)


Angehängte Dateien:

Lesenswert?

Leider gleich das nächste Problem: Beim erstmaligen Aufruf der 
Platinenansicht (Auto-Placer startet) sehe ich die Meldung im Bild. Im 
Schaltplan tragen aber aber alle Bauteile dieses Häkchen in der 
Symbolmitte. Reo ändert daran auch nichts. Wo liegt das Problem?

Bei der Gelegenheit: Kann ich mir eigentlich die Anzahl meiner Bauteile 
anzeigen lassen? Ich fand bisher nur die Auflistung meiner Bauteile 
(Einstellungen -> Projekt-Bauteile).

von Horst S. (Gast)


Lesenswert?

Gustav K. schrieb:
> Bei der Gelegenheit: Kann ich mir eigentlich die Anzahl meiner Bauteile
> anzeigen lassen? Ich fand bisher nur die Auflistung meiner Bauteile
> (Einstellungen -> Projekt-Bauteile).

Datei->Ein/Ausgabeformate->Datenaustausch->Stückliste.
In der generierten Excel-Datei findest Du die Bauteile fortlaufend 
nummeriert.

Gustav K. schrieb:
> Leider gleich das nächste Problem: Beim erstmaligen Aufruf der
> Platinenansicht (Auto-Placer startet) sehe ich die Meldung im Bild. Im
> Schaltplan tragen aber aber alle Bauteile dieses Häkchen in der
> Symbolmitte. Reo ändert daran auch nichts. Wo liegt das Problem?

Das passiert bei mir, wenn der Platinenumriss zu klein gewählt ist und 
im Autoplatzierer "innerhalb der Platine" angewählt wurde. Dann passen 
die Teile mit dem vorgegebenen Abstand gar nicht auf die Platine.
Die müsstest Du dann aber in der Platinenansicht trotzdem einzeln über 
"Einf" angeboten bekommen.

von Gustav K. (hauwech)


Lesenswert?

Horst S. schrieb:
> Datei->Ein/Ausgabeformate->Datenaustausch->Stückliste.

Hat funktioniert - nochmals vielen Dank !

Horst S. schrieb:
> Das passiert bei mir, wenn der Platinenumriss zu klein gewählt ist und
> im Autoplatzierer "innerhalb der Platine" angewählt wurde.

Platine ist Standard (100x160) und im Autoplatzierer wurde "außen 
oberhalb der Platine" gewählt.

Datei->Ein/Ausgabeformate->Datenaustausch->Stückliste erbrachte hier 57 
Bauteile und in der Fehlermeldung ist zu lesen: 57 Bauteile platziert, 
31 Bauteile übrig. Also sind alle Bauteile platziert worden, welches 
sind nun die 31 übrigen Bauteile?

Ich hatte einige Male Bauteile gelöscht und durch andere ersetzt. 
Scheinbar haben sich die gelöschten Bauteile im digitalen Nirvana 
verlaufen. Würde diesen Fehler gerne beheben, bevor ich weiter mache.

von Bussard (Gast)


Lesenswert?

Gustav K. schrieb:
...
> Datei->Ein/Ausgabeformate->Datenaustausch->Stückliste erbrachte hier 57
> Bauteile und in der Fehlermeldung ist zu lesen: 57 Bauteile platziert,
> 31 Bauteile übrig. Also sind alle Bauteile platziert worden, welches
> sind nun die 31 übrigen Bauteile?
>
> Ich hatte einige Male Bauteile gelöscht und durch andere ersetzt.
> Scheinbar haben sich die gelöschten Bauteile im digitalen Nirvana
> verlaufen. Würde diesen Fehler gerne beheben, bevor ich weiter mache.

Sollte durch Reorganisation leicht zu beheben STRG + F12.
Dort gibt es auch noch einige standardmäßig ausgegraute Optionen, die 
auszutesten lohnt.

Das setzt voraus, daß die Bauteile auch noch 1 Stck und nicht zerrissen 
und teilweise rausgelöscht wurden:
- hier mal mit Rechtsclick auf eine freie Stelle das Menü öffnen und die 
Häkchen bei
"Bauteil immer komplett markieren" sowie
"Modul immer komplett markieren" setzen. Dann kannst Du eventuele Reste 
löschen.

Wenn das noch immer nicht hilft, unter dem Reiter Einstellungen die 2 
Zeilen "Freie Elemente ..." kontrollieren.

Gruß

von Horst S. (Gast)


Lesenswert?

Wenn Du jetzt auf der Platinenansicht "Einf" drückst, ist die Liste leer 
(bis auf den Eintrag "Freies Gehäuse")?

Wow, den hatte ich auch noch nicht.

Wenn gar nix mehr hilft, probier mal, mit STRG+A/Strg+C alles aus dem 
Schaltplan zu kopieren und in ein neues Projekt (Strg+V) einzufügen.

von Gustav K. (hauwech)


Angehängte Dateien:

Lesenswert?

Bussard schrieb:
> Sollte durch Reorganisation leicht zu beheben STRG + F12.

Tut sich nix :-(

> Das setzt voraus, daß die Bauteile auch noch 1 Stck und nicht zerrissen
> und teilweise rausgelöscht wurden

Überprüft, nichts gefunden.

> Wenn das noch immer nicht hilft, unter dem Reiter Einstellungen die 2
> Zeilen "Freie Elemente ..." kontrollieren.

Ich finde unter "Freie Elemente" 14 Linien, die sich in zwei Symbolen 
finden, die ich mit dem Bleistift Symbol hinzugefügt habe.
Unter "Freie Elemente" finde ich einen Eintrag: "Kein Element gefunden".

Horst S. schrieb:
> Wenn Du jetzt auf der Platinenansicht "Einf" drückst, ist die Liste leer
> (bis auf den Eintrag "Freies Gehäuse")?

Genau so ist es.

> Wow, den hatte ich auch noch nicht.

Ich auch noch nicht, obwohl ich bereits ein Target-Projekt durchgezogen 
habe.

Nachdem ich noch einige Bauteile hinzugefügt habe, sind auch die übrigen 
Bauteile mehr geworden (Bild) :-(

von Stefan (Gast)


Lesenswert?

Lad die Datei mal hoch.
Da kann man dann mal schauen wo das
Problem ist.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.