Forum: Analoge Elektronik und Schaltungstechnik Nachfüllautomatik/Verzögerung


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Nikolas H. (quicknik)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich möchte mir eine Nachfüllanlage für mein Aquarium bauen. Und das 
ganze am besten möglichst Simple mit Teilen aus der einfachen 
Bastelkiste.

Dazu hab ich mir mal eine Grundschaltung simuliert (siehe. noC-Ohm.png). 
Die beiden Elektroden die nachher im Wasser hängen (das werden 
Kohlefaserstäbe später). Hab ich hier mal mit einem Switch simuliert der 
alle 2 sek. an und aus geht.

Das Relay welches später die Pumpe schaltet ist hier durch eine LED 
simuliert. Ggf. wird Q1 noch ein 337 ich muss mal schauen, was das 
Relais an Strom zieht aber das ist hier erstmal egal.

In dem Graphen sieht man jeweils die Spannung am SW (Grün, 5V -> 
Kontakt, 0V Kein Kontakt) und den Strom durch die LED (bzw. später dann 
Pumpe an/aus).

Soweit so gut nun zu meinen Fragen:

Ich möchte eigentlich gerne, das die Pumpe etwas nachläuft. Aus 
folgendem Grund: In dem Becken herrscht etwas Oberflächenbewegung. Ohne 
nachlaufen oder alternativ Einschaltverzögerung klickert das Relais dann 
die ganze Zeit.

Darum hab ich in 150c-Ohm.png einen Elko entsprechend geschaltet und 
damit eine Einschaltverzögerung. Das ist zwar schoen und gut nur sieht 
die Realitat leider so aus das, das was in der dem Schaltplan sw1 ist in 
Wirklichkeit nachher Wasser ist und das hat eben keinen Wiederstand von 
0 Ohm sondern irgendwas im KOhm Bereich und damit hat das dann mit der 
Verzögerung nicht mehr hin siehe 150C-47K.png

Ich vermute das liegt Daran das der Elko sich in der Konstellation nicht 
richtig entläd, aber sicher bin ich mir nicht, da ich absoluter Laie bin 
was Elektronik angeht.

Ich würde mich freuen wenn mich jemand auf die richtige Fährte führen 
könnte.
Nochmal in Kurz:
1.Warum dieser Effekt bei 47k und was kann man dagegen tun?
2.Warum führ das auf 150c-Ohm.png überhaupt zu einer 
Einschaltverzögerung und nicht zum Nachlaufen der Pumpe?

Viele Grüsse,
Nikolas

von Dieter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Zurückzuführen ist das auf den Einfluss des Kondensators.

Besser funktioniert dies mit einem anderen Ansatz schon auf der 
Sensorebene mit Hysterese. Einer der Sensoren detektiert "Min" der 
andere "Max" und toggeln darüber an und aus der Pumpe.

von Nikolas H. (quicknik)


Bewertung
0 lesenswert
nicht lesenswert
Dieter schrieb:
> Besser funktioniert dies mit einem anderen Ansatz schon auf der
> Sensorebene mit Hysterese. Einer der Sensoren detektiert "Min" der
> andere "Max" und toggeln darüber an und aus der Pumpe.

Hmm, ich kann nicht so recht folgen, kannst Du das noch ein bischen 
weiter ausführen gernen mit link Beispielen dann kann ich das besser 
nachvollziehen und ggf. adaptieren.

Gruss,
Nikolas

von Dieter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Zum Beispiel als Und-Schaltung:

https://www.elektronik-kompendium.de/sites/dig/0710091.htm

Ggf. Signal ist vorher zu invertieren.

Sensor 1: Aus wenn unter Füllstand
und zugleich
Sensor 2: Aus wenn über Füllstand
Pumpe läuft.

Alle anderen Zustände Pumpe aus.

von Dieter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Korrektur

Zum Beispiel als Und-Schaltung:

https://www.elektronik-kompendium.de/sites/dig/0710091.htm

Ggf. Signal ist vorher zu invertieren.

Sensor 1: Aus wenn unter Füllstand
und zugleich
Sensor 2: Aus wenn über Füllstand nicht erreicht
Pumpe läuft.

Alle anderen Zustände Pumpe aus.

von Nikolas H. (quicknik)


Bewertung
0 lesenswert
nicht lesenswert
Nabend,

ah ok verstehe, d.h. ich brauche noch eine 3te Elektrode. Etwa so:

A  ganz oben
B. sagen wir nen cm drunter
C. richtig tief

Und dann so:

A | B | C | Pumpe | Grund
0   0   0     0      Hier stimmt was nicht
0   0   1     1      Wasser stand echt tief
0   1   0     0      Hier stimmt was nicht
0   1   1     1      Alles ok auffuellen ist angesagt
1   0   0     0      Hier stimmt was nicht
1   0   1     0      Hier stimmt was nicht
1   1   1     0      Wasserstand ist ok

Das müsste ja mit 3 Transistoren hinzubekommen sein wobei ich mir nicht 
sicher bin ob der 0 0 0 Zustand nicht nen Sonderfall wird.

Nachtrag vermutlich ist es einfacher die pumpe nur bei 0 1 1 anzumachen 
und bei allen anderen aus.

Da forsch ich morgen mal ein bischen :)

Gruss,
Nikolas

: Bearbeitet durch User
von Nikolas H. (quicknik)


Bewertung
0 lesenswert
nicht lesenswert
Moin,

so @Dieter ich hab mal ob Deiner Eingaben etwas geforscht.
Wenn ich sowas hier mache:


A = Max (ganz oben im becken)
B = Min (nen cm oder so unter max)
C = irgendwo ganz unten

Ich lege "High" auf C. Sorge dafuer das a Not high & b not High nen 
FlipFlop "High machen" welches die Pumpe anknipst und dann dafuer, dass 
das FlipFlop bei A und B high auf low geht.

Ich hab da gestern Nacht ein paar Schaltungen gesehen aus som 
Schulprojekten und bei Instructables die was aehnliches machen.

http://www.elektronik.nmp24.de/?Bauanleitungen:F%26uuml%3Bllstands-Regelung
(das scheint mir etwas over overengineered zu sein ist aber dafuer "well 
defined")

https://www.instructables.com/id/1-AUTOMATIC-WATER-LEVEL-CONTROLLER/
(Tut was es soll sieht aber irgendwie "komisch" aus versteh ich auch 
nicht richtig aus die Diode da kommt mir irgendwie komisch sieht nicht 
nach ner flyback aus aber was weiss ich schon- lass mich aber gerne 
aufklaeren)

Was ich halt idealerweise moechte ist bei max/min = not 1 (0 gibts ja 
nicht wirklich) Pumpe an und bei max/min = 1 pumpe aus, dafuer muss man 
sich vermutlich den uebergang merken
daher die Idee mit dem flipflop. Was es dann noch brauch ist nen 
failover, denn Zustaende wie:
max = 1, min = Not 0 oder gar "nicht mal C ist im wasser", weil der 
sensor hinten runtergefallen ist oder die Katze das Kabel zerbissen hat.

Hmpf ich komm hier irgendwie vom 100ten ins 1000te, aber immerhin machts 
Spass :).

Gruss,
Nikolas

von Dieter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Die Diode übernimmt den Flyback beim Ausschalten der Spule.

von Ach Du grüne Neune (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
T1 und T2 sind das RS-Flip-Flop. T3 schaltet bei erreichen der 
min-Position das Relais ein und T4 schaltet bei erreichen der 
max-Position das Relais wieder aus. Das RC-Glied (10µF / 470k) sorgt nur 
dafür, dass nicht zuviel Strom durch die Fische fließt. Eine stündliche 
Abfrage für 10 Sekunden wäre für die Fische wohl gesünder. Das RC-Glied 
(10µF / 100R) sorgt dafür, dass nach einem Stromausfall das Flip-Flop 
auf die sichere Seite einschaltet.

Aber wahrscheinlich ist ein Styroporschwimmer mit Mikroschalter das 
Sicherste. Der Mikroschalter hat werkseitig schon eine Hysterese 
eingebaut.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.