Forum: Analoge Elektronik und Schaltungstechnik Invertriender OPV Schwingt zufällig


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Christopher G. (turooc)


Angehängte Dateien:

Bewertung
-1 lesenswert
nicht lesenswert
Hallo!

Ich habe folgendes Problem: Ich soll eine Schaltung fixen, die ich 
selber nicht entworfen habe und so langsam bin ich mit meinen Ideen am 
Ende.
Kurzfassung: Der TL072 schwingt am Ausgang und das Zufällig!
Er ist Teil einer größeren Schaltung. Diese soll im Prinzip den AC Teil 
eines Signals rausfilter, invertieren und später wieder hinzufügen.

Der TL072 wird einmal als Diff-Verstärker verwendet und im Anschluss als 
Invertierender Verstärker. Die Schaltung befindet sich im Anhang. Nun 
ist das Problem das er 1. einen DC-Offset ( Hinnehmbar) aber 2. zufällig 
anfängt zu schwingen. Man sieht dies in den Screenshots im Anhang. Ich 
habe alle Anderen Stellen in der Schaltung bereits mit dem Oszilloskop 
angeschaut, es schwingt nur der Ausgang vom OPV.

Jemand eine Idee wie man das vermeiden kann? OPV wechseln?

Vielen Dank und Grüße,
CG

von hinz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Stützkondensatoren an der Versorgung des Opamp vorhanden?

von Günter Lenz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich sehe drei OPV, welcher von den dreien Schwingt?
Vielleicht bekommt die Schaltung Störungen von außen
irgendwo her.

von Forist (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Christopher G. schrieb:
> Jemand eine Idee wie man das vermeiden kann?

Zeig doch mal eine Schaltplan, auf dem man trotz Lupe nicht nur 
Pixelbrei auf Grund von JPEG-Artefakten sieht.

Wozu gibt es eigentlich beim Upload den Hinweis auf die Bildformate

von Löschgeschädigter (Gast)


Bewertung
2 lesenswert
nicht lesenswert
Günter Lenz schrieb:
> Ich sehe drei OPV, welcher von den dreien Schwingt?

Ich sehe nur einen, der als invertierender Verstärker beschaltet ist: 
Den in der Mitte. An dessen Ausgang hat er gemessen und da schwingt es.

@TO Schön wäre es, wenn man sehen könnte, wo die Strippe, die zwischen 
dem 1 MOhm und dem 470 K Widerständen an diesem OPV angschlossen ist, 
herkommt.

von Glaub Esuns (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Abblock-Kondensatoren sowie andere Massnahmen zur Entstörung/
Filterung von Versorgungsspannungen sind völlig unnötig und
daher als reiner Luxus zu betrachten.

Selbst wenn solche vorhanden wären ist es völlig legitim diese
im Schaltplan wegzulassen - es würde die Befragten nur irreführen.

von Löschgeschädigter (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Glaub Esuns schrieb:
> Abblock-Kondensatoren sowie andere Massnahmen zur Entstörung/
> Filterung von Versorgungsspannungen sind völlig unnötig und
> daher als reiner Luxus zu betrachten.

Meinst Du nicht, daß es genügt, wenn EINER darauf hinweist? Solche 
geistreichen Einwürfe lassen manch Einem das Messer in der Tasche 
aufgehen.

von Wolfgang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Vielleicht schwingt der OP nicht zufällig, sondern weil der Abstand zum 
nächsten Smart Phone zu klein und die "Antennen"-Drähte am Eingang zu 
lang sind.

von Klaus R. (klara)


Bewertung
0 lesenswert
nicht lesenswert
Christopher G. schrieb:
> Kurzfassung: Der TL072 schwingt am Ausgang und das Zufällig!

Ein TL072 schwingt nicht so einfach. Diese OPV sind ziemlich gutmütig. 
Es sieht ganz nach Einstrahlungen aus. Mit welcher Frequenz schwingt es 
denn?
mfg Klaus

von Christopher G. (turooc)


Bewertung
0 lesenswert
nicht lesenswert
Klaus R. schrieb:
> Ein TL072 schwingt nicht so einfach. Diese OPV sind ziemlich gutmütig.
> Es sieht ganz nach Einstrahlungen aus. Mit welcher Frequenz schwingt es
> denn?

Evtl ist schwingen das falsche Wort... Man sieht dieses "gezappel" in 
dem gemessenen Strom. Das ist sehr niederfrequent. Auf dem Osziloskop 
ist es kaum zu messen. Die Kennleinen haut in diesen Momenten nach oben 
und unten kurz ab.

hinz schrieb:
> Stützkondensatoren an der Versorgung des Opamp vorhanden?

Ja sind sie. Der TL072 besitzt ja zwei OPVs und der erste wird als 
Differenzverstärker genutzt, dieser funktioniert einwandfrei.

Löschgeschädigter schrieb:
> Günter Lenz schrieb:
>> Ich sehe drei OPV, welcher von den dreien Schwingt?
>
> Ich sehe nur einen, der als invertierender Verstärker beschaltet ist:
> Den in der Mitte. An dessen Ausgang hat er gemessen und da schwingt es.
>
> @TO Schön wäre es, wenn man sehen könnte, wo die Strippe, die zwischen
> dem 1 MOhm und dem 470 K Widerständen an diesem OPV angschlossen ist,
> herkommt.

Es ist eine zweite Beschaltung vorgesehen, die aber nicht bestückt ist. 
Die Strippe geht zu der zweiten Beschaltung.

Forist schrieb:
> Christopher G. schrieb:
>> Jemand eine Idee wie man das vermeiden kann?
>
> Zeig doch mal eine Schaltplan, auf dem man trotz Lupe nicht nur
> Pixelbrei auf Grund von JPEG-Artefakten sieht.
>
> Wozu gibt es eigentlich beim Upload den Hinweis auf die Bildformate

 Ja , ich gebe zu, die Qualität ist mies. Ich werde versuchen Montag ein 
bessres Bild zu erstellen oder das Ganze morgen mal nach zu zeichnen.


Vielen Dank erstmal für die Antworten!

von Wolfgang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Christopher G. schrieb:
> Das ist sehr niederfrequent.

Wie soll man das ohne vernünftige Zeitachse ahnen?

Christopher G. schrieb:
> Langzeitmessung.jpg
> LD_swing.JPG

von Karl (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Christopher G. schrieb:
> Evtl ist schwingen das falsche Wort...

Ja, das ist es. Die klassische Schwingung ist eher sinusförmig. Es sieht 
ein bisschen nach aufgehobener Rückkopplung aus, aber dann müsste das 
Ausgangssignal am rail kleben.
Es ist schwer dir zu helfen, wenn du die benötigten Informationen nicht 
bestellst. Dazu gehört ein vollständiger Schaltplan den man lesen kann 
und in dem der genaue Messpunkt der Signale ersichtlich wird.

Wenn ein OP Mist macht, schau dir auf jeden Fall alle drei relevanten 
Signale an. + - und Ausgang. Am besten in einfach verdaulicher Form 
aufbereitet mit Wert und Zeitachse. Notfalls Zoom auf auffällige 
Bereiche.

Ist das ein Einzelstück oder ein Seitenproblem?

von Christian L. (cyan)


Bewertung
0 lesenswert
nicht lesenswert
Christopher G. schrieb:
> Löschgeschädigter schrieb:
>> Günter Lenz schrieb:
>>> Ich sehe drei OPV, welcher von den dreien Schwingt?
>>
>> Ich sehe nur einen, der als invertierender Verstärker beschaltet ist:
>> Den in der Mitte. An dessen Ausgang hat er gemessen und da schwingt es.
>>
>> @TO Schön wäre es, wenn man sehen könnte, wo die Strippe, die zwischen
>> dem 1 MOhm und dem 470 K Widerständen an diesem OPV angschlossen ist,
>> herkommt.
>
> Es ist eine zweite Beschaltung vorgesehen, die aber nicht bestückt ist.
> Die Strippe geht zu der zweiten Beschaltung.

Wie lang ist die entsprechende Leitung? Kann es sein, dass diese wie 
eine Antenne Störungen in den hochohmigen Teil der Schaltung einkoppelt?

Falls die Leitung etwas länger ist, dann solltest du mal versuchen die 
Leitung so nah, wie möglich an den hochohmigen Widerständen 
aufzutrennen.

von niederohmig (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich würde den 1M und 470k mal verkleinern.

von Karl B. (gustav)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Christian L. schrieb:
> Wie lang ist die entsprechende Leitung? Kann es sein, dass diese wie
> eine Antenne Störungen in den hochohmigen Teil der Schaltung einkoppelt?

Hi,
Bauteile im Bild scheinen mehr und mehr aus der Mode gekommen zu sein 
beim Schaltungsdesign?
Also die Ferritperlen direkt an + bzw. - Eingänge des TL,
Wenn es garnichts hilft, Metallgehäuse (Ecke oben rechts im Bild) und 
Durchführungs-Kerkos.
Die Transienten auf der Spannungsversorgung, die die Schwingneigung 
anstossen könnten, wären mit Supressordioden (hier nur als Beispiel 
12V-Type) auch evtl. in den Griff zu bekommen.

Selbstverständlich spielt das Platienlayout eine wichtige Rolle.
Aber nicht nur, wie ich letztens bei meinen Basteleien feststellen 
musste.
Da sind bei mir ganz prinzipielle Dinge im gesamten Schaltungsdesign 
völlig falsch verstanden worden.

Rien ne va plus.
Nochmal auf zero.

ciao
gustav

: Bearbeitet durch User
von A.N.Walt (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ohne lesbaren Schaltplan, aus dem man wenigsten klar erkennen kann, 
welches invertierender und welches nicht invertierender Eingang der OPs 
ist, sag' ich gar nichts.

von J. Zimmermann (Gast)


Bewertung
0 lesenswert
nicht lesenswert
niederohmig schrieb:
> Ich würde den 1M und 470k mal verkleinern.

das auf jeden Fall, es besteht doch keine Notwendigkeit den Ausgang des 
Multiplizierers so hochohmig anzugehen.
Evtl. (konnte keinen Hinweis im Datenblatt finden) ist der TL072 nicht 
stabil für "kleine" Verstärkungen (Stichwort unity gain stability).
mfg
Achim

von Reiner (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Klaus R. schrieb:
> Ein TL072 schwingt nicht so einfach. Diese OPV sind ziemlich gutmütig.
> Es sieht ganz nach Einstrahlungen aus. Mit welcher Frequenz schwingt es
> denn?

Bei mir hat mal ein TL072 fürchterlich geschwungen, weil die 
Abblock-Kondensatoren (100nF) zu weit entfern waren (damals wusste ich 
es noch nicht besser).
Nachdem ich sie nahe am OP positioniert hatte, war der Schwingspuk 
schlagartig vorbei.

Das Schwingen war übrigens deutlich als eine Art Rauschen zu hören.

von 3? (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Aber das ist keine solche Schwingung, wenn ich auch nicht weiß, was es 
ist.

Beitrag #5536868 wurde vom Autor gelöscht.
von Christopher G. (turooc)


Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Soo ich habe den Schaltplan nochmal in einer vernünftigen (hoffe ich)
Auflösung angehangen.



J. Zimmermann schrieb:
> niederohmig schrieb:
>> Ich würde den 1M und 470k mal verkleinern.
>
> das auf jeden Fall, es besteht doch keine Notwendigkeit den Ausgang des
> Multiplizierers so hochohmig anzugehen.
> Evtl. (konnte keinen Hinweis im Datenblatt finden) ist der TL072 nicht
> stabil für "kleine" Verstärkungen (Stichwort unity gain stability).
> mfg
> Achim

Ich habe die Widerstände um Faktor 100 verkleinert und den Gain auf >2
eingestellt. Das scheint die Lösung gewesen zu sein.

Vielen Dank!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.